Can not access administration panel

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
daggy821
Registered User
Posts: 10
Joined: Thu Sep 01, 2005 8:31 pm
Location: Norway

Can not access administration panel

Post by daggy821 » Thu Oct 26, 2006 4:52 pm

Hi.

I can not access the administration panel of my PHPBB2 forum. When logging in as administrator and trying to access /admin, it just redirects to the forum/index.php again. I am logged in. Used to work great before, what has happened ?

steptoe1977
Registered User
Posts: 18
Joined: Mon Oct 09, 2006 8:20 pm
Location: England
Contact:

Post by steptoe1977 » Thu Oct 26, 2006 5:17 pm

my board is doing the same once you have logged in and it redirects you log in again and it should have the goto admin at the bottom click it and login and it should take you there.

I have no idea why it is doing it
http://www.thegenealogystore.co.uk/Z/forum/index.php

FJA Mods
Registered User
Posts: 13
Joined: Thu Oct 26, 2006 5:56 pm
Location: Syracuse, NY
Contact:

Post by FJA Mods » Thu Oct 26, 2006 5:58 pm

Mine is doing the same thing. Once in a while the Admin panel will come up but then once I try to select a catagory the frame on the right brings up the main forum index page.
Jerry

FJA Mods
Registered User
Posts: 13
Joined: Thu Oct 26, 2006 5:56 pm
Location: Syracuse, NY
Contact:

Post by FJA Mods » Thu Oct 26, 2006 8:15 pm

Any ideas? I tried the auto cookie thing and that didn't help.
Jerry

MCDCOS
Registered User
Posts: 29
Joined: Tue Sep 12, 2006 8:33 pm
Contact:

Post by MCDCOS » Fri Oct 27, 2006 3:15 pm

Hi, the administration panel for my board is completely gone...how do we fix this? Also, you can't post. If you try to post or reply to a post you just get redirected to log in again. Once you're logged in, you can't log out.

Thanks for the help.

Marcia
www.thebookkeepersforum.com
MCD

wpcgoddess
Registered User
Posts: 3
Joined: Fri Oct 27, 2006 4:57 pm

Post by wpcgoddess » Fri Oct 27, 2006 5:00 pm

I notice these posts have not been answered and I am having the SAME issue. I have doublechecked the code and my user access level but when I click on the admin link on the bottom of the forum it will not go there and takes me back to the regular forum index, so I have no access to the admin panel.

I hope someone has a solution to this problem. Thank you!

User avatar
Jim_UK
Former Team Member
Posts: 18478
Joined: Tue Oct 12, 2004 5:36 pm
Location: Darwen N.West UK

Post by Jim_UK » Fri Oct 27, 2006 5:02 pm

Most of these sort of problems are due to incorrect configuration.
To correct configuration problems use the Auto cookie mod.
You must ftp the complete install directory to the root of phpBB2
Run the file with your browser like http://yourdomain/yourphpBB2/install/cookie.php
Accept all suggested settings and then:-
Delete the install directory
Log out and clear cache and cookies in your browser.
Now close and restart your browser.
If this does not work then run the mod again and post the "Suggested" and "Actual" settings into this support thread

Jim
The truth is out there.
Unfortunately they will not let you anywhere near it!

wpcgoddess
Registered User
Posts: 3
Joined: Fri Oct 27, 2006 4:57 pm

Post by wpcgoddess » Fri Oct 27, 2006 5:04 pm

I actually already ran it and it didn't work so I will run again and post the suggested/actual settings momentarily.

wpcgoddess
Registered User
Posts: 3
Joined: Fri Oct 27, 2006 4:57 pm

Post by wpcgoddess » Fri Oct 27, 2006 5:10 pm

My Current Cookie Settings:
  • Domain Name: www.womanpokerplayer.com
  • Server Port: 80
  • Script path: /forums/
  • Cookie secure: Disabled
  • Cookie domain: .womanpokerplayer.com
  • Cookie path: /forums
  • Cookie name: womanpoker_forum
  • Session length [ seconds ]: 3600
  • Allow automatic logins: No
  • Automatic login key expiry:
My Suggested Cookie Settings:
  • Domain Name: www.womanpokerplayer.com
  • Server Port: 80
  • Script path: /forums/
  • Cookie secure: Disabled
  • Cookie domain: .womanpokerplayer.com
  • Cookie path: /forums
  • Cookie name: womanpoker_forum
  • Session length [ seconds ]: 3600
  • Allow automatic logins: Yes
  • Automatic login key expiry: 0
There you are - thank you! :D

User avatar
Jim_UK
Former Team Member
Posts: 18478
Joined: Tue Oct 12, 2004 5:36 pm
Location: Darwen N.West UK

Post by Jim_UK » Fri Oct 27, 2006 5:10 pm

MCDCOS
If you have a web accelerator as a plug in for your browser then please disable it and try again.
Web accelerators are a real no no!!

Jim
The truth is out there.
Unfortunately they will not let you anywhere near it!

User avatar
Jim_UK
Former Team Member
Posts: 18478
Joined: Tue Oct 12, 2004 5:36 pm
Location: Darwen N.West UK

Post by Jim_UK » Fri Oct 27, 2006 5:34 pm

The only change there is that you have nothing set for the login key expiry.
Have you accepted the suggested settings?

Jim
The truth is out there.
Unfortunately they will not let you anywhere near it!

MCDCOS
Registered User
Posts: 29
Joined: Tue Sep 12, 2006 8:33 pm
Contact:

Post by MCDCOS » Fri Oct 27, 2006 5:37 pm

Jim_UK

I did have a web accelerator. Disabled it and everything is working again. Thanks. The web accelerator problem is very curious.
MCD

User avatar
Jim_UK
Former Team Member
Posts: 18478
Joined: Tue Oct 12, 2004 5:36 pm
Location: Darwen N.West UK

Post by Jim_UK » Fri Oct 27, 2006 5:59 pm

MCDCOS wrote: Jim_UK

I did have a web accelerator. Disabled it and everything is working again. Thanks. The web accelerator problem is very curious.


At least that is one in this topic solved. :D

Jim
The truth is out there.
Unfortunately they will not let you anywhere near it!

FJA Mods
Registered User
Posts: 13
Joined: Thu Oct 26, 2006 5:56 pm
Location: Syracuse, NY
Contact:

Post by FJA Mods » Fri Oct 27, 2006 6:33 pm

Here are my results. The first set is the default settings. The second is the auto cookie suggested settings. I had already tried using the auto cookie with no success. I can get the administration panel to come up once in a while, but it will bring up my forum page in the right frame as soon as I try to choose an admin catagory.
Jerry



My Default Cookie Settings:



Domain Name: www.fjamods.com

Server Port: 80

Script path: /forum/ phpBB2/

Cookie secure: Disabled

Cookie domain:

Cookie path: /

Cookie name: phpbb2mysql

Session length [ seconds ]: 3600

Allow automatic logins: Yes

Automatic login key expiry: 0



My Suggested Cookie Settings:



Domain Name: www.fjamods.com

Server Port: 80

Script path: /forum/phpBB2/

Cookie secure: Disabled

Cookie domain: .fjamods.com

Cookie path: /forum/phpBB2

Cookie name: fjamods_forum

Session length [ seconds ]: 3600

Allow automatic logins: Yes

Automatic login key expiry: 0

User avatar
Brf
Support Team Member
Support Team Member
Posts: 51760
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Post by Brf » Fri Oct 27, 2006 6:36 pm

You need to set your cookie domain

Locked

Return to “2.0.x Support Forum”