Problem: 'Could not insert new word'

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
Captain Jim
Registered User
Posts: 32
Joined: Thu Aug 19, 2004 11:58 pm
Contact:

Problem: 'Could not insert new word'

Post by Captain Jim » Tue Dec 26, 2006 11:57 pm

This is the error message I or anyone else makes a post, the post goes through correctly though.......but it doesn't show up as the latest post but it's there.

Could not insert new word

DEBUG MODE

INSERT IGNORE INTO phpbb_search_wordlist (word_text, word_common) VALUES ('congrats', 0), ('miamiu', 0)

Line : 234
File : functions_search.php

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Post by espicom » Wed Dec 27, 2006 12:11 am

Start with a repair of the affected table - if the problem still exists, and you have phpmyadmin (the best way to do the repair mentioned a moment ago), you can try executing the same query in its SQL window, and see what the actual error message MySQL is giving is.

First link in my signature can help with repairs, if you do not have phpmyadmin.
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

Captain Jim
Registered User
Posts: 32
Joined: Thu Aug 19, 2004 11:58 pm
Contact:

Post by Captain Jim » Wed Dec 27, 2006 12:14 am

The Collation for this table is 'In Use'

While all the other tables are 'latin1_swedish_ci'

Here is what SQL error I'm getting from phpmyadmin:

#1016 - Can't open file: 'phpbb_search_wordlist.MYI' (errno: 145)

User avatar
Lumpy Burgertushie
Registered User
Posts: 66477
Joined: Mon May 02, 2005 3:11 am
Contact:

Post by Lumpy Burgertushie » Wed Dec 27, 2006 12:30 am

did you do the repair that marshall told you?

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

Captain Jim
Registered User
Posts: 32
Joined: Thu Aug 19, 2004 11:58 pm
Contact:

Post by Captain Jim » Wed Dec 27, 2006 12:31 am

Lumpy Burgertushie wrote: did you do the repair that marshall told you?

robert


I ran the repair and the issue is fixed.

Thanks a lot! You guys are good!

Locked

Return to “2.0.x Support Forum”