Page 1 of 2

Really weird errors... Please Help

Posted: Sun Jan 21, 2007 4:31 pm
by No_Mercy
At my website there are some strange things going on.

On friday night everything worked fine. Then 25 hours later I signed on and stuff is happening.

I know this is a MOD but I think it falls under the same problem.
The shoutbox doesn't work because when people enter a message and hit send it doesn't appear.

Also, when people try to post they get the 'You have tried to post a message to soon' bit. Even though people havent posted in like a day now.

The newest member thing is wrong. It displays a member from like a day or 2 ago when we have had newer members.

And the dates in the forum are all completely off.


Please help soon, my forum was starting to take off but now it's 'run out of gas' so to speak.

Posted: Sun Jan 21, 2007 4:34 pm
by stevemaury
Well, the time on your server seems to be off. It is probably set to a time in the future. Check with your host.

Posted: Sun Jan 21, 2007 4:35 pm
by No_Mercy
How would I reset this?

Posted: Sun Jan 21, 2007 4:40 pm
by KevC
You have to ask your host to do it.

Posted: Sun Jan 21, 2007 4:42 pm
by No_Mercy
To do what, change the date?
Will this help the other problems?

And can't I do it through phpmyadmin?

Posted: Sun Jan 21, 2007 4:45 pm
by stevemaury
Changing the date is the first step. It SHOULD fix the "too soon" problem and since they all started at the same time, I suspect all have the same cause.

Listen carefully. You must contact your host to change the time on the server. You can't do it.

Posted: Sun Jan 21, 2007 4:48 pm
by No_Mercy
How do I/you know if the server time is wrong?

Posted: Sun Jan 21, 2007 4:51 pm
by who_cares
No_Mercy wrote: How do I/you know if the server time is wrong?

you can look at the clock on the index page

Posted: Sun Jan 21, 2007 4:52 pm
by stevemaury
Go to your Forum Index page and look in the upper left corner where it says "the time now is . . ." Refresh the browser.

I suspect the date may be off as well. I surmise this from the errors you describe.

Posted: Sun Jan 21, 2007 4:52 pm
by KevC
No_Mercy wrote: How do I/you know if the server time is wrong?

Cos we've seen it before :)

If they've set the time on the server to be in the future, when you post, the server says 'hang on, that time hasn't come up yet, you must be posting too soon before the allowed 30 second anti flood' so it stops your post going through.

Posted: Sun Jan 21, 2007 4:54 pm
by contract
the server has a set time as well as your forums, the server in a way over writes your set time in your forums. The database is with your server not with your boards. Contact them to see if the time is off and if it is have them reset it. That should fix most if not all the time problems you are having.

Posted: Sun Jan 21, 2007 4:54 pm
by No_Mercy
You last visited on Sat Jan 20, 2007 The time now is Sun Jan 21, 2007

So it also says I''m not visiting. O.o

Posted: Sun Jan 21, 2007 4:57 pm
by No_Mercy
Now I think I see a problem...

All the posts were like a bit forwards 'Days like 24th, 25th, are the recent ones'

That means now it says it's the 21st so it's in the negatives for time since post.

Is there a way to fix any of this without waiting until like the 26th?

Posted: Sun Jan 21, 2007 4:58 pm
by stevemaury
Log out, so that the timezone set in your ACP is operative, whatever it is (check its offset first in the ACP). Now, compare the TIME displayed on the Index page with the correct time as determined by your forum's offset. Is the TIME in the future????

Posted: Sun Jan 21, 2007 4:58 pm
by who_cares
No_Mercy wrote: Is there a way to fix any of this without waiting until like the 26th?

you could start by having your host set the clock properly