Page 1 of 1

Need help-email at registration

Posted: Mon Apr 23, 2007 11:46 am
by patrunjelu
Whenever a new user registrates on my forum,he gets this error.I don't know what the problem is...so i want you to tell me how to fix it.. Thanks.

Code: Select all

Failed sending email :: PHP ::

DEBUG MODE

Line : 234
File : emailer.php
Why do i (test user) get this error ?

Re: Need help-email at registration

Posted: Mon Apr 23, 2007 12:24 pm
by MikovChain
Because you set the account be actived by user himself at your admin control panel.

The location of it:
phpBB Administration->General Admin->Configuration->Enable account activation (None User Admin)

You can simply set it to "NONE". Then the new register won't see the debug information again.

In a standard version of phpbb, you can't disable the email function built in the system. So if user set watching some topic, you will meet this information again.
You can google the error message for solution. You may need some code change.

Re: Need help-email at registration

Posted: Mon Apr 23, 2007 1:47 pm
by rvmomma
this is really bad advice.

setting to none means that anyone in the world ( read spammers ) can register and post to your board.

the problem here is that your email on your server is not working.

try this,
go to the admin panel, set smtp to yes and put localhost in the server box.

then test,

if that does not work, then contact your host and ask them how to send mail from your server using php.

phpbb can only use whatever the host has setup for you. phpbb even gives you two ways to use the server's email but it is ultimately up to the host whether the email on his server works or not.

Re: Need help-email at registration

Posted: Mon Apr 23, 2007 2:29 pm
by MikovChain
I don't think the registration without email authentication is a bad idea.
For a board at startup stage, it need easy registration for more members, while for the spammers, we can block them in other ways.

It's just my opinion, because I don't want to waste my time in activating my account.
And you can see at my board, the spammers are fully under control :)

Re: Need help-email at registration

Posted: Tue Apr 24, 2007 12:51 am
by rvmomma
MikovChain wrote: I don't think the registration without email authentication is a bad idea.
For a board at startup stage, it need easy registration for more members, while for the spammers, we can block them in other ways.

It's just my opinion, because I don't want to waste my time in activating my account.
And you can see at my board, the spammers are fully under control :)

you are certainly entitled to your opinion and can run your board as you see fit.

however, we spend way too much time here trying to help people get the spam under control.without you telling them to leave the activation to "none" that is one of the main things we tell everyone not to do if they want to keep out the spammers.

yes, there are ways around it, but those same people that are just starting, don't need this hassle to have to deal with as well.

Re: Need help-email at registration

Posted: Tue Apr 24, 2007 1:33 am
by Marshalrusty
I'll solve this by saying that even when set to 'None', the board will send an email saying "Thanks for registering". In other words, the error will still be displayed.

Here is a KB article regarding this issue: http://www.phpbb.com/kb/article/explana ... 234-error/