Problem with new/additional language pack

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
kulinar
Registered User
Posts: 651
Joined: Thu Feb 17, 2005 7:31 pm
Contact:

Problem with new/additional language pack

Post by kulinar » Fri May 04, 2007 3:07 pm

I just installed vanilla 2.0.22 and added/uploaded/ Bulgarian language pack. Then in ACP I changed the language to Bulgarian. What was my surprise to see that the board's language is English. I checked my DB, pbpbb_config table and my board language is Bulgarian. I made a test, deleted lang_bulgarian directory and... nothing changed: no error messages, language is still English and in phpbb_config is still bulgarian. I don't know whether that is a bug or I did something wrong.

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50922
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Problem with new/additional language pack

Post by stevemaury » Fri May 04, 2007 3:16 pm

From the Downloads page -

"To install a language pack simply decompress the downloaded package into the languages/ directory. It will immediately become available to all users.

Do not forget to download the related subSilver package, this contains localised button images for the default subSilver style. These should be decompressed in the templates/ directory. Support for these is automatic when the appropriate language is utilised.

Remember when decompressing the package that you must retain the directory or folder structure. If you are unsure how to do this with your software please check its documentation. Failure to retain the directory structure will result in the language not being available."

P.S. Did you change the language in your Profile?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

kulinar
Registered User
Posts: 651
Joined: Thu Feb 17, 2005 7:31 pm
Contact:

Re: Problem with new/additional language pack

Post by kulinar » Fri May 04, 2007 3:27 pm

stevemaury wrote: From the Downloads page -
....................................................
I did all that stuff.
stevemaury wrote: P.S. Did you change the language in your Profile?
Board language is still English when I am logged out.

User avatar
Marshalrusty
Project Manager
Project Manager
Posts: 29253
Joined: Mon Nov 22, 2004 10:45 pm
Location: New York City
Name: Yuriy Rusko
Contact:

Re: Problem with new/additional language pack

Post by Marshalrusty » Sat May 05, 2007 7:42 am

In the administration panel>configuration, set the default language to Bulgarian. The setting there will determine the default setting for guests and new users. All existing users will need to change this for themselves in their profiles.
Have comments/praise/complaints/suggestions? Please feel free to PM me.

Need private help? Hire me for all your phpBB and web development needs

kulinar
Registered User
Posts: 651
Joined: Thu Feb 17, 2005 7:31 pm
Contact:

Re: Problem with new/additional language pack

Post by kulinar » Sat May 05, 2007 8:36 am

Marshalrusty wrote: In the administration panel>configuration, set the default language to Bulgarian.
As I said before, I already did that.
Marshalrusty wrote: The setting there will determine the default setting for guests and new users.
Well, that is the strange thing. The language for guests was still English.
Marshalrusty wrote: All existing users will need to change this for themselves in their profiles.
Sure.

It is OK right now. After I changed the personal setting of the admin user (the only user), everything went right. I think that's a bug and I will report it when I have time.

User avatar
karlsemple
Former Team Member
Posts: 39802
Joined: Mon Nov 01, 2004 8:54 am
Location: Hereford, UK
Contact:

Re: Problem with new/additional language pack

Post by karlsemple » Sat May 05, 2007 8:40 am

Check the database phpbb_config database table and see what value is for the config_name "default_lang"
Image

kulinar
Registered User
Posts: 651
Joined: Thu Feb 17, 2005 7:31 pm
Contact:

Re: Problem with new/additional language pack

Post by kulinar » Sat May 05, 2007 8:47 am

karlsemple wrote: Check the database phpbb_config database table and see what value is for the config_name "default_lang"
In the first post of the thread kulinar wrote: I checked my DB, pbpbb_config table and my board language is Bulgarian.

User avatar
karlsemple
Former Team Member
Posts: 39802
Joined: Mon Nov 01, 2004 8:54 am
Location: Hereford, UK
Contact:

Re: Problem with new/additional language pack

Post by karlsemple » Sat May 05, 2007 8:49 am

kulinar wrote:
karlsemple wrote: Check the database phpbb_config database table and see what value is for the config_name "default_lang"
In the first post of the thread kulinar wrote: I checked my DB, pbpbb_config table and my board language is Bulgarian.



Is that language pack present and complete, with the proper file permissions so the forum can access it, the language normally only defaults back to English if the board default language pack can not be found or accessed
Image

kulinar
Registered User
Posts: 651
Joined: Thu Feb 17, 2005 7:31 pm
Contact:

Re: Problem with new/additional language pack

Post by kulinar » Sat May 05, 2007 8:54 am

OK, guys. The problem is solved. Thanks all.

User avatar
karlsemple
Former Team Member
Posts: 39802
Joined: Mon Nov 01, 2004 8:54 am
Location: Hereford, UK
Contact:

Re: Problem with new/additional language pack

Post by karlsemple » Sat May 05, 2007 8:57 am

kulinar wrote: OK, guys. The problem is solved. Thanks all.



what was the issue for future users who may have this problem :)
Image

Locked

Return to “2.0.x Support Forum”