Page 1 of 1

Problem with new/additional language pack

Posted: Fri May 04, 2007 3:07 pm
by kulinar
I just installed vanilla 2.0.22 and added/uploaded/ Bulgarian language pack. Then in ACP I changed the language to Bulgarian. What was my surprise to see that the board's language is English. I checked my DB, pbpbb_config table and my board language is Bulgarian. I made a test, deleted lang_bulgarian directory and... nothing changed: no error messages, language is still English and in phpbb_config is still bulgarian. I don't know whether that is a bug or I did something wrong.

Re: Problem with new/additional language pack

Posted: Fri May 04, 2007 3:16 pm
by stevemaury
From the Downloads page -

"To install a language pack simply decompress the downloaded package into the languages/ directory. It will immediately become available to all users.

Do not forget to download the related subSilver package, this contains localised button images for the default subSilver style. These should be decompressed in the templates/ directory. Support for these is automatic when the appropriate language is utilised.

Remember when decompressing the package that you must retain the directory or folder structure. If you are unsure how to do this with your software please check its documentation. Failure to retain the directory structure will result in the language not being available."

P.S. Did you change the language in your Profile?

Re: Problem with new/additional language pack

Posted: Fri May 04, 2007 3:27 pm
by kulinar
stevemaury wrote: From the Downloads page -
....................................................
I did all that stuff.
stevemaury wrote: P.S. Did you change the language in your Profile?
Board language is still English when I am logged out.

Re: Problem with new/additional language pack

Posted: Sat May 05, 2007 7:42 am
by Marshalrusty
In the administration panel>configuration, set the default language to Bulgarian. The setting there will determine the default setting for guests and new users. All existing users will need to change this for themselves in their profiles.

Re: Problem with new/additional language pack

Posted: Sat May 05, 2007 8:36 am
by kulinar
Marshalrusty wrote: In the administration panel>configuration, set the default language to Bulgarian.
As I said before, I already did that.
Marshalrusty wrote: The setting there will determine the default setting for guests and new users.
Well, that is the strange thing. The language for guests was still English.
Marshalrusty wrote: All existing users will need to change this for themselves in their profiles.
Sure.

It is OK right now. After I changed the personal setting of the admin user (the only user), everything went right. I think that's a bug and I will report it when I have time.

Re: Problem with new/additional language pack

Posted: Sat May 05, 2007 8:40 am
by karlsemple
Check the database phpbb_config database table and see what value is for the config_name "default_lang"

Re: Problem with new/additional language pack

Posted: Sat May 05, 2007 8:47 am
by kulinar
karlsemple wrote: Check the database phpbb_config database table and see what value is for the config_name "default_lang"
In the first post of the thread kulinar wrote: I checked my DB, pbpbb_config table and my board language is Bulgarian.

Re: Problem with new/additional language pack

Posted: Sat May 05, 2007 8:49 am
by karlsemple
kulinar wrote:
karlsemple wrote: Check the database phpbb_config database table and see what value is for the config_name "default_lang"
In the first post of the thread kulinar wrote: I checked my DB, pbpbb_config table and my board language is Bulgarian.



Is that language pack present and complete, with the proper file permissions so the forum can access it, the language normally only defaults back to English if the board default language pack can not be found or accessed

Re: Problem with new/additional language pack

Posted: Sat May 05, 2007 8:54 am
by kulinar
OK, guys. The problem is solved. Thanks all.

Re: Problem with new/additional language pack

Posted: Sat May 05, 2007 8:57 am
by karlsemple
kulinar wrote: OK, guys. The problem is solved. Thanks all.



what was the issue for future users who may have this problem :)