Page 1 of 2

[Answd] I'm screwed!

Posted: Thu Nov 21, 2002 6:01 pm
by Slim~keith
i have installed most all of the MODs on my 2.0.3 version board. everything seem to run smooth but. i have added some "moderators"in the past but i was trying to add one more and i got an error!First thing i did was go search. i found a few thingts that may help but NO real answer.
--------------------------------------------------------
Couldn't update private forum permissions

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax near ' 1)' at line 2

INSERT INTO phpbb_auth_access (forum_id, group_id, auth_mod) VALUES (1, , 1)

Line : 385
File : d:\www\stranke\***********.com\forum\admin\admin_ug_auth.php
--------------------------------------------------------------------

Can someone help me with this?

Posted: Fri Nov 22, 2002 3:26 am
by Slim~keith
humm... :roll:

Posted: Fri Nov 22, 2002 9:20 am
by primedomain
Have you modified admin_ug_auth.php in any way?

Posted: Sat Nov 23, 2002 5:56 pm
by Slim~keith
I didn't think so. but the first thing i did was replace that file with the original file! please tell me that the error is not telling me the table's are not screwed up.

Posted: Sat Nov 23, 2002 6:01 pm
by primedomain
so the error persists even after you have deleted this file and re-uploaded it in ASCII?

Posted: Sat Nov 23, 2002 6:15 pm
by Slim~keith
Well all i did was overwrite the file. i had it on auto but i will try your way!

Posted: Sun Nov 24, 2002 3:35 am
by Slim~keith
OK, i just did that and No luck :roll:. Do you have more ideas?

Posted: Sun Nov 24, 2002 4:11 am
by issue9mm
Well, by reading the error message, it indicates that there is no value for the "group_id". For whatever reason, it's not populating the query with that value , as evidenced by the (1, , 1) portion of the INSERT statement. That's causing a syntax error, and mySQL isn't able to do an insert.

Post a copy of your admin_ug_auth.php file and that should give us more insight as to why that field isn't being populated.

-9mm-

Posted: Mon Nov 25, 2002 3:43 am
by Slim~keith
I'm hopeing this is what you want!

Posted: Mon Nov 25, 2002 5:29 pm
by Slim~keith
bump :?

Posted: Tue Nov 26, 2002 4:41 pm
by Slim~keith
i will not give up! i need an Answer.....

Posted: Tue Nov 26, 2002 5:33 pm
by R. U. Serious
Save the following script as .php in your phpbb folder and run it from your browser:
http://www.phpbb.com/phpBB/viewtopic.ph ... highlight=

Posted: Wed Nov 27, 2002 6:37 am
by Slim~keith
R. U. Serious, you are the man! "THANK YOU" so much that worked the first time! :wink:

Many thanks from Taiwan, too

Posted: Tue Dec 03, 2002 4:24 am
by gussie
Thank you from me, too! 8)

I was stumped by the Delete (personal) Group problem I encountered after I installed Niels' Delete Inactive Users mod (http://mods.db9.dk/viewtopic.php?t=460)

I'm unsure this is related to his mod per se. He requested that we try deleting someone using the regular ACP Members Management form. I got the same problem -- suggesting it is a problem with the underlying database.

Tommy's (dkklein) solution assigns Personal Group IDs to inactive accounts -- then allowing Niels mod to do its thing.

Whew! Blew 2 hours trying to figure this out :oops:

Posted: Sun Feb 09, 2003 1:59 pm
by danb00
You saved my life!!

Is this a know bug then?

Cos that script worked.

works on phpbb 2.0.4