Page 1 of 1

Can't get my forum to launch. Poor instructions for noobs.

Posted: Wed Oct 03, 2007 12:09 am
by vcxzzxcvvcxzzxcv
OK, I searched the forum for a similar problem, and the one I found seemed unresolved to me.

OK, I have been an ametuer webmaster for a couple of years, and now I want to add a forum to my site. I am brand new to php, and sql. So I printed the entire phpbb userguide. Here is what I have done so far:

- I downloaded the zip file of phpbb2 to my computer
- I extracted the whole thing to my website folder.
- Using FrontPage, I opened my website and made sure the file was there.
- Then I published my site to my Server using the ftp thingy.

My server doess support php and mysql. I use freeservers.com (upgraded for php etc)

- I opened the folder in my browser by typing the address http:/mywebsite.com/phpbb2. It only showed the root directory.

This puzzled me because according to step 1, after doing this everything else is supposed to be "fully automated" according to the instructions.

- I went back into the instructions and noticed it said that if the files end in .php that they must be changed to either .php3 or .phtml.
- So I went in and changed every single php file in every single folder to .php3.
- I erased the entire old phpbb2 folder from my server, then republished the new phpbb2 folder with the new extensions.

I got the exact same result - root directory. No "fully automated" anything.

I called my server's tech support, and they acted like they have never heard of phpbb, but then they said that their servers DO support it, but they really weren't any more help.

Should I go back and change all the extensions to .phtml? And why on EARTH would the zip files not be 'properly' named? And what is a "shell access"? And how are a "vast majority of these steps unnecessary"?

Any help getting me past step 1 would be greatly appreciated!

Re: Can't get my forum to launch. Poor instructions for noobs.

Posted: Wed Oct 03, 2007 12:16 am
by ric323
Do not use FrontPage for anything to do with PHP files!

Just unzip the install package onto your PC's hard drive, then use a plain FTP program (like FileZilla, Cute_FTP, WS_FTP etc.) to upload the files up onto your web server.
Do NOT use any Microsoft "publish" option, that can be guaranteed to alter the files.

There are a number of "how to" guides and walkthrough on how to do this up in the "Read me before posting/FAQ" topic at the head of this forum.

Re: Can't get my forum to launch. Poor instructions for noobs.

Posted: Wed Oct 03, 2007 12:19 am
by will_hough
A few phpBB2.x Flash Tutorials - http://www.phpbb.com/support/tutorials/2.0/

Re: Can't get my forum to launch. Poor instructions for noobs.

Posted: Mon Oct 15, 2007 2:50 am
by chicagotransam
The reason is you must first turn on CGI (under your control panel on freeservers.com). Then, you must upload your forum to your /CGI folder.

Re: Can't get my forum to launch. Poor instructions for noobs.

Posted: Tue Oct 16, 2007 6:24 am
by Lumpy Burgertushie
chicagotransam wrote:The reason is you must first turn on CGI (under your control panel on freeservers.com). Then, you must upload your forum to your /CGI folder.
do you know this for certain? do you have a freeserver.com account?

phpbb should never be installed inside the cgi-gin folder. as far as that goes, php should not be installed as a cgi module to start with.

if you install to the cgi folder, then some or all of your images will not work as well as other things.

if your host does not know how to setup their servers correctly for php to work, then I would suggest finding a better host.

robert