[FIXED] Really need help fixing a problem please.

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
User avatar
DrJOnes666
Registered User
Posts: 65
Joined: Wed Aug 21, 2002 8:43 pm

[FIXED] Really need help fixing a problem please.

Post by DrJOnes666 »

Hi,

I searched through this forum to fix the "Could not insert data into groups table" when a new user tries to register, a problem I've been having for a couple of weeks now.

I've narrowed down the problem a bit more.
The thing that happens each time a new member tries to register is this: in the group table, the new user is assigned the following grou_id number: 8388607 . This doesn't make much sense, because the highest number before that is 187. Once that number (8388607) has been added to the group table, no one else can register and the error message "Could not insert data into groups table" appears each time a new user tries to register and his data is not added to the database.

Worth mentioning: if I try to create a new group in the admin panel, the same problem occurs. After I delete the 8388607 entry, I can create the new group in the admin panel, but the same group_id number appears at the end of the group table, and the problem starts over again.


Now, questions:

- WHY is that specific number being added to the group_id everytime a new user tries to register?
- WHY does this block any further new user from registering?
- HOW can I correct this problem?

I have tried the fix from this topic http://www.phpbb.com/phpBB/viewtopic.ph ... highlight= , but it doesn't the problem I have.


SPECS:
I have 2.03 installed.
I have the "default avatar" mod installed.
I am using Grunge skin.
I have the "extended user search" mod installed.

Here is the DEBUG MODE MESSAGE:
=======================
Could not insert data into groups table

DEBUG MODE

SQL Error : 1062 Duplicate entry '8388607' for key 1

INSERT INTO phpbb_groups (group_name, group_description, group_single_user, group_moderator) VALUES ('', 'Personal User', 1, 0)

Line : 524
File : /www/mperreault/latexlover/bianca/forum/includes/usercp_register.php
========================



I would really like to fix this problem once and for all (I've posted here before about it) so all suggestions will be more than welcome.

If there is no direct fix, is there any other way I can do this? Like:
- backup my user data
- back up my messages
- re-install PHPBB from scratch
- restore the date

Would this fix the problem? If so, how would I go on backuping all the data?



Thank you.

DrJOnes666
Last edited by DrJOnes666 on Fri Dec 06, 2002 8:27 pm, edited 1 time in total.
User avatar
zeroK
Former Team Member
Posts: 20964
Joined: Sun Jan 20, 2002 7:36 pm
Location: Klagenfurt / Austria
Contact:

Post by zeroK »

is group_id set to auto_inclrement? you can check this via phpMyAdmin.
Image My weblog | gamerslog.com | No support via PM or ICQ or email - If you don't know a term or a program mentioned in a post -> Google is your friend
User avatar
DrJOnes666
Registered User
Posts: 65
Joined: Wed Aug 21, 2002 8:43 pm

Post by DrJOnes666 »

where is phpmyadmin?
User avatar
DrJOnes666
Registered User
Posts: 65
Joined: Wed Aug 21, 2002 8:43 pm

Post by DrJOnes666 »

If I go in the MySQL admin and look at the table config, it says:
group_id mediumint(8) No Primary NULL auto_increment


If the autoincrement worked, wouldn't the next goup_id be 185 instead of '8388607' (the highest group_id is currently 184).

Why does it keep adding the '8388607' number?
User avatar
DrJOnes666
Registered User
Posts: 65
Joined: Wed Aug 21, 2002 8:43 pm

Post by DrJOnes666 »

I made a search in the forums (again) and found a code to fix the corrupted table.

The problem is now gone and fixed for good.

DrJOnes666
User avatar
gussie
Registered User
Posts: 92
Joined: Wed Nov 27, 2002 1:26 am

Do you mean this one?

Post by gussie »

User avatar
DrJOnes666
Registered User
Posts: 65
Joined: Wed Aug 21, 2002 8:43 pm

Post by DrJOnes666 »

That's the one!

DrJOnes666
Locked

Return to “2.0.x Support Forum”