Default Styles

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
juliekate
Registered User
Posts: 779
Joined: Sun May 05, 2002 5:32 pm
Location: Philadelphia
Contact:

Post by juliekate » Fri Jan 03, 2003 2:01 pm

You are using English as your main language on the board, right?

Everything looks as it should be, but if the "$lang['Configuration'] = 'Configuration';" or something isn't defined in the language file, that could cause it not to show up.

Go to root/languages/lang_english/lang_admin.php and look for this line:

Code: Select all

$lang['Configuration'] = 'Configuration';
Make sure this is there (it's at the beginning)

Then go down the file a bit to here:

Code: Select all

//
// Configuration
//
$lang['General_Config'] = 'General Configuration';
Paste the chunk of text there and a little below it.

Get2sammyb
Registered User
Posts: 87
Joined: Mon Dec 16, 2002 5:36 pm
Location: Midlands
Contact:

Post by Get2sammyb » Fri Jan 03, 2003 5:48 pm

Here we go -

Code: Select all

[code]
//
// Configuration
//
$lang['General_Config'] = 'General Configuration';
$lang['Config_explain'] = 'The form below will allow you to customize all the general board options. For User and Forum configurations use the related links on the left hand side.';

$lang['Click_return_config'] = 'Click %sHere%s to return to General Configuration';

$lang['General_settings'] = 'General Board Settings';
$lang['Server_name'] = 'Domain Name';
$lang['Server_name_explain'] = 'The domain name this board runs from';
$lang['Script_path'] = 'Script path';
$lang['Script_path_explain'] = 'The path where phpBB2 is located relative to the domain name';
$lang['Server_port'] = 'Server Port';
$lang['Server_port_explain'] = 'The port your server is running on, usually 80, only change if different';
$lang['Site_name'] = 'Site name';
$lang['Site_desc'] = 'Site description';
$lang['Board_disable'] = 'Disable board';
$lang['Board_disable_explain'] = 'This will make the board unavailable to users. Do not logout when you disable the board, you will not be able to log back in!';
$lang['Acct_activation'] = 'Enable account activation';
$lang['Acc_None'] = 'None'; // These three entries are the type of activation
$lang['Acc_User'] = 'User';
$lang['Acc_Admin'] = 'Admin';

$lang['Abilities_settings'] = 'User and Forum Basic Settings';
$lang['Max_poll_options'] = 'Max number of poll options';
$lang['Flood_Interval'] = 'Flood Interval';
$lang['Flood_Interval_explain'] = 'Number of seconds a user must wait between posts'; 
$lang['Board_email_form'] = 'User email via board';
$lang['Board_email_form_explain'] = 'Users send email to each other via this board';
$lang['Topics_per_page'] = 'Topics Per Page';
$lang['Posts_per_page'] = 'Posts Per Page';
$lang['Hot_threshold'] = 'Posts for Popular Threshold';
$lang['Default_style'] = 'Default Style';
$lang['Override_style'] = 'Override user style';
$lang['Override_style_explain'] = 'Replaces users style with the default';
$lang['Default_language'] = 'Default Language';
$lang['Date_format'] = 'Date Format';
$lang['System_timezone'] = 'System Timezone';
$lang['Enable_gzip'] = 'Enable GZip Compression';
$lang['Enable_prune'] = 'Enable Forum Pruning';
$lang['Allow_HTML'] = 'Allow HTML';
$lang['Allow_BBCode'] = 'Allow BBCode';
$lang['Allowed_tags'] = 'Allowed HTML tags';
$lang['Allowed_tags_explain'] = 'Separate tags with commas';
$lang['Allow_smilies'] = 'Allow Smilies';
$lang['Smilies_path'] = 'Smilies Storage Path';
$lang['Smilies_path_explain'] = 'Path under your phpBB root dir, e.g. images/smiles';
$lang['Allow_sig'] = 'Allow Signatures';
$lang['Max_sig_length'] = 'Maximum signature length';
$lang['Max_sig_length_explain'] = 'Maximum number of characters in user signatures';
$lang['Allow_name_change'] = 'Allow Username changes';

$lang['Avatar_settings'] = 'Avatar Settings';
$lang['Allow_local'] = 'Enable gallery avatars';
$lang['Allow_remote'] = 'Enable remote avatars';
$lang['Allow_remote_explain'] = 'Avatars linked to from another website';
$lang['Allow_upload'] = 'Enable avatar uploading';
$lang['Max_filesize'] = 'Maximum Avatar File Size';
$lang['Max_filesize_explain'] = 'For uploaded avatar files';
$lang['Max_avatar_size'] = 'Maximum Avatar Dimensions';
$lang['Max_avatar_size_explain'] = '(Height x Width in pixels)';
$lang['Avatar_storage_path'] = 'Avatar Storage Path';
$lang['Avatar_storage_path_explain'] = 'Path under your phpBB root dir, e.g. images/avatars';
$lang['Avatar_gallery_path'] = 'Avatar Gallery Path';
$lang['Avatar_gallery_path_explain'] = 'Path under your phpBB root dir for pre-loaded images, e.g. images/avatars/gallery';

$lang['COPPA_settings'] = 'COPPA Settings';
$lang['COPPA_fax'] = 'COPPA Fax Number';
$lang['COPPA_mail'] = 'COPPA Mailing Address';
$lang['COPPA_mail_explain'] = 'This is the mailing address where parents will send COPPA registration forms';

$lang['Email_settings'] = 'Email Settings';
$lang['Admin_email'] = 'Admin Email Address';
$lang['Email_sig'] = 'Email Signature';
$lang['Email_sig_explain'] = 'This text will be attached to all emails the board sends';
$lang['Use_SMTP'] = 'Use SMTP Server for email';
$lang['Use_SMTP_explain'] = 'Say yes if you want or have to send email via a named server instead of the local mail function';
$lang['SMTP_server'] = 'SMTP Server Address';
$lang['SMTP_username'] = 'SMTP Username';
$lang['SMTP_username_explain'] = 'Only enter a username if your smtp server requires it';
$lang['SMTP_password'] = 'SMTP Password';
$lang['SMTP_password_explain'] = 'Only enter a password if your smtp server requires it';

$lang['Disable_privmsg'] = 'Private Messaging';
$lang['Inbox_limits'] = 'Max posts in Inbox';
$lang['Sentbox_limits'] = 'Max posts in Sentbox';
$lang['Savebox_limits'] = 'Max posts in Savebox';

$lang['Cookie_settings'] = 'Cookie settings'; 
$lang['Cookie_settings_explain'] = 'These details define how cookies are sent to your users browsers. In most cases the default values for the cookie settings should be sufficient but if you need to change them do so with care, incorrect settings can prevent users logging in';
$lang['Cookie_domain'] = 'Cookie domain';
$lang['Cookie_name'] = 'Cookie name';
$lang['Cookie_path'] = 'Cookie path';
$lang['Cookie_secure'] = 'Cookie secure';
$lang['Cookie_secure_explain'] = 'If your server is running via SSL set this to enabled else leave as disabled';
$lang['Session_length'] = 'Session length [ seconds ]';
[/code]

That text was there by the way, the first code you mentioned.[/code]
Image

User avatar
Techie-Micheal
Security Consultant
Posts: 19511
Joined: Sun Oct 14, 2001 12:11 am
Location: In your servers

Post by Techie-Micheal » Fri Jan 03, 2003 6:16 pm

Okay. Let's walk through this:
1. You have reuploaded the files in ASCII.
2. You have no MODs.
3. You have upgraded.

Any of these correct?
Proven Offensive Security Expertise. OSCP - GXPN

Get2sammyb
Registered User
Posts: 87
Joined: Mon Dec 16, 2002 5:36 pm
Location: Midlands
Contact:

Post by Get2sammyb » Fri Jan 03, 2003 7:53 pm

Techie-Micheal wrote: Okay. Let's walk through this:
1. You have reuploaded the files in ASCII.
2. You have no MODs.
3. You have upgraded.

Any of these correct?


1. Yes.
2. I have several.
3. Upgraded to what?

Ta for the help guys.

I will also give you some background.

Forum has been working fine. I installed Subblack3d and wanted to set it as default, except I had no 'configuration' link, like the instructions told me. I created this topic.

My host moved servers and we decided to park my forwarding domain. 'cubers.cyberscore.net/forum/phpBB2/' became 'cubers.co.uk/forum/phpBB2/'. Cookie problems arose, I needed to change the route in the 'configuration' link. I don't have one.

Now when someone is on cubers, if they close the window which the forum is loaded in, or load a new page ontopof the forum, when they return it tells them to log in.

Sometimes users can't even log in, when they type in their username and password it takes them to the homepage.

The problem has developed since I created this topic.
Image

User avatar
Techie-Micheal
Security Consultant
Posts: 19511
Joined: Sun Oct 14, 2001 12:11 am
Location: In your servers

Post by Techie-Micheal » Fri Jan 03, 2003 9:07 pm

Ah. Here I thought you didn't have any MODs. Something tells me that one or more of those MODs has something to do with that. :) Remove all of your MODs and we'll go from there. Upgrade to 2.0.3 of course.
Proven Offensive Security Expertise. OSCP - GXPN

Get2sammyb
Registered User
Posts: 87
Joined: Mon Dec 16, 2002 5:36 pm
Location: Midlands
Contact:

Post by Get2sammyb » Sat Jan 04, 2003 12:39 pm

Ok then. I downloaded 2.0.3 and uploaded, and it was still the same. Right ok then, can I ask why I have to remove my mods. They don't have any admin or FTP access.
Image

User avatar
zeroK
Former Team Member
Posts: 20964
Joined: Sun Jan 20, 2002 7:36 pm
Location: Klagenfurt / Austria
Contact:

Post by zeroK » Sat Jan 04, 2003 12:43 pm

i think there is a misunderstanding ;) under MODs we understand modifications of the board :) and not moderators :)
Image My weblog | gamerslog.com | No support via PM or ICQ or email - If you don't know a term or a program mentioned in a post -> Google is your friend

Locked

Return to “2.0.x Support Forum”