Help Please...!

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
Crumblylettuce
Registered User
Posts: 488
Joined: Sat Apr 06, 2002 6:43 pm

Help Please...!

Post by Crumblylettuce » Fri Dec 27, 2002 3:12 pm

Ummm yes.

I backed up the database on my lycos hosted forum.

Then when i got onto a new forum, on a new host, i went to restore data base. And then, after a while i got this message:
phpBB : Critical Error

Could not get theme data for themes_id [5]


:cry: help!

Mr C.Lettuce

User avatar
zeroK
Former Team Member
Posts: 20964
Joined: Sun Jan 20, 2002 7:36 pm
Location: Klagenfurt / Austria
Contact:

Post by zeroK » Fri Dec 27, 2002 3:18 pm

check the database if there#s a row with the theme_id = 5 in the phpbb_themes table :)
Image My weblog | gamerslog.com | No support via PM or ICQ or email - If you don't know a term or a program mentioned in a post -> Google is your friend

Crumblylettuce
Registered User
Posts: 488
Joined: Sat Apr 06, 2002 6:43 pm

Post by Crumblylettuce » Fri Dec 27, 2002 3:22 pm

i dont know what to do cos i dont have access to the database!

User avatar
zeroK
Former Team Member
Posts: 20964
Joined: Sun Jan 20, 2002 7:36 pm
Location: Klagenfurt / Austria
Contact:

Post by zeroK » Fri Dec 27, 2002 3:25 pm

sure you have. there is a management link or something like that in the php4u section in your lycos-account panel :)
Image My weblog | gamerslog.com | No support via PM or ICQ or email - If you don't know a term or a program mentioned in a post -> Google is your friend

Crumblylettuce
Registered User
Posts: 488
Joined: Sat Apr 06, 2002 6:43 pm

Post by Crumblylettuce » Fri Dec 27, 2002 3:29 pm

but i have moved away from lycos! 8)

maybe you should explain more, i am really crap with phpBB stuff.

User avatar
zeroK
Former Team Member
Posts: 20964
Joined: Sun Jan 20, 2002 7:36 pm
Location: Klagenfurt / Austria
Contact:

Post by zeroK » Fri Dec 27, 2002 3:38 pm

oh :oops: then install phpMyAdmin :)
http://www.phpmyadmin.net
Image My weblog | gamerslog.com | No support via PM or ICQ or email - If you don't know a term or a program mentioned in a post -> Google is your friend

Crumblylettuce
Registered User
Posts: 488
Joined: Sat Apr 06, 2002 6:43 pm

Post by Crumblylettuce » Fri Dec 27, 2002 3:41 pm

:cry:

what do i do if i find that then?

should it or shouldnt it be there?

I know thisis ridiculous, but im a complete n00b

User avatar
zeroK
Former Team Member
Posts: 20964
Joined: Sun Jan 20, 2002 7:36 pm
Location: Klagenfurt / Austria
Contact:

Post by zeroK » Fri Dec 27, 2002 3:48 pm

probably it isn#t there. then you'll have to generate it manually. additonally could you please post the full error message after enabling the debug mode? :)
http://www.phpbb.com/phpBB/viewtopic.php?t=13308
Image My weblog | gamerslog.com | No support via PM or ICQ or email - If you don't know a term or a program mentioned in a post -> Google is your friend

Crumblylettuce
Registered User
Posts: 488
Joined: Sat Apr 06, 2002 6:43 pm

Post by Crumblylettuce » Fri Dec 27, 2002 5:42 pm

I don't have ftp access!

Crumblylettuce
Registered User
Posts: 488
Joined: Sat Apr 06, 2002 6:43 pm

Post by Crumblylettuce » Fri Dec 27, 2002 8:05 pm

can n e one tell me what i actually did wrong?

User avatar
MSENYSZAK
Registered User
Posts: 178
Joined: Tue Jul 30, 2002 5:27 pm
Location: Perth, Scotland (AND PROUD :) )
Contact:

Post by MSENYSZAK » Sun Dec 29, 2002 12:22 pm

hi its me thats hosting:

no row like you said in phpbb_themes

the error even with debug on is:

phpBB : Critical Error

Could not get theme data for themes_id [5] [/code]

User avatar
zeroK
Former Team Member
Posts: 20964
Joined: Sun Jan 20, 2002 7:36 pm
Location: Klagenfurt / Austria
Contact:

Post by zeroK » Sun Dec 29, 2002 12:29 pm

are the subsilver files still on the server? if so then just make a query like this :)

Code: Select all

INSERT INTO `phpbb_themes` (`themes_id`, `template_name`, `style_name`, `head_stylesheet`, `body_background`, `body_bgcolor`, `body_text`, `body_link`, `body_vlink`, `body_alink`, `body_hlink`, `tr_color1`, `tr_color2`, `tr_color3`, `tr_class1`, `tr_class2`, `tr_class3`, `th_color1`, `th_color2`, `th_color3`, `th_class1`, `th_class2`, `th_class3`, `td_color1`, `td_color2`, `td_color3`, `td_class1`, `td_class2`, `td_class3`, `fontface1`, `fontface2`, `fontface3`, `fontsize1`, `fontsize2`, `fontsize3`, `fontcolor1`, `fontcolor2`, `fontcolor3`, `span_class1`, `span_class2`, `span_class3`, `img_size_poll`, `img_size_privmsg`) VALUES (1, 'subSilver', 'subSilver', 'subSilver.css', '', 'E5E5E5', '000000', '006699', '5493B4', '', 'DD6900', 'EFEFEF', 'DEE3E7', 'D1D7DC', '', '', '', '98AAB1', '006699', 'FFFFFF', 'cellpic1.gif', 'cellpic3.gif', 'cellpic2.jpg', 'FAFAFA', 'FFFFFF', '', 'row1', 'row2', '', 'Verdana, Arial, Helvetica, sans-serif', 'Trebuchet MS', 'Courier, \'Courier New\', sans-serif', 10, 11, 12, '444444', '006600', 'FFA34F', '', '', '', NULL, NULL);
this should install the subSilver template set again. no change the user_style of your profile in the phpbb_users table back to 1 and you should be able to get to the admin panel again where you can install the other templates :)
Image My weblog | gamerslog.com | No support via PM or ICQ or email - If you don't know a term or a program mentioned in a post -> Google is your friend

User avatar
MSENYSZAK
Registered User
Posts: 178
Joined: Tue Jul 30, 2002 5:27 pm
Location: Perth, Scotland (AND PROUD :) )
Contact:

Post by MSENYSZAK » Sun Dec 29, 2002 12:35 pm

error:

MySQL said:


Duplicate entry '1' for key 1

User avatar
MSENYSZAK
Registered User
Posts: 178
Joined: Tue Jul 30, 2002 5:27 pm
Location: Perth, Scotland (AND PROUD :) )
Contact:

Post by MSENYSZAK » Mon Dec 30, 2002 7:59 pm

hello? *taps on glass*

Locked

Return to “2.0.x Support Forum”

cron