How do external pictures load in the page?

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
Berend
Registered User
Posts: 285
Joined: Tue Nov 20, 2001 4:44 pm
Location: NL

How do external pictures load in the page?

Post by Berend »

Hope I can explain my question: How do external pictures load in the page?

When a user uses an exteral picture, say avatar or another, how does this load in the page? Does phpBB first load the intire page including pics before showing it on the screen or does it show the page and then loads the external pics?

hsim
Registered User
Posts: 1554
Joined: Tue Oct 23, 2001 9:39 pm
Contact:

Post by hsim »

it generates the HTML and your browser loads the pics :lol:
email me: hsim at gmx.li

Berend
Registered User
Posts: 285
Joined: Tue Nov 20, 2001 4:44 pm
Location: NL

Post by Berend »

And how does that work? First the HTML is displayed and then the pics, or all in one time, wich takes longer.

My question is about what external pics do to the speed...

hsim
Registered User
Posts: 1554
Joined: Tue Oct 23, 2001 9:39 pm
Contact:

Post by hsim »

well it completely depends on the external Server and your Browser. phpBB does nothing, neither to internal nor external pictures.
email me: hsim at gmx.li

User avatar
Eelke
QA Team
Posts: 2903
Joined: Thu Dec 20, 2001 8:00 am
Location: NL, Bussum
Name: Eelke Blok
Contact:

Post by Eelke »

Pictures are embedded in phpBB by generating an <img> HTML-tag. This is interpreted by the browser. The browser sees the tag, reads the URL in it, and downloads the pciture from whatever location is entered. phpBB has nothing to do with that process, al it does is generate the appropriate HTML.

How the browser handles it, is up to the browser; some browsers already start laying out the page when they have loaded all the HTML but not all graphics yet, others wait until everything is available and then lay out the page (well, actually, most browsers use the former method, but hey.. :) ) How fast the browser is able to load the picture depends on lots of factors, such as the speed of the connection and the speed of the server serving the picture.

hsim
Registered User
Posts: 1554
Joined: Tue Oct 23, 2001 9:39 pm
Contact:

Post by hsim »

my browser loads no pictures at all, only when I explicitly tell it to load this pic ;)
email me: hsim at gmx.li

SamG
Former Team Member
Posts: 3221
Joined: Fri Aug 31, 2001 6:35 pm
Location: Beautiful Northwest Lower Michigan
Name: Sam Graf

Post by SamG »

I think what everybody is trying to say is that an external pic does not do anything to the speed of the BB itself. You need to separate the BB from the browser when you think about this. The browser is not happy until everything is loaded for a given page. But in the case of your question, we're not too concerned about the browser. The board scripts have gone on to something else after the BB page load is done, whether your browser is happy or not.

But this means your users need to know that they can get on with business even if the browser is still trying to load the whole page - including a pic from some sleepy server somewhere. If there is a pic out there that is just taking forever to load, every internal feature of the forum is still available as it would normally be without that pic. Users do not need to wait for all external graphics to load before they can do whatever they care to do with the forums.

Berend
Registered User
Posts: 285
Joined: Tue Nov 20, 2001 4:44 pm
Location: NL

Post by Berend »

That`s what I mean. Some users complain the board is slow because they have to look at a grey screen while the page is loading. It would be nicer if they can look at the text while the pics load, but that`s browserdependant, right?

SamG
Former Team Member
Posts: 3221
Joined: Fri Aug 31, 2001 6:35 pm
Location: Beautiful Northwest Lower Michigan
Name: Sam Graf

Post by SamG »

Well, I think most browsers will display the text while the graphics are being loaded. For example, over in General Chat is a topic "My computer room (picture!)" - or something like that. Several big pictures. But in both Opera and IE, I can see the entire page, even the forum graphics, while the external pics load. I think that's the way most browsers work. So I'm not sure why your users are seeing only the background gray while external pics load. Can they scroll around, or is just nothing but gray and no scroll?

Berend
Registered User
Posts: 285
Joined: Tue Nov 20, 2001 4:44 pm
Location: NL

Post by Berend »

I get it. I`ll ask them about the scrolling.

User avatar
Eelke
QA Team
Posts: 2903
Joined: Thu Dec 20, 2001 8:00 am
Location: NL, Bussum
Name: Eelke Blok
Contact:

Post by Eelke »

I think some older browsers, in particular NS 4, are not able to layout the page before all dimensions for all elements it is going to draw are known (i.e. no dynamic redrawing when dimensions "change"). This means that when an img-tag has no size information, the dimensions are not known until the image is actually downloaded, so a single image can stop a complete page from being rendered in some browsers. Other browsers will just use some standard area-size for the time and redraw as required when (if) the image is received. Upgrade or suffer :)

SamG
Former Team Member
Posts: 3221
Joined: Fri Aug 31, 2001 6:35 pm
Location: Beautiful Northwest Lower Michigan
Name: Sam Graf

Post by SamG »

Yes, this is so. Paid the "computer room" thread a visit in NN 4.7, and it wasn't a pretty thing to see. First a row of ICQ buttons across the top - eventually. Nothing else. Then after the pics all loaded, a very badly formatted page. Pictures on top of posts. A mess.

If Berend's users are having load time problems because of NN 4, I bet they are having more problems than just that.

Monster
Registered User
Posts: 30
Joined: Fri Nov 30, 2001 12:23 pm

Post by Monster »

NS 4 is a pain in the...

I had to design a proffesional page and I was working on adding websites headers/footers to phpBB and another script. It was taking 10 seconds to load and was crashing NS4 while it was loading. I ended up giving up on it and just using the default design.

NS4 is a pathetic browser and I do not understand why it is still being distributed or being used when Netscape 6 or IE 5/6 are available and show everything better. I use IE 6 and I am not ever planning to re-install a copy of netscape on my computer. I've had enough of the software ;)

Locked

Return to “2.0.x Support Forum”