Phpbb Critical Error- "Cannot Connect to Database"

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
{TS}Mafia_aw3524
Registered User
Posts: 6
Joined: Wed Feb 12, 2003 1:05 am

Phpbb Critical Error- "Cannot Connect to Database"

Post by {TS}Mafia_aw3524 » Sun Feb 16, 2003 4:52 pm

Hey,
I just started getting that error for my forums a few days ago. I installed a fiapple template; it works good, installed a little snowflake hack, didn't work; installed a few mods, and all of a sudden; a day later I got this.

Does anyone know what's wrong?
Adam

Luciouslinda
Registered User
Posts: 190
Joined: Thu Dec 26, 2002 6:12 am
Location: Singapore
Contact:

Post by Luciouslinda » Sun Feb 16, 2003 5:00 pm

Just a question have you deleted your config.php file or modified that in anyway!

Or have you changed you DB password or username!!!
Linda

adonis_bimmer
Registered User
Posts: 8
Joined: Sun Feb 16, 2003 5:12 pm
Contact:

Post by adonis_bimmer » Sun Feb 16, 2003 5:16 pm

I also get this message
phpBB : Critical Error

Could not connect to the database


i havent changed anything in the files or folders.

Please help :!:

Luciouslinda
Registered User
Posts: 190
Joined: Thu Dec 26, 2002 6:12 am
Location: Singapore
Contact:

Post by Luciouslinda » Sun Feb 16, 2003 5:31 pm

Right there is a box where is say DSN (Database Server Hostname) Make sure that you fill this in!

Errr, let me check for you, i had the same problem once and i can not remember what i did with it!!!
Linda

jpmontoya_fan
Registered User
Posts: 9
Joined: Mon Dec 16, 2002 9:42 pm
Location: Bogota - Colombia
Contact:

Post by jpmontoya_fan » Sun Feb 16, 2003 6:08 pm

I've experienced the same problem, please help!
JP Montoya rules!

adonis_bimmer
Registered User
Posts: 8
Joined: Sun Feb 16, 2003 5:12 pm
Contact:

Post by adonis_bimmer » Sun Feb 16, 2003 6:35 pm

yep, i filled in all the boxes, except the password for the under DNS.

can someone just try it for me if i give them my login and password??? LOL pwease haha

Luciouslinda
Registered User
Posts: 190
Joined: Thu Dec 26, 2002 6:12 am
Location: Singapore
Contact:

Post by Luciouslinda » Sun Feb 16, 2003 7:38 pm

What do you mean except the password under the DSN

You have to fill in all of the boxes!!!!!

DSN
Database Name
Database Username
Database Password

And so on, leave no box blank
Linda

adonis_bimmer
Registered User
Posts: 8
Joined: Sun Feb 16, 2003 5:12 pm
Contact:

Post by adonis_bimmer » Sun Feb 16, 2003 8:41 pm

oops, i read on another post not to fill in the password. BUT i tried with and without, still get the same thing.

If you want to try urself Linda, ill give u my password etc :)

{TS}Mafia_aw3524
Registered User
Posts: 6
Joined: Wed Feb 12, 2003 1:05 am

Post by {TS}Mafia_aw3524 » Sun Feb 16, 2003 8:44 pm

Hey,
I've had my forum up for quite sometime; and just lately it started to give me that error.

Please please help!
Adam

User avatar
The Spy
Registered User
Posts: 46
Joined: Sat Jan 11, 2003 5:51 pm
Location: Florida, USA
Contact:

Post by The Spy » Sun Feb 16, 2003 9:40 pm

i'm getting this same problem on a forum i have up that is running on 2.0.1 and friend is having it as well with 2.0.3. i haven't recieved this error on the forum i have up that is on 2.0.4 any solutions???
"I'm just a figment of your imagination."

User avatar
A_Jelly_Doughnut
Former Team Member
Posts: 34457
Joined: Sat Jan 18, 2003 1:26 am
Location: Where the Rivers Run
Contact:

Post by A_Jelly_Doughnut » Sun Feb 16, 2003 10:57 pm

There are only 3 possible causes for this:
1. Invalid username/password/CHMOD in config.php

2. The Database is down.

3. Some code that does the connecting of the database was damaged during modifications.

I think they all have obvious solutions, but

1. Check the password by opening config.php in Notepad or other text editor

2. Ask your host

3. Replace all of phpBB's files.
A Donut's Blog
"Bach's Prelude (Cello Suite No. 1) is driving Indiana country roads in Autumn" - Ann Kish

Locked

Return to “2.0.x Support Forum”