Yet another 2.0.22 to 2.0.23 problem

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
DeckRev
Registered User
Posts: 13
Joined: Tue Mar 18, 2008 6:14 am

Yet another 2.0.22 to 2.0.23 problem

Post by DeckRev »

Hi all.

Okay, I have recently been made the acting webmaster/admin on our forum website because the actual owner has no more time for it. He has given me full FTP and mySQL access and I can find my way around those easy enough, but I am a novice in terms of getting stuff done.

The problem I am having is that I have been unable to upgrade the phpbb version. I have followed the instructions from the knowledge base on how to upgrade versions (starting with the patch file, etc.) but I keep getting stalled when it comes time for me to enter the "patch" command. I loaded the correct .patch file into the correct directory (the one containing index.php, viewforum.php etc., as per the article's instructions). On step 3, I found no "/install" directory, and so created one, and uploaded the update_to_latest.php file there. Then when I entered the command, I continuously got the message "500 PATCH not understood." I don't know if this is because I am entering the information wrong or what, but any insight will be helpful. I have searched the forums for similar problems but have not found an exact case like my own, so I apologize if there is one in existence.

Helpful info:
-I am on a Mac computer
-I am using Firefox, and thus FireFTP
-site name: http://www.deckrevolution.com

Anything else you need in terms of offering a solution, just ask.

User avatar
ric323
Former Team Member
Posts: 22910
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Yet another 2.0.22 to 2.0.23 problem

Post by ric323 »

Very few people use the patch method. That is only for people experienced with UNIX command line access.

Does this board have any MODs (modifications) installed?
If not, then there are much easier ways to update.
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

DeckRev
Registered User
Posts: 13
Joined: Tue Mar 18, 2008 6:14 am

Re: Yet another 2.0.22 to 2.0.23 problem

Post by DeckRev »

Well I wish I would have been told that there was an easier way than the patch method.

I believe there are mods installed... granted I am not sure and can't talk with the server owner as he is on vacation. Is there a way to check that? If there isn't an easy way to check that, I should probably update it under the assumption that there are MODs installed.

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51348
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Yet another 2.0.22 to 2.0.23 problem

Post by stevemaury »

DeckRev wrote:Well I wish I would have been told that there was an easier way than the patch method.
When you saw that there were three different download types each in three different compression formats, where did you look to see what the difference was? Not in the FAQ at the top of this forum, that's for sure.

Anyway, you should use the Code Changes method of updating and hence that is what you should download. I suggest the .zip format.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

DeckRev
Registered User
Posts: 13
Joined: Tue Mar 18, 2008 6:14 am

Re: Yet another 2.0.22 to 2.0.23 problem

Post by DeckRev »

I'll be glad to use the Code Changes option, except the instructions from the Knowledge Base involve using EasyMOD, which I don't have (since there is no section for it on the ACP). Is there another way? Or do I have get EasyMOD first?

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51348
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Yet another 2.0.22 to 2.0.23 problem

Post by stevemaury »

The Code Changes are a MOD. It will take longer to install EasyMOD than to do the code edits. You download the files to be edited, back them up, and make the edits as set out in the phpbb2.0.22_to_2.0.23.txt file. Then you upload the edited files to the proper folders and the install folder to the forum root and browse to yourforum/your_forum_root/install/update_to_latest.php and delete the install folder.

These articles may be helpful:

How to install a MOD and
Knowledge Base - How to Install MODs
[url=http://www.phpbb.com/kb/article/install ... right-way/]Knowledge Base - Installing MODs the Right Way[/ur
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

DeckRev
Registered User
Posts: 13
Joined: Tue Mar 18, 2008 6:14 am

Re: Yet another 2.0.22 to 2.0.23 problem

Post by DeckRev »

I installed EasyMOD, simply because that seemed like a good thing for future use. When I went to install the update via EasyMOD, I got the following message:

"Critical Error
Function Trace: open_files[5]->modio_open[1]
Could not open [admin/admin_styles.php] for reading.
MOD script line #152 :: FAQ :: Report

After looking in my admin folder, there is no "admin_styles.php" document there. So what do I have to change/move/edit/etc. to enable the MOD to go through?

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51348
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Yet another 2.0.22 to 2.0.23 problem

Post by stevemaury »

There should be an admin_styles.php file there. Upload it from the download from here. You are looking in root/admin and not templates/*/admin?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

DeckRev
Registered User
Posts: 13
Joined: Tue Mar 18, 2008 6:14 am

Re: Yet another 2.0.22 to 2.0.23 problem

Post by DeckRev »

Confirmed, there is no admin_styles.php document there. There are all of the other usual admin_*blank*.php documents, but not that one. There are xs_*blank*.php documents, and there is a xs_styles.php... but I don't know what the difference is unfortunately.

I will try uploading that specific document from the phpbb2 package to see if it does any good.

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51348
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Yet another 2.0.22 to 2.0.23 problem

Post by stevemaury »

What did you use to upload these file? Shouldn't be xs_* files there.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

DeckRev
Registered User
Posts: 13
Joined: Tue Mar 18, 2008 6:14 am

Re: Yet another 2.0.22 to 2.0.23 problem

Post by DeckRev »

I received this board from the server owner, since he no longer has time to run it. The xs_* files were already in place when I got access.

And I forgot that the admin_styles.php from the latest phpbb2 download is version .23, and therefore won't work with the update. So I am still where I was on this.

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 51348
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Yet another 2.0.22 to 2.0.23 problem

Post by stevemaury »

Why don't you forget EasyMOD and do it manually. You could have been done hours ago.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

User avatar
Lumpy Burgertushie
Registered User
Posts: 67733
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Yet another 2.0.22 to 2.0.23 problem

Post by Lumpy Burgertushie »

go ahead and upload the file from .23, then , open the update file and remove the part that says to change that file.

the xs files are part of the extremem styles MOD. since the admim_styles.php file is no longer used when you have the xs MOD installed, the previous owner probably removed it.

and I agree, if you have done the update manually you would have been done a long time ago.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?

DeckRev
Registered User
Posts: 13
Joined: Tue Mar 18, 2008 6:14 am

Re: Yet another 2.0.22 to 2.0.23 problem

Post by DeckRev »

Thank you all for your help, I'm all set. And I did the last portion manually and it did go much faster, so thanks. I think i will do that from now on.

zoecat
Registered User
Posts: 3
Joined: Wed Apr 04, 2007 8:53 pm

Re: Yet another 2.0.22 to 2.0.23 problem

Post by zoecat »

Ok, I just tried all these steps. Let me preface this post/issue by stating that I am very new to this (the editing of all the files took my about 60 minutes, not 20). I inherited this board from someone and am trying to learn how to upgrade from 2.0.22 to 2.023.

When I went into my admin. panel after editing all these files, my left had navigation menu pane is missing/ all messed up. Instead of the normal menu choices, I get this error message below. How do I fix this??

Error message:
Parse error: syntax error, unexpected ')' in /home/dixonten/public_html/boards/admin/admin_ug_auth.php on line 334

I looked back at the file above (hard because my pc isn;t showing me the line numbers in the file when I edit it) and it looks like I replaced the code as instructed. I am a not a coder at all. How do I find this extract parenthese??

Locked

Return to “2.0.x Support Forum”