Can someone Help me !! :(

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
PsychO.zZ
Registered User
Posts: 9
Joined: Sat May 10, 2008 5:54 pm

Can someone Help me !! :(

Post by PsychO.zZ » Sat May 10, 2008 6:18 pm

First sorry for my english, because im from Albania.
I have phpBB2 Forum, and I need help because when some one register or some times post New Topic or Post Reply , than I see this

Image

Please can some one tell me how to fix it.

User avatar
Jim_UK
Former Team Member
Posts: 18478
Joined: Tue Oct 12, 2004 5:36 pm
Location: Darwen N.West UK

Re: Can someone Help me !! :(

Post by Jim_UK » Sat May 10, 2008 7:07 pm

Copy the code below into Notepad. Enter your email address
Save as mailtest.php
ftp the file to the root of your webspace and then navigate to it with your browser like http://your_domain_name/mailtest.php

If you get an email then PHP sendmail is working and we need to find out what has happened.
If you do not get an email then contact your host and tell them the PHP mailer is not working.

Code: Select all

<?php 
mail("youremail address", "Test", "This is a mail test "); 
?>
Jim
The truth is out there.
Unfortunately they will not let you anywhere near it!

PsychO.zZ
Registered User
Posts: 9
Joined: Sat May 10, 2008 5:54 pm

Re: Can someone Help me !! :(

Post by PsychO.zZ » Sat May 10, 2008 7:17 pm

I tried like this :

Code: Select all

    <?php
    mail("psychozz@msn.com", "Test", "This is a mail test ");
    ?>
I saved mailtest.php i uploaded in my Host, and I tried to open www.mydomain.ch/mailtest.php and I cant see anything just a Blank page :(

User avatar
Jim_UK
Former Team Member
Posts: 18478
Joined: Tue Oct 12, 2004 5:36 pm
Location: Darwen N.West UK

Re: Can someone Help me !! :(

Post by Jim_UK » Sat May 10, 2008 7:20 pm

PsychO.zZ wrote:I tried like this :

Code: Select all

    <?php
    mail("psychozz@msn.com", "Test", "This is a mail test ");
    ?>
I saved mailtest.php i uploaded in my Host, and I tried to open http://www.mydomain.ch/mailtest.php and I cant see anything just a Blank page :(
That is correct. You should get a blank page and it should send you an email.
Did you get the test email?

Jim
The truth is out there.
Unfortunately they will not let you anywhere near it!

PsychO.zZ
Registered User
Posts: 9
Joined: Sat May 10, 2008 5:54 pm

Re: Can someone Help me !! :(

Post by PsychO.zZ » Sat May 10, 2008 8:05 pm

No I didn't but I'll try to put there other email addres ;)

PsychO.zZ
Registered User
Posts: 9
Joined: Sat May 10, 2008 5:54 pm

Re: Can someone Help me !! :(

Post by PsychO.zZ » Sat May 10, 2008 8:11 pm

No it didn't work i Tried 2 other emails, but it didn't work :(

User avatar
Jim_UK
Former Team Member
Posts: 18478
Joined: Tue Oct 12, 2004 5:36 pm
Location: Darwen N.West UK

Re: Can someone Help me !! :(

Post by Jim_UK » Sat May 10, 2008 8:17 pm

That is good!!!
That means that it is not your board that is at fault.

Try this
Go to Admin CP>general admin>configuration and set the smtp mail to on (yes)
Now enter these settings.
Servername = "localhost" (no quotes)
Username = leave blank
Password = leave blank

Test

If that does not work then contact your hosts and tell them that the PHP sendmail is not working. If they say they have disabled it then ask them for the smtp connection info so that you can send mail.

Jim
The truth is out there.
Unfortunately they will not let you anywhere near it!

PsychO.zZ
Registered User
Posts: 9
Joined: Sat May 10, 2008 5:54 pm

Re: Can someone Help me !! :(

Post by PsychO.zZ » Sat May 10, 2008 11:46 pm

It didn't worked but I asked my Host to give me the smtp connection info, but they didn't answer yet, Im waiting :), anyway thanks a lot from you Jim ;)

PsychO.zZ
Registered User
Posts: 9
Joined: Sat May 10, 2008 5:54 pm

Re: Can someone Help me !! :(

Post by PsychO.zZ » Sun May 11, 2008 11:55 am

I dont know what to do I think I'll let it, because they said that Safe mod is on and you cannot use the mail() function.

Anyway thnx ;)

User avatar
ric323
Former Team Member
Posts: 22909
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: Can someone Help me !! :(

Post by ric323 » Sun May 11, 2008 12:03 pm

Did you try Jim's last suggestion to use SMTP?
Safe mode will NOT stop that from working.
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

User avatar
Jim_UK
Former Team Member
Posts: 18478
Joined: Tue Oct 12, 2004 5:36 pm
Location: Darwen N.West UK

Re: Can someone Help me !! :(

Post by Jim_UK » Sun May 11, 2008 5:27 pm

Get the smtp connection details from them. If they do not allow smtp either then get a different host is my advice.

Jim
The truth is out there.
Unfortunately they will not let you anywhere near it!

PsychO.zZ
Registered User
Posts: 9
Joined: Sat May 10, 2008 5:54 pm

Re: Can someone Help me !! :(

Post by PsychO.zZ » Sun May 11, 2008 6:50 pm

Yes I want to get a different host, but I need some help, can u Add me on MSN, my email is " psychozz@msn.com " , if you dont have an email account plz just send to me on PM your email addres and I'll contact you ;)

User avatar
Jim_UK
Former Team Member
Posts: 18478
Joined: Tue Oct 12, 2004 5:36 pm
Location: Darwen N.West UK

Re: Can someone Help me !! :(

Post by Jim_UK » Sun May 11, 2008 7:02 pm

We always suggest that users get advice from http://www.webhostingtalk.com or http://www.webhostingjury.com

If you mean you want to ask me about hosting then do so via PM and not in this topic please.

Jim
f you dont have an email account plz just send to me on PM your email addres
That would be tricky if I did not have one. :lol:
The truth is out there.
Unfortunately they will not let you anywhere near it!

Locked

Return to “2.0.x Support Forum”