Ikonboard 3.x Converter

This is an archive of the phpBB 2.0.x convertors forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
egypttpyge
Registered User
Posts: 57
Joined: Mon Feb 14, 2005 3:50 am

Post by egypttpyge »

The image is not posting properly , I can only post the thumbnail.
You can click on this link to see the image if you can't read the thumbnail.

http://egypttpyge.com/forums/download.php?id=354


Image



Thanks alot for your help :)
vHiker
Registered User
Posts: 333
Joined: Thu Feb 14, 2002 9:59 pm

Post by vHiker »

I still can't see it. Email it to the address at the top of the script.
egypttpyge
Registered User
Posts: 57
Joined: Mon Feb 14, 2005 3:50 am

Post by egypttpyge »

vHiker wrote: I still can't see it. Email it to the address at the top of the script.



I made th conversion an so far it looks very good :D

I think I will run it again though becasue I although I have the attachment Mod installed I did not get any attachments in the posts.


Thanks again :)
raymonkondos
Registered User
Posts: 74
Joined: Tue May 04, 2004 11:40 pm

Post by raymonkondos »

egypttpyge,
أهلا
This is raymon of youregypt ... nice to come across you here :)
Joshua5692
Registered User
Posts: 3
Joined: Thu Oct 13, 2005 4:19 pm

Post by Joshua5692 »

I hate it when a person with 1 post asks for help.

First of all thank you so much for the effort you have put into this script vHiker!!! Much overdue.

My problem has not been posted if it has, I am sorry I have scanned all 37 pages of this.

It is a MS VBscript error the one that ends with 005 and it has been in here a couple times. But not on the line I am having it on, and the problem does not appear to be something that I can play with much.

Code: Select all

TextFile.Write (X & Append)
That is where the error is, in character 5 line 971.

So it is saying that your " T " is the devil. What am I doing wrong? Anyone know?
vHiker
Registered User
Posts: 333
Joined: Thu Feb 14, 2002 9:59 pm

Post by vHiker »

I need the exact error message (and line number). The line of code you posted is line 1095 (not 971). :wink:
Joshua5692
Registered User
Posts: 3
Joined: Thu Oct 13, 2005 4:19 pm

Post by Joshua5692 »

vHiker wrote: I need the exact error message (and line number). The line of code you posted is line 1095 (not 971). :wink:


I deleted the un-needed lines of instruction ;)

I will post screen shot in 3 minutes of error/s dunno if the two are related.
Joshua5692
Registered User
Posts: 3
Joined: Thu Oct 13, 2005 4:19 pm

Post by Joshua5692 »

Ok I missed it because I was typing when the first one came on so it immediately cancelled it. The first error though asks me if I would like to attempt to convert this link or that link, then as soon (instant) as i click yes or no both I get the following error.
Image

The process then stops. It does however create 4 files that I can see...
Image
The warning file only mentions 1 duplicate username, then two link errors (the same one's it asks me to repair.
vHiker
Registered User
Posts: 333
Joined: Thu Feb 14, 2002 9:59 pm

Post by vHiker »

Joshua5692, I sent you a PM but haven't heard back. I assume you've figured out the problem.
PKfanSteph
Registered User
Posts: 15
Joined: Thu Mar 11, 2004 8:07 am
Contact:

Post by PKfanSteph »

I am on a Mac and can't run the .vbs file. Is there any other way to do this, or would someone here be willing to run it for me?
PKfanSteph
Registered User
Posts: 15
Joined: Thu Mar 11, 2004 8:07 am
Contact:

Post by PKfanSteph »

OK, I found someone to run it (thanks for the offer, vHiker). But, like egypttpyge, I used the Attach mod and can't see any of my attachments. I know they're there--the admin attach cp says so, and when I edit the message, it says they're there. I just can't see them in the posts.

What am I doing wrong? Is it an issue with the attach mod or this one? I also just installed a new board with no converted messages and everything worked fine, which has me puzzled.
Opus
Registered User
Posts: 34
Joined: Sun Nov 06, 2005 3:10 am
Contact:

Post by Opus »

I am unable to do a dump using the built in backup feature.

I am able to however, use SSH and create a backup that way.

Can this be modified to change over a *.sql file?

Thanks,
PKfanSteph
Registered User
Posts: 15
Joined: Thu Mar 11, 2004 8:07 am
Contact:

Post by PKfanSteph »

PKfanSteph wrote: OK, I found someone to run it (thanks for the offer, vHiker). But, like egypttpyge, I used the Attach mod and can't see any of my attachments.

I finally got mine to work by copying the files from the working board (everything except the config file with the database info). I'm not sure what was wrong, but whatever works! And it's much better than losing everything during the switch! This converter saved my tail! Thanks!
kilorat
Registered User
Posts: 1
Joined: Thu Nov 10, 2005 9:30 am

Post by kilorat »

This is just an awesome polished mod, it does such a complete job, I'm very impressed.
vHiker
Registered User
Posts: 333
Joined: Thu Feb 14, 2002 9:59 pm

Post by vHiker »

Opus wrote: Can this be modified to change over a *.sql file?

Thanks,


It could, but might take some time. It's been a long time since I coded the converter and my database was DBM, so I have no idea what the sql database structure looks like, but should be similar. If you want to pm a link to your sql backup I could take a look at it and see if it's doable.
Locked

Return to “[2.0.x] Convertors”