Ikonboard 3.x Converter

This is an archive of the phpBB 2.0.x convertors forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
atlantiscomics
Registered User
Posts: 2
Joined: Fri Dec 09, 2005 2:32 am
Location: Portsmouth, VA
Contact:

Post by atlantiscomics » Fri Dec 09, 2005 7:03 am

Does anybody have any suggestions for how to convert from a non-working Ikonboard 3.1.2a to phpBB? I have ftp and control panel access to the mysql database and all the files but ikonboard won't run. After 38 pages of posts I can assume that I am f'ed. Some folks mentioned doing it manually. Anybody know where to find out more about that?

Any suggestions on converting. I looked at invision as was mentioned in an earlier post but that has a pretty hefty price tag just so I can convert from ikonboard to invision to phpBB.

I did do what I thought was a full backup about a month ago but when I run the converter all I get is this error:
Error: member_profiles.txt was not found!
More than likely you specified an incomplete path to your unzipped IB3 tar backup


Then I get:
Script: C:\Documents and settings\Stephen Matousek\Desktop\readme.vbs
Line: 139
Char: 222
Error: Type mismatch: 'Error'
Code: 800A000D
Source: Microsoft VBScript runtime error


I am fairly certain I have the path correct since it's all right on the desktop.

vHiker
Registered User
Posts: 333
Joined: Thu Feb 14, 2002 9:59 pm

Post by vHiker » Fri Dec 09, 2005 7:28 am

Make sure you unzip all files into the same folder. If you don't see a member_profiles.txt in the folder then you haven't got them all. It would be possible to change the converter to read a sql backup, but I would need to have a backup to work from and I can't guarantee any sort of quick turnaround.

atlantiscomics
Registered User
Posts: 2
Joined: Fri Dec 09, 2005 2:32 am
Location: Portsmouth, VA
Contact:

Post by atlantiscomics » Fri Dec 09, 2005 8:24 am

I will have to assume that the backup did not finish since the member_profiles is not there in the backup folder. If you would be willing to try to convert the mysql database what would you need. I can give you control panel access where you can manage the mysql database. Or ftp access. Let me know what you would need and how much time you think it could take.

And if I can help motivate you with comic books, games, or rpg books let me know :)

vHiker
Registered User
Posts: 333
Joined: Thu Feb 14, 2002 9:59 pm

Post by vHiker » Fri Dec 23, 2005 7:50 pm

If anyone else needs to convert from mysql backup let me know. I was able to patch something together for atlantiscomics, but it needs more testing before I release it with the converter.

Fyfe
Registered User
Posts: 1
Joined: Fri Jan 13, 2006 12:49 pm

Post by Fyfe » Fri Jan 13, 2006 12:51 pm

vHiker could you send me the ikonboard mysql converter please (I now also sent you a pm)

mugwumpr
Registered User
Posts: 79
Joined: Fri Feb 10, 2006 6:40 am
Contact:

Thank you vHiker....

Post by mugwumpr » Sat Feb 11, 2006 10:06 am

I just used your converter, and it's incredible!!

*HUG*

THANK YOU!!

:D

blueroadster
Registered User
Posts: 5
Joined: Thu Feb 16, 2006 9:06 pm

Post by blueroadster » Thu Feb 16, 2006 9:19 pm

DELETED
Last edited by blueroadster on Thu Feb 16, 2006 10:59 pm, edited 2 times in total.

vHiker
Registered User
Posts: 333
Joined: Thu Feb 14, 2002 9:59 pm

Post by vHiker » Thu Feb 16, 2006 9:46 pm

Are you sure? I just downloaded it and it isn't empty. Make sure you read the instructions in readme.txt. That readme.txt file is the converter.

blueroadster
Registered User
Posts: 5
Joined: Thu Feb 16, 2006 9:06 pm

Post by blueroadster » Sun Feb 19, 2006 12:47 am

vHiker,

Thanks a lot. Your converter rocks. I successfully converted my board over and all appears to work well. I did have a question though about rebuilding the search tables. When the script is running, it repeats the following line over and over (where SITE DIRECTORY = the server path for the forum software):

Warning: mysql_free_result(): supplied argument is not a valid MySQL result resource in /SITE DIRECTORY/db/mysql4.php on line 318

Is this normal or indicative of a problem?

Thanks,
Eric

vHiker
Registered User
Posts: 333
Joined: Thu Feb 14, 2002 9:59 pm

Post by vHiker » Sun Feb 19, 2006 9:28 am

I'm not sure why that message is appearing but it should be fine as long as that is the only error message.

Buttonman
Registered User
Posts: 2
Joined: Wed Apr 19, 2006 10:57 pm

Cannot log into phpBB after importing the data - phpBB 2.20

Post by Buttonman » Sat May 13, 2006 8:48 am

Hi,

Following the use of this most excellent import script I am coming across problems.

Details:
Ikonboard 3.1.2a
phpBB: 2.20
mySQL: 4.1.18-standard
php: 5.1.2
OS: Linux
Install: Vanilla + attachment mod

I have imported all data - all links, users, posts and forums have been imported successfully. When I try to log in after making the adjustments to the login.php script I cannot log in as an administrator nor as anybody else. Restoring to a previous mySQL backup fixes the problem. Changing back to an SQL backup of the post-import data generates the problem again.

After the import I tried by adjusting the password on the administrator to the md5 value with no luck and then tried adjusting a new user's user_level to 0 (administrator) again with no luck. Neither would logging in as an existing user work.

I then removed the adjustments to login.php and tried to log in.

Nothing has worked. Any ideas?

Thanks

Scott

vHiker
Registered User
Posts: 333
Joined: Thu Feb 14, 2002 9:59 pm

Post by vHiker » Sat May 13, 2006 4:20 pm

I am not sure I understand your problem. Are you saying the login problem does not occur if you use a previous backup? Feel free to PM me.

kamesh
Registered User
Posts: 18
Joined: Thu May 20, 2004 10:25 pm
Contact:

Post by kamesh » Wed Jun 21, 2006 7:34 pm

Dear vHiker,

Thanks for your excellent script. I was able to move all the posts and the users to phpbb from ikonboard. But I am having 2 minor problems.

1) I could not use the rebuild search tables script. Actually its running for a while and returning the following error.

Code: Select all

 500 - Internal server error
PHP file

All php files must be non-writeable by group and world to be parsed by suPHP. Change permissions on the php files: chmod go-w ~/public.www/*.php 
I tried to change the permissions as it said but again its still giving the same error. I tried different combinations as well which did not work. Though now I can make some searches. But it does not give all the search results.

2) I could not see the profiles of my members including mine. When I click on the profiles link it just gives me a blank page. It was working fine before.

The following is the link to my forums.
http://www.aisl.cyd.liu.se/forum/index.php

Thanks and Regards,
Kamesh.
Truth lies every where and partially even with error.

User avatar
D¡cky
Former Team Member
Posts: 11812
Joined: Tue Jan 25, 2005 8:38 pm
Location: New Hampshire, USA
Name: Richard Foote
Contact:

Post by D¡cky » Wed Jun 21, 2006 9:11 pm

1) This is the tool that I use to rebuild the search index, www.phpbbhacks.com/downloads/434

2) I have not seen a blank profile page before. My first thought was there is a problem with profile_view_body.tpl, but I see you trying different styles and the profile doesn't work on any of them, so that rules out a templating problem.
Have you done any modifications to profile.php? You might try uploading a fresh copy to rule out any problems with that file.
The only other thing I can think of, is that there is a problem with the phpbb_users table. Have a look and see if anything looks out of line. Memberlist.php works fine which makes it very strange that profile doesn't work.
Have you hugged someone today?

kamesh
Registered User
Posts: 18
Joined: Thu May 20, 2004 10:25 pm
Contact:

Post by kamesh » Wed Jun 21, 2006 10:42 pm

D¡cky wrote: 1) This is the tool that I use to rebuild the search index, www.phpbbhacks.com/downloads/434


Thanks a lot D¡cky. This soultion worked perfectly. :D
D¡cky wrote: 2) I have not seen a blank profile page before. My first thought was there is a problem with profile_view_body.tpl, but I see you trying different styles and the profile doesn't work on any of them, so that rules out a templating problem.
Have you done any modifications to profile.php? You might try uploading a fresh copy to rule out any problems with that file.
The only other thing I can think of, is that there is a problem with the phpbb_users table. Have a look and see if anything looks out of line. Memberlist.php works fine which makes it very strange that profile doesn't work.


I did not do any modifcations to the profile.php file. As you suggested I have uploaded that file again. But nothing seems to have changed. The phpbb_users file which gets generated after I execute vHiker scripts is as follows.

http://www.aisl.cyd.liu.se/temp/phpbb_users.wri

As far as I can see there is nothing strange in that file.

Thanks and Regards
Kamesh.
Truth lies every where and partially even with error.

Locked

Return to “[2.0.x] Convertors”