[SUPPORT] PHP-Nuke to phpBB

This is an archive of the phpBB 2.0.x convertors forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
User avatar
D¡cky
Former Team Member
Posts: 11812
Joined: Tue Jan 25, 2005 8:38 pm
Location: New Hampshire, USA
Name: Richard Foote
Contact:

Re: [SUPPORT] PHP-Nuke to phpBB

Post by D¡cky » Fri Feb 29, 2008 6:54 pm

If you are sure that your user_id is 2

Code: Select all

UPDATE phpbb_users SET user_level = 1 WHERE user_id = 2;
Have you hugged someone today?

luvcl
Registered User
Posts: 26
Joined: Sat Sep 22, 2007 7:27 pm

Re: [SUPPORT] PHP-Nuke to phpBB

Post by luvcl » Fri Feb 29, 2008 7:54 pm

Thanks, Dicky!
And the rest I have to go to support . Sorry to bother you.
I got a lot of help here. Again, many thanks!

User avatar
ric323
Former Team Member
Posts: 22908
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: [SUPPORT] PHP-Nuke to phpBB

Post by ric323 » Fri Feb 29, 2008 9:51 pm

If you just want to change a user into an admin, you can do that with the admin toolkit (link in my sig).
It's very easy to install, just one file to upload to your web server.
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

luvcl
Registered User
Posts: 26
Joined: Sat Sep 22, 2007 7:27 pm

Re: [SUPPORT] PHP-Nuke to phpBB

Post by luvcl » Sat Mar 01, 2008 5:18 am

Thanks, ric323.
I will try that.

QueenItalia
Registered User
Posts: 1
Joined: Tue Mar 04, 2008 1:10 pm

Re: [SUPPORT] PHP-Nuke to phpBB

Post by QueenItalia » Tue Mar 04, 2008 1:16 pm

Hello and first of all: many thanks for your incredible support, you do a lot for us users.

Now I have a problem: I'm trying to migrate my actual phpnuke portal (what a bad experience!) forum into a proper phpbb forum. I read all the 40 pages and got an idea of what to do, though I never worked with database. I tried with the script but I got the 50000 queries limit problem. I asked my host (shame on them) to rise it up for the time of conversion but they said "no way". I tried to convert manually but I cannot succeed.

I read that other user had my same problem about the queries limit so I wonder: is there any chance that you can elaborate a new script which override this problem? I read about the "trick" of having more database users but this is useful in case you have to make db backups, I can't figure out how to use this strategy with the phpnuke-->phpbb script.

Any help? Please try and support me, this is becoming a nightmare for me and for my extensive community!

Thanks in advance,
Luca

User avatar
baldeagle
Registered User
Posts: 12
Joined: Sun May 23, 2004 7:53 pm
Location: Belgium
Contact:

Re: [SUPPORT] PHP-Nuke to phpBB

Post by baldeagle » Thu Mar 13, 2008 9:55 am

Hi,

I try to move my phpnuke integrated phpbb 2.0.16 to the phpbb3 version that i installed using fantastico.

When i try to run the conv_nuke.php i get this result.

Warning: main(./extension.inc) [function.main]: failed to open stream: No such file or directory in /home/alterna1/public_html/BB/conv_nuke.php on line 15

Warning: main(./extension.inc) [function.main]: failed to open stream: No such file or directory in /home/alterna1/public_html/BB/conv_nuke.php on line 15

Warning: main() [function.include]: Failed opening './extension.inc' for inclusion (include_path='.:/usr/php4/lib/php:/usr/local/php4/lib/php') in /home/alterna1/public_html/BB/conv_nuke.php on line 15

Warning: main(./common.) [function.main]: failed to open stream: No such file or directory in /home/alterna1/public_html/BB/conv_nuke.php on line 16

Warning: main(./common.) [function.main]: failed to open stream: No such file or directory in /home/alterna1/public_html/BB/conv_nuke.php on line 16

Warning: main() [function.include]: Failed opening './common.' for inclusion (include_path='.:/usr/php4/lib/php:/usr/local/php4/lib/php') in /home/alterna1/public_html/BB/conv_nuke.php on line 16
Connecting to PHP-Nuke database server...Success
Connecting to PHP-Nuke database...Success
Connecting to phpBB database server...Failed

Reason
0:

I checked twice that all settings for the new phpbb is correct and that my user got rights to the new installation. this is all filled in correct. What else can be the problem?

Thx in advance.

BaldEagle.

User avatar
D¡cky
Former Team Member
Posts: 11812
Joined: Tue Jan 25, 2005 8:38 pm
Location: New Hampshire, USA
Name: Richard Foote
Contact:

Re: [SUPPORT] PHP-Nuke to phpBB

Post by D¡cky » Thu Mar 13, 2008 2:35 pm

baldeagle,

conv_nuke.php is for converting PHP-Nuke to phpBB2. To convert to phpBB3, use this convertor, PHP-NUKE to phpBB3 Convertor 0.0.5.

I hate to see you use Fantastico to install phpBB3. Fantastico changes some phpBB3 files in order to do the install. This can sometimes cause problems with the running of phpBB3. You are better off to install phpBB3 yourself using the files from the Downloads page, uploading and running the install.
Have you hugged someone today?

User avatar
thalador
Registered User
Posts: 23
Joined: Tue Sep 21, 2004 8:20 pm

Re: [SUPPORT] PHP-Nuke to phpBB

Post by thalador » Sun Apr 20, 2008 8:14 pm

Dicky,

I have tried using the con_nuke_214a.php I saw you mention in another thread and I get this when I try to run it

./conv_nuke_214a.php
./conv_nuke_214a.php: line 1: ?php: No such file or directory
./conv_nuke_214a.php: line 2: /bin: is a directory
./conv_nuke_214a.php: line 3: phpBB: Is a directory
./conv_nuke_214a.php: line 4: cgi-bin: command not found
./conv_nuke_214a.php: line 6: cgi-bin: command not found
./conv_nuke_214a.php: line 7: cgi-bin: command not found
./conv_nuke_214a.php: line 9: cgi-bin: command not found
./conv_nuke_214a.php: line 10: cgi-bin: command not found
./conv_nuke_214a.php: line 11: cgi-bin/: is a directory
./conv_nuke_214a.php: line 13: syntax error near unexpected token `'IN_PHPBB','
./conv_nuke_214a.php: line 13: `define('IN_PHPBB', true);'

Any ideas what I am doing wrong? I have installed a stock 2.0.23 phpbb board.

Thanks for the help

User avatar
thalador
Registered User
Posts: 23
Joined: Tue Sep 21, 2004 8:20 pm

Re: [SUPPORT] PHP-Nuke to phpBB

Post by thalador » Tue Apr 22, 2008 1:03 pm

Just to update I have tried this in the forum root and 1 up and down with the same result. Anyone have any thoughts?

KutuluXul
Registered User
Posts: 1
Joined: Wed Apr 23, 2008 1:06 pm

Re: [SUPPORT] PHP-Nuke to phpBB

Post by KutuluXul » Wed Apr 23, 2008 2:16 pm

Hey there!
Looks like some great support and phpBB community smarts here!
I need all the help I can get! Heh - I am very much an amateur website admin, using PHPNUKE 8.0.

Our forum code is : phpbb2 forums port version 2.0.5 (c) 2003.

And my problem is this:

Every now and then - and seemingly random times - our forums will disappear. They just won't load. The rest of the website will load. Other features of the website, using the same MySQL database, (like the gallery) still load just fine.
But - on the forum page - I just get a blank right there in the center block where the forums should be... and, beyond the forums, the "right-side" blocks don't load either.

This could happen 1 a week, on average... sometimes we go longer without it happening, sometimes it is two days in a row...
Then, the duration of the "outage" seems random. Sometimes it is 30 minutes. Sometimes it is a few hours.
I have no idea how to get the forums to come back up. Then, for some unknown reason.... POP... the forums are back up and running fine.

I don't know much about error codes - but, I'll post some below - just in case it means something to you:

[Wed Apr 23 09:54:06 2008] [error] PHP Fatal error: Cannot redeclare class sql_db in /home/theunhol/public_html/html/db/mysql.php on line 0

[Wed Apr 23 09:54:06 2008] [error] PHP Warning: main(): Failed opening 'modules/Forums/includes/functions_view_or_mark_unread_posts.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/theunhol/public_html/html/modules/Forums/common.php on line 179

[Wed Apr 23 09:54:06 2008] [error] PHP Warning: main(modules/Forums/includes/functions_view_or_mark_unread_posts.php): failed to open stream: No such file or directory in /home/theunhol/public_html/html/modules/Forums/common.php on line 179

[Wed Apr 23 09:53:18 2008] [error] PHP Fatal error: Cannot redeclare class sql_db in /home/theunhol/public_html/html/db/mysql.php on line 0

User avatar
ric323
Former Team Member
Posts: 22908
Joined: Tue Feb 06, 2007 12:33 am
Location: Melbourne, Australia
Name: Ric
Contact:

Re: [SUPPORT] PHP-Nuke to phpBB

Post by ric323 » Wed Apr 23, 2008 10:37 pm

KutuluXul wrote:Hey there!
Looks like some great support and phpBB community smarts here!
I need all the help I can get! Heh - I am very much an amateur website admin, using PHPNUKE 8.0.

Our forum code is : phpbb2 forums port version 2.0.5 (c) 2003.
...
You have posted in a topic dedicated to converting from PHP-Nuke to phpBB.
I'm sorry, there is no support for running PHP-Nuke here. Please ask for help on a Nuke site.
The Knowledge Base contains solutions to many common problems!
How to fix "Doesn't have a default value" and "Incorrect string value: xxx for column 'post_text' " errors.
How to do a clean re-install of the latest phpBB3 version.
Problems with permissions? Read phpBB3 Permissions

User avatar
D¡cky
Former Team Member
Posts: 11812
Joined: Tue Jan 25, 2005 8:38 pm
Location: New Hampshire, USA
Name: Richard Foote
Contact:

Re: [SUPPORT] PHP-Nuke to phpBB

Post by D¡cky » Fri May 09, 2008 4:40 am

thalador wrote:Dicky,

I have tried using the con_nuke_214a.php I saw you mention in another thread and I get this when I try to run it

./conv_nuke_214a.php
./conv_nuke_214a.php: line 1: ?php: No such file or directory
./conv_nuke_214a.php: line 2: /bin: is a directory
./conv_nuke_214a.php: line 3: phpBB: Is a directory
./conv_nuke_214a.php: line 4: cgi-bin: command not found
./conv_nuke_214a.php: line 6: cgi-bin: command not found
./conv_nuke_214a.php: line 7: cgi-bin: command not found
./conv_nuke_214a.php: line 9: cgi-bin: command not found
./conv_nuke_214a.php: line 10: cgi-bin: command not found
./conv_nuke_214a.php: line 11: cgi-bin/: is a directory
./conv_nuke_214a.php: line 13: syntax error near unexpected token `'IN_PHPBB','
./conv_nuke_214a.php: line 13: `define('IN_PHPBB', true);'

Any ideas what I am doing wrong? I have installed a stock 2.0.23 phpbb board.

Thanks for the help
It looks like your conv_nuke_214a.php file may be corrupted.
Have you hugged someone today?

sancora
Registered User
Posts: 2
Joined: Mon May 19, 2008 9:18 pm

Re: [SUPPORT] PHP-Nuke to phpBB

Post by sancora » Mon May 19, 2008 9:25 pm

Hi,
I changed the package conv_nuke 1.2.13 by entering the code that allows you to save the data administrator.
To download here
http://www.linuxap.it


this is the changed code

Code: Select all

  print("Exporting data from PHP-Nuke tables: users...");

    @mysql_connect($config['nuke_server'],$config['nuke_username'],$config['nuke_password']);
    mysql_select_db($config['nuke_db']);
    
    $res = @mysql_query("SELECT * FROM ".$config['nuke_prefix']."users");

    @mysql_connect($config['phpbb_server'],$config['phpbb_username'],$config['phpbb_password']);
    mysql_select_db($config['phpbb_db']);
    // by linuxap: cancella l'user anonimo, assegna all'amministratore un id negativo, carica gli id del nuke,
    // legge l'ultimo id e lo aggiorna all'amministratore

   @mysql_query_fail("DELETE FROM ".$config['phpbb_prefix']."users WHERE username = 'Anonymous'" );
    
    @mysql_query_fail("UPDATE " . $config['phpbb_prefix'] ."users SET user_id = '-2'");// negativo - il -1 verra' assgnato all'Anonymous
     
	$id=0;

	while ( $row = @mysql_fetch_array($res) )
	{
    // calcola l'ultimo id
	$id_nuke=$row['user_id'];
	if($id_nuke >$id) $id=$id_nuke;

    $time = $row['user_regdate'];
    $date = str_replace(",","",$time);
    $date = explode(" ",$date);
      switch($date[0]) {
         case('Jan'): $m=1;  break;
         case('Feb'): $m=2;  break;
         case('Mar'): $m=3;  break;
         case('Apr'): $m=4;  break;
         case('May'): $m=5;  break;
         case('Jun'): $m=6;  break;
         case('Jul'): $m=7;  break;
         case('Aug'): $m=8;  break;
         case('Sep'): $m=9;  break;
         case('Oct'): $m=10; break;
         case('Nov'): $m=11; break;
         case('Dec'): $m=12; break;
      }

    $timestamp = date("U", gmmktime(0,0,0,$m,$date[1],$date[2]));
    $user_level = $row['user_level'] - 1;
    $user_style = 1;

/*   jaymer - had to explicitly use field names for the INSERT, plus
added the "slash" stuff below on a few fields.   */
    $query = "INSERT INTO ".$config['phpbb_prefix']."users
(user_id,
user_active,
username,
user_password,
user_session_time,
user_session_page,
user_lastvisit,
user_regdate,
user_level,
user_posts,
user_timezone,
user_style,
user_lang,
user_dateformat,
user_new_privmsg,
user_unread_privmsg,
user_last_privmsg,
user_emailtime,
user_viewemail,
user_attachsig,
user_allowhtml,
user_allowbbcode,
user_allowsmile,
user_allowavatar,
user_allow_pm,
user_allow_viewonline,
user_notify,
user_notify_pm,
user_popup_pm,
user_rank,
user_avatar,
user_avatar_type,
user_email,
user_icq,
user_website,
user_from,
user_sig,
user_sig_bbcode_uid,
user_aim,
user_yim,
user_msnm,
user_occ,
user_interests,
user_actkey,
user_newpasswd
) values (
              '".$row['user_id']."',
              '".$row['user_active']."',
              '".sql_addslashes($row['username'])."',
              '".$row['user_password']."',
              '".$row['user_session_time']."',
              '".$row['user_session_page']."',
              '".$row['user_lastvisit']."',
              '".$timestamp."',
              '".$user_level."',
              '".$row['user_posts']."',
              '".$row['user_timezone']."',
              '".$user_style."',
              '".$row['user_lang']."',
              '".$row['user_dateformat']."',
              '".$row['user_new_privmsg']."',
              '".$row['user_unread_privmsg']."',
              '".$row['user_last_privmsg']."',
              '".$row['user_emailtime']."',
              '".$row['user_viewemail']."',
              '".$row['user_attachsig']."',
              '".$row['user_allowhtml']."',
              '".$row['user_allowbbcode']."',
              '".$row['user_allowsmile']."',
              '".$row['user_allowavatar']."',
              '".$row['user_allow_pm']."',
              '".$row['user_allow_viewonline']."',
              '".$row['user_notify']."',
              '".$row['user_notify_pm']."',
              '".$row['user_popup_pm']."',
              '".$row['user_rank']."',
              '".sql_addslashes($row['user_avatar'])."',
              '".$row['user_avatar_type']."',
              '".$row['user_email']."',
              '".$row['user_icq']."',
              '".$row['user_website']."',
              '".sql_addslashes($row['user_from'])."',
              '".sql_addslashes($row['user_sig'])."',
              '".$row['user_sig_bbcode_uid']."',
              '".sql_addslashes($row['user_aim'])."',
              '".sql_addslashes($row['user_yim'])."',
              '".sql_addslashes($row['user_msnm'])."',
              '".sql_addslashes($row['user_occ'])."',
              '".sql_addslashes($row['user_interests'])."',
              '".$row['user_actkey']."',
              '".$row['user_newpasswd']."'
              )";
/*    echo $query;     */

    @mysql_query_fail($query);

  }
  $table = "users";
  
	$sql = "UPDATE " . $config['phpbb_prefix'] . $table . " SET user_id = '-1', user_active = '0' WHERE username = 'Anonymous'";
	$result = $db->sql_query($sql);
				if ( !$result )
				{
					message_die(GENERAL_ERROR, "Could not update anonymous user in phpbb users table", "", __LINE__, __FILE__, $sql);
				}
	$id=$id+1;// aumenta di uno l'ultimo id
	@mysql_query_fail("UPDATE " . $config['phpbb_prefix'] ."users SET user_id = '$id' WHERE user_id = '-2'");// assgna l'ultimo id+1

  //print("numero: $id<br />");
  print("Success<br />");



bye linuxap.it

Idroy
Registered User
Posts: 2
Joined: Fri May 23, 2008 1:17 pm

Re: [SUPPORT] PHP-Nuke to phpBB

Post by Idroy » Fri May 23, 2008 1:22 pm

I've a problem the converter worked properly but my usernames and posts are screwed up.

I mean á é í ý etc is now converted to other characters.

Løcø is in one of my members usernames and on the converted board its now Løcø

I don't know if there's a solution to this, if the solution is posted before i can't use the in topic search function on this board so :)

Please help in advance

User avatar
D¡cky
Former Team Member
Posts: 11812
Joined: Tue Jan 25, 2005 8:38 pm
Location: New Hampshire, USA
Name: Richard Foote
Contact:

Re: [SUPPORT] PHP-Nuke to phpBB

Post by D¡cky » Tue May 27, 2008 2:09 pm

The most common cause of characters changing is when you export a database and then when you import the file, the correct character encoding is not used.
Have you hugged someone today?

Locked

Return to “[2.0.x] Convertors”

Who is online

Users browsing this forum: No registered users and 1 guest

cron