Page 6 of 26

Posted: Sat Aug 13, 2005 5:42 am
by idburns
Can I get a link to the converter to test with? I have a smf database ready to go.

Posted: Sat Aug 13, 2005 4:08 pm
by SlapShot434
Not at the moment, I'm not re-releasing the code until some major errors are fixed, but I'll let you know as soon as I do.

Posted: Sat Aug 13, 2005 7:47 pm
by DoW Kid Rock
I first of all want to thank you for making this. Now I am a big supporter of SMF, but with my team wanting to use phpnuke (I do too don't get me wrong) I am in need of switching the main forum.

Just thought I would post that for the person that was asking why anyone would want to switch. I don't personally want to switch, but because I have to I am glad it is phpbb

and just FYI Proud is one of my admin team that I wouldn't know what to do without

Posted: Sun Aug 14, 2005 5:19 pm
by CAPZkilla
SlapShot434 wrote: not sure whats going on, did you use the script i sent you?
yes i did, it worked perfectly, apart from the things i reported in my last post, i now have everything working it seems, all the data is at my phpBB, posts, users, topics, almost everything, all i had to do afterwards was delete the extra usergroups

Posted: Sun Aug 14, 2005 5:21 pm
by SlapShot434
Good to hear.

Just to update everyone, I am still awaiting word from one beta tester who is going to try both versions of the converter, and hopefully that will prove what the problem is behind the empty user tables. I will then release the converters for futher public testing.

Posted: Mon Aug 15, 2005 1:57 pm
by idburns
SlapShot434 wrote: Good to hear.

Just to update everyone, I am still awaiting word from one beta tester who is going to try both versions of the converter, and hopefully that will prove what the problem is behind the empty user tables. I will then release the converters for futher public testing.


Awesome, can't wait!

Posted: Tue Aug 16, 2005 2:54 pm
by CAPZkilla
im having an issue, and it must be caused by the converted database since im running a clean phpbb install now, with no MODs
when i turn the board emailing system off, and users have the "Notify me when a reply is posted" option on, they get
sending email :: PHP ::

DEBUG MODE

Line : 234
File : emailer.php
with email system on, and "Notify me when a reply is posted" option off, they also get the same error when posting in certain topics in the board, this only seems to be happening in catagories i've added after the conversion and have forums from the old smf database in them.

Even though this, to me looks like an error created by a MOD, since i have no, it must be the converted database.. cant wait for my new php & mysql book :P then i'll finally understand how all of this works :o

Also, there is no need to look into the "isn't converting in a non "phpBB2" dir" issue, since it doesnt seem to happen anymore. I've downloaded the phpbb install again and it's gone, so that was most likely caused by a slightly corrupted phpbb install.

Posted: Tue Aug 16, 2005 6:00 pm
by Graham
This is neither a bug, nor a MOD - it is an issue caused by your mail settings. Try opening a topic in support on it

Posted: Thu Aug 18, 2005 8:18 am
by xdarkday
Let us take a look at the beta please. Im starting to belive that there is no converter or for some wierd reason you wont let us help you.

Posted: Thu Aug 18, 2005 4:59 pm
by DoW Kid Rock
xdarkday wrote: Let us take a look at the beta please. Im starting to belive that there is no converter or for some wierd reason you wont let us help you.


I know there is a beta and at this point only a few beta testers are required, so it doesn't overload the programmer of the conversion tool

Posted: Thu Aug 18, 2005 5:50 pm
by SlapShot434
The point of a BETA version of a program is to allow people to try it out and look for problems. I allowed this to go on for a number of weeks, and in that time collected a large amount of bug reports. I am now in the process of fixing these problems. Please understand that I started school again this week, so I am quite busy, and working on the converter cannot be a priority to me. I ask that you be patient as I do my best to figure out what the problem is.

Posted: Fri Aug 19, 2005 2:24 pm
by CAPZkilla
xdarkday wrote: Let us take a look at the beta please. Im starting to belive that there is no converter or for some wierd reason you wont let us help you.
i have the converter, so that proves it exists, however there are a few things that just dont work like they should. And i dont think he needs more testers, having too many will make the debugging process chaotic.

At this point,i can tell you that, even though you would like to use it, it's best not to. You cannot use this on a live board in the state which it's in.

As SlapShot posted, alot of work has to be done to make sure nobody ends up with a malfunctioning board. Just stick around and wait for a proper release, one thing is for sure, a properly functioning smf to phpbb converter is in the works, and it will be done, when it's done

Posted: Fri Aug 19, 2005 9:20 pm
by killerbob
Beta means testing... something a lot of SW vendors don't understand. No, I don't have a copy of what he's working on, but I do know from experience that it can be a royal pain in the arse to try to troubleshoot something.

You could try rolling your own. I might have something you could try if all you care about is posts/userprefs (and don't mind users losing their PM boxes or any attachments on posts), but I would need to check with the person who wrote it to see if she minds releasing it, and she isn't online right now. It's a quick&dirty hack that she threw together in an afternoon, but it worked when I converted a board over from SMF earlier this week.

Posted: Fri Aug 19, 2005 10:11 pm
by SlapShot434
I have released version 1.0 BETA 4. This version should fix the problem many people were having with the user conversion stopping due to blank moderator tables. Please see the first post for the new file.

Posted: Sat Aug 20, 2005 4:54 am
by idburns
When I click the download link I get a file called download.php.