Page 7 of 26

Posted: Sat Aug 20, 2005 3:38 pm
by CAPZkilla
try the mirror
i'm wondering why people keep having that, downloading php files..
oh well.. anyway, after getting some help from the phpbb support section, i now have my phpbb up and running, with no errors what so ever ( with beta3 )

Posted: Sat Aug 20, 2005 4:34 pm
by D¡cky
The mirror "Can't be Found"
CAPZkilla wrote: i'm wondering why people keep having that, downloading php files..)

I am not sure either. The link works fine with Firefox and Netscape, but when using Internet Explorer, I also get the download.php file.

Posted: Sat Aug 20, 2005 5:21 pm
by SlapShot434
sorry guys, looks like theres something wrong with my attach mod, Ive updated the link to go directly to the file itself.

Posted: Sun Aug 21, 2005 3:22 am
by idburns
Ok, I tried the converter and I get as far as the warning page where it talks about the passwords being reset. When I click Here to continue I get a Page not found error.

smf = 1.0.5
phpBB = 2.0.17
MySQL = 4.0.25
PHP = 4.3.10

I have duplicated my smf database to a new one for the conversion, and installed the phpBB database to it. The only forum I have using this new database is the phpBB, my SMF forums is pointing to it's original database.

Here are my settings:

Image

Am I doing something wrong? I'm thinking I might be screwing up something with my forum path field...

Posted: Sun Aug 21, 2005 1:59 pm
by SlapShot434
yes, the path needs to go to your smf forum, NOT the phpbb forum

Posted: Sun Aug 21, 2005 2:25 pm
by gothic1213
Hi. I have been testing out the converter locally, importing my remotely hosted db into the installation on my machine. Theoretically an absolute mirror!
I run the converter and after a short while I get the following error:

Code: Select all

Couldn't obtain table information.

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-1' at line 4

SELECT messages.ID_MSG, messages.ID_TOPIC, messages.ID_BOARD, messages.ID_MEMBER, messages.posterName, messages.posterTime, messages.posterIP, messages.smileysEnabled, messages.modifiedTime, messages.modifiedName FROM smf_messages messages LEFT JOIN smf_topics AS topics USING (ID_TOPIC) LIMIT 6360, -1
Looking at the phpbb db at this stage I notice that everything up to "posts" has been imported, but "post text" and after has not!
Anybody have any suggestions please?

Posted: Sun Aug 21, 2005 4:17 pm
by SlapShot434
Ah.. this would not be my doing, I have had this problem hundreds of times, its a problem with the convert ucs itself, not my converter. I simply dont know how to fix that, and I apologize. I have thought about editing my converter to a stand-alone converter, however, due to school, I dont have a lot of time to get this done. Please bear with me as I continue to attempt to reserve some time to work on this.

Posted: Mon Aug 22, 2005 2:36 am
by idburns
SlapShot434 wrote: yes, the path needs to go to your smf forum, NOT the phpbb forum


Ok.

I have installed phpBB right alongside the smf forum (http://www.mong.tv/smf and http://www.mong.tv/phpBB) so my path should be "../smf/" correct? I'm still getting the timeout error.

Do'h... Even though I've been getting the page not found error it looks like some of the database has been converted. My phpBB install is showing the forum names and thread/post counts and the member groups are there. The forums security even looks like it got transfered correctly since guests only see the news forum.

But it has not moved the members over and it looks like the actual threads and posts have not moved either.

Ideas?

Posted: Mon Aug 22, 2005 8:50 pm
by Pablasso
well, ive been testing the succesfully converted forum (thanks slap!) and the forum is working pretty well, awesome work.

just a pair of issues i had found, like the ones in this post >

http://www.ciberpc.com/forum/viewtopic.php?t=1037

you can see some pages corrupted like this ->

http://www.ciberpc.com/forum/viewtopic. ... start=2000

and you cant see the final page of the post, because it simple doesnt exists..

there are some few post like that one in the forum, but most of them are working well

nice work slap

Posted: Thu Aug 25, 2005 12:46 am
by CAPZkilla
i had a similar thing aswell
sometimes entire topics would be embedded in 1 post, removing the quote opening tag would fix it ( there is no close tag )

Posted: Thu Aug 25, 2005 12:55 am
by SlapShot434
i dont think this has anything to do with the converter. What is happening is people arent correctly closing the quote tags. SMF correctly ignores this, but phpbb doesnt always correctly realize there's no closing tag.

Posted: Thu Aug 25, 2005 9:30 am
by Graham
On a new post if I do this

[quote]blah

and don't close it, it will be ignored - because phpBB checks the tags on posting and doesn't add the bbcode_uid to invalid tags - if you are adding the uid to all tags whether matched or not, that is the problem

Posted: Thu Aug 25, 2005 9:25 pm
by SlapShot434
Aha, looks like i completely forgot about that when I made it convert the quote tags, I'll fix it soon and update the link asap

Posted: Fri Aug 26, 2005 7:56 am
by xdarkday
CAPZkilla wrote:
xdarkday wrote:Let us take a look at the beta please. Im starting to belive that there is no converter or for some wierd reason you wont let us help you.
i have the converter, so that proves it exists, however there are a few things that just dont work like they should. And i dont think he needs more testers, having too many will make the debugging process chaotic.

At this point,i can tell you that, even though you would like to use it, it's best not to. You cannot use this on a live board in the state which it's in.

As SlapShot posted, alot of work has to be done to make sure nobody ends up with a malfunctioning board. Just stick around and wait for a proper release, one thing is for sure, a properly functioning smf to phpbb converter is in the works, and it will be done, when it's done
Ugh... Lets please not assume that i was asking for a "release" version of the converter. Anywho back to planet reality.....
CAPZkilla wrote: im having an issue, and it must be caused by the converted database since im running a clean phpbb install now, with no MODs
when i turn the board emailing system off, and users have the "Notify me when a reply is posted" option on, they get
sending email :: PHP ::

DEBUG MODE

Line : 234
File : emailer.php
with email system on, and "Notify me when a reply is posted" option off, they also get the same error when posting in certain topics in the board, this only seems to be happening in catagories i've added after the conversion and have forums from the old smf database in them.

Even though this, to me looks like an error created by a MOD, since i have no, it must be the converted database.. cant wait for my new php & mysql book :P then i'll finally understand how all of this works :o

Also, there is no need to look into the "isn't converting in a non "phpBB2" dir" issue, since it doesnt seem to happen anymore. I've downloaded the phpbb install again and it's gone, so that was most likely caused by a slightly corrupted phpbb install.
Graham wrote: This is neither a bug, nor a MOD - it is an issue caused by your mail settings. Try opening a topic in support on it

This post alone got me thinking that more people need to take a look at the converter.


Thanks for the links (both PMed and posted). So far I have had a smooth conversion with minimal errors. I have had a few pages corrupted like posted above. Im glad I have somthing to play around with for a while. Ill be posting updates soon.

Posted: Fri Aug 26, 2005 9:19 pm
by SlapShot434
The reason I took the beta link down a week ago was because a major bug appeared that was causing errors on all who tried it. Therefore, I wasnt going to allow more people to download it and get the same error, and thus complain about it, until i discovered the cause and fixed it.