Page 1 of 1

Trouble with Invision Board 2.1.x -> phpBB 2.x (Fixed!)

Posted: Sun Feb 03, 2008 2:54 am
by ctb
Trying to move from Invision Board 2.1.5 -> phpBB2 -> phpBB3. Yeah, it's crazy, but I friggin hate IPB.

When running the convertor, there are places where it doesn't appear to fully convert the full count of items. Like posts, for example. It says "Number of posts to convert : 58924 ." but only gets to around 38500 or 39000 before it stops the conversion. It doesn't display any error message either.

I've re-tried multiple times, each time starting with a database in a pre-conversion/post-phpBB2 install state (with both the ibf_ and phpbb_ tables intact).

Anyone have any suggestions for troubleshooting this? I can happily provide more details. And if there's any way to turn on logging for the conversion, pls let me know! :)

I'm running this on CentOS 5.0, MySQL 5.0.2, PHP 5.1.6 and Apache 2.2.3. Thanks!

- ctb

Re: Trouble with Invision Board 2.1.x -> phpBB 2.x converter

Posted: Sun Feb 10, 2008 4:10 am
by D¡cky
This is a common problem with this convertor. The best solution is to do the conversion in steps.

When the convertor stops, look at your phpBB database and see what the last row that is converted. When you browse the table near the top of the page should be a message that shows the total number of rows. You will want to start the convertor with the next row.

OPEN conv_posts or conv_posts_text (whichever one the convertor stalls on.

FIND

Code: Select all

$posts_loc=0;
Change the zero to the total number of rows plus 1

Also be sure to delete the section that empties the database when the script starts

Code: Select all

		// emptying the database 
 
		$sql = "TRUNCATE TABLE " . POSTS_TABLE;
		
		if( !$db->sql_query($sql) ) 
		{ 
		message_die(GENERAL_ERROR, 'Could not delete Posts Text', '', __LINE__, __FILE__, $sql); 
		}

Re: Trouble with Invision Board 2.1.x -> phpBB 2.x converter

Posted: Wed Mar 05, 2008 7:59 am
by ctb
I edited my php.ini as you suggested here and changed the following:

max_execution_time = 36000
max_input_time = 6000

Then restarted httpd, re-ran the conversion script, and this time it worked!

I also ran all the database maintenance tasks for Invision from its admin panel before exporting the database, that way all the posts and such were in correct order, etc.

Thanks for your help! :)