Page 1 of 1

phpBB 3.0.6 Release Candidate 2 released

Posted: Fri Sep 25, 2009 7:14 pm
by Acyd Burn
Warning: This release candidate is only meant for people who want to participate in the QA process - if you are interested, please subscribe to the QA Mailing List to be notified about additional release candidates.

Hello,

In an effort to increase product stability we are happy to announce the availability of the second release candidate for the next release - phpBB 3.0.6.

This second release candidate contains mostly regression fixes. We also tested the automatic updater with some heavily modified boards and were able to significantly decrease it's failure rate.
The automatic updater is now able to detect and solve most usual conflicts and only shows conflicts for lines where a MOD/User changed the same line as we did. The updater also resolves SVN $Id$ conflicts on it's own.
This - and some fixes to the updater - results in a lot less conflicts and therefore a much more pleasant update experience.

Everyone able to should test this release and report critical bugs (those, stopping the operation of the forum) and issues to the bug tracker or directly to the developers.

We recommend international support sites to update their sites to RC2 too. We are able to provide direct support to them within our international support sites forums.

Note to people using 3.0.4 files in 3.0.5 installations

We know that some replaced their includes/functions_messenger.php file from their phpBB 3.0.5 installation with the version from phpBB 3.0.4 due to the following bug:
Ticket #46725 - functions_messenger [...] causing emailing issues

If you update to RC2 please *re-upload the 3.0.5 functions_messenger.php file* and any other file you replaced with previous versions. If you do not use phpBB 3.0.5 files all modifications will be identified as non-phpBB modifications and merged during the automatic update. This will result in wrong updates where to-be-updated parts for phpBB 3.0.6 will not be included and you will not benefit from the bug fixes - or even notice grave errors.

Language Packs and Styles

We already gave out instructions to language pack authors to let them update their language packs in a timely manner. The changes are provided with the code changes package (see downloads section below). Style authors should also download the code changes package and adjust their styles accordingly. Please post within our Styles forums if you have questions or encounter problems.

There were no changes to the language files or the styles from RC1 to RC2.

The package is downloadable from:
http://www.phpbb.com/files/qa/phpBB-3.0 ... hanges.zip
http://www.phpbb.com/files/qa/phpBB-3.0 ... es.tar.bz2

New features, changes, bug fixes

For a list of changes, please see our changelog located at:
http://www.phpbb.com/support/documents. ... &version=3

Or our Release Candidate 1 Announcemente located at:
http://www.phpbb.com/community/viewtopi ... &t=1777815

Available packages:

With this release, there are five packages available.

Full Package:
Contains entire phpBB3 source and english language files.

Automatic Update Package:
Update package for the automatic updater, containing the changes from previous release to this release.

Changed Files Only:
Contains only those files changed from previous versions of phpBB3. Please note this archive contains changed files for each previous release.

Patch Files:
Contains patch compatible patches from previous versions of phpBB3.

Code Changes Package:
Package contains changes to the following sections: Language changes, prosilver style changes and subsilver2 style changes.

Select whichever package is most suitable for you. As a tiny guide we recommend the following methods based on the requirements:
  • For a new installation you should use the Full Package
  • For updates of boards without modifications you can basically use the Automatic Update Package (guided udpate) or the Changed Files Only package (manual update).
  • For updates of boards with modifications you should use the Automatic Update Package. If you are confident with patch files and patching you can use the Patch Files Package.
  • Style Authors and Translators may use the Code Changes Package to update their styles or language packs directly.
  • International Support Teams may use the Patch Package in conjunction with the Code Changes to better support users having problems with conflicts or specific code sections.
  • If you are a hoster/provider, you may want to use the Patch Files Package to update all of your client installations.
Please ensure you read the INSTALL and README documents in docs/ before proceeding with installation, updates or conversions!

Download:

Full Package:
http://www.phpbb.com/files/qa/phpBB-3.0.6-RC2.zip
http://www.phpbb.com/files/qa/phpBB-3.0.6-RC2.tar.bz2

Automatic Update Package (3.0.5 to 3.0.6-RC2):
http://www.phpbb.com/files/qa/phpBB-3.0 ... .6-RC2.zip
http://www.phpbb.com/files/qa/phpBB-3.0 ... C2.tar.bz2

Automatic Update Package (3.0.6-RC1 to 3.0.6-RC2):
http://www.phpbb.com/files/qa/phpBB-3.0 ... .6-RC2.zip
http://www.phpbb.com/files/qa/phpBB-3.0 ... C2.tar.bz2

Changed Files Only Package:
http://www.phpbb.com/files/qa/phpBB-3.0.6-RC2-files.zip
http://www.phpbb.com/files/qa/phpBB-3.0 ... es.tar.bz2

Patch Files Package:
http://www.phpbb.com/files/qa/phpBB-3.0.6-RC2-patch.zip
http://www.phpbb.com/files/qa/phpBB-3.0 ... ch.tar.bz2

Code Changes Package:
http://www.phpbb.com/files/qa/phpBB-3.0 ... hanges.zip
http://www.phpbb.com/files/qa/phpBB-3.0 ... es.tar.bz2


IMPORTANT

To correctly perform an update, do not forget to re-enable the PHPBB_QA constant within your includes/constants.php file. Else you are not prompted for an update within the ACP and the automatic update will eventually fail. :)


Have fun with the release,
the phpBB Team