[UPDATED] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Read me first before posting anywhere!
Subscribe to the feed, available in Image Atom or Image RSS format.
Scam Warning
Post Reply
Oleg
Former Team Member
Posts: 1221
Joined: Sat Jan 30, 2010 4:42 pm
Location: NYC
Contact:

[UPDATED] phpBB 3.1 "Ascraeus" to require PHP 5.3.3

Post by Oleg » Fri Mar 09, 2012 4:21 pm

The next major release of phpBB, phpBB 3.1 "Ascraeus", will require PHP 5.3.2 or newer.

PHP 5.3 provides important functionality that a number of established projects are using. As it is phpBB's goal to use components from other projects where doing so makes sense, raising minimum PHP version to 5.3 allows phpBB to reuse some components from Symfony instead of reimplementing equivalent functionality. This will speed up the completion of phpBB 3.1 by reducing the amount of work that Development Team has to do.

You can read the discussion leading to the decision.

All major distributions are already shipping PHP 5.3.2 or newer in their current stable versions. You can find a table of several distributions and the versions they ship here.

phpBB 3.0 "Olympus" will continue to require PHP 4.3.3 as the minimum version.

phpBB 3.0.10 supports PHP 5.3. Since PHP 5.2 is no longer maintained by PHP developers, all users not already running PHP 5.3 are strongly encouraged to move to PHP 5.3.

As phpBB 3.1 "Ascraeus" is still under active development, there is still plenty of time to upgrade your PHP installation.

Additionally, one should note that this announcement does not imply that phpBB 3.1 will see large portions of code rewritten in order to take advantage of new features in PHP 5.3. Instead, sections of code will be updated as needed in the 3.x release cycle.


Please discuss this announcement here.
Participate in phpBB development: Get involved | Issue tracker | Report a bug | Development board | [url=irc://chat.freenode.net/phpbb-dev]Development IRC chat[/url]
My stuff: mindlinkgame.com

User avatar
naderman
Consultant
Consultant
Posts: 3735
Joined: Fri Aug 01, 2003 10:06 pm
Location: Berlin, Germany
Name: Nils Adermann
Contact:

Re: phpBB 3.1 "Ascraeus" to require PHP 5.3.2

Post by naderman » Thu Nov 08, 2012 3:33 pm

We decided to slightly amend the required version for our next major release, phpBB 3.1 "Ascraeus", again, and will require PHP 5.3.3 or newer.

As per the previous announcement we intended to introduce 3rd party components into phpBB and therefore announced the minimum requirement increase to PHP 5.3.2. However, Symfony updated their minimum requirement shortly after. Our code now relies on changes made after the version requirement increase.

The discussion leading to this decision can be found on Area51.

All major distributions are already shipping PHP 5.3.3 or newer in their current stable versions.
I appreciate gifts from my Amazon wishlist.
naderman.de twitter: @naderman

Post Reply

Return to “Announcements”

Who is online

Users browsing this forum: oBot and 29 guests