[20/01/07] Admin Userlist

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
398
72%
Very Good
98
18%
Good
38
7%
Fair
11
2%
Poor
11
2%
 
Total votes: 556

bsolah
Registered User
Posts: 86
Joined: Sun Feb 19, 2006 12:32 am
Location: Melbourne, Australia
Contact:

Post by bsolah »

Ok, scrap that stupid question. My brain is not functioning tonight.
Image
sergeyka
Registered User
Posts: 4
Joined: Mon Sep 18, 2006 2:05 pm

Post by sergeyka »

This is screenshot of addon for this beautyfull mod :)
Image

With this add-on you can search (filter results) by mask in username, website & email. This usefull for search spamers :)

Installation instruction you can see http://www.phpbb.com/phpBB/viewtopic.ph ... 20#2438020
falski
Registered User
Posts: 2
Joined: Wed Dec 06, 2006 4:11 am

Post by falski »

rh71 wrote: I upgraded from 2.0.2 to 2.0.6b using the upgrade_userlist_202_to_206b.txt script (via MOD install). I am getting the following error after the delete confirmation button:

Could not delete auto-login keys for this user

DEBUG MODE

SQL Error : 1146 Table 'ovechkin_phpbb1.SESSIONS_KEYS_TABLE' doesn't exist

DELETE FROM SESSIONS_KEYS_TABLE WHERE user_id = 476

Line : 338
File : admin_userlist.php


It seems to delete the user fine though, but if I choose to delete multiple users, it only does the first one and the rest checked remain... so in effect right now, I can only delete one at a time, plus I'm getting this error. I tried to revert back to 2.0.2 and it still gives me this error now (it didn't before the upgrade). Any help appreciated.


It's probably little consolation but I'm getting exactly the same problem after upgrading from 2.0.2 to 2.0.6b ... hopefully someone out there has faced the same problem and solved it!
asinshesq
Registered User
Posts: 6266
Joined: Sun Feb 22, 2004 9:34 pm
Location: NYC
Name: Alan

Post by asinshesq »

Sounds like you guys are on a prior version of phpbb2 (before it had a sessions_keys table). If so, you need to update to current phpbb2 to fix that problem and to close up some real security holes.
User avatar
igorw
Former Team Member
Posts: 8024
Joined: Fri Dec 16, 2005 12:23 pm
Location: {postrow.POSTER_FROM}
Name: Igor Wiedler

Post by igorw »

milkboy31, is there any news?
Igor Wiedler | area51 | GitHub | trashbin | Formerly known as evil less than three
JulieJesta
Registered User
Posts: 116
Joined: Mon Oct 16, 2006 8:39 am
Location: England
Contact:

Request....

Post by JulieJesta »

Hiya, in the next admin userlist can there be a link to the actual PUBLIC profile, rather than the edit admin profile thingy?

the reason i ask is i have multiple psudoes hunter mod installed (collects all ips including reg ip, adds a small ip link to the profile page view able to admin/mods only. and shows in each post to admins/mod too. this mod compares all members ips and lets you know if one user is likely to be using several accounts)
and i have terrafrosts hide zero posters mod.
i like both these mods, but would like to be able to have them all working a bit more seamlessly. at the moment, if i wish to ban a new member (for example one with a porno link on thier profile or clearly a bot), with zero posts by ip its alot of effort. logging in to admin, finding user name on the admin user lists, hoovering over their name to get the u=50 number. then i have to go back to my forum, view a normal members profile, alter the u=number and load that profile fore the spammer newbie. then click on the ip button, then back to admin and banning that ip.

one little button for ip or profile in the admin user list, pleaaaaaaaaaaaaase. and thanks!
Julie, Mum to 1 boy, 1 boyfriend, and many fluffy pets. :)
http://www.parentstime.co.uk
User avatar
milkboy31
Registered User
Posts: 422
Joined: Tue Aug 09, 2005 2:44 pm

Re: Request....

Post by milkboy31 »

The latest version of this mod can be found by going here:
http://www.deathmonkeighs.com/files/Adm ... t_206b.zip
asinshesq wrote: I think the select all/unselect all button at the bottom is sufficient and doesn't create the same risk. So I think I'm going to get rid of that tricky top box on my board.


The box at the top is not only a select all, but it is an inversing box as well. So if you want all users but 5 selected, you can click those 5, then click the top box and poof... done. So it has benefits over just the Select All button at the bottom of the page.
sabsfan2 wrote: I've just installed this great mod and it appeared to work well, prompting me to install both the Log IP Address on Registration mod by TerraFrost and the Admin Userlist regIP add on by exreaction.

While everything works well in the userlist, when I do have to go into a users profile under "manage" and make changes, i get a "oops....page not found" error. I know I've done a lot of things correct (since they were installed by easymod) but at some point, I think I've messed up something else. I can't make/save changes under user admin.

Any suggestions? I'm sorry if I've got this under the wrong mod. I'm starting at the major mod and working to toward the others. I'm not sure what file is wonky, or what mod might have helped me screw up.

Thanx.


The last time I checked, the mod from exReaction was not compatible with the latest version of this mod. That may be the problem.
elimere wrote:
elimere wrote:Ive got a problem with the mod, its not just my coding as i used easy mod to install it. I have two styles and its the same problem on both:
I tick the box next to a username, put the drop down box to "Add to a Group" and hit go.
The problem is, the page goes to the next one, except it isnt the add group page, it looks exactly the same as the userlist page, minus all information (including the directions in the dropdown box).
Its not a lack of usergroups, i have several.
It doesnt come up with an error message.
Anyone able to help?

-Going from the main page, i can go into the usergroups page and add members to the groups by their username and it works fine, just not from the Admin Userlist.

The activate/deactivate works, so does the ban & delete.


Okay, i think ive waited long enough to bump... anyone going to help?.... bump



What version are you running? If you don't know, you don't have the latest. The latest lists the version number at the top of the page.
KY Dave wrote: Has anyone had problems or reported that the DESCENDING SORT Feature doesn't work correctly for all FIELDS?

The first one I noticed was the JOINED DATE sort for DESCENDING. Then I found the USER ID doesn't sort DESCENDING. I haven't checked all fields though.


I think this was fixed a long time ago. It sounds like you are running 2.0.2. Get the latest version from the link at the end of this post.
bsolah wrote: I'm wondering if this works on phpBB 2.0.21.


Yes, quite spectacularly! :-D
Valery_Kondakoff wrote: Excuse me for a novice question, but is it possible to select multiple users in Userlist without manually checking every checkbox?

There are more than 2000 non-active users in my Userlist, so I just wanted to select them all and to delete them.

Thank you!


Sure, with the latest version installed, you sort by "Active Ascending" with a show value of 1,000 or whatever you want... then either use the select all or the inversing check all button at the top to check every user. Verify no one is accidentally checked that shouldn't be (a quick scroll down to see that) then choose delete from the dropdown list and hit ok. Doing this WILL show you active members below your non-active accounts. So make sure none of those are checked before you delete them.
nims wrote: Is there any update planned for this MOD to make it compatible with other MODs like xdata which is used to add fields to the user registration, so that we can effectively use this MOD to list those fields also that have been added using XDATA ?


No, but if anyone wants to contribute they can always post add-ons here. The issue with xdata is that it likely gives a field any name the user desires... to make this mod show that custom name in here, the xdata mod would have to be updated to modify this list when it adds a new field, not the other way around. So perhaps your best bet would be to post to the xdata thread about this issue.
eviL<3 wrote: milkboy31, is there any news?


Mod was denied for a couple of corrections... nothing major. I plan to resubmit in the coming week here. Meant to do it today, but just had too much to do. The changes I have to work out yet will take some testing to ensure they work.
JulieJesta wrote: Hiya, in the next admin userlist can there be a link to the actual PUBLIC profile, rather than the edit admin profile thingy?

the reason i ask is i have multiple psudoes hunter mod installed (collects all ips including reg ip, adds a small ip link to the profile page view able to admin/mods only. and shows in each post to admins/mod too. this mod compares all members ips and lets you know if one user is likely to be using several accounts)
and i have terrafrosts hide zero posters mod.
i like both these mods, but would like to be able to have them all working a bit more seamlessly. at the moment, if i wish to ban a new member (for example one with a porno link on thier profile or clearly a bot), with zero posts by ip its alot of effort. logging in to admin, finding user name on the admin user lists, hoovering over their name to get the u=50 number. then i have to go back to my forum, view a normal members profile, alter the u=number and load that profile fore the spammer newbie. then click on the ip button, then back to admin and banning that ip.

one little button for ip or profile in the admin user list, pleaaaaaaaaaaaaase. and thanks!


If you have the latest version of this mod, you can just click the box next to the user you wish to ban, then go to "Ban" from the dropdown menu and hit OK. That should be a much better solution. ;-)


---------------


To the couple that said they are having issues with the delete function, yes, asinshesq was correct. You don't have the latest version of PHPBB installed so you are getting an error. In fact, you have a rather old version installed... you really should update that for security reasons alone.

BUT if you absolutely cannot do that, you can do this to fix the issue from showing up... as a previous user had asked:
milkboy31 wrote:
crownroyal wrote:Is there anyway that we can work around this message:

Could not delete auto-login keys for this user

DEBUG MODE

SQL Error : 1146 Table 'ven_fx.SESSIONS_KEYS_TABLE' doesn't exist

DELETE FROM SESSIONS_KEYS_TABLE WHERE user_id = 1416

Line : 338
File : admin_userlist.php


I have 3000 people that i would like to delete out of my system and I can't because i get this error above.

I know what teh reason is because of my version. I have :

Powered by phpBB 2.0.18 © 2001 phpBB Group

And I should have

Powered by phpBB 2.0.21 © 2001 phpBB Group

But i really don't want to update, I have tried many times to update phpbb version and I always screw my sdite up.


The following code was added to the admin_userlist.php file when version 19 of the forums required it. Perhaps if you remove this you will see the errors go away...

Code: Select all

				$sql = "DELETE FROM " . SESSIONS_TABLE . " 
                  WHERE session_user_id = $user_id"; 
               if ( !$db->sql_query($sql) ) 
               { 
                  message_die(GENERAL_ERROR, 'Could not delete sessions for this user', '', __LINE__, __FILE__, $sql); 
               } 

               $sql = "DELETE FROM " . SESSIONS_KEYS_TABLE . " 
                  WHERE user_id = $user_id"; 
               if ( !$db->sql_query($sql) ) 
               { 
                  message_die(GENERAL_ERROR, 'Could not delete auto-login keys for this user', '', __LINE__, __FILE__, $sql); 
               } 
At least, that's what I can see by looking back at page 80 of this thread: http://www.phpbb.com/phpBB/viewtopic.php?p=2103751
So open admin_userlist.php in a text editor and remove that code.


The latest version of this mod can be found by going here:
http://www.deathmonkeighs.com/files/Adm ... t_206b.zip
KY Dave
Registered User
Posts: 87
Joined: Thu Oct 24, 2002 3:26 am
Contact:

Re: Request....

Post by KY Dave »

milkboy31 wrote:
KY Dave wrote:Has anyone had problems or reported that the DESCENDING SORT Feature doesn't work correctly for all FIELDS?

The first one I noticed was the JOINED DATE sort for DESCENDING. Then I found the USER ID doesn't sort DESCENDING. I haven't checked all fields though.


I think this was fixed a long time ago. It sounds like you are running 2.0.2. Get the latest version from the link at the end of this post.

The latest version of this mod can be found by going here:
http://www.deathmonkeighs.com/files/Adm ... t_206b.zip

Updating to the latest release fixed the sorting problem.
Thanks for the reply!
No matter how much you know today, you'll have to know more tomorrow...

Image
minihammer
Registered User
Posts: 28
Joined: Thu Jan 12, 2006 6:50 pm

Post by minihammer »

I just installed it from the latest version you just posted. I'm getting the following error when I click on user list.


Template->make_filename(): Error - file admin/userlist_body.tpl does not exist

Version I'm using: http://www.deathmonkeighs.com/files/Adm ... t_206b.zip
User avatar
igorw
Former Team Member
Posts: 8024
Joined: Fri Dec 16, 2005 12:23 pm
Location: {postrow.POSTER_FROM}
Name: Igor Wiedler

Post by igorw »

Rokit, did you upload the file to the template that you're using?
Igor Wiedler | area51 | GitHub | trashbin | Formerly known as evil less than three
camaro92
Registered User
Posts: 450
Joined: Sat Oct 05, 2002 10:55 pm
Contact:

Post by camaro92 »

I added ALL my inactive users to a "INACTIVE" group so I can Mass email that group to welcome them back to the msgboard.

Now I just realized that the script doesn't have a feature to "REMOVE FROM GROUP" to the select users.

I am now going through my list and seeing INACTIVE people coming back so I want to remove them from the list.. That's easily shown by the list. Unfortunately there is no way to simply select all that I need and REMOVE them from the group they are in.. HELP!!
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52105
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Post by Brf »

camaro92 wrote: Unfortunately there is no way to simply select all that I need and REMOVE them from the group they are in.. HELP!!


You can do that in the regular Usergroups screen.... it allows you to select multiple users and remove them from the group.
camaro92
Registered User
Posts: 450
Joined: Sat Oct 05, 2002 10:55 pm
Contact:

Post by camaro92 »

Brf wrote:
camaro92 wrote: Unfortunately there is no way to simply select all that I need and REMOVE them from the group they are in.. HELP!!


You can do that in the regular Usergroups screen.... it allows you to select multiple users and remove them from the group.


yeah, but it doesn't display when they were last active. I have over 3000 people to go through (one at a time?? :roll: :wink: 8) 8O )

Either that or how to add another row to the groups list that shows when they were last active.
User avatar
milkboy31
Registered User
Posts: 422
Joined: Tue Aug 09, 2005 2:44 pm

Post by milkboy31 »

camaro92 wrote: Either that or how to add another row to the groups list that shows when they were last active.


That would be a feature of a different mod (or a mod in inself) so perhaps it may help to ask in the mod requests forum.

All you need are instructions on how to add a "last active" column to the usergroup membership lists that references the session_time variable.
Tom_S
Registered User
Posts: 524
Joined: Tue Jul 29, 2003 6:54 pm
Location: 127.0.0.1
Contact:

Post by Tom_S »

sergeyka wrote: This is screenshot of addon for this beautyfull mod :)
Image

With this add-on you can search (filter results) by mask in username, website & email. This usefull for search spamers :)

Installation instruction you can see http://www.phpbb.com/phpBB/viewtopic.ph ... 20#2438020


Now I like that! Thanks :D
I went back in Time...
Image
Post Reply

Return to “[2.0.x] MOD Database Releases”