View Topic Name While Posting MOD

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
18
62%
Very Good
5
17%
Good
3
10%
Fair
1
3%
Poor
2
7%
 
Total votes: 29

puffer
Registered User
Posts: 6
Joined: Tue Aug 05, 2003 4:28 pm

Post by puffer » Wed Jan 21, 2004 7:14 pm

Excellent, easy to install mod.

User avatar
GPHemsley
Registered User
Posts: 1475
Joined: Fri Apr 18, 2003 3:12 am
Location: Long Beach, NY
Name: Gordon Hemsley
Contact:

Post by GPHemsley » Thu Jan 22, 2004 2:24 am

puffer wrote: Excellent, easy to install mod.

Thank you. :mrgreen:

Klabautermann
Registered User
Posts: 1
Joined: Wed Feb 04, 2004 10:27 pm

There is an Bug

Post by Klabautermann » Wed Feb 04, 2004 10:46 pm

Hello,

I found a Bug in this Mod.

The Topic whond be displayed by using the "post reply" Button it dose only work with the "quote" Button.

This occours because this query:

Code: Select all

    case 'reply':
	case 'vote':
		if ( empty( $topic_id) )
		{
			message_die(GENERAL_MESSAGE, $lang['No_topic_id']);
		}

		$sql = "SELECT f.*, t.topic_status
			FROM " . FORUMS_TABLE . " f, " . TOPICS_TABLE . " t
			WHERE t.topic_id = $topic_id
				AND f.forum_id = t.forum_id";
		break;
in Posting.php dose not select the Topic Title.

You can Fix this by just adding the Field to the select Statement:

Code: Select all

    case 'reply':
	case 'vote':
		if ( empty( $topic_id) )
		{
			message_die(GENERAL_MESSAGE, $lang['No_topic_id']);
		}

		$sql = "SELECT f.*, t.topic_status, t.topic_title
			FROM " . FORUMS_TABLE . " f, " . TOPICS_TABLE . " t
			WHERE t.topic_id = $topic_id
				AND f.forum_id = t.forum_id";
		break;
// Edit: :oops: Ooops, somebody fund it earlyer. Sorry ;)

Have fun
Klabautermann

User avatar
GPHemsley
Registered User
Posts: 1475
Joined: Fri Apr 18, 2003 3:12 am
Location: Long Beach, NY
Name: Gordon Hemsley
Contact:

Re: There is an Bug

Post by GPHemsley » Wed Feb 04, 2004 10:58 pm

Klabautermann wrote: // Edit: :oops: Ooops, somebody fund it earlyer. Sorry ;)

Yeah, it's a bug in phpBB 2.0.3... if you found it, that probably means you're still using it.. Maybe you should upgrade to phpBB 2.0.6. ;)

Skelp
Registered User
Posts: 73
Joined: Mon Mar 08, 2004 11:38 pm

Post by Skelp » Mon Mar 08, 2004 11:42 pm

I must be doing something wrong... I used Easy Mod to install this (cause it says it's EM compatible) but it's not working......
Easy Mod says it installed no problem but I don't see the topic name when I'm replying. There's 6 txt files in the zip for this. I tried installing with those 6 files in the mod dorectory, no go, I tried removing all but one of them (went through each text file) and still nothing.....

Any ideas? Or is there one out there that works?

User avatar
GPHemsley
Registered User
Posts: 1475
Joined: Fri Apr 18, 2003 3:12 am
Location: Long Beach, NY
Name: Gordon Hemsley
Contact:

Post by GPHemsley » Mon Mar 08, 2004 11:49 pm

In order to install this with EasyMOD, you have to have it stored in something similar to admin/mods/View_Topic_While_Posting_MOD_1-0-5/ and you have to run ONLY the file named View_Topic_While_Posting_Mod_1-0-5.txt. The remaining files in the archive are for upgrading from previous versions. If you are unsure of what you should be looking for after installing this MOD, take a look at the posts on the first page of this topic. :mrgreen:

Skelp
Registered User
Posts: 73
Joined: Mon Mar 08, 2004 11:38 pm

Post by Skelp » Tue Mar 09, 2004 12:22 am

I tried that and got nothing. I checked out the mod file and noticed that it only mods the subsilver template, so I changed that to my template and still no go. I also checked the sub silver theme and it wasn't showing up there either. :(

User avatar
GPHemsley
Registered User
Posts: 1475
Joined: Fri Apr 18, 2003 3:12 am
Location: Long Beach, NY
Name: Gordon Hemsley
Contact:

Post by GPHemsley » Tue Mar 09, 2004 12:36 am

I'm not quite sure what is happening, but it's most likely that it's an EasyMOD "problem" (using the term loosely). We'll continue the discussion over there. :mrgreen:

Skelp
Registered User
Posts: 73
Joined: Mon Mar 08, 2004 11:38 pm

Post by Skelp » Tue Mar 09, 2004 2:17 am

Fixed it GP.. for some reason (don't knowif it was EM or what), when the new lines were being added to the files they were also getting commented out. :? I just removed the comment markers and it's working fine now.

Now........ hehe I wanna get it so that the Topic title is listed there when you are viewing the topic Like so:

Forum Index :: -> Computer Gaming Support :: -> Topic Title

I tried messing with the view topic files but nothing yet so far.

Also another wish list item... on the main forum page (index page) ya know where it lists Last Post and it has the date, time and username of the last poster in that forum? I'd like it to also show the topic name of the last post...... any ideas?

And thanksfor the help too GP.

User avatar
GPHemsley
Registered User
Posts: 1475
Joined: Fri Apr 18, 2003 3:12 am
Location: Long Beach, NY
Name: Gordon Hemsley
Contact:

Post by GPHemsley » Tue Mar 09, 2004 2:21 am

Skelp wrote: Now........ hehe I wanna get it so that the Topic title is listed there when you are viewing the topic Like so:

Forum Index :: -> Computer Gaming Support :: -> Topic Title

I tried messing with the view topic files but nothing yet so far.

I'm not sure what you mean by this.
Skelp wrote: Also another wish list item... on the main forum page (index page) ya know where it lists Last Post and it has the date, time and username of the last poster in that forum? I'd like it to also show the topic name of the last post...... any ideas?

And thanksfor the help too GP.

Ptirhiik's Categories Hierarchy MOD has the ability to do this. :mrgreen:

BatLady
Registered User
Posts: 8
Joined: Wed Apr 23, 2003 8:14 pm
Location: Middle Earth

Post by BatLady » Wed Apr 07, 2004 3:43 pm

GPHemsley wrote: This version is exactly the same as the previous version. :D

I'm just confirming that it works with 2.0.6 ;)
How about 2.0.8? I just upgraded, and haven't seen any mods/templates/etc that even mention this version, is it that new? I'm starting to think I should have stayed with 2.0.6! 8O
^v^ BatLady ^v^
batlady@ladysuede.com

User avatar
GPHemsley
Registered User
Posts: 1475
Joined: Fri Apr 18, 2003 3:12 am
Location: Long Beach, NY
Name: Gordon Hemsley
Contact:

Post by GPHemsley » Wed Apr 07, 2004 10:31 pm

I see no reason why this MOD wouldn't work with any upgrade between 2.0.6 and now. Reason being that for each new release since, about one security bug was fixed (with maybe a few other bugs along with it). Which means that 99% of the MODs that say they're compatible with 2.0.6 are also compatible with all of the 2.0.7s and all of the 2.0.8s. 8)

BatLady
Registered User
Posts: 8
Joined: Wed Apr 23, 2003 8:14 pm
Location: Middle Earth

Post by BatLady » Thu Apr 08, 2004 6:10 pm

Thank you, that's very encouraging! I'm a total noob at this. :oops:
^v^ BatLady ^v^
batlady@ladysuede.com

User avatar
beggers
Registered User
Posts: 1257
Joined: Fri Nov 23, 2001 8:19 pm
Location: Las Vegas
Contact:

Post by beggers » Fri Apr 09, 2004 6:04 am

Good job. It was easy to install and worked perfectly the first time. How many mods can you say that about? :lol:

User avatar
GPHemsley
Registered User
Posts: 1475
Joined: Fri Apr 18, 2003 3:12 am
Location: Long Beach, NY
Name: Gordon Hemsley
Contact:

Post by GPHemsley » Fri Apr 09, 2004 6:12 am

beggers wrote: Good job. It was easy to install and worked perfectly the first time.

Thanks! :mrgreen:
beggers wrote: How many mods can you say that about? :lol:

:lol:

Post Reply

Return to “[2.0.x] MOD Database Releases”