Flash MOD

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
68
51%
Very Good
15
11%
Good
17
13%
Fair
7
5%
Poor
26
20%
 
Total votes: 133

User avatar
adzyboy
Registered User
Posts: 215
Joined: Fri Jun 20, 2003 8:50 pm
Location: Burnley, England
Contact:

Post by adzyboy » Wed Sep 17, 2003 5:50 pm

Yes, I got it working now...

Thank you for your help in this situation.

I am very much appreciated of you!

CyanBlue
Registered User
Posts: 409
Joined: Mon Jul 28, 2003 9:55 am

Post by CyanBlue » Wed Sep 17, 2003 6:39 pm

Glad you got it working... :)

Ixtlan
Registered User
Posts: 26
Joined: Wed Mar 19, 2003 10:28 pm

Missing bgcolor parameter

Post by Ixtlan » Sun Sep 21, 2003 10:29 pm

In some other threads people are missing the bgcolor parameter for flash movies display.

This is necessary if you have (transparent) movies with light fonts and a board with light background.
Or if you have more than one templates with different backgrounds (light and dark) in the viewtopic's message area.

See some of those postings:
Flash MOD - Background colour
Flash Mod - Background of Flashmovie is transparent?

Here is how it can be managed to get the bgcolor parameter for flash movies in phpBB postings working.
You'll have to change the original mod's code at three places.

I want to mention first that I've installed the [2.0.6] Macromedia Flash Player BBcode MOD, for QBB
successfully on a heavy modded 2.0.4 board (thx to Davidls) BUT without any buttons and QBB stuff!

(This saved me 70% of the installation time and efforts. I don't need those buttons at the editor.
Users are afraid of too much buttons in the editor ;-)

Better is to have carefully updated the lang_bbcode.php helpfile as mentioned in the orig mod.
Please correct it. - There are dead links for the example movies in it so the php will never stop loading!
- Everyone who needs flash in his messages can and will copy & paste the correct code from there.)

So the three changes of the original mod's code are:
  1. includes/bbcode.php

    Code: Select all

    	//Begin Flash Mod for 2.0.6
    	$bbcode_tpl['flash'] = str_replace('{WIDTH}', '\\1', $bbcode_tpl['flash']);
    	$bbcode_tpl['flash'] = str_replace('{HEIGHT}', '\\2', $bbcode_tpl['flash']);
    	$bbcode_tpl['flash'] = str_replace('{LOOP}', '\\3', $bbcode_tpl['flash']);
    	$bbcode_tpl['flash'] = str_replace('{URL}', '\\4', $bbcode_tpl['flash']);
    	$bbcode_tpl['cf'] = str_replace('{URL}', '\\1', $bbcode_tpl['cf']);
    	//End Flash Mod for 2.0.6
    Replace with:

    Code: Select all

    		//Begin Flash Mod for 2.0.6
    	$bbcode_tpl['flash'] = str_replace('{WIDTH}', '\\1', $bbcode_tpl['flash']);
    	$bbcode_tpl['flash'] = str_replace('{HEIGHT}', '\\2', $bbcode_tpl['flash']);
    	$bbcode_tpl['flash'] = str_replace('{BGCOLOR}', '\\3', $bbcode_tpl['flash']);
    	$bbcode_tpl['flash'] = str_replace('{LOOP}', '\\4', $bbcode_tpl['flash']);
    	$bbcode_tpl['flash'] = str_replace('{URL}', '\\5', $bbcode_tpl['flash']);
    	$bbcode_tpl['cf'] = str_replace('{URL}', '\\1', $bbcode_tpl['cf']);
    	//End Flash Mod for 2.0.6
    
  2. Replace in the same file includes/bbcode.php

    Code: Select all

    	//Begin Flash Mod for 2.0.6
    	//[flash width= heigth= loop=] and[ /flash ]
    	$text = preg_replace("#\[flash width=([0-6]?[0-9]?[0-9]) height=([0-4]?[0-9]?[0-9]) loop=(true|false)\](([a-z]+?)://([^, \n\r]+))\[\/flash\]#si","[flash width=\\1 height=\\2 loop=\\3:$uid\]\\4[/flash:$uid]", $text); 
    $text = preg_replace("#\[flash width=([0-6]?[0-9]?[0-9]) height=([0-4]?[0-9]?[0-9])\](([a-z]+?)://([^, \n\r]+))\[\/flash\]#si","[flash width=\\1 height=\\2 loop=false:$uid\]\\3[/flash:$uid]", $text); 
    $text = preg_replace("#\[flash\](([a-z]+?)://([^, \n\r]+))\[\/flash\]#si","[flash:$uid\]\\1[/flash:$uid]", $text); 
    	//End Flash Mod for 2.0.6
    With:

    Code: Select all

    		//Begin Flash Mod for 2.0.6
    	//[flash width= heigth= loop=] and[ /flash ]
    $text = preg_replace("#\[flash width=([0-6]?[0-9]?[0-9]) height=([0-4]?[0-9]?[0-9]) bgcolor=(\#[0-9A-F]{6}|[a-z\-]+) loop=(true|false)\](([a-z]+?)://([^, \n\r]+))\[\/flash\]#si","[flash width=\\1 height=\\2 bgcolor=\\3 loop=\\4:$uid\]\\5[/flash:$uid]", $text); 
    $text = preg_replace("#\[flash width=([0-6]?[0-9]?[0-9]) height=([0-4]?[0-9]?[0-9])\](([a-z]+?)://([^, \n\r]+))\[\/flash\]#si","[flash width=\\1 height=\\2 bgcolor=\\3 loop=false:$uid\]\\4[/flash:$uid]", $text); 
    $text = preg_replace("#\[flash\](([a-z]+?)://([^, \n\r]+))\[\/flash\]#si","[flash:$uid\]\\1[/flash:$uid]", $text); 
    	//End Flash Mod for 2.0.6
    
  3. changes for templates/subSilver/bbcode.tpl

    Code: Select all

    <!-- BEGIN flash --><!-- URL's used in the movie--> 
    <!-- text used in the movie--> 
    <!-- --> 
    <OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" 
    codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0" 
    WIDTH={WIDTH} HEIGHT={HEIGHT}> 
    <PARAM NAME=movie VALUE="{URL}"> <PARAM NAME=loop VALUE={LOOP}> <PARAM NAME=quality VALUE=high> <PARAM NAME=scale VALUE=noborder> <PARAM NAME=wmode VALUE=transparent> <PARAM NAME=bgcolor VALUE=#000000> <EMBED src="{URL}" loop={LOOP} quality=high scale=noborder wmode=transparent bgcolor=#000000 WIDTH={WIDTH} HEIGHT={HEIGHT} TYPE="application/x-shockwave-flash" PLUGINSPAGE="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash"></EMBED> 
    </OBJECT><!-- END flash --> 
    Replace with (transparency is disabled too in the <object...> tag):

    Code: Select all

    <!-- BEGIN flash --><!-- URL's used in the movie--> 
    <!-- text used in the movie--> 
    <!-- --> 
    <OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" 
    codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0" 
    WIDTH={WIDTH} HEIGHT={HEIGHT}> 
    <PARAM NAME=movie VALUE="{URL}"> <PARAM NAME=loop VALUE={LOOP}> <PARAM NAME=quality VALUE=high> <PARAM NAME=scale VALUE=noborder> <PARAM NAME=bgcolor VALUE={BGCOLOR}> <EMBED src="{URL}" loop={LOOP} quality=high scale=noborder wmode=transparent bgcolor={BGCOLOR} WIDTH={WIDTH} HEIGHT={HEIGHT} TYPE="application/x-shockwave-flash" PLUGINSPAGE="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash"></EMBED> 
    </OBJECT><!-- END flash --> 
    
Please tell your users in your help files that they will have to fill out ALL parameters with correct syntax. Example:

[flash width=80 height=80 bgcolor=#545454 loop=true]http://www.<URL of your>.swf[/flash]

Wrong would be bgcolor=545454 p.e. or width="150" or any missing parameter!

If you want to have other swf-in-html parameters (p.e. transparency...) to be defined as switchable tags
within the phpBB code it will be easy for you to implement it by watching and analyzing carefully the changes made above.

Those changes won't affect the "simple version":
[flash]http://www.<URL of your>.swf[/flash]
This will still work but it's unuseable in most of the cases because the flash movie will look distorted.
You can't save the background color within .swf files afaik. (But you could use a sprite as background.)

HTH
(Sorry for my bad english.)

User avatar
smithy_dll
Former Team Member
Posts: 7630
Joined: Tue Jan 08, 2002 6:27 am
Location: Australia
Name: Lachlan Smith
Contact:

Post by smithy_dll » Fri Oct 10, 2003 5:46 am

default properties (sizes, colour etc...) are set in the html code in bbcode.tpl

Rayxen
Registered User
Posts: 17
Joined: Sat Oct 18, 2003 5:02 am
Contact:

Post by Rayxen » Sat Oct 18, 2003 5:09 am

Just an issue regarding the Language files. I believe the new 2.06 standards are that single quotes are used instead of double quotes? Is this correct? If so, should this mod be updated to have the single quotes?

For example:

Code: Select all

#-----[ OPEN ]---------------------------------
#
language/lang_english/lang_main.php


# 
#-----[ FIND ]---------------------------------
# 
#  NOTE: the full line to look for is:
#$lang['bbcode_f_help'] = "Font size: [size=x-small]small text[/size]";
#
$lang['bbcode_f_help']


# 
#-----[ AFTER, ADD ]---------------------------------
# 

$lang['bbcode_m_help'] = "flash: [flash width= height= loop=]text[/flash] (alt+<hotkey>)";
Should be:

Code: Select all

#-----[ OPEN ]---------------------------------
#
language/lang_english/lang_main.php


# 
#-----[ FIND ]---------------------------------
# 
#  NOTE: the full line to look for is:
#$lang['bbcode_f_help'] = 'Font size: [size=x-small]small text[/size]';
#
$lang['bbcode_f_help']


# 
#-----[ AFTER, ADD ]---------------------------------
# 

$lang['bbcode_m_help'] = 'flash: [flash width= height= loop=]text[/flash] (alt+<hotkey>)';
The same applies for the editing of lang_bbcode.php. I don't know the correct avenues regarding how to get this 'fixed' as such. I just thought I should let everyone know.

Thanks for the mod.

Fenjor
Registered User
Posts: 1
Joined: Thu Apr 15, 2004 7:44 am

Post by Fenjor » Thu Apr 15, 2004 7:52 am

kender wrote: has anyone fixed this problem
seems limits on flash files with this mod are

width=699
height=499

any larger either way and you get a display of the flash entry text, like the bbcode doesnt exist for that (it prints [flash width=700 height=500]url[/flash]


Fix:

Code: Select all

#-----[ OPEN ]--------------------------------- 
# 
includes/bbcode.php

# 
#-----[ FIND ]--------------------------------- 
# 
$patterns[] = "#\[flash width=([0-6]?[0-9]?[0-9]) height=([0-4]?[0-9]?[0-9]) loop=(true|false):$uid\](.*?)\[/flash:$uid\]#si";

#
#-----[ REPLACE WITH ]---------------------------------------------
#
$patterns[] = "#\[flash width=([0-8]?[0-9]?[0-9]) height=([0-6]?[0-9]?[0-9]) loop=(true|false):$uid\](.*?)\[/flash:$uid\]#si";

# 
#-----[ FIND ]--------------------------------- 
# 
$text = preg_replace("#\[flash width=([0-6]?[0-9]?[0-9]) height=([0-4]?[0-9]?[0-9]) loop=(true|false)\](([a-z]+?)://([^, \n\r]+))\[\/flash\]#si","[flash width=\\1 height=\\2 loop=\\3:$uid\]\\4[/flash:$uid]", $text); 
$text = preg_replace("#\[flash width=([0-6]?[0-9]?[0-9]) height=([0-4]?[0-9]?[0-9])\](([a-z]+?)://([^, \n\r]+))\[\/flash\]#si","[flash width=\\1 height=\\2 loop=false:$uid\]\\3[/flash:$uid]", $text);

#
#-----[ REPLACE WITH ]---------------------------------------------
# 
$text = preg_replace("#\[flash width=([0-8]?[0-9]?[0-9]) height=([0-6]?[0-9]?[0-9]) loop=(true|false)\](([a-z]+?)://([^, \n\r]+))\[\/flash\]#si","[flash width=\\1 height=\\2 loop=\\3:$uid\]\\4[/flash:$uid]", $text); 
$text = preg_replace("#\[flash width=([0-8]?[0-9]?[0-9]) height=([0-6]?[0-9]?[0-9])\](([a-z]+?)://([^, \n\r]+))\[\/flash\]#si","[flash width=\\1 height=\\2 loop=false:$uid\]\\3[/flash:$uid]", $text);


Now you can play Flash up to 899 * 699

User avatar
walkiria
Registered User
Posts: 59
Joined: Wed Apr 28, 2004 11:28 pm
Location: Argentina
Contact:

Post by walkiria » Tue Sep 07, 2004 8:29 pm

Hi!! I have one question to make. I´m uploading to the 210.php, I have unzipped all the files and I have uploaded all of them to my server updating them. But, where do I have to upload the htaccess file?? which folder? and the flash_mod_206_qbb.mod???
Thank you so much
Walkiria

wGEric
Former Team Member
Posts: 8805
Joined: Sun Oct 13, 2002 3:01 am
Location: Friday
Name: Eric Faerber
Contact:

Post by wGEric » Wed Oct 06, 2004 9:38 pm

MOD Updated to version 2.0.10
See first post for Download Link

(¯`·._.·[LaZaRuS]·._.·´¯)
Registered User
Posts: 24
Joined: Thu May 27, 2004 8:11 pm
Location: Up on the roof

Post by (¯`·._.·[LaZaRuS]·._.·´¯) » Mon Nov 15, 2004 7:01 pm

Hi, Have installed this mod, and erm, well Im not sure wether it is the syntax or not.. but...

All i get is [size=:acd57ba838][flash width=900 height=900]URL[/flash]

User avatar
smithy_dll
Former Team Member
Posts: 7630
Joined: Tue Jan 08, 2002 6:27 am
Location: Australia
Name: Lachlan Smith
Contact:

Post by smithy_dll » Tue Nov 16, 2004 9:51 am

you must use a valid uniform resource locator which points to a file with the .swf extension

(¯`·._.·[LaZaRuS]·._.·´¯)
Registered User
Posts: 24
Joined: Thu May 27, 2004 8:11 pm
Location: Up on the roof

Post by (¯`·._.·[LaZaRuS]·._.·´¯) » Wed Nov 17, 2004 3:39 am

smithy_dll wrote: you must use a valid uniform resource locator which points to a file with the .swf extension


Which means, in english?

N@stY
Registered User
Posts: 93
Joined: Wed Nov 17, 2004 9:11 pm

Post by N@stY » Wed Nov 17, 2004 9:14 pm

:( i cant find

Code: Select all

$EMBB_widths = array(''
and

Code: Select all

$EMBB_values = array(''
in includes/bbcode.php WTF :S am i the only one... i am using phpbb 2.0.10 and this is the first mod i cant get working :(

User avatar
smithy_dll
Former Team Member
Posts: 7630
Joined: Tue Jan 08, 2002 6:27 am
Location: Australia
Name: Lachlan Smith
Contact:

Post by smithy_dll » Thu Nov 18, 2004 1:25 am

@N@stY

you should've read the author notes
##############################################################
## Author Notes:
## You must have Multiple BBCode MOD installed for this to work.
## Get it here: http://www.phpbb.com/phpBB/viewtopic.php?t=74705
##############################################################





@(¯`·._.·[LaZaRuS]·._.·´¯)

you've hit the soft flash movie size limit, read this thread to find out more about it

N@stY
Registered User
Posts: 93
Joined: Wed Nov 17, 2004 9:11 pm

Post by N@stY » Thu Nov 18, 2004 4:11 pm

smithy_dll wrote: @N@stY

you should've read the author notes
##############################################################
## Author Notes:
## You must have Multiple BBCode MOD installed for this to work.
## Get it here: http://www.phpbb.com/phpBB/viewtopic.php?t=74705
##############################################################

I get "Could not obtain category id. File not downloaded." when i click on Download File: multi-bbc-1-0-1.mod :(

EDIT: ooh i found v. 140c lets try that one :)

TequilaTown
Registered User
Posts: 96
Joined: Wed Jun 23, 2004 11:28 am
Contact:

Post by TequilaTown » Fri Nov 19, 2004 12:05 pm

I had the same problem with the link! I got the version from phpbbhacks in the end....but it makes no modifications to the bbcode.php file! Odd!

Post Reply

Return to “[2.0.x] MOD Database Releases”