Multiple BBCode MOD

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
140
59%
Very Good
35
15%
Good
18
8%
Fair
6
3%
Poor
38
16%
 
Total votes: 237

User avatar
iyeru42
Registered User
Posts: 1120
Joined: Wed Feb 01, 2006 7:22 pm
Location: Madison, WI
Contact:

Post by iyeru42 » Mon Jan 15, 2007 6:05 pm

When easyMOD 3.0 tries to install this modification, it brings up a blank easyMOD page on the right admin screen, and the modification won't show in mod history.

GaDo
Registered User
Posts: 63
Joined: Sat Jul 31, 2004 8:50 am

Post by GaDo » Sun Jan 21, 2007 5:06 am

Hi

I Have Installe the Hide (Aka Lockdown) Mod.

This is a bbcode with NORMAL instalation.

When i install this and youtube mod, hide and youtube its the same bbcode (i press hide button and appear hide and i press youtube botom appear hiden bbcode)

I need Help, thanks :)

thekingz
Registered User
Posts: 12
Joined: Mon Jan 22, 2007 5:08 am

Post by thekingz » Mon Jan 22, 2007 5:18 am

#-----[ FIND ]---------------------------------
#
# NOTE - the full line to look for is:
# make_jumpbox('viewforum.'.$phpEx);
#
make_jumpbox(


#
#-----[ AFTER, ADD ]---------------------------------
#
Multi_BBCode();

I don't get this....
Can someone explain how that exact line should be? It says, after make_jumpbox(Multi_BBCode();? I don't get this... can someone fix it for me. thx

User avatar
Socialoutcast
Registered User
Posts: 61
Joined: Fri Oct 20, 2006 2:43 am
Location: Scotland

Post by Socialoutcast » Mon Jan 22, 2007 3:22 pm

thekingz wrote: #-----[ FIND ]---------------------------------
#
# NOTE - the full line to look for is:
# make_jumpbox('viewforum.'.$phpEx);
#
make_jumpbox(


#
#-----[ AFTER, ADD ]---------------------------------
#
Multi_BBCode();

I don't get this....
Can someone explain how that exact line should be? It says, after make_jumpbox(Multi_BBCode();? I don't get this... can someone fix it for me. thx

I believe [AFTER, ADD] means you add it on the next line. That's what I've been doing anyway.

User avatar
smackdown
Registered User
Posts: 89
Joined: Tue Aug 24, 2004 5:55 pm

Post by smackdown » Thu Jan 25, 2007 2:53 am

According to the instructions, it should look like this:

make_jumpbox(
Multi_BBCode();
'viewforum.'.$phpEx);

:?: :!: :?: :!:


I agree with Socialoutcast on this one.
-misleading lines
-wrong codes in FIND sections
-two files to edit listed when there's actually 5

This thread wouldn't be 48 pages long if the changes were made in 2004 when they were discovered.

If this mod is the lynch-pin for all the other bbcode mods, wouldn't having it mistake free be pretty important? just sayin'...
You can PM me with support questions, but I don't know a thing about phpBB...

User avatar
smackdown
Registered User
Posts: 89
Joined: Tue Aug 24, 2004 5:55 pm

Post by smackdown » Fri Jan 26, 2007 2:00 am

I'm no expert by any means, but I took the liberty to fix some of the typos in this mod and added a few notes.

Could someone please check this and tell me if it is correct?

Look for the red #'s to signify where the changes are...
Thanks.

DON'T USE THIS VERSION UNTIL IT'S CHECKED!!!!
## easymod compliant
##############################################################
## MOD Title: Multiple BBCode MOD
## MOD Author: Nuttzy99 < nospam@blizzhackers.com > (n/a) http://www.blizzhackers.com
## MOD Author, Secondary: wGEric < eric@best-dev.com > (Eric Faerber) http://mods.best-dev.com/
##
## MOD Description: Allows you to install BBCode MODs that
## add quick BBCode buttons in post edits. Without this
## MOD, there is no standard way of installing BBCode MODs.
## MOD Version: 1.4.0c
##
## Installation Level: EASY
## Installation Time: 2 minutes
## Files To Edit: posting.php
## templates/subSilver/posting_body.tpl
## privmsg.php
## includes/bbcode.php
## language/lang_english/lang_main.php

## Included Files: n/a
##############################################################
## For Security Purposes, Please Check: http://www.phpbb.com/mods/ for the
## latest version of this MOD. Downloading this MOD from other sites could cause malicious code
## to enter into your phpBB Forum. As such, phpBB will not offer support for MOD's not offered
## in our MOD-Database, located at: http://www.phpbb.com/mods/
##############################################################
##
## Author Notes:
## + if Multi BBCode MOD v1.0.1 is already installed, use the update to 1.2.0 MOD
## and do NOT install this MOD script
## + Works with phpBB 2.0.2 thru 2.0.10
## + installable with EasyMOD
##
## Version 1.4.0 makes it so MOD Authors don't have to set a hotkey for their BBCodes.
##
## I have added instructions to the MOD that tell MOD Authors what to do in the language files
## This isn't required but I heavily recommend that you do it anyways just in case the MOD Authors
## use something in what I have added as their FIND.
##
##############################################################
##
## MOD History:
##
## 2004-09-26 - Version 1.4.0
## + Sets hot key automatically
## + Adds it to Private Messages (version b)
## + Fixes a help line bug (version c)
##
## 2003-09-25 - Version 1.2.1
## + improved MOD Template compliance
##
## 2003-08-15 - Version 1.2.0
## + updated for 2.0.6
## + allows additional hotkeys - Xore did most of the work ;-)
## + made EasyMOD compatiable
##
## 2003-02-03 - Version 1.0.1
## + updated for 2.0.4
## + no code changes required, just updated the header info
##
## 2002-08-31 - Version 1.0.0
## + initial release
##
##############################################################
## Before Adding This MOD To Your Forum, You Should Back Up All Files Related To This MOD
##############################################################


#
#-----[ OPEN ]---------------------------------
#
posting.php


#
#-----[ FIND ]---------------------------------
#
# NOTE - the full line to look for is:
# make_jumpbox('viewforum.'.$phpEx);
#
make_jumpbox(


#
#-----[ AFTER, ADD ]---------------------------------
#
Multi_BBCode();


#
# NOTE - Insert after full line begining with make_jumpbox(
make_jumpbox('viewforum.'.$phpEx);
Multi_BBCode();

#


#
#-----[ OPEN ]---------------------------------
#
privmsg.php


#
#-----[ FIND ]---------------------------------
#
generate_smilies('inline', PAGE_PRIVMSGS);


#
#-----[ AFTER, ADD ]---------------------------------
#
Multi_BBCode();

#
#-----[ OPEN ]---------------------------------
#
includes/bbcode.php
#
#-----[ FIND ]---------------------------------
#
$bbcode_tpl = null;
#
#-----[ AFTER, ADD ]---------------------------------
#

// MULTI BBCODE-begin
function Multi_BBCode()
{
global $template, $lang;

// DO NOT CHANGE THIS ARRAY
$hotkeys = array('', 'd', 'e', 'g', 'h', 'j', 'k', 'm', 'n', 'r', 't', 'v', 'x', 'y', 'z', '1', '2', '3', '4', '5', '6', '7', '8', '9', '0');

//NOTE: the first element of each array must be '' Add new elements AFTER the ''
$EMBB_widths = array('') ;
$EMBB_values = array('') ;
for ($i=1; $i<count($EMBB_values); $i++)
{
// load BBcode MODs info
$val = ($i*2)+16 ;
$help_lang = ( !empty($lang['bbcode_help'][(strtolower($EMBB_values[$i]))]) ) ? $lang['bbcode_help'][(strtolower($EMBB_values[$i]))] : $lang['bbcode_help'][$EMBB_values[$i]];
$template->assign_block_vars('MultiBB', array(
'KEY' => $hotkeys[$i],
'NAME' => "addbbcode$val",
'HELP' => sprintf($help_lang, $hotkeys[$i]),
'WIDTH' => $EMBB_widths[$i],
'VALUE' => $EMBB_values[$i],
'STYLE' => "bbstyle($val)")
);
}
}
// MULTI BBCODE-end

#
#-----[ OPEN ]---------------------------------
#
templates/subSilver/posting_body.tpl


#
#-----[ FIND ]---------------------------------
#
f_help = "{L_BBCODE_F_HELP}";

#
#-----[ AFTER, ADD ]---------------------------------
#
<!-- BEGIN MultiBB -->
{MultiBB.VALUE}_help = "{MultiBB.HELP}";
<!-- END MultiBB -->

#
#-----[ FIND ]---------------------------------
#
# NOTE - the full line to look for is:
# <input type="button" class="button" accesskey="w" name="addbbcode16" value="URL" style="text-decoration: underline; width: 40px" onClick="bbstyle(16)" onMouseOver="helpline('w')" />
# </span></td>
#
name="addbbcode16"
</td>

#
#-----[ AFTER, ADD ]---------------------------------
#

<!-- BEGIN MultiBB -->
<td><span class="genmed">
<input type="button" class="button" accesskey="{MultiBB.KEY}" name="{MultiBB.NAME}" value="{MultiBB.VALUE}" style="width: {MultiBB.WIDTH}px" onClick="{MultiBB.STYLE}" onMouseOver="helpline('{MultiBB.VALUE}')" />
</span></td>
<!-- END MultiBB -->
#
#-----[ FIND ]---------------------------------
#
# NOTE - the full line to look for is:
<select name="addbbcode18" onChange="bbfontstyle('[color=' + this.form.addbbcode18.options[this.form.addbbcode18.selectedIndex].value + ']', '[/color]')" onMouseOver="helpline('s')">

#
#-----[ IN-LINE FIND ]---------------------------------
#
name="addbbcode18"


#
#-----[ IN-LINE REPLACE WITH ]---------------------------------
#
name="addbbcodefontcolor"


#
#-----[ IN-LINE FIND ]---------------------------------
#
this.form.addbbcode18.options


#
#-----[ IN-LINE REPLACE WITH ]---------------------------------
#
this.form.addbbcodefontcolor.options


#
#-----[ IN-LINE FIND ]---------------------------------
#
this.form.addbbcode18.selectedIndex


#
#-----[ IN-LINE REPLACE WITH ]---------------------------------
#
this.form.addbbcodefontcolor.selectedIndex


#
# NOTE - When Complete, line should read:
<select name="addbbcodefontcolor" onChange="bbfontstyle('[color=' +this.form.addbbcodefontcolor.options[this.form.addbbcodefontcolor.selectedIndex].value + ']', '[/color]')" onMouseOver="helpline('s')">
#

#
#-----[ FIND ]---------------------------------
#
# NOTE - the full line to look for is:
# </select> &nbsp;{L_FONT_SIZE}:<select name="addbbcode20" onChange="bbfontstyle('[size=' + this.form.addbbcode20.options[this.form.addbbcode20.selectedIndex].value + ']', '[/size]')" onMouseOver="helpline('f')">


#
#-----[ IN-LINE FIND ]---------------------------------
#
name="addbbcode20"


#
#-----[ IN-LINE REPLACE WITH ]---------------------------------
#
name="addbbcodefontsize"


#
#-----[ IN-LINE FIND ]---------------------------------
#
this.form.addbbcode20.options


#
#-----[ IN-LINE REPLACE WITH ]---------------------------------
#
this.form.addbbcodefontsize.options


#
#-----[ IN-LINE FIND ]---------------------------------
#
this.form.addbbcode20.selectedIndex


#
#-----[ IN-LINE REPLACE WITH ]---------------------------------
#
this.form.addbbcodefontsize.selectedIndex


#
# NOTE - When complete, line should read:
</select> &nbsp;{L_FONT_SIZE}:<select name="addbbcodefontsize" onChange="bbfontstyle('[size=' + this.form.addbbcodefontsize.options[this.form.addbbcodefontsize.selectedIndex].value + ']', '[/size]')" onMouseOver="helpline('f')">
#
#



#
#-----[ OPEN ]---------------------------------
#
language/lang_english/lang_main.php

#
#-----[ FIND ]---------------------------------
#
# NOTE - the full line to look for is:
# $lang['bbcode_f_help'] = 'Font size: [size=x-small]small text[/size]';
#
$lang['bbcode_f_help']

#
#-----[ AFTER, ADD ]---------------------------------
#

//
// bbcode help format goes like this
// $lang['bbcode_help']['value'] = 'BBCode Name: Info (Alt+%s)';
//
// value is what you put in $EMBB_values in posting.php
// %s gets replaced with the automatic hotkey that the bbcode gets assigned
//
$lang['bbcode_help']['value'] = 'BBCode Name: Info (Alt+%s)';

#
#-----[ SAVE/CLOSE ALL FILES ]---------------------------------
#
# EoM
Last edited by smackdown on Fri Jan 26, 2007 3:29 am, edited 1 time in total.
You can PM me with support questions, but I don't know a thing about phpBB...

HelloPpl
Registered User
Posts: 14
Joined: Sat Jan 06, 2007 12:15 am

Post by HelloPpl » Fri Jan 26, 2007 2:57 am

sry..

I installed this mod and my buttons for bbcode and emoticons didnt work nemore. Anyone have an idea? Btw, do extra spaces affect this? If it does, i could go back and see if theres any, which is doubtful.
:(

Everything else including manually typing the codes still worked. All I did was everything the mod said, and nothing more. Is there anything else I should do after it or something?

User avatar
smackdown
Registered User
Posts: 89
Joined: Tue Aug 24, 2004 5:55 pm

Post by smackdown » Fri Jan 26, 2007 3:32 am

Did you install the full version or an upgrade?
You can PM me with support questions, but I don't know a thing about phpBB...

HelloPpl
Registered User
Posts: 14
Joined: Sat Jan 06, 2007 12:15 am

Post by HelloPpl » Fri Jan 26, 2007 3:46 am

full, of course

*edit- great.. now i cant even remove it by deleting the scripts... thought it wouldnt have done anything :| forgot to backup lol.. is there anyway to have it fixed instead of re-installing the forum?

User avatar
smackdown
Registered User
Posts: 89
Joined: Tue Aug 24, 2004 5:55 pm

Post by smackdown » Fri Jan 26, 2007 3:55 am

Double check the templates/subSilver/posting_body.tpl

Make sure there is no space as you have already guessed.
If your using a style other than subsilver, make sure you edited the posting_body.tpl file in your style's folder.

That's all I can think of...sorry.
You can PM me with support questions, but I don't know a thing about phpBB...

HelloPpl
Registered User
Posts: 14
Joined: Sat Jan 06, 2007 12:15 am

Post by HelloPpl » Fri Jan 26, 2007 3:59 am

i checked, and took away a few spaces, but it didnt fix it.

Melian01
Registered User
Posts: 42
Joined: Thu Jan 25, 2007 1:03 am
Contact:

Post by Melian01 » Sat Feb 03, 2007 11:11 pm

Hello there, here is what i get using the mods moderator tags, google video and youtube video.

As you can see 2 of the 3 tags appear next to the table.

Image

I use subsilver, and i can't figure how to fix this problem.

Any ideas ?

User avatar
inferno5
Registered User
Posts: 24
Joined: Sun Feb 04, 2007 6:59 pm
Contact:

Post by inferno5 » Sun Feb 04, 2007 7:20 pm

I am having some hard time installing this MOD. I have changed all the files and I did understand what was asked to do in the instructions even though they were a little confusing. However, the problem is that I don't see any change in the forum at all. There is neither any error, nor the BBcode Tags and Buttons showing up in Post Reply, which are the only two outcomes I thought of.

I have changed all the other files correctly, but I am a bit confused about the posting_body.tpl. I am using the Classic template and thats why I think there might be some issues that need to be solved.

The file can be downloaded from here.

If you need to see my other files, please do not hesitate to ask me. I have been looking over and over the code for 3 days now. Any help would be much appreciated

User avatar
Socialoutcast
Registered User
Posts: 61
Joined: Fri Oct 20, 2006 2:43 am
Location: Scotland

Post by Socialoutcast » Tue Feb 06, 2007 3:47 am

inferno5 This MOD doesn't make any visible changes to your forum. It is meant to allow you to add other BBcode MODS like the one for youtube.

OUTLAWRIDAZ
Registered User
Posts: 31
Joined: Thu Dec 28, 2006 1:48 am

Post by OUTLAWRIDAZ » Sat Feb 10, 2007 10:21 am

this is a great... thanks

Post Reply

Return to “[2.0.x] MOD Database Releases”