Simply Merge Threads

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
64
52%
Very Good
25
20%
Good
14
11%
Fair
6
5%
Poor
15
12%
 
Total votes: 124

lumanacom
Registered User
Posts: 9
Joined: Tue Mar 29, 2005 3:57 pm

Post by lumanacom »

I dont get how to do this at all, I just read all of the posts here but no one explains which directories to put it in...

Can someone help me. I have done nothing but unzip it, Im lost. :oops:

asinshesq
Registered User
Posts: 6266
Joined: Sun Feb 22, 2004 9:34 pm
Location: NYC
Name: Alan

A minor change that may be helpful to some people....

Post by asinshesq »

One minor annoyance in using this mod is that when you are merging a topic and you click 'select' to find the destination topic, the screen opens up with no topics in the list because it does not yet know which forum the user wants to choose the topic from. Most often (at least for me), the destination will be in the same forum as the topic being merged. For that reason, I thought it would be useful if the screen that opens up when you click select shows you by default all the topics from the forum of the topic you are merging (and of course if you want to select another forum to look through, you can do that too).

Anyway, here's the change that implements that default forum idea:

Code: Select all

OPEN
merge.php

FIND
	$sql = "SELECT topic_title FROM " . TOPICS_TABLE . " WHERE topic_id=$from_topic_id";

REPLACE WITH
	$sql = "SELECT topic_title, forum_id FROM " . TOPICS_TABLE . " WHERE topic_id=$from_topic_id";

FIND
		$from_title = $row['topic_title'];

AFTER, ADD
		$forum_id = $row['forum_id'];

FIND
$forum_id = 0;

REPLACE WITH
$forum_id = ($forum_id) ? $forum_id : 0;

asinshesq
Registered User
Posts: 6266
Joined: Sun Feb 22, 2004 9:34 pm
Location: NYC
Name: Alan

Post by asinshesq »

A number of posts in this thread asked about a mod that would split posts from a topic and merge them into an existing topic in a single step. Here is a mod that does that: http://www.phpbb.com/phpBB/viewtopic.ph ... 85#1519485

The gui is not as elegant as the gui for this mod, but it seems to get the job done.

sssphpbb
Registered User
Posts: 127
Joined: Wed Jun 16, 2004 7:37 pm

Topic list graphics

Post by sssphpbb »

What is the point of the Topic list graphics with the little dot in the upper left? They seem to be randomly applied to some Topics and not others.

And do these show to general users, or just to the moderator merging the forums?

chatasos
Registered User
Posts: 748
Joined: Wed May 15, 2002 1:16 pm
Location: Paralia

Post by chatasos »

Quite a nice (& useful) mod and easy to install...
If only those extra mods weren't needed :wink:

HSorgYves
Registered User
Posts: 28
Joined: Sun Apr 17, 2005 10:55 pm
Location: Luxembourg
Contact:

Post by HSorgYves »

Works fine on 2.0.14 ;-)

User avatar
Hawk-Metal
Registered User
Posts: 34
Joined: Sun Jun 13, 2004 5:56 pm
Location: Croatia
Contact:

Post by Hawk-Metal »

Does this MOD work with new Category Hierarchy MOD? I think this is a great mod & I'm sure I would have a big use of it on my boards, but just want to know if it's compatible. Thanks!

RamEEz
Registered User
Posts: 321
Joined: Fri Jun 11, 2004 12:55 am

Post by RamEEz »

ok i am thinking to install this mod. I downloaded the zip file but i ma confused with the zip contents :S i mean there are four folders and so many files.

i dont know wat to do. i am using ZONE COPPER template and i dont want to replace the "MOVE, DELETE, SPLIT" images.

what to do and how to do it.

man this is one difficult mod to install :(

HSorgYves
Registered User
Posts: 28
Joined: Sun Apr 17, 2005 10:55 pm
Location: Luxembourg
Contact:

Re: A minor change that may be helpful to some people....

Post by HSorgYves »

asinshesq wrote:

Code: Select all

$forum_id = ($forum_id) ? $forum_id : 0;

Unfortunately $forum_id might not have been initialised here, which is bad style and could lead to security problems...
I would use:

Code: Select all

OPEN
merge.php

FIND
$from_title = '';

AFTER, ADD
$forum_id = 0;

FIND
	$sql = "SELECT topic_title FROM " . TOPICS_TABLE . " WHERE topic_id=$from_topic_id";

REPLACE WITH
	$sql = "SELECT topic_title, forum_id FROM " . TOPICS_TABLE . " WHERE topic_id=$from_topic_id";

FIND
		$from_title = $row['topic_title'];

AFTER, ADD
		$forum_id = $row['forum_id'];

FIND
$forum_id = 0;

REPLACE WITH


User avatar
Brf
Support Team Member
Support Team Member
Posts: 51980
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Post by Brf »

I dowmloaded the Simply Merge Threads mod a couple days ago and fixed two bugs.

Bug #1: Topic Search will not go beyond Page-2 of a forum.
Bug #2: New Thread Title is not applied.

In fixing Bug #1, I uncovered and fixed a 3rd bug.

Bug #3: Topic Search Page is not reset when switching between forums, therefore when switching from a forum beyond page-1 to a shorter forum, an error condition occurs.

-------------------- Fix ---------------------------
##############################################################
## MOD Title: Fix Simply Merge Threads Bugs
## MOD Author: Brf < N/A > (Brad Fermanich) http://www.castledoom.com
## MOD Description: Bugfixes to Simply Merge Threads Mod
## MOD Version: 0.0.1
##
## Installation Level: (Easy)
## Installation Time: 1 Minutes
## Files To Edit: merge.php
## Included Files: (n/a)
##############################################################
##############################################################
## Before Adding This MOD To Your Forum, You Should Back Up All Files Related To This MOD
##############################################################
#
#-----[ OPEN ]------------------------------------------
#

merge.php

#
#-----[ FIND ]------------------------------------------
#

if (isset($HTTP_POST_VARS['start'])) $start = intval($start);

#
#-----[ IN-LINE FIND ]------------------------------------------
#

intval($start);

#
#-----[ IN-LINE REPLACE WITH ]------------------------------------------
#

intval($HTTP_POST_VARS['start']);

#
#-----[ FIND ]------------------------------------------
#

$page_next = isset($HTTP_POST_VARS['page_next']);

#
#-----[ AFTER, ADD ]------------------------------------------
#

if (!$page_next && !$page_prec)
{
$start=0;
}

#
#-----[ FIND ]------------------------------------------
#

$sql_title = "topic_title = '" . str_replace("\'", "''", $topic_title) . "'";

#
#-----[ IN-LINE FIND ]------------------------------------------
#

$sql_title =

#
#-----[ IN-LINE REPLACE WITH ]------------------------------------------
#

$sql_update =

#
#-----[ SAVE/CLOSE ALL FILES ]------------------------------------------
#
# EoM

bbus3r
Registered User
Posts: 158
Joined: Sat Apr 16, 2005 2:10 pm

Post by bbus3r »

the zip file i downloaded from the first post works!! glad I found this one!

I noticed other codes listed, so should I add those also, or should I leave it alone.

TIA

frickangel
Registered User
Posts: 16
Joined: Wed May 11, 2005 11:27 am
Location: Malaysia

Post by frickangel »

Hey, found this MOD and it works great (a real blessing when people decide to post a fic in multiple threads, one for each chapter). Only one tiny problem, the >< button doesn't appear at all (no red x, even). I access the merge option by directing it straight to merge.php (ie. http://www.mydomain.com/merge.php).

Is there a way to fix this.

Forum: 2.0.14
Theme: FSGreen.

Wonderful MOD btw.

Thanks!

bbus3r
Registered User
Posts: 158
Joined: Sat Apr 16, 2005 2:10 pm

Post by bbus3r »

frickangel wrote: Hey, found this MOD and it works great (a real blessing when people decide to post a fic in multiple threads, one for each chapter). Only one tiny problem, the >< button doesn't appear at all (no red x, even). I access the merge option by directing it straight to merge.php (ie. http://www.mydomain.com/merge.php).

Is there a way to fix this.

Forum: 2.0.14
Theme: FSGreen.

Wonderful MOD btw.

Thanks!


Did you --> copy topic_merge.gif to templates/subSilver/images/topic_merge.gif

then check this section:
templates/subSilver/subSilver.cfg in MOD-merge.txt and use your template instead

frickangel
Registered User
Posts: 16
Joined: Wed May 11, 2005 11:27 am
Location: Malaysia

Post by frickangel »

bbus3r wrote: Did you --> copy topic_merge.gif to templates/subSilver/images/topic_merge.gif

then check this section:
templates/subSilver/subSilver.cfg in MOD-merge.txt and use your template instead


Yep, copied the files to subsilver and even to my FSGreen template but nothing. It works though, just the inconvinience of no >< button. :)

bbus3r
Registered User
Posts: 158
Joined: Sat Apr 16, 2005 2:10 pm

Post by bbus3r »

frickangel wrote:
bbus3r wrote:Did you --> copy topic_merge.gif to templates/subSilver/images/topic_merge.gif

then check this section:
templates/subSilver/subSilver.cfg in MOD-merge.txt and use your template instead


Yep, copied the files to subsilver and even to my FSGreen template but nothing. It works though, just the inconvinience of no >< button. :)


Open your fsgreen.cfg and post the code to the 10 lines before ?>

Post Reply

Return to “[2.0.x] MOD Database Releases”