Simply Merge Threads

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
64
52%
Very Good
25
20%
Good
14
11%
Fair
6
5%
Poor
15
12%
 
Total votes: 124

User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik » Mon Feb 16, 2004 8:54 am

The message is pretty clear : the file is not at the place it is supposed to be, and so the includes files required aren't found. BTW, are you running phpBB or some *nuke products ? Your directory structure seems very strange...


> Kaos : the mod @phpbbhacks.com has the same version level.

pure1
Registered User
Posts: 6
Joined: Mon Feb 16, 2004 7:32 am

Post by pure1 » Mon Feb 16, 2004 3:06 pm

My main site is running phpnuke and the forum with phpbb.

well I have checked the merge.php file is in /Forums folder and I uploaded all the other files in the appropriate folders as mentioned in the installation file.

Where can I find these files?

extension.inc
common.
functions_admin

Thanks

pure1
Registered User
Posts: 6
Joined: Mon Feb 16, 2004 7:32 am

Post by pure1 » Mon Feb 16, 2004 3:52 pm

Ok Ptirhiik

I got rid of all the warnings, the path in merge.php was not correct. Now I don't get any warnings but when I click on the icon >< which is still with a red x not showing the actual pic I get the following message.

Code: Select all

Sorry, such file doesn't exist...
Any idea?

Thaks

suek
Registered User
Posts: 8
Joined: Mon Feb 16, 2004 4:25 pm

Post by suek » Mon Feb 16, 2004 4:37 pm

Hello sir,

New user here. Thank you for this MOD, the directions were quite clear, however, I ran into this error when viewing the index.php on my test board (using subSilver):

Code: Select all

Warning: Cannot modify header information - headers already sent by (output started at /home/mydomain/public_html/OLTestBoard/templates/subSilver/subSilver.cfg:1) in /home/mydomain/public_html/OLTestBoard/includes/page_header.php on line 474

Warning: Cannot modify header information - headers already sent by (output started at /home/mydomain/public_html/OLTestBoard/templates/subSilver/subSilver.cfg:1) in /home/mydomain/public_html/OLTestBoard/includes/page_header.php on line 476

Warning: Cannot modify header information - headers already sent by (output started at /home/mydomain/public_html/OLTestBoard/templates/subSilver/subSilver.cfg:1) in /home/mydomain/public_html/OLTestBoard/includes/page_header.php on line 477
And this error when trying to log in:

Code: Select all

Warning: Cannot modify header information - headers already sent by (output started at /home/mydomain/public_html/OLTestBoard/templates/subSilver/subSilver.cfg:1) in /home/mydomain/public_html/OLTestBoard/includes/sessions.php on line 359

Warning: Cannot modify header information - headers already sent by (output started at /home/mydomain/public_html/OLTestBoard/templates/subSilver/subSilver.cfg:1) in /home/mydomain/public_html/OLTestBoard/includes/sessions.php on line 360

Warning: Cannot modify header information - headers already sent by (output started at /home/mydomain/public_html/OLTestBoard/templates/subSilver/subSilver.cfg:1) in /home/mydomain/public_html/OLTestBoard/includes/functions.php on line 771
The only other MOD installed on this test board is the "restrict guest" MOD and that worked perfectly.

What happened?

User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik » Mon Feb 16, 2004 7:11 pm

> Suek : you have made an error in subSilver.cfg : pay a particular attention to the AFTER/BEFORE add. Also be sure there is nothing, even an empty line, before <?php or after ?>,

> pure1 : *nuke products are not phpBB, so the mod will probably not work with. You may ask at phpnuke support board for adaptation of it.

suek
Registered User
Posts: 8
Joined: Mon Feb 16, 2004 4:25 pm

Post by suek » Mon Feb 16, 2004 8:06 pm

Ptirhiik - RPGnet-fr: WOW! That worked perfectly. I did have a space right after the last ?> which caused the problem. Thank you so much, will now rate this MOD! :D

pure1
Registered User
Posts: 6
Joined: Mon Feb 16, 2004 7:32 am

Post by pure1 » Mon Feb 16, 2004 10:42 pm

Ptirhiik, Thanks I will try it at phpnuke.

Plinko
Registered User
Posts: 17
Joined: Sun Sep 15, 2002 12:46 am

Post by Plinko » Fri Feb 20, 2004 2:38 am

This is a long-shot, but I'll give it a go:

The admins and mods of my forum can merge topics, however, I installed the super-mod hack as well, and super-mods (even if they are mods of a particular forum) cannot merge threads. I don't expect support for this, but does anyone know if a fix is possible?

User avatar
vinnieza
Registered User
Posts: 51
Joined: Sat Dec 13, 2003 7:12 pm

Post by vinnieza » Sat Feb 21, 2004 4:26 pm

i have downloaded this mod from: http://www.phpbbhacks.com/viewhack.php?id=1690

and when i goto my forum it comes up with this:
Parse error: parse error in ...../phpBB2/includes/functions.php on line 25

Fatal error: Call to undefined function: encode_ip() in ...../phpBB2/common.php on line 159


However i haven't edited common.php? anyway what am i doing wrong?

Click here for functions.php text

thanks :)

p.s i have phpBB 2.0.6
*** no questions asked ***

User avatar
vinnieza
Registered User
Posts: 51
Joined: Sat Dec 13, 2003 7:12 pm

Post by vinnieza » Tue Feb 24, 2004 5:32 pm

forget that post above, i have now solved the problem, i was suppose to put the lines i added on a new line, thanks Ptirhiik :)
*** no questions asked ***

madzimambo
Registered User
Posts: 14
Joined: Wed Sep 10, 2003 6:09 am

post install - need instructions

Post by madzimambo » Tue Feb 24, 2004 5:51 pm

Hello
Forgive my ignorance but after seemingly succesfully installing the MOD (Simply Merge Threads version 1.0.1) I cannot figure out how to merge threads... Can someone point me to the instructions or provide them here?
For example something basic along the lines of
Step 1) you must be logged in with moderator privelege
Step 2) bring up the topic as you normally would to view it
Step 3) click on the "moderate this forum"
Step 4) locate the "Merge Topics (Threads?)"
Step 5) Check off the 2 Topics (Threads?) you want to merge together


I am not sure that "Threads" are topics in terms of PHPBB and I need help.

Thanks

madzimambo
Registered User
Posts: 14
Joined: Wed Sep 10, 2003 6:09 am

reply to my post

Post by madzimambo » Wed Feb 25, 2004 5:07 pm

I finally saw the tiny icon to merge threads (topics)...

When logged in as moderator for that forum open the topic as you normally would to view it, in the lower left hand corner (SubSilver skin) there is a tiny icon of two black triangles pointing at one another (looks kind of like a bowtie) that will bring you to the merge thread screen.

jmjawors
Registered User
Posts: 151
Joined: Sat May 10, 2003 5:06 pm
Location: Champaign, IL
Contact:

Post by jmjawors » Thu Mar 04, 2004 7:43 pm

This mod works great. I have had none of the issues that others have had:
  • No problem with the install instructions
  • No problem learning to use the mod
  • No error messages
And, yes, I realize that when using other templates, besides SubSilver, it's a "do-so-at-your-own-risk" type of venture.

I do employ other templates at my message board. Subsilver, being one of them, utilizes this mod very very well. The others don't. In fact, though everything is uploaded correctly, it won't even show the icon! Just the dreaded "red x" with a link that takes you back to the index page.

So, my question is NOT "how can I adapt this to my template?" or "can someone do this for me?" I realize it's the .tpl files. My question is a little more generic. What lines within these .tpl files allow it to work on subsilver, and disallow it to work on other templates? I've tried piecing it together on my own, and I get nada. If I knew where the problem lay, I could probably finish the job off myself.

Not trying to stress anyone out with this post. Love the mod so much that I really really want to use it is all. Thanks in advance!

User avatar
Ptirhiik
Registered User
Posts: 7411
Joined: Mon Jan 06, 2003 10:36 pm
Contact:

Post by Ptirhiik » Thu Mar 04, 2004 11:19 pm

Most of the time, you have to redraw icons and put them in the appropriate directory, and also copy and edit the tpls to change the classes used in HTML tags. IMHO, you have to choice between install mods, and install various template, untill you get very comfortable with the phpBB templating system (which would result in most of the time of drawing your own templates, and use only one rather that a bunch of). A lot of things can be done only cleaning subSilver from all the qualified pathes and heights (so very minor edition of the tpls), and playing with the CSS and images pack.

wingchun
Registered User
Posts: 5
Joined: Fri Mar 26, 2004 4:19 pm
Contact:

the merge icon

Post by wingchun » Sun Mar 28, 2004 10:53 pm

i installed phpBB a week ago. it works great.
i installed this mod 2 days ago. it's a great mod.
i can't believe it's not part of the phpBB system.
i think it should be.

but.. i have a small problem:
i can't see the >< icon
onle the red x of no pic.

the topic_merge.gif is in place. for sure.
checked it a zillion times, and then re-uploaded it again to
the same place. just to make sure.

(i downloaded the mod from this site)


thanks

Post Reply

Return to “[2.0.x] MOD Database Releases”

Who is online

Users browsing this forum: No registered users and 7 guests