[2.0.19] Forum Icon with ACP Control

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
36
60%
Very Good
14
23%
Good
6
10%
Fair
2
3%
Poor
2
3%
 
Total votes: 60

Haros
I've Been Banned!
Posts: 97
Joined: Wed May 24, 2006 4:25 pm

Post by Haros »

Yes, i did finished the instalation, but i see no changes.

ycl6
Translator
Posts: 5696
Joined: Sat Feb 15, 2003 10:35 am
Location: Taiwan
Contact:

Post by ycl6 »

If you are using non-subSilver, themplates, you will need to edit the TPL files for those themes.

~Mac

Haros
I've Been Banned!
Posts: 97
Joined: Wed May 24, 2006 4:25 pm

Post by Haros »

Already I tested with template subsilver. But I see no changes, nothing happend. 8O

Haros
I've Been Banned!
Posts: 97
Joined: Wed May 24, 2006 4:25 pm

Post by Haros »

Look I did nothing with add-ons folder, and screenshots folder even translations folder. I just follew with Forum_Icon_en.

Also I tested with SubSilver, but nothing happend.

turborabbit
Registered User
Posts: 5
Joined: Mon May 22, 2006 6:09 pm

Post by turborabbit »

Hi.

I'm trying to install this mod on .19 phpbb with easymod 0.3.0 and getting following error:

Critical Error

FIND FAILED: In file [templates/subSilver/admin/forum_admin_body.tpl] could not find:

<td class="row2"><span class="gen"><a href="{catrow.forumrow.U_VIEWFORUM}" target="_new">{catrow.forumrow.FORUM_NAME}</a></span>

MOD script line #276 :: FAQ :: Report

Any ideas ?

ycl6
Translator
Posts: 5696
Joined: Sat Feb 15, 2003 10:35 am
Location: Taiwan
Contact:

Post by ycl6 »

Open your forum_admin_body.tpl, do you have code that looks like this

Code: Select all

	<!-- BEGIN forumrow -->
	<tr> 
		<td class="row2"><span class="gen"><a href="{catrow.forumrow.U_VIEWFORUM}" target="_new">{catrow.forumrow.FORUM_NAME}</a></span><br /><span class="gensmall">{catrow.forumrow.FORUM_DESC}</span></td>
		<td class="row1" align="center" valign="middle"><span class="gen">{catrow.forumrow.NUM_TOPICS}</span></td>
~Mac

ycl6
Translator
Posts: 5696
Joined: Sat Feb 15, 2003 10:35 am
Location: Taiwan
Contact:

Post by ycl6 »

Haros wrote: Look I did nothing with add-ons folder, and screenshots folder even translations folder. I just follew with Forum_Icon_en.

Also I tested with SubSilver, but nothing happend.

So you did go into ACP -> Forum Admin -> Management
and select a forum to edit to add the icon image path?

~Mac

MrC
Registered User
Posts: 857
Joined: Mon Jun 30, 2003 4:11 pm
Location: The Netherlands
Name: Ivo
Contact:

Post by MrC »

MrC wrote: Very nice, will try this asap and post my comments.


My asap took me almots 6 months :wink:
It works perfect, thanks for the change.

For those who use an Orion board use this in index_body.tpl

Code: Select all

# 
#-----[ ORION FIND ]------------------------------------------ 
#  	
  	<!-- BEGIN forumrow -->
  <!-- IF ! forumrow.PARENT -->
<tr>
<td class="row1" height="45" align="center">{catrow.forumrow.S_MARK_LINK_START}<img src="{catrow.forumrow.FORUM_FOLDER_IMG}" id="forumimage_{catrow.forumrow.FORUM_ID}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" border="0" />{catrow.forumrow.S_MARK_LINK_END}</td>
<td class="row1" height="45" align="center"><a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">{catrow.forumrow.FORUM_ICON_IMG}</a></td>
<td class="row1" width="100%" onMouseOver="this.style.backgroundColor='#d9e2ec'; this.style.cursor='default';" onMouseOut="this.style.backgroundColor='#eaedf4';" onClick="window.location.href='{catrow.forumrow.U_VIEWFORUM}';"><a href="{catrow.forumrow.U_VIEWFORUM}" class="nav">{catrow.forumrow.FORUM_NAME}</a><br />
<span class="genmed">{catrow.forumrow.FORUM_DESC}<br />
</span>
<!-- IF catrow.forumrow.MODERATORS --><span class="gensmall">{catrow.forumrow.L_MODERATOR} {catrow.forumrow.MODERATORS}<br /></span><!-- ENDIF -->
	  <!-- BEGIN sub --><!-- DEFINE $HAS_SUB = 1 --><!-- IF catrow.forumrow.sub.NUM > 0 -->, <!-- ELSE --><span class="genmed">{L_SUBFORUMS}: <!-- ENDIF -->{catrow.forumrow.sub.LAST_POST_SUB} <a href="{catrow.forumrow.sub.U_VIEWFORUM}" <!-- IF catrow.forumrow.sub.UNREAD -->class="topic-new"<!-- ENDIF --> title="{catrow.forumrow.sub.FORUM_DESC_HTML}">{catrow.forumrow.sub.FORUM_NAME}</a><!-- END sub -->
	  <!-- IF $HAS_SUB --></span><!-- UNDEFINE $HAS_SUB --><!-- ENDIF -->
	</td>
	<td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.TOTAL_TOPICS}</span></td>
	<td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.TOTAL_POSTS}</span></td>

<td class="row3" align="center" nowrap="nowrap"><span class="gensmall">{catrow.forumrow.LAST_POST}</span></td>
</tr>
  <!-- ENDIF -->
<!-- END forumrow -->
# 
#-----[ ORION REPLACE WITH ]------------------------------------------ 
#
<!-- BEGIN forumrow -->
  <!-- IF ! forumrow.PARENT -->
<tr>
<td class="row1" height="45" align="center"><img src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" /></td>
  <td class="row1" width="100%" onMouseOver="this.style.backgroundColor='#d9e2ec'; this.style.cursor='default';" onMouseOut="this.style.backgroundColor='#eaedf4';" onClick="window.location.href='{catrow.forumrow.U_VIEWFORUM}';">
  <table width="100%" cellpadding="2" cellspacing="0" border="0">
  <tr><td><a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">{catrow.forumrow.FORUM_ICON_IMG}</a></td>
  <td width="100%"><span class="forumlink"> <a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">{catrow.forumrow.FORUM_NAME}</a><br />
    </span> <span class="genmed">{catrow.forumrow.FORUM_DESC}<br />
<!-- IF catrow.forumrow.MODERATORS --><span class="gensmall">{catrow.forumrow.L_MODERATOR} {catrow.forumrow.MODERATORS}<br /></span><!-- ENDIF -->
    <!-- BEGIN sub --><!-- DEFINE $HAS_SUB = 1 --><!-- IF catrow.forumrow.sub.NUM > 0 -->, <!-- ELSE --><span class="genmed">{L_SUBFORUMS}: <!-- ENDIF -->{catrow.forumrow.sub.LAST_POST_SUB} <a href="{catrow.forumrow.sub.U_VIEWFORUM}" <!-- IF catrow.forumrow.sub.UNREAD -->class="topic-new"<!-- ENDIF --> title="{catrow.forumrow.sub.FORUM_DESC_HTML}">{catrow.forumrow.sub.FORUM_NAME}</a><!-- END sub -->
    <!-- IF $HAS_SUB --></span><!-- UNDEFINE $HAS_SUB --><!-- ENDIF -->
        </td></tr></table>
  </td>
  <td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.TOTAL_TOPICS}</span></td>
  <td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.TOTAL_POSTS}</span></td>


  <td class="row2" align="center" valign="middle" height="50" nowrap="nowrap"> <span class="gensmall">{catrow.forumrow.LAST_POST}</span></td> 
</tr>
  <!-- ENDIF -->
<!-- END forumrow -->

Thanks to Freitag who's post helped me on the way

gtanime
Registered User
Posts: 76
Joined: Sat Jan 14, 2006 8:32 am
Contact:

An old question

Post by gtanime »

First of all, forgive me if some post this questio before.

I'm trying to install the mod so in myphpadmin, instead of adding the alter table with the SQL button with the key inquires, but it gave me this error
Image

so I made the table from the scructure... adding a new table and I setup like this:

Image

is this ok? I just add the table in this part of the myphpthing. (I did it like that cuz Im a new in this stuff, and it seemed more easy like that for me)

I dont wanna keep doing the mod, until some1 can tell me if this is not going to mess up all my databases. Thank you.

forgive me for my english

ycl6
Translator
Posts: 5696
Joined: Sat Feb 15, 2003 10:35 am
Location: Taiwan
Contact:

Post by ycl6 »

The query you used aren't the same as the one stated in the MOD, this is the query I have

Code: Select all

ALTER TABLE phpbb_forums ADD forum_icon VARCHAR(255) DEFAULT NULL;
But what you added manually is correct :wink: Now, test if you can actually add icon in your ACP, and if it shows up correctly.

~Mac

User avatar
Saeru
Registered User
Posts: 622
Joined: Sun Feb 19, 2006 5:44 am
Location: Under a pile of PHP code.
Contact:

Post by Saeru »

There a demo of this?
"Naku ga yousuru ichidanto tsuyosa kyaku ga icchuu wo yusuru."[/size]

ycl6
Translator
Posts: 5696
Joined: Sat Feb 15, 2003 10:35 am
Location: Taiwan
Contact:

Post by ycl6 »

Screenshots are available in the package.

~Mac

gtanime
Registered User
Posts: 76
Joined: Sat Jan 14, 2006 8:32 am
Contact:

Post by gtanime »

Thank you, I will try now. One question more, actually I used the same code you wrote down but it seems like the phpmyadmin didnt recognize it. weird huh :?: I even copied the code from your post and the same thing happened. :x

but anyways with my "manual" attempt checked with you its enough for me. Thank you! :wink:

gtanime
Registered User
Posts: 76
Joined: Sat Jan 14, 2006 8:32 am
Contact:

A LIL HELP FOR THOSE USING BBLITE STYLE OR ANOTHERTYPE

Post by gtanime »

I was struggling today trying to figureout how to change certain BBlite style code in a place where it should be another code (the code from subsilver) let me explain you...

Asuming you have the subsilver style, this is the code the mode order you to find and after that, to replace..

Code: Select all

templates/subSilver/index_body.tpl
# 
#-----[ FIND ]------------------------------------------ 
# 
	<td class="row1" width="100%" height="50"><span class="forumlink"> <a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">{catrow.forumrow.FORUM_NAME}</a><br />
	  </span> <span class="genmed">{catrow.forumrow.FORUM_DESC}<br />
	  </span><span class="gensmall">{catrow.forumrow.L_MODERATOR} {catrow.forumrow.MODERATORS}</span></td>
# 
#-----[ REPLACE WITH ]------------------------------------------ 
#
	<td class="row1" width="100%" height="50"><table width="100%" cellpadding="2" cellspacing="0" border="0">
		<tr><td><a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">{catrow.forumrow.FORUM_ICON_IMG}</a></td>
			<td width="100%"><span class="forumlink"><a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">{catrow.forumrow.FORUM_NAME}</a><br />
  				</span> <span class="genmed">{catrow.forumrow.FORUM_DESC}<br />
  				</span><span class="gensmall">{catrow.forumrow.L_MODERATOR} {catrow.forumrow.MODERATORS}</span>
  			</td>
  		</tr>
  	</table></td>
But wut happen when you dont have the required field? that happend to me. This is the bblite index_body.tpl and here is the code when I found almost the same code the mode are requiring to change.

Code: Select all

<tr> 
	<td class="row1lt" align="center" valign="middle" height="50"><img src="{catrow.forumrow.FORUM_FOLDER_IMG}" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" /></td>
	<td class="row1rt" width="100%" height="50"><span class="forumlink"> <a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">{catrow.forumrow.FORUM_NAME}</a><br />
	  </span> <span class="genmed">{catrow.forumrow.FORUM_DESC}<br />
	  </span><span class="gensmall">{catrow.forumrow.L_MODERATOR} {catrow.forumrow.MODERATORS}</span></td>
	<td class="row1" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.TOPICS}</span></td>
	<td class="row1" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.POSTS}</span></td>
	<td class="row1" align="center" valign="middle" height="50" nowrap="nowrap"> <span class="gensmall">{catrow.forumrow.LAST_POST}</span></td>
  </tr>
But... WTF!! Its not the same stuff???? wut I should do?

After reading and reading, I choose to act, changing the part where the code has to be changed in order to work with the mode, replacing the piece of code but leaving the row name that it was before and it is working pefectly!!

I know for a lot of master in php and stuff, this is going to be a reason to roll on floor laughing but I posted for all the guys who are new in this stuff, like me. The advice for all this is simple "read mofos.. try to chek everysingle detail of the code, so then, later on u will be able to imagine all the code in your head, before even see it, and change the codes in the best way possible, acording to your goals...


Sorry, but my english is not well developed.. lol .. I hope you can understand.
Last edited by gtanime on Fri Jun 16, 2006 2:36 am, edited 2 times in total.

Kirsty2
Registered User
Posts: 320
Joined: Wed Jun 14, 2006 4:08 am

Post by Kirsty2 »

I'm tryng to install this, and it's all ok until i reach this bit

Code: Select all

#-----[ OPEN ]------------------------------------------ 
# 
templates/subSilver/index_body.tpl
# 
#-----[ FIND ]------------------------------------------ 
# 
	<td class="row1" width="100%" height="50"><span class="forumlink"> <a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">{catrow.forumrow.FORUM_NAME}</a><br />
	  </span> <span class="genmed">{catrow.forumrow.FORUM_DESC}<br />
	  </span><span class="gensmall">{catrow.forumrow.L_MODERATOR} {catrow.forumrow.MODERATORS}</span></td>
# 
#-----[ REPLACE WITH ]------------------------------------------ 
#
	<td class="row1" width="100%" height="50"><table width="100%" cellpadding="2" cellspacing="0" border="0">
		<tr><td><a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">{catrow.forumrow.FORUM_ICON_IMG}</a></td>
			<td width="100%"><span class="forumlink"><a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">{catrow.forumrow.FORUM_NAME}</a><br />
  				</span> <span class="genmed">{catrow.forumrow.FORUM_DESC}<br />
  				</span><span class="gensmall">{catrow.forumrow.L_MODERATOR} {catrow.forumrow.MODERATORS}</span>
  			</td>
  		</tr>
  	</table></td>
Mine says

Code: Select all

        <td class="row1" width="100%" height="50"><span class="forumlink"> <a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">{catrow.forumrow.FORUM_NAME}</a><br />
          </span> <span class="genmed">{catrow.forumrow.FORUM_DESC}<br />
<!-- IF catrow.forumrow.MODERATORS --><span class="gensmall">{catrow.forumrow.L_MODERATOR} {catrow.forumrow.MODERATORS}<br /></span><!-- ENDIF -->
	  <!-- BEGIN sub --><!-- DEFINE $HAS_SUB = 1 --><!-- IF catrow.forumrow.sub.NUM > 0 -->, <!-- ELSE --><span class="genmed">{L_SUBFORUMS}: <!-- ENDIF -->{catrow.forumrow.sub.LAST_POST_SUB} <a href="{catrow.forumrow.sub.U_VIEWFORUM}" <!-- IF catrow.forumrow.sub.UNREAD -->class="topic-new"<!-- ENDIF --> title="{catrow.forumrow.sub.FORUM_DESC_HTML}">{catrow.forumrow.sub.FORUM_NAME}</a><!-- END sub -->
	  <!-- IF $HAS_SUB --></span><!-- UNDEFINE $HAS_SUB --><!-- ENDIF -->
	</td>
Is it still possible to install, and if so how would i edit this code?

Post Reply

Return to “[2.0.x] MOD Database Releases”