[2.0.19] Forum Icon with ACP Control

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
36
60%
Very Good
14
23%
Good
6
10%
Fair
2
3%
Poor
2
3%
 
Total votes: 60

aag
Registered User
Posts: 12
Joined: Sat Jun 09, 2007 10:56 pm

Re: [2.0.19] Forum Icon with ACP Control

Post by aag »

thank you

i have install this mod every thing is work but when i creat a forum topic in catagorie i get error :(

Couldn't insert row in forums table

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'prune_enable, auth_view, auth_read, auth_post, auth_reply, auth_edit, auth_delet' at line 1

INSERT INTO phpbb_forums (forum_id, forum_name, cat_id, forum_desc, forum_order, forum_status, forum_icon prune_enable, auth_view, auth_read, auth_post, auth_reply, auth_edit, auth_delete, auth_sticky, auth_announce, auth_vote, auth_pollcreate) VALUES ('4', 'aaa', 3, 'aaaa', 10, 0, '', 0, 0, 0, 1, 1, 1, 1, 3, 3, 1, 1)

Line : 406
File : admin_forums.php


this is the line code:401 407
// There is no problem having duplicate forum names so we won't check for it.
$sql = "INSERT INTO " . FORUMS_TABLE . " (forum_id, forum_name, cat_id, forum_desc, forum_order, forum_status, forum_icon prune_enable" . $field_sql . ")
VALUES ('" . $next_id . "', '" . str_replace("\'", "''", $HTTP_POST_VARS['forumname']) . "', " . intval($HTTP_POST_VARS[POST_CAT_URL]) . ", '" . str_replace("\'", "''", $HTTP_POST_VARS['forumdesc']) . "', $next_order, " . intval($HTTP_POST_VARS['forumstatus']) . ", '" . str_replace("\'", "''", $HTTP_POST_VARS['forumicon']) . "', " . intval($HTTP_POST_VARS['prune_enable']) . $value_sql . ")";
if( !$result = $db->sql_query($sql) )
{
message_die(GENERAL_ERROR, "Couldn't insert row in forums table", "", __LINE__, __FILE__, $sql);
}




plz help me

User avatar
Raimon
Former Team Member
Posts: 12088
Joined: Tue May 30, 2006 5:31 pm
Location: Netherlands
Name: Raimon Meuldijk
Contact:

Re: [2.0.19] Forum Icon with ACP Control

Post by Raimon »

find :

Code: Select all

forum_icon prune_enable
replace with;

Code: Select all

forum_icon, prune_enable
You forgot the ,
Need phpBB installation, extenstions, Styles or integrate phpBB with you website?
Contact me for fair prices and good service!

aag
Registered User
Posts: 12
Joined: Sat Jun 09, 2007 10:56 pm

Re: [2.0.19] Forum Icon with ACP Control

Post by aag »

thank you for your replay

but where have to add this code ? in admin_forums.php

User avatar
Raimon
Former Team Member
Posts: 12088
Joined: Tue May 30, 2006 5:31 pm
Location: Netherlands
Name: Raimon Meuldijk
Contact:

Re: [2.0.19] Forum Icon with ACP Control

Post by Raimon »

Yess in the file;

Code: Select all

admin_forums.php
and in this line what you have posted ;

Code: Select all

// There is no problem having duplicate forum names so we won't check for it.
$sql = "INSERT INTO " . FORUMS_TABLE . " (forum_id, forum_name, cat_id, forum_desc, forum_order, forum_status, forum_icon prune_enable" . $field_sql . ")
Need phpBB installation, extenstions, Styles or integrate phpBB with you website?
Contact me for fair prices and good service!

aag
Registered User
Posts: 12
Joined: Sat Jun 09, 2007 10:56 pm

Re: [2.0.19] Forum Icon with ACP Control

Post by aag »

ya i have found and i forget to add these code :mrgreen:

Code: Select all

			// There is no problem having duplicate forum names so we won't check for it.
			$sql = "INSERT INTO " . FORUMS_TABLE . " (forum_id, forum_name, cat_id, forum_desc, forum_order, forum_status, forum_icon prune_enable" . $field_sql . ")

aag
Registered User
Posts: 12
Joined: Sat Jun 09, 2007 10:56 pm

Re: [2.0.19] Forum Icon with ACP Control

Post by aag »

thank you so much

User avatar
EduCatOR
Registered User
Posts: 18
Joined: Mon Oct 15, 2007 11:13 pm

Re: [2.0.19] Forum Icon with ACP Control

Post by EduCatOR »

Hey guys I just tested this with 2.0.22...and everything seemed to go fine until I visited my admin page. Basically, the whole left side of the administration page is blank...nothing loads. Anyone know why this could happen? I run a php-nuke evolution site...but phpbb is the forum with which most of php nuke runs off of. This mod also really doesnt have anything to do with nuke so I figured I would ask anyway. I also changed the sql table prefix to match. I replaced all the files, but still my admin hasnt come back... :cry:

Anyone think they could help me? If you have AIM, my sn is BrianAStier

Thanks in advance, it's always greatly appreciated.

I forgot to mention - you can view the website in it's entirety @ http://www.nsiderevolution.com

ycl6
Translator
Posts: 5696
Joined: Sat Feb 15, 2003 10:35 am
Location: Taiwan
Contact:

Re: [2.0.19] Forum Icon with ACP Control

Post by ycl6 »

Hi EduCatOR,

I can't be sure this MOD will run normally in Nuke, so if you are sure you've done everything correctly, it might simply be a incompatible issue. You will need to seek support from a Nuke board instead. I'm sure something like this exist for Nuke users.

One issue that can lead to blank page is missing semi-colon or other PHP syntax error. And it only occur if your phpBB or PHP doesn't run in debug mode, i.e. doesn't output error message, therefore you see a blank page.

These are the only hints I can give you.

~Mac

User avatar
EduCatOR
Registered User
Posts: 18
Joined: Mon Oct 15, 2007 11:13 pm

Re: [2.0.19] Forum Icon with ACP Control

Post by EduCatOR »

This is the error I get when I go to the admin panel...

Code: Select all

PHP Fatal error:  Cannot redeclare get_info() (previously declared in /home/nside/public_html/modules/Forums/admin/admin_forums.php:89) in /home/nside/public_html/modules/Forums/admin/admin_forums1.php on line 137, referer: http://www.nsiderevolution.com/modules/Forums/admin/index.php

User avatar
EduCatOR
Registered User
Posts: 18
Joined: Mon Oct 15, 2007 11:13 pm

Re: [2.0.19] Forum Icon with ACP Control

Post by EduCatOR »

Wow...I'm retarded. I got the admin panel back...now its time to see if the image actually works. =) Whew! what a relief...

Ill post to let everyone know if I get this working with Nuke-Evolution + phpbb 2.0.22

:edit:

Ok, so I think I got it pretty much setup the way I need to...except there's just one problem. The regular forum icon is still up there as well. I'm going to look through this topic (and what a daunting task it is), but if I don't find it...is there a way to set the forum icon to be in the same place as the regular one?

This is what I'm talking about.

Image

With that, let me confirm that this mod works with PHP Nuke-Evolution as well as phpbb 2.0.22 (at least it did for me..)

SUPERB job on this..

Btw, thanks mac for coming to respond to such an old thread. 8-)

ycl6
Translator
Posts: 5696
Joined: Sat Feb 15, 2003 10:35 am
Location: Taiwan
Contact:

Re: [2.0.19] Forum Icon with ACP Control

Post by ycl6 »

I don't know how different is the phpBB is Nuke and the vanilla one, but this is from the default index_body.tpl

The code responsible for the default icon

Code: Select all

	<td class="row1" align="center" valign="middle" height="50"><img src="{catrow.forumrow.FORUM_FOLDER_IMG}" width="46" height="25" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" /></td>
If you are deleting it, you may need to adjust the colspan number

from default subSilver index_body.tpl

Code: Select all

	<th colspan="2" class="thCornerL" height="25" nowrap="nowrap">&nbsp;{L_FORUM}&nbsp;</th>
from default subSilver index_body.tpl

Code: Select all

	<td class="catLeft" colspan="2" height="28"><span class="cattitle"><a href="{catrow.U_VIEWCAT}" class="cattitle">{catrow.CAT_DESC}</a></span></td>
I think you know your forum code very well, so you should be able to edit accordingly if those line are different from subSilver ;)

~Mac

User avatar
EduCatOR
Registered User
Posts: 18
Joined: Mon Oct 15, 2007 11:13 pm

Re: [2.0.19] Forum Icon with ACP Control

Post by EduCatOR »

Thankyou, my forum looks marvelous now. :D Two thumbs up for this mod!

AllanTan
Registered User
Posts: 5
Joined: Sat Sep 22, 2007 7:39 pm

Re: [2.0.19] Forum Icon with ACP Control

Post by AllanTan »

Hi,

i'm having this minor problem after installing the mod. Please help. There's this list of all the forums i have on top of the usual i see.

Refer to pic: http://i31.photobucket.com/albums/c399/ ... /error.jpg

refer to forum address: http://fishclubsg.org/forum

ycl6
Translator
Posts: 5696
Joined: Sat Feb 15, 2003 10:35 am
Location: Taiwan
Contact:

Re: [2.0.19] Forum Icon with ACP Control

Post by ycl6 »

Allan,

The problem occurs in index page only right?

I'll suggest you re-do index.php and templates/subSilver/index_body.tpl

~Mac

User avatar
Limun
Registered User
Posts: 6
Joined: Fri May 04, 2007 7:39 pm

Re: [2.0.19] Forum Icon with ACP Control

Post by Limun »

i never understended this

Code: Select all

#-----[ SQL ]------------------------------------------ 
#
# Remember to change the table prefix used on your database
ALTER TABLE phpbb_forums ADD forum_icon VARCHAR(255) DEFAULT NULL;
what i shoud do with this...any help please ?? :(

Post Reply

Return to “[2.0.x] MOD Database Releases”