Page 35 of 35

Re: [2.0.19] Forum Icon with ACP Control

Posted: Thu Nov 01, 2007 11:58 am
by ycl6
Limun

Many MODs require additional tables or data fields in the database to store data, and in this case, this MOD requires an additional data field "forum_icon" in the "phpbb_forums" table in your database.

Most likely you will be using MySQL database with phpmyadmin. There's a KB article that teaches you the basics to SQL query execution in phpmyadmin. If you don't understand how to maintain/use your database, you should contact your web host.

~Mac

Re: [2.0.19] Forum Icon with ACP Control

Posted: Thu Nov 01, 2007 2:10 pm
by PHIL63
If you want that forum icons with ACP control AND Simple Subforum works together, look here :
http://www.phpbb.com/community/viewtopi ... 8#p2866868
Now I have icons in subforums.

Re: [2.0.19] Forum Icon with ACP Control

Posted: Wed Jan 02, 2008 7:20 pm
by krijo
having porblem with the icon dosent shows up on forum index. any help please?

this is my index_body.tpl

Code: Select all

<!-- mod : Loewen Enterprise - Donation MOD -->
<table width="100%" cellspacing="0" cellpadding="2" border="0" align="center">
  <tr> 
	<td align="left" valign="bottom"><span class="gensmall">
	<!-- BEGIN switch_user_logged_in -->
	{LAST_VISIT_DATE}<br />
	<!-- END switch_user_logged_in -->
	{CURRENT_TIME}<br /></span><span class="nav"><a href="{U_INDEX}" class="nav">{L_INDEX}</a></span></td>
	<td align="right" valign="bottom" class="gensmall">
		<!-- BEGIN switch_user_logged_in -->
		<a href="{U_SEARCH_UNAPPROVED}" class="gensmall">{L_SEARCH_UNAPPROVED}</a><br /><a href="{U_SEARCH_NEW}" class="gensmall">{L_SEARCH_NEW}</a><br /><a href="{U_SEARCH_SELF}" class="gensmall">{L_SEARCH_SELF}</a><br />
		<!-- END switch_user_logged_in -->
		<a href="{U_SEARCH_UNANSWERED}" class="gensmall">{L_SEARCH_UNANSWERED}</a></td>
  </tr>
</table>

<table width="100%" cellpadding="2" cellspacing="1" border="0" class="forumline">
  <tr> 
	<th colspan="2" class="thCornerL" height="25" nowrap="nowrap">&nbsp;{L_FORUM}&nbsp;</th>
	<th width="50" class="thTop" nowrap="nowrap">&nbsp;{L_TOPICS}&nbsp;</th>
	<th width="50" class="thTop" nowrap="nowrap">&nbsp;{L_POSTS}&nbsp;</th>
	<th width="50" class="thTop" nowrap="nowrap">&nbsp;{L_VIEWS}&nbsp;</th>

	
	<th class="thCornerR" nowrap="nowrap">&nbsp;{L_LASTPOST}&nbsp;</th>
  </tr>
  <!-- BEGIN catrow -->
  <tr> 
	<td class="catLeft" colspan="2" height="28"><span class="cattitle"><a href="{catrow.U_VIEWCAT}" class="cattitle">{catrow.CAT_DESC}</a></span></td>
	<td class="rowpic" colspan="4" align="right">&nbsp;</td>
  </tr>
  <!-- BEGIN forumrow -->
  <!-- IF ! forumrow.PARENT -->


  <tr> 
	<td class="row1" width="100%" height="50"><table width="100%" cellpadding="2" cellspacing="0" border="0">
		<tr><td><a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">{catrow.forumrow.FORUM_ICON_IMG}</a></td>
			<td width="100%"><span class="forumlink"><a href="{catrow.forumrow.U_VIEWFORUM}" class="forumlink">{catrow.forumrow.FORUM_NAME}</a><br />
  				</span> <span class="genmed">{catrow.forumrow.FORUM_DESC}<br />
  				</span><span class="gensmall">{catrow.forumrow.L_MODERATOR} {catrow.forumrow.MODERATORS}</span>
					<td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.TOTAL_POSTS}</span></td>
	<td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.FORUM_VIEWS}</span></td>
  			</td>
<!-- IF catrow.forumrow.MODERATORS --><span class="gensmall">{catrow.forumrow.L_MODERATOR} {catrow.forumrow.MODERATORS}<br /></span>	<td class="row2" align="center" valign="middle" height="50"><span class="gensmall">{catrow.forumrow.TOTAL_TOPICS}</span></td>
<!-- ENDIF -->
	  <!-- BEGIN sub --><!-- DEFINE $HAS_SUB = 1 --><!-- IF catrow.forumrow.sub.NUM > 0 -->, <!-- ELSE --><span class="genmed">{L_SUBFORUMS}: <!-- ENDIF -->{catrow.forumrow.sub.LAST_POST_SUB} <a href="{catrow.forumrow.sub.U_VIEWFORUM}" <!-- IF catrow.forumrow.sub.UNREAD -->class="topic-new"<!-- ENDIF --> title="{catrow.forumrow.sub.FORUM_DESC_HTML}">{catrow.forumrow.sub.FORUM_NAME}</a><!-- END sub -->
	  <!-- IF $HAS_SUB --></span><!-- UNDEFINE $HAS_SUB --><!-- ENDIF -->

  	</table></td>



	<td class="row2" align="center" valign="middle" height="50" nowrap="nowrap"> <span class="gensmall">{catrow.forumrow.LAST_POST}</span></td>
  </tr>
  <!-- ENDIF -->


  <!-- END forumrow -->
  <!-- END catrow -->
</table>

<table width="100%" cellspacing="0" border="0" align="center" cellpadding="2">
  <tr> 
 	<td align="left">
 	<!-- BEGIN switch_user_logged_in -->
 		<span class="gensmall"><a href="{U_MARK_READ}" class="gensmall">{L_MARK_FORUMS_READ}</a></span>
 	<!-- END switch_user_logged_in -->
 	</td>
	<td align="right"><span class="gensmall">{S_TIMEZONE}</span></td>
  </tr>
</table>

<table width="100%" cellpadding="3" cellspacing="1" border="0" class="forumline">
  <tr> 
	<td class="catHead" colspan="2" height="28"><span class="cattitle"><a href="{U_VIEWONLINE}" class="cattitle">{L_WHO_IS_ONLINE}</a></span></td>
  </tr>
  <tr> 
	<td class="row1" align="center" valign="middle" rowspan="2"><img src="templates/subSilver/images/whosonline.gif" alt="{L_WHO_IS_ONLINE}" /></td>
	<td class="row1" align="left" width="100%"><span class="gensmall">{TOTAL_POSTS}<br />{TOTAL_USERS}<br />{NEWEST_USER}</span>
	</td>
  </tr>
  <tr> 
	<td class="row1" align="left"><span class="gensmall">{TOTAL_USERS_ONLINE} &nbsp; [ {L_WHOSONLINE_ADMIN} ] &nbsp; [ {L_WHOSONLINE_MOD} ]<br />{RECORD_USERS}<br />{LOGGED_IN_USER_LIST}</span></td>
  </tr>
  <!-- BEGIN birthdays -->
  <tr>
	<td class="catHead" colspan="2" height="28"><span class="cattitle">{L_TODAYS_BIRTHDAYS}</span></td>
  </tr>
  <tr> 
	<td class="row1" colspan="2"><table cellpadding="0" cellspacing="0" border="0">
		<tr>
			<td align="center" valign="middle" style="padding-right: 3px"><img src="templates/subSilver/images/icon_birthday.gif" alt="{L_VIEW_BIRTHDAYS}" /></td>
			<td align="left" width="100%">
			  <span class="gensmall">{BIRTHDAYS}
			  <!-- BEGIN upcoming -->
			  <br />{UPCOMING}
			  <!-- END upcoming -->
			  </span>
			</td>
	  	</tr>
	</table></td>
  </tr>
  <!-- END birthdays -->
  <tr> 
	<td class="catHead" colspan="2" height="28"><span class="gensmall">{L_LW_LAST_DONORS}</span></span></td>
  </tr>
  <tr> 
	<td class="row1" colspan="2" align="left" width="100%"><span class="gensmall">{LW_LAST_DONORS}</span></td>
  </tr>  
</table>

<table width="100%" cellpadding="1" cellspacing="1" border="0">
<tr>
	<td align="left" valign="top"><span class="gensmall">{L_ONLINE_EXPLAIN}</span></td>
</tr>
</table>

<!-- BEGIN switch_user_logged_out -->
<form method="post" action="{S_LOGIN_ACTION}">
  <table width="100%" cellpadding="3" cellspacing="1" border="0" class="forumline">
	<tr> 
	  <td class="catHead" height="28"><a name="login"></a><span class="cattitle">{L_LOGIN_LOGOUT}</span></td>
	</tr>
	<tr> 
	  <td class="row1" align="center" valign="middle" height="28"><span class="gensmall">{L_USERNAME}: 
		<input class="post" type="text" name="username" size="10" />
		&nbsp;&nbsp;&nbsp;{L_PASSWORD}: 
		<input class="post" type="password" name="password" size="10" maxlength="32" />
		<!-- BEGIN switch_allow_autologin -->
		&nbsp;&nbsp; &nbsp;&nbsp;{L_AUTO_LOGIN} 
		<input class="text" type="checkbox" name="autologin" />
		<!-- END switch_allow_autologin -->
		&nbsp;&nbsp;&nbsp; 
		<input type="submit" class="mainoption" name="login" value="{L_LOGIN}" />
		</span> </td>
	</tr>
  </table>
</form>
<!-- END switch_user_logged_out -->

<br clear="all" />

<table cellspacing="3" border="0" align="center" cellpadding="0">
  <tr> 
	<td width="20" align="center"><img src="templates/subSilver/images/folder_new_big.gif" alt="{L_NEW_POSTS}"/></td>
	<td><span class="gensmall">{L_NEW_POSTS}</span></td>
	<td>&nbsp;&nbsp;</td>
	<td width="20" align="center"><img src="templates/subSilver/images/folder_big.gif" alt="{L_NO_NEW_POSTS}" /></td>
	<td><span class="gensmall">{L_NO_NEW_POSTS}</span></td>
	<td>&nbsp;&nbsp;</td>
	<td width="20" align="center"><img src="templates/subSilver/images/folder_locked_big.gif" alt="{L_FORUM_LOCKED}" /></td>
	<td><span class="gensmall">{L_FORUM_LOCKED}</span></td>
  </tr>
</table>

Re: [2.0.19] Forum Icon with ACP Control

Posted: Fri Jan 04, 2008 6:42 pm
by krijo
any help plz :?

Re: [2.0.19] Forum Icon with ACP Control

Posted: Mon Jan 07, 2008 7:19 am
by Freitag
I am in the process of porting my random icon change to this MOD to the phpBB3 code since some found it useful.

It is not yet in proper MODX format but is available as an ALPHA level code.

You can see it in action here on a board I sometimes assist with.

Re: [2.0.19] Forum Icon with ACP Control

Posted: Sun Jan 13, 2008 8:24 pm
by JAMEEL225
hello

ur given link not working plz repair the link

thanks

Re: [2.0.19] Forum Icon with ACP Control

Posted: Sun Jan 13, 2008 9:08 pm
by Freitag
JAMEEL225 wrote:hello

ur given link not working plz repair the link

thanks
All 3 links work just fine. Which one were you having difficulty with?

Re: [2.0.19] Forum Icon with ACP Control

Posted: Sat Feb 09, 2008 11:09 am
by pois26
hello,

I've installed the mod , it works correctly when I put just one icon , but when i want to put another icon , there is an error :
Couldn't insert row in forums table

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''0, 0, 0, 1, 1, 1, 1, 3, 3, 1, 1)' at line 2

INSERT INTO phpbb_forums (forum_id, forum_name, cat_id, forum_desc, forum_order, forum_status, forum_icon, prune_enable, auth_view, auth_read, auth_post, auth_reply, auth_edit, auth_delete, auth_sticky, auth_announce, auth_vote, auth_pollcreate) VALUES ('2', 'forum', 2, 'forumi', 10, 0, '/images/lucky.png', '0, 0, 0, 1, 1, 1, 1, 3, 3, 1, 1)

Line : 409
File : admin_forums.php

Can you help me to solve this problem , i've tried in mysql but with not sucess.
(sorry, perhaps my english is bad , because i'm french , im sorry)

bye, Francis

Re: [2.0.19] Forum Icon with ACP Control

Posted: Sat Feb 09, 2008 12:45 pm
by Brf
You have an extra ' in there.

Re: [2.0.19] Forum Icon with ACP Control

Posted: Sun Jun 15, 2008 3:00 pm
by Techit
I installed this successfully, great little mod... but one thing im after, is there any way that you can choose what you have the image link going to....

On my forum, i have like sponsors of each forum, the image icon is the sponsors banner. I would like the icon to go to the sponsor's website upon click, not the thread section.

Cheers

James

Re: [2.0.19] Forum Icon with ACP Control

Posted: Sat Jun 21, 2008 1:33 pm
by Zaid
mod seems to work but IT IS NOT compatible with Subforums Mod?

i cant get the image to appear next to the subforums ?