[Tool] phpBB 2.0.8 to phpBB 2.0.10 Code Changes

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
32
68%
Very Good
6
13%
Good
4
9%
Fair
1
2%
Poor
4
9%
 
Total votes: 47

stephen_a
Registered User
Posts: 103
Joined: Thu Mar 18, 2004 12:52 pm

Post by stephen_a »

I got it past the first odd find in privmsg.php by ensuring that all my files were unix format (as I'm running on linux).

But it then fell over at:
FIND FAILED: In file [privmsg.php] could not find:

$pm_sql_user .= "AND ( ( pm.privmsgs_to_userid = " . $userdata['user_id'] . "

MOD script line #667



Oddly I'm using Easy Mod but it claims that this mod isn't EMC?

Steve
djkoelkast
Registered User
Posts: 10
Joined: Mon Feb 16, 2004 12:37 pm

Post by djkoelkast »

besides that I also see:

Code: Select all

The following commands were not recognized by EasyMOD and were ignored. The MOD script line number is displayed. 
Unprocessed Commands 
DELETE    line #621  
					//
					// Define censored word matches
					//
					$orig_word = array();
					$replacement_word = array();
					obtain_word_list($orig_word, $replacement_word);

 
 
Graham
Former Team Member
Posts: 8462
Joined: Tue Mar 19, 2002 7:11 pm
Location: UK
Contact:

Post by Graham »

Delete is not a command EasyMOD recognises, you will need to carry out that part by hand.
"So Long, and Thanks for All the Fish"

phpBB Useful Links: Knowledge Base | Userguide | Forum Search | MOD Database | Styles Database
My Links: Blog!
djkoelkast
Registered User
Posts: 10
Joined: Mon Feb 16, 2004 12:37 pm

Post by djkoelkast »

Graham wrote: Delete is not a command EasyMOD recognises, you will need to carry out that part by hand.


ok thanks but EasyMod says: installation failed due to the failure described before, will there be an update?
stephen_a
Registered User
Posts: 103
Joined: Thu Mar 18, 2004 12:52 pm

Post by stephen_a »

I just double checked for the problem I had and found that the line in my privmsg.php is actually:
$pm_sql_user = "AND ( ( pm.privmsgs_to_userid = " . $userdata['user_id'] . "


Which is what it wants to change it to..

So I commented that change out and its all run fine.
User avatar
Magee
Registered User
Posts: 115
Joined: Sat Jul 10, 2004 5:17 pm
Location: wirral, engand

Post by Magee »

so i think if i follow what you did, stephen mine should work..
tbartold
Registered User
Posts: 138
Joined: Sat Mar 15, 2003 3:51 am
Contact:

Post by tbartold »

Graham wrote: Delete is not a command EasyMOD recognises, you will need to carry out that part by hand.


Why do it by hand? Can't it just be changed to REPLACE with a blank line?
User avatar
Magee
Registered User
Posts: 115
Joined: Sat Jul 10, 2004 5:17 pm
Location: wirral, engand

Post by Magee »

my installation worked with easymod, except i had to do all the editing to privmsg.php and onwards by hand. only problem now is that it doesnt say phpBB version 2.0.10 at the bottom..
User avatar
A_Jelly_Doughnut
Former Team Member
Posts: 34457
Joined: Sat Jan 18, 2003 1:26 am
Location: Where the Rivers Run
Contact:

Post by A_Jelly_Doughnut »

tbartold: No, I don't think EasyMOD supports that either.

Magee: You know to run the /install/update_to_2010.php file right?
A Donut's Blog
"Bach's Prelude (Cello Suite No. 1) is driving Indiana country roads in Autumn" - Ann Kish
User avatar
GPHemsley
Registered User
Posts: 1475
Joined: Fri Apr 18, 2003 3:12 am
Location: Long Beach, NY
Name: Gordon Hemsley
Contact:

Post by GPHemsley »

A_Jelly_Doughnut wrote: Magee: You know to run the /install/update_to_2010.php file right?

Actually, oddly enough, I believe that file is called update_to_210.php. :?
cifroes
Registered User
Posts: 108
Joined: Wed Mar 27, 2002 4:09 pm

Post by cifroes »

stephen_a wrote: I just double checked for the problem I had and found that the line in my privmsg.php is actually:
$pm_sql_user = "AND ( ( pm.privmsgs_to_userid = " . $userdata['user_id'] . "


Which is what it wants to change it to..

So I commented that change out and its all run fine.


I also did that change to this mod and also:

If you have installed Categories hierarchy mod

this:

Code: Select all

modcp.php

#
#-----[ FIND ]---------------------------------------------
# Line 841
					'S_FORUM_SELECT' => make_forum_select("new_forum_id", false, $forum_id))
				);
must be replaced wit:

Code: Select all

modcp.php

#
#-----[ FIND ]---------------------------------------------
# Line 841
					'S_FORUM_SELECT' => selectbox("new_forum_id", false, $forum_id))
//-- fin mod : categories hierarchy ----------------------------------------------------------------
				);

tbartold
Registered User
Posts: 138
Joined: Sat Mar 15, 2003 3:51 am
Contact:

Post by tbartold »

A_Jelly_Doughnut wrote: tbartold: No, I don't think EasyMOD supports that either.


Right, I've used it to do that though, but by including an extra line that doesn't change in the replace. I find EasyMOD especially useful in changing templates.
Last edited by tbartold on Tue Jul 20, 2004 2:05 pm, edited 1 time in total.
leoz
Registered User
Posts: 35
Joined: Wed Nov 12, 2003 6:35 am
Location: Nashville, TN, USA.
Contact:

install/update_to_???.php where is it?

Post by leoz »

GPHemsley wrote:
A_Jelly_Doughnut wrote:Magee: You know to run the /install/update_to_2010.php file right?

Actually, oddly enough, I believe that file is called update_to_210.php. :?


Great where is this file?
Peatminers
Registered User
Posts: 45
Joined: Sun Feb 16, 2003 2:56 pm
Contact:

Post by Peatminers »

Does this file make any other changes to the database, besides the version-number?

I'm running 2.0.8a at the moment and if the number is the only change, I'll adjust it manually.

@leoz: you can find the file in the "changed files only"-package in the Download section of this page.
djkoelkast
Registered User
Posts: 10
Joined: Mon Feb 16, 2004 12:37 pm

Post by djkoelkast »

stephen_a wrote: I just double checked for the problem I had and found that the line in my privmsg.php is actually:
$pm_sql_user = "AND ( ( pm.privmsgs_to_userid = " . $userdata['user_id'] . "


Which is what it wants to change it to..

So I commented that change out and its all run fine.


Works perfectly now!
Post Reply

Return to “[2.0.x] MOD Database Releases”