[Tool] phpBB 2.0.8 to phpBB 2.0.10 Code Changes

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
32
68%
Very Good
6
13%
Good
4
9%
Fair
1
2%
Poor
4
9%
 
Total votes: 47

tbartold
Registered User
Posts: 138
Joined: Sat Mar 15, 2003 3:51 am
Contact:

Re: lost and out

Post by tbartold »

webhostau wrote: Where is this file update_to_210.php file ?? cant seem to find it anywere. Thanks..


The file is in any of the downloads for the latest release.

The smalest download is probably the patch version.

You should make sure that the update_to_210.php file is in the install subdirectory on your forum when you execute it, otherwise you will get the "error" that boon.cc reported above.
webhostau
Registered User
Posts: 45
Joined: Thu Jun 10, 2004 3:00 am
Location: Melbourne AU

Post by webhostau »

I cant seem to find in there. Any direct link please?
~ Webhosting Melbourne
For all your web hosting needs visit http://www.webhostau.com
tbartold
Registered User
Posts: 138
Joined: Sat Mar 15, 2003 3:51 am
Contact:

Post by tbartold »

boon.cc wrote: After install the 2.0.10 version, the IP logger works bad.

I think is because of this:


Any idea??
What about puting as before in 2.0.8 ???


This question is not about this MOD, but to the actual changes that were made in the 2.0.10 upgrade. You should probably ask this on the phpBB Support forum.
tbartold
Registered User
Posts: 138
Joined: Sat Mar 15, 2003 3:51 am
Contact:

Post by tbartold »

vietgamer wrote: After installed the .10 updates, my guestbook mod stopped working. :)


You should probably be asking that wherever you got the guestbook MOD from.
tbartold
Registered User
Posts: 138
Joined: Sat Mar 15, 2003 3:51 am
Contact:

Post by tbartold »

webhostau wrote: I cant seem to find in there. Any direct link please?


I don't know of any more direct link, except for the link to download the zip file. I have seen the link fail, but just try again after a couple seconds.

The file you're looking for is inside the zip.
webhostau
Registered User
Posts: 45
Joined: Thu Jun 10, 2004 3:00 am
Location: Melbourne AU

Post by webhostau »

How does one install the .patch file?
~ Webhosting Melbourne
For all your web hosting needs visit http://www.webhostau.com
tbartold
Registered User
Posts: 138
Joined: Sat Mar 15, 2003 3:51 am
Contact:

Post by tbartold »

webhostau wrote: How does one install the .patch file?


This MOD is instead of the .patch file. You do not need to even look at the .patch if you're using this MOD. You do need to run the install/update_to_210.php script.

Otherwise, it's all explained in the INSTALL instructions.
webhostau
Registered User
Posts: 45
Joined: Thu Jun 10, 2004 3:00 am
Location: Melbourne AU

Post by webhostau »

the update file updates the databases. I have manual configured all the files to suit.

Thanks for your speedy assistance.. well done!
~ Webhosting Melbourne
For all your web hosting needs visit http://www.webhostau.com
fxforum
Registered User
Posts: 159
Joined: Sun Jul 13, 2003 8:10 am
Contact:

Post by fxforum »

whether i should run install/update_to_210.php after finishing the process ??

when i run it, the result is " pls go to read install.html " :?: :?:
tbartold
Registered User
Posts: 138
Joined: Sat Mar 15, 2003 3:51 am
Contact:

Post by tbartold »

fxforum wrote: whether i should run install/update_to_210.php after finishing the process ??

when i run it, the result is " pls go to read install.html " :?: :?:


What does it say exactly? (the word "pls" is nowhere in that file) If it says "Please read: INSTALL.html before attempting to update." there should be other messages before that. But it may simply be that you don't have the script in the right directory.
TequilaTown
Registered User
Posts: 96
Joined: Wed Jun 23, 2004 11:28 am
Contact:

Post by TequilaTown »

vietgamer wrote: After installed the .10 updates, my guestbook mod stopped working. :)


My Bookie Mod also played up after this upgrade! After going over the changed lines and files I left out this bit!
#
#-----[ FIND ]---------------------------------------------
# Line 174
if( getenv('HTTP_X_FORWARDED_FOR') != '' )
{
$client_ip = ( !empty($HTTP_SERVER_VARS['REMOTE_ADDR']) ) ? $HTTP_SERVER_VARS['REMOTE_ADDR'] : ( ( !empty($HTTP_ENV_VARS['REMOTE_ADDR']) ) ? $HTTP_ENV_VARS['REMOTE_ADDR'] : $REMOTE_ADDR );

$entries = explode(',', getenv('HTTP_X_FORWARDED_FOR'));
reset($entries);
while (list(, $entry) = each($entries))
{
$entry = trim($entry);
if ( preg_match("/^([0-9]+\.[0-9]+\.[0-9]+\.[0-9]+)/", $entry, $ip_list) )
{
$private_ip = array('/^0\./', '/^127\.0\.0\.1/', '/^192\.168\..*/', '/^172\.((1[6-9])|(2[0-9])|(3[0-1]))\..*/', '/^10\..*/', '/^224\..*/', '/^240\..*/');
$found_ip = preg_replace($private_ip, $client_ip, $ip_list[1]);

if ($client_ip != $found_ip)
{
$client_ip = $found_ip;
break;
}
}
}
}
else
{
$client_ip = ( !empty($HTTP_SERVER_VARS['REMOTE_ADDR']) ) ? $HTTP_SERVER_VARS['REMOTE_ADDR'] : ( ( !empty($HTTP_ENV_VARS['REMOTE_ADDR']) ) ? $HTTP_ENV_VARS['REMOTE_ADDR'] : $REMOTE_ADDR );
}

#
#-----[ REPLACE WITH ]---------------------------------------------
#
// I'm removing HTTP_X_FORWARDED_FOR ... this may well cause other problems such as
// private range IP's appearing instead of the guilty routable IP, tough, don't
// even bother complaining ... go scream and shout at the idiots out there who feel
// "clever" is doing harm rather than good ... karma is a great thing ... :)
//
$client_ip = ( !empty($HTTP_SERVER_VARS['REMOTE_ADDR']) ) ? $HTTP_SERVER_VARS['REMOTE_ADDR'] : ( ( !empty($HTTP_ENV_VARS['REMOTE_ADDR']) ) ? $HTTP_ENV_VARS['REMOTE_ADDR'] : $REMOTE_ADDR );


due to the
this may well cause other problems


After that it all worked again! Something to try perhaps vietgamer!
tdk1nc
Registered User
Posts: 6
Joined: Sat Jun 26, 2004 8:14 pm

Post by tdk1nc »

This is slightly OT, but I'm not sure where else to post it where People Who Know These Things can help:

Has anyone had any problems with the embedded Gallery 1.4.3 after applying the 2.0.8 to 2.0.10 update mod? Acyd Burn is typically very reliable, so I don't doubt the mod. I have found, however, that every time I click on the link to go to my Gallery, I get this error:

Code: Select all

Warning: main(./modules//.php): failed to open stream: No such file or directory in /home/clevela/public_html/forum/modules.php on line 55

Warning: main(): Failed opening './modules//.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/clevela/public_html/forum/modules.php on line 55
It seems like there is something in the mod that changes how phpBB passes around data. I'm usually good at hacking my way through things like this, but I don't know enough phpBB/Gallery internals to diagnose this problem. Has anyone else encountered/tackled this problem?

Of course, all apologies for any duplication.
-Troy

PS. I've posted this on the Gallery support forum too.
Powerlord
Registered User
Posts: 15
Joined: Wed Aug 07, 2002 11:16 am

Post by Powerlord »

For some reason, when editing the admin_styles file, I have

Code: Select all

$confirm = ( isset($HTTP_POST_VARS['confirm']) ) ? TRUE : FALSE;
$cancel = ( isset($HTTP_POST_VARS['cancel']) ) ? TRUE : FALSE;
in the file already, but up before the $no_page_header line. Is that supposed to be there, or did I enter some weird distortional field at some point? ;)
Birdonawire
Registered User
Posts: 493
Joined: Fri Apr 16, 2004 12:17 pm

About upgrading from 2.0.8 - 2.0.10

Post by Birdonawire »

I posted this also in the php support..maybe that was the wrong place to post it. I will post it here I hope it is ok. Can someone "please"help.

I'm trying to uprade from the version 2.0.8 to 2.0.10
I have quite a few mods on my board so I downloaded this mod -http://www.phpbb.com/phpBB/viewtopic.php?t=211068

I have half of the codes changed, the only problem is when I get to the common.php file...and change the codes and go to check my board
it tells me I'm banned from my board. I then have to reupload the back up file to the common.php to get back in. Can someone please help with this, what am I doing wrong?
Thanks so much.
Birdonawire
Registered User
Posts: 493
Joined: Fri Apr 16, 2004 12:17 pm

Post by Birdonawire »

Figured it out..Sorry.

Took me awhile,but I got it.
Post Reply

Return to “[2.0.x] MOD Database Releases”