Page 1 of 3

[Tool] phpBB 2.0.9 to phpBB 2.0.10 Code Changes

Posted: Sat Jul 17, 2004 2:46 pm
by Extensions Robot
MOD Name: phpBB 2.0.9 to phpBB 2.0.10 Code Changes
Author: Acyd Burn
MOD Description: These are the Changes from phpBB 2.0.9 to phpBB 2.0.10 summed up into a little Mod.
This might be very helpful if you want to update your Board and have installed a bunch of Mods. Then it's normally easier to apply the Code Changes than to install all Mods again.

MOD Version: 1.0.1 (Updated 07/18/04)



Download File: phpBB-2.0.9_to_2.0.10_101.zip
mods overview page: View
File Size: 8125 Bytes

Security Score:

Posted: Sat Jul 17, 2004 9:58 pm
by morpheus2matrix
MOD Validated/Released

Notes:

Posted: Sat Jul 17, 2004 10:33 pm
by pulling his hair
Just like to point out to some of the people here, that, you can use the text/mod version in EasyMOD to update your forums.


Anyway, I wasn't excepting 2.0.10 so soon... and, as I said last time, Thanks Acyd! :)

Posted: Sat Jul 17, 2004 10:34 pm
by Acyd Burn
There is one little error in a FIND Statement, uploaded version 1.0.1. If you use EasyMod, please wait for the update.

Posted: Sat Jul 17, 2004 10:42 pm
by pulling his hair
OK, if anyone else get's a critical error on line 232, then, go into the MOD file, and goto line #232, which says:

Code: Select all

#-----[ FIND ]---------------------------------------------
# Line 116
					$redirect = ( !empty($HTTP_POST_VARS['redirect']) ) ? str_replace('&', '&', htmlspecialchars($HTTP_POST_VARS['redirect'])) : '';
					$redirect = str_replace('?', '&', $redirect);
Replace the code of that to:

Code: Select all

			$redirect = ( !empty($HTTP_POST_VARS['redirect']) ) ? str_replace('&', '&', htmlspecialchars($HTTP_POST_VARS['redirect'])) : "";
			$redirect = str_replace("?", "&", $redirect);

Posted: Sat Jul 17, 2004 10:43 pm
by pulling his hair
Acyd Burn wrote: There is one little error in a FIND Statement, uploaded version 1.0.1. If you use EasyMod, please wait for the update.


I had started my post below yours before you posted that ;)

Posted: Sun Jul 18, 2004 4:31 am
by bcs10
again great mod... i find these very helpful... as i am in the process of makeing a modded version of phpbb and i do not want to have to start over every time a new version of phpbb 2.0.x is released....

Posted: Sun Jul 18, 2004 5:12 am
by alsakrah
bcs10 wrote: again great mod... i find these very helpful... as i am in the process of makeing a modded version of phpbb and i do not want to have to start over every time a new version of phpbb 2.0.x is released....


You right it is better to have updating action so it will be very easy to us to update our moded forums

thanx phpBB team

Posted: Sun Jul 18, 2004 5:22 am
by alsakrah
Sorry :oops:

It is the download file was update it or not :?:

Posted: Sun Jul 18, 2004 5:27 am
by bcs10
alsakrah wrote: Sorry :oops:

It is the download file was update it or not :?:
ya.. this confused me to... you said you updated the mod to version 1.0.1.... is the download 1.0.0 or 1.0.1 please clarify...this is very confusing

Posted: Sun Jul 18, 2004 12:17 pm
by morpheus2matrix
MOD Updated to version 1.0.1
See first post for Download Link

Incorect classification

Posted: Sun Jul 18, 2004 1:40 pm
by Grand Edgemaster
Why is this MOD called
[2.0.7] 2.0.9 to 2.0.10 code change MOD
. When this is NOT a mod for 2.0.7? Same for 2.0.8 to 2.0.9.

Re: Incorect classification

Posted: Sun Jul 18, 2004 2:00 pm
by pulling his hair
Grand Edgemaster wrote: Why is this MOD called
[2.0.7] 2.0.9 to 2.0.10 code change MOD
. When this is NOT a mod for 2.0.7? Same for 2.0.8 to 2.0.9.


The MODs database has varieus categorys, and, they mean that you can't have a 2.0.8, .9 or .10 MOD yet.

Posted: Sun Jul 18, 2004 2:33 pm
by Grand Edgemaster
But other ones of these mods (8->9) are categorised under tools

Posted: Sun Jul 18, 2004 7:48 pm
by gel
First time I'm installing a mod with easy mod instead of updating and reinstalling all the mods afterwards - Installation had no errors and I think the update completed but in the bottom I still see phpbb 2.0.9 instead of 2.0.10 - Any ideas on how to solve it acyd?