[beta] EasyMOD v0.4.0

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
User avatar
yngwiethps
Registered User
Posts: 138
Joined: Thu Jun 16, 2005 1:22 am
Contact:

Post by yngwiethps » Tue Feb 07, 2006 1:55 am

Okay thanks. That cleared up some other things to.

ximpdbydefault
Registered User
Posts: 33
Joined: Sun Feb 05, 2006 8:13 am

Post by ximpdbydefault » Tue Feb 07, 2006 5:19 pm

Ive just replaced the contents of my forum dir due to clashing mods and mutiple errors in scripts The board is running well without mods, however neither do I have easymod installed either, or so I think...
I mounted this to my server under forum/admin/mods and went to launch the install.php when it tells me that its already installed:
Error

Critical Error: This version of EM has already been installed. Terminating to prevent reinstallation.

If you are trying to reinstall this version, change the EM version number from the Admin Control Panel under EasyMOD Settings. Or you could also use the EM Version Changer (by GPHemsley) here.

Expanded Debug Info
(formatted for forum posting)
EM installer v0.3.0 wrote: Update EM from: 0.3.0
phpBB version: 2.0.18
Working Dir: /home/host016/public_html/forum/admin/mods/easymod
Install Step: 1
Mode:

The Error wrote: Critical Error: This version of EM has already been installed. Terminating to prevent reinstallation.

If you are trying to reinstall this version, change the EM version number from the Admin Control Panel under EasyMOD Settings. Or you could also use the EM Version Changer (by GPHemsley) here.



Permissions: (including system errors)

read access :: OK
write access :: No
root path write :: No
chmod access :: unattempted
unlink access :: unattempted
mkdir access :: unattempted
tmp path write :: OK
FTP extension :: OK
Safe Mode :: OFF
copy access :: No


Additional System Information:

System: Linux holhost.holhost.com 2.6.10dn #1 SMP Thu Feb 17 16:46:53 EST 2005 i686
Configure Command: './configure' '--with-apxs=/usr/local/apache/bin/apxs' '--prefix=/usr' '--with-xml' '--enable-bcmath' '--enable-calendar' '--enable-ftp' '--with-gd' '--with-jpeg-dir=/usr/local' '--with-png-dir=/usr' '--with-xpm-dir=/usr/X11R6' '--enable-magic-quotes' '--with-mysql=/usr' '--enable-discard-path' '--with-pear' '--enable-sockets' '--enable-track-vars' '--enable-versioning' '--with-zlib'
PHP version: 4.4.1
register_globals: ON
magic_quotes_gpc: ON
magic_quotes_runtime: OFF
allow_url_fopen: ON
sockets_support: enabled


Recommendations:
write: buffer & ftp
move: automated FTP

Selected settings:
write:
move:
ftp dir: /
ftp host: localhost
ftp port: 21
ftp debug: false
ftp ext: fsock
ftp cache: false

CWD Listing:

Code: Select all

drwxr-xr-x . 
drwxr-xr-x .. 
drwxr-xr-x em_includes 
drwxr-xr-x includes 
drwxr-xr-x languages 
drwxr-xr-x templates 
drwxr-xr-x _vti_cnf 
-rw-r--r-- easymod_install.php 
-rw-r--r-- easymod_display_functions.php 
-rw-r--r-- easymod.gif 

Not testing FTP since it is not being used.

Again, the forum dir is flushed completly with new files (Except the config file) even the acp is virgin, therefore no EM in the left menu. How do I go about installing this again? are there mysql tables that need deleting. Many thanks in advance. Additional information is available upon request

Geddy
Registered User
Posts: 19
Joined: Thu Jan 26, 2006 11:54 pm

Problems with Installation

Post by Geddy » Tue Feb 07, 2006 9:54 pm

When installing and encountering the error
Most likely your phpBB files are set to read-only (644 or 444 access). You need to give all the files in your phpBB installation write access to the file owner (744). This is not a security hole.


Would I need to change all the files within my phpBB2 folder from 644/444 to 744 for installation purposes? Then after installation, do I change everything back to the way it was?

Or am I just changing the installation files?

aleingang
Registered User
Posts: 23
Joined: Wed Jan 25, 2006 2:40 am

Can't register for area51 forums

Post by aleingang » Tue Feb 07, 2006 11:37 pm

I have tried 8 or 9 times now to register for the area51 forums and every time I do it tells me "The confirmation code you entered was incorrect."
Now, I may not be the smartest guy in the world, but I CAN read a code and type it into a field. I've tried it with two browsers and had the same problem.
Apparently this is a known issue - there's a post from Nuttzy in here somewhere where he talks about allowing guest-posting to the forums if the problems aren't resolved. I appreciate that it's a beta, and I really appreciate all of the work that that the developers, etc. put in, but I'm getting really frustrated with trying to register over and over again! I assume other people are having the same problem.
I'm having problems installing EasyMod and could really use some help!
Thanks,
ALbo

User avatar
webmacster87
Former Team Member
Posts: 3758
Joined: Fri Jun 11, 2004 2:30 am
Location: San Mateo, CA
Name: Douglas Bell
Contact:

Re: Can't register for area51 forums

Post by webmacster87 » Tue Feb 07, 2006 11:39 pm

aleingang wrote: I have tried 8 or 9 times now to register for the area51 forums and every time I do it tells me "The confirmation code you entered was incorrect."
Now, I may not be the smartest guy in the world, but I CAN read a code and type it into a field. I've tried it with two browsers and had the same problem.
Apparently this is a known issue - there's a post from Nuttzy in here somewhere where he talks about allowing guest-posting to the forums if the problems aren't resolved. I appreciate that it's a beta, and I really appreciate all of the work that that the developers, etc. put in, but I'm getting really frustrated with trying to register over and over again! I assume other people are having the same problem.
I'm having problems installing EasyMod and could really use some help!
Thanks,
ALbo

The area51 issue is known, and it is for that reason that this thread has been unlocked; this thread serves as a "backup plan" for area51.
But anyways, this is EasyMOD support, not area51 support, so back on topic we go. ;)

thesnowgod
Registered User
Posts: 41
Joined: Sun Jul 27, 2003 2:43 pm

EasyMOD troubles

Post by thesnowgod » Wed Feb 08, 2006 4:10 am

I hope you can help (I also couldn't register at Area 51).

I am stuck at Step 2. I don't know what to put in the field for "FTP path to phpBB2" in the EasyMOD Settings . At step 2 I get this message:

Testing selected write method
Testing FTP access...
1) Logged in successfully

FTP ERROR: could not cd to /home/thesnowgod/www
You successfully logged into the server, but could not change direcory (CD) to the easymod directory. The following is recommended:


1. Are you sure you entered the correct path? Below is a directory listing of the files in the FTP root directory. The FTP root directory is simply the starting point when you connect. The path to the phpBB2 installation should begin with one of the directory names listed below.
2. Directory names are case sensitive. Be sure the easymod directory is all lowercase.
3. In some *very rare* cases it's possible that you are not connecting to the proper FTP Server. Try specifying the hostname in the FTP Server field and the port in the FTP Port field.
4. Some servers have issues with the passive mode that EasyMOD attempts to use by default. If you have the PHP FTP extension loaded, then enable that option in step 1.


FTP root directory:
/


Directory listing: your FTP Path should start with one of the directories listed below
FTP Error: A file listing could not be obtained. This usually indicates solution 4 listed above.

================================================================

When I debug I get this:

quote="EM installer v0.3.0"]
[b]EM status:[/b] New Install
[b]phpBB version:[/b] 2.0.19
[b]Working Dir:[/b] /home/thesnowgod/www/phpBB2/admin/mods/easymod
[b]Install Step:[/b] 2
[b]Mode:[/b] debug


[quote="The Error"]
[color=green][b]No error.[/b][/color]
[/quote]


[b]Permissions:[/b] (including system errors)
read access :: [b][color=green]OK[/color][/b]
write access :: [b]No[/b]
root path write :: [b]No[/b]
chmod access :: unattempted
unlink access :: unattempted
mkdir access :: unattempted
tmp path write :: [b][color=green]OK[/color][/b]
FTP extension :: [b][color=green]OK[/color][/b]
Safe Mode :: [b][color=green]OFF[/color][/b]
copy access :: [b]No[/b]


[b]Additional System Information:[/b]

[b]System:[/b] Linux warp.phpwebhosting.com 2.4.21-20.0.1.ELsmp #1 SMP Wed Nov 24 20:34:01 EST 2004 i686
[b]Configure Command:[/b] './configure' '--with-apxs=/usr/local/apache/bin/apxs' '--with-mysql' '--enable-track-vars' '--with-xml' '--enable-memory-limit=yes' '--enable-bcmath' '--enable-calendar' '--with-gd' '--enable-gd-native-tt' '--enable-gd-imgstrttf' '--with-jpeg-dir=/usr/local' '--with-png-dir=/usr/local' '--with-zlib-dir=/usr/include' '--with-freetype-dir=/usr/lib' '--with-gdbm=/usr/include' '--enable-trans-sid' '--with-imap' '--with-imap-ssl' '--with-gettext' '--enable-sockets' '--with-mcrypt' '--enable-xslt' '--with-xslt-sablot' '--with-sablot-js' '--enable-sablot-errors-descriptive' '--with-xmlrpc' '--with-dom' '--with-ming' '--with-curl' '--enable-ftp' '--with-kerberos' '--with-openssl' '--with-iconv' '--with-pear' '--enable-exif'
[b]PHP version:[/b] 4.4.1
[b]register_globals:[/b] ON
[b]magic_quotes_gpc:[/b] ON
[b]magic_quotes_runtime:[/b] OFF
[b]allow_url_fopen:[/b] OFF
[b]sockets_support:[/b] enabled


[b]Recommendations:[/b]
[b]write:[/b] buffer & ftp
[b]move:[/b] automated FTP

[b]Selected settings:[/b]
[b]write:[/b] ftpb
[b]move:[/b] ftpa
[b]ftp dir:[/b] /home/thesnowgod/www/phpBB2/admin
[b]ftp host:[/b] localhost
[b]ftp port:[/b] 21
[b]ftp debug:[/b] false
[b]ftp ext:[/b] ext
[b]ftp cache:[/b] false

[b]CWD Listing:[/b]
[code]
drwxr-xr-x .
drwxr-xr-x ..
drwxr-xr-x em_includes
drwxr-xr-x includes
-rw-r--r-- easymod.gif
-rw-r--r-- easymod_display_functions.php
-rw-r--r-- easymod_install.php
drwxr-xr-x languages
drwxr-xr-x templates
[/code]
Testing FTP access...
1) Logged in successfully
Current Working Directory: /
Directory listing: (0 files being listed)

FTP ERROR: could not cd to /home/thesnowgod/www/phpBB2/admin
You successfully logged into the server, but could not change direcory (CD) to the easymod directory. The following is recommended:


1. Are you sure you entered the correct path? Below is a directory listing of the files in the FTP root directory. The FTP root directory is simply the starting point when you connect. The path to the phpBB2 installation should begin with one of the directory names listed below.
2. Directory names are case sensitive. Be sure the easymod directory is all lowercase.
3. In some *very rare* cases it's possible that you are not connecting to the proper FTP Server. Try specifying the hostname in the FTP Server field and the port in the FTP Port field.
4. Some servers have issues with the passive mode that EasyMOD attempts to use by default. If you have the PHP FTP extension loaded, then enable that option in step 1.


FTP root directory:
/


Directory listing: your FTP Path should start with one of the directories listed below
FTP Error: A file listing could not be obtained. This usually indicates solution 4 listed above.
[/quote]



I hope someone here can help!! Thanks!
**edit** in the FTP path to phpBB2 field I have tried everything I could possibly think of. There's GOT to be something simple I'm missing, hopefully something easy.

User avatar
niksa
Registered User
Posts: 612
Joined: Mon Sep 08, 2003 7:20 pm
Location: Future birthplace of James T. Kirk
Contact:

Post by niksa » Wed Feb 08, 2006 4:33 am

Are you use it's www and not public_html? Just a guess.. might be worth a try while you wait anyway.

If it's www for sure, I'm certain someone will have an answer for you soon! Good luck with it.

User avatar
ndonezn
Registered User
Posts: 118
Joined: Fri Nov 11, 2005 10:05 pm
Location: pasadena
Contact:

Post by ndonezn » Wed Feb 08, 2006 10:21 am

was trying to install att.mod and got this error...

Critical Error: could not find [../admin/em_includes/em_functions.php]. Aborting.

does this mean i have to locate those files and then put them in that directory...i dont know why they wouldnt be there :?

User avatar
ndonezn
Registered User
Posts: 118
Joined: Fri Nov 11, 2005 10:05 pm
Location: pasadena
Contact:

Post by ndonezn » Wed Feb 08, 2006 10:28 am

bump

User avatar
DennyCrane
Registered User
Posts: 86
Joined: Mon Oct 17, 2005 3:47 am

Post by DennyCrane » Wed Feb 08, 2006 1:17 pm

what the heck are you bumping for? it had only been a few minutes and the thread is a STICKY!

Yjax
Registered User
Posts: 17
Joined: Wed Feb 01, 2006 7:48 pm

Post by Yjax » Wed Feb 08, 2006 2:17 pm

I got this error message when I tried to install cashmod with Easymod:

-------------------------------------------------------------------------------------
Critical Error

COPY FAILED: The target file to be copied [./mods/cashmod/admin/admin_cash.php could not be found.
copy admin/admin_cash.php to admin/admin_cash.php
MOD script line #96 :: FAQ :: Report

------------------------------------------------------------------------------------



This error message is showed many times, but the text I made in bold, is changed in every error message.
Anyone know how to solve this??

User avatar
Nigelman
Registered User
Posts: 210
Joined: Sun Jun 12, 2005 3:59 pm
Contact:

Post by Nigelman » Wed Feb 08, 2006 2:41 pm

Ok I'm with the others I can't get into AREA 51 because the visual thing is not working.

So it seems lots of us have EASY MOD installed but we're all here because we get an error when installing something. What are we supposed to do when these happen? I use a templete called GEN ELECTRO and most of the times the error is from this template.

Also I have another question....in my admin/mod/easymod/MOD, can I delete the files after I've installed it? Can I create a sub folder so I can delete the files from the mod? It's getitng pretty full when you consider some of the mods have a 10 15 files.

Ok thanks and I hope we can get some answears....

Nigelman

User avatar
ndonezn
Registered User
Posts: 118
Joined: Fri Nov 11, 2005 10:05 pm
Location: pasadena
Contact:

Post by ndonezn » Wed Feb 08, 2006 6:54 pm

dirTdogE wrote: what the heck are you bumping for? it had only been a few minutes and the thread is a STICKY!



lol...just joking around

User avatar
ndonezn
Registered User
Posts: 118
Joined: Fri Nov 11, 2005 10:05 pm
Location: pasadena
Contact:

Post by ndonezn » Wed Feb 08, 2006 7:33 pm

ndonezn wrote: was trying to install att.mod and got this error...

Critical Error: could not find [../admin/em_includes/em_functions.php]. Aborting.

does this mean i have to locate those files and then put them in that directory...i dont know why they wouldnt be there :?



any ideas?

User avatar
niksa
Registered User
Posts: 612
Joined: Mon Sep 08, 2003 7:20 pm
Location: Future birthplace of James T. Kirk
Contact:

Post by niksa » Thu Feb 09, 2006 12:03 am

ndonezn wrote:
ndonezn wrote:was trying to install att.mod and got this error...

Critical Error: could not find [../admin/em_includes/em_functions.php]. Aborting.

does this mean i have to locate those files and then put them in that directory...i dont know why they wouldnt be there :?



any ideas?


Did it give you any info about what caused this (like the line of code from the install file that caused the problem)?
I got this error message when I tried to install cashmod with Easymod:

-------------------------------------------------------------------------------------
Critical Error

COPY FAILED: The target file to be copied [./mods/cashmod/admin/admin_cash.php could not be found.
copy admin/admin_cash.php to admin/admin_cash.php
MOD script line #96 :: FAQ :: Report

------------------------------------------------------------------------------------



This error message is showed many times, but the text I made in bold, is changed in every error message.
Anyone know how to solve this??


Do you have all the cashmod files uploaded to yoursite.com/forum/admin/mods/cashmod/ ?

Have you been able to install anything successfully with EM before Cashmod?

Locked

Return to “[2.0.x] MOD Database Releases”

Who is online

Users browsing this forum: No registered users and 1 guest

cron