[2.0.18] Auto Cookies

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
283
73%
Very Good
30
8%
Good
22
6%
Fair
6
2%
Poor
49
13%
 
Total votes: 390

adensmore
Registered User
Posts: 2
Joined: Mon May 21, 2007 7:23 pm

Re: [2.0.18] Auto Cookies

Post by adensmore »

Hi, thanks in advance for your time:

My phpbbv2.1 forum is at http://forum.sellinggalveston.com and the web "root" that is referred to in setup i assume would be
/home/sellingg/public_html/forum
(even though it redirects to /home/sellingg/public_html/forum/cgi-bin/yabb2)

So i created
/home/sellingg/public_html/forum/install/cookie.php

and ran
http://forum.sellinggalveston.com/install/cookie.php

and got:

---------------------------------------------------------------------------------------------------
Warning: main(./../extension.inc): failed to open stream: No such file or directory in /home/sellingg/public_html/forum/install/cookie.php on line 137

Warning: main(): Failed opening './../extension.inc' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/sellingg/public_html/forum/install/cookie.php on line 137

Warning: main(./../common.): failed to open stream: No such file or directory in /home/sellingg/public_html/forum/install/cookie.php on line 138

Warning: main(): Failed opening './../common.' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/sellingg/public_html/forum/install/cookie.php on line 138

Warning: main(./../language/lang_english/lang_main.): failed to open stream: No such file or directory in /home/sellingg/public_html/forum/install/cookie.php on line 141

Warning: main(): Failed opening './../language/lang_english/lang_main.' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/sellingg/public_html/forum/install/cookie.php on line 141

Warning: main(./../language/lang_english/lang_admin.): failed to open stream: No such file or directory in /home/sellingg/public_html/forum/install/cookie.php on line 142

Warning: main(): Failed opening './../language/lang_english/lang_admin.' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/sellingg/public_html/forum/install/cookie.php on line 142

Forum Home Auto Cookies Detection and Reset

The following settings have been automatically detected....

---------------------------------------------------------------------------------------------------

The rest of the page loads without error and the detected settings seem right.

I'm just confused about where else I could put cookie.php in order to make those relative paths resolve ...

IF THIS CONTEXT HELPS i'm including it:
---------
Ultimately, I'm doing this because our admin login suddenly is invalid and no one thinks they changed it.
We can't see that the forums were defaced though anywhere.
I tried to install Starfoxtj PHPBB ToolKits and got this error:
MySQL Error: Table 'sellingg_sellingg.phpbb_config' doesn't exist
...Which is true - and I can't find the phpbb mysql tables anywhere in the mysql databases, and I've searched and searched and can't find a simple path to the phpbb settings templates on the server that would reveal where it's finding those tables - they must be there or the forums wouldn't be working right?
Then I tried to do this cookie fix when I got a dead end with the above.
---------

Sorry if this is too all over the place, I really did search for a few hours before giving up and posting.
Thanks very much,
Alan

geocator
Registered User
Posts: 16242
Joined: Fri Jan 09, 2004 11:56 pm
Location: On dry land
Contact:

Re: [2.0.18] Auto Cookies

Post by geocator »

Your forum is a YaBB forum not a phpBB forum. This is the wrong site for you.

adensmore
Registered User
Posts: 2
Joined: Mon May 21, 2007 7:23 pm

Re: [2.0.18] Auto Cookies

Post by adensmore »

Whoa I got two clients crossed over in my head wow I feel stupid. Thanks though for pointing that out! ha :)

jzahlaway
Registered User
Posts: 5
Joined: Thu Apr 19, 2007 2:09 pm

Re: [2.0.18] Auto Cookies

Post by jzahlaway »

I had a user experiencing a double-login problem (which also seemed to manifest in the form of him not getting the "New Posts" icon to function properly), so I ran this mod today. Seemed to fix his problem ... but it messed me up.

Here's what the previous settings were, along with new, mod-generated settings (which I accepted, and are now in place):

My Current Cookie Settings:
  • Domain Name: mydomain.net
  • Server Port: 80
  • Script path: /
  • Cookie secure: Disabled
  • Cookie domain:
  • Cookie path: /
  • Cookie name: mydomain
  • Session length [ seconds ]: 3600
  • Allow automatic logins: Yes
  • Automatic login key expiry: 0
My Suggested Cookie Settings:
  • Domain Name: www.mydomain.net
  • Server Port: 80
  • Script path: /
  • Cookie secure: Disabled
  • Cookie domain: www.mydomain.net
  • Cookie path: /
  • Cookie name: phpBB2_forum
  • Session length [ seconds ]: 3600
  • Allow automatic logins: Yes
  • Automatic login key expiry: 0
Great ... except that, I don't go to www.mydomain.net ... I go to mydomain.net (no www) ... and, as such, my auto-login no longer works; if I log in, then immediately go to "mydomain.net" without the www, I am logged out and have to log in again. Does reverting the domain back to mydomain.net (no www) in the cookie settings screw over those users who *do* use the www?? There's gotta be a way around this. This seems ridiculous. :evil:

EDIT: I seem to have worked around this by creating an .htaccess file that automatically redirects visits to mydomain.net to www.mydomain.net, in case that helps anyone with a similar problem.

This is what goes in the .htaccess file (obviously, you replace "yourdomain.com" with whatever your domain is):

Options +FollowSymLinks
RewriteEngine on
RewriteCond %{HTTP_HOST} ^yourdomain.com [NC]
RewriteRule ^(.*)$ http://www.yourdomain.com/$1 [L,R=301]
Last edited by jzahlaway on Thu Sep 20, 2007 2:10 pm, edited 1 time in total.

User avatar
Techie-Micheal
Security Consultant
Posts: 19511
Joined: Sun Oct 14, 2001 12:11 am
Location: In your servers

Re: [2.0.18] Auto Cookies

Post by Techie-Micheal »

If you don't want it to be www.domain.com, it should be .domain.com (note the 2 dots) under the cookie domain name. You don't need a .htaccess file.
Proven Offensive Security Expertise. OSCP - GXPN

wildmagiclady
Registered User
Posts: 24
Joined: Fri May 11, 2007 10:08 pm

Re: [2.0.18] Auto Cookies

Post by wildmagiclady »

THIS IS TOTALLY AWESOME. IT WORKS. IT RESOLVED MY ISSUES. THANKS SO MUCH!
:D

FFLink13
Registered User
Posts: 12
Joined: Sun Jun 03, 2007 12:01 pm

Re: [2.0.18] Auto Cookies

Post by FFLink13 »

I have unzipped it to /Install, but when I type in the http://www.mydomain.com/install/cookie.php, I got a 404 error.

Am I doing something wrong?

nevermind, it's working now. I named the folder Install instead of install.

shesteasing
Registered User
Posts: 6
Joined: Thu Jun 16, 2005 6:20 pm

Re: [2.0.18] Auto Cookies

Post by shesteasing »

this completely fixed my errors!! Thank you so much!

Contee
Registered User
Posts: 9
Joined: Fri Jun 15, 2007 11:20 pm

Re: [2.0.18] Auto Cookies

Post by Contee »

I did a fresh install of phpBB 2.0.22. It seemed to go fine. I could log in but couldn't get to the Administration Panel. (I got timed out errors). I was sent this link for a fix. I've d/l the MOD, installed it per directions, made my settings, saved to data base, deleted the install, cleared cookies, shut down and rebooted. Went to my site, tried to log in and now get the "This page cannot be displayed" error page. So, I came back here read back to page 3, post by GFXman on Nov. 2,2004 and found that this isn't what I neeeded at all. Any ideas how to undo this? I'm new to all this so any help is appreciated. Thanks.

geocator
Registered User
Posts: 16242
Joined: Fri Jan 09, 2004 11:56 pm
Location: On dry land
Contact:

Re: [2.0.18] Auto Cookies

Post by geocator »

What do you mean by made your changes. The point of this mod is that it detects the proper settings for you, and most of the time should not be changed. Please start a topic in the support forum, and include the output of the MOD provided at the bottom.

DALMOSH78
Registered User
Posts: 17
Joined: Wed Jul 04, 2007 1:55 pm

Re: [2.0.18] Auto Cookies

Post by DALMOSH78 »

you guys are the best.

one small thing. i cleard the cookis but when is trying to redirect i'm getting The page cannot be displayed
what i'm doing wrong


My Current Cookie Settings:

Domain Name: brzabrzina.com
Server Port: 80
Script path: /phpBB2/
Cookie secure: Enabled
Cookie domain: brzabrzina.com
Cookie path: /phpBB2
Cookie name: brzabrzina_forum
Session length [ seconds ]: 3600
: Yes
: 0



My Suggested Cookie Settings:

Domain Name: brzabrzina.com
Server Port: 80
Script path: /phpBB2/
Cookie secure: Enabled
Cookie domain: brzabrzina.com
Cookie path: /phpBB2
Cookie name: brzabrzina_forum
Session length [ seconds ]: 3600
: Yes
: 0


And this is the web site link http://brzabrzina.com/phpBB2/index.php
thank you



EDIT
Problem is fixed by changeing cookie secure to disabled
Last edited by DALMOSH78 on Wed Jul 04, 2007 10:32 pm, edited 3 times in total.

Havokx
Registered User
Posts: 4
Joined: Wed Jul 04, 2007 6:17 pm

Re: [2.0.18] Auto Cookies

Post by Havokx »

Hi, I'm having problems loging into the admin panel. It keeps asking me to login over and over again.
here's my Auto cookie settings:

Current:
Domain Name: http://www.trulydogs.com
Server port: 80
Script Path: /phpbb2/
Cookie Secure: Disabled
Cookie domain: .trulydogs.com
Cookie Path: /phpbb2
Cookie Name: phpbb2_forum
Session Length: 3600
Allow Automatic logins: Yes
Automatic login key expiry : 0

Suggested:
Domain Name: http://www.trulydogs.com
Server port: 80
Script Path: /phpbb2/
Cookie Secure: Enabled
Cookie domain: http://www.trulydogs.com
Cookie Path: /phpbb2
Cookie Name: phpbb2_forum
Session Length: 3600
Allow Automatic logins: Yes
Automatic login key expiry : 0

Is there a problem with it? I'm using firefox and clears all cookie data everytime I exit. Thanks in advance for the help. :)

geocator
Registered User
Posts: 16242
Joined: Fri Jan 09, 2004 11:56 pm
Location: On dry land
Contact:

Re: [2.0.18] Auto Cookies

Post by geocator »

There is no way that the script is suggesting those settings. It is absolutely impossible. Please start a support post in the support forum, and someone will help you sort the issue.

dlown
Registered User
Posts: 7
Joined: Sun Jul 08, 2007 12:38 am

Re: [2.0.18] Auto Cookies

Post by dlown »

I have done all the above, when I click write these settings to database - I get http 404 not found - page not found. What do I do now???

geocator
Registered User
Posts: 16242
Joined: Fri Jan 09, 2004 11:56 pm
Location: On dry land
Contact:

Re: [2.0.18] Auto Cookies

Post by geocator »

dlown wrote:I have done all the above, when I click write these settings to database - I get http 404 not found - page not found. What do I do now???
Please provide a link to your site with the cookie script uploaded to me via PM. Do not post it here.

Post Reply

Return to “[2.0.x] MOD Database Releases”