[Tool] phpBB 2.0.10 to 2.0.11 Changes

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
43
70%
Very Good
7
11%
Good
5
8%
Fair
0
No votes
Poor
6
10%
 
Total votes: 61

starc
Registered User
Posts: 33
Joined: Sun Mar 16, 2003 12:07 am

Post by starc »

A few pages back... http://www.phpbb.com/phpBB/viewtopic.ph ... 7ce533462d

Acyd Burn says " The update file will update your database from every version of 2.0 to 2.0.11. "

Can I use this download http://www.phpbb.com/phpBB/catdb.php?mo ... id=1320115 to go straight from 2.0.6 to 2.0.11 or is it necessary to go from 2.0.6 to 2.0.7 from 2.0.7 to 2.0.8 etc all the way to 2.0.11

Thanks
webguyz
Registered User
Posts: 3
Joined: Tue Jan 04, 2005 8:49 am

Post by webguyz »

Hi all,

tanfwc found a shortcoming in this mod. Maybe I'm crazy, but I had the same problem and didn't see the additional edit necessary for /templates/TEMPLATENAME/profile_add_body.tpl in any of the files.

http://www.phpbb.com/phpBB/viewtopic.ph ... 78#1380378

Updating this mod would be great for us late-to-the-game 2.0.11 upgraders. :D
Graham
Former Team Member
Posts: 8462
Joined: Tue Mar 19, 2002 7:11 pm
Location: UK
Contact:

Post by Graham »

starc - This MOD will only do the 2.0.10 to 2.0.11 update. If you need to go from an earlier version with this method (presumably because you can't use one of the standard upgrade methods) then you will need to go step by step using the others you list

webguyz - This is not an error. That code has been present in subSilver since 2.0.6 so there is no need to add it. If you use other templates, the changes are detailed either in this thread or in the Sticky in the Styles Development forum.
"So Long, and Thanks for All the Fish"

phpBB Useful Links: Knowledge Base | Userguide | Forum Search | MOD Database | Styles Database
My Links: Blog!
starc
Registered User
Posts: 33
Joined: Sun Mar 16, 2003 12:07 am

Post by starc »

Thanks
webguyz
Registered User
Posts: 3
Joined: Tue Jan 04, 2005 8:49 am

Post by webguyz »

Graham wrote: starc - This MOD will only do the 2.0.10 to 2.0.11 update. If you need to go from an earlier version with this method (presumably because you can't use one of the standard upgrade methods) then you will need to go step by step using the others you list

webguyz - This is not an error. That code has been present in subSilver since 2.0.6 so there is no need to add it. If you use other templates, the changes are detailed either in this thread or in the Sticky in the Styles Development forum.


Ahhh ok, my mistake! ;)

Image
User avatar
DragonMaster1
Registered User
Posts: 994
Joined: Tue Aug 17, 2004 11:04 am
Name: Terry
Contact:

Post by DragonMaster1 »

Can someone help me with this PLEASE?

I keep getting this error as soon as people click the confirm page to register.


Could not delete stale confirm data

DEBUG MODE

SQL Error : 1146 Table 'ronnieja_phpbb1.confirm' doesn't exist

DELETE FROM confirm WHERE session_id NOT IN ('1afb873251ad51671997839ccb3b7eea', '358dd7d721d689964a96578255db920c', '3a6c48797477e83667d018357c369833', '42d1c211372bdb25f786fc58989a88f8', '456ad45b5fd97dca7bc72960a8426626', '4d60fd4e0bc5cbca48633ce316b7a967', '5ca451050be1e5c44a6fcf38139a5f55', '89e12587f29787c18d4769500f460e1f', '8fa9e6d8a1787eb4e0501f40de53bea0', '9bd5f2f12bcb79c388fcb179f8800c2c', 'a19d8800e6f8cc8ddd9e07a42e79757d', 'b221fb3928f525203b137c0d944fe3b5', 'b4b6c1425f2b5fffc6aa7779a678c2e2', 'ccbbaa971b61c0294a073388bad06d9c', 'd06340a6c0a9d8462b7892f52ef3d137', 'f03a45720a0db48fdd939badf4c5422f', 'f449d81407fc78338f66582a2b12f5ca', 'f82b9dae2f94eed193c089454f1d6193', 'fc082cf59b8634609f2a17bcd5e0c261')

Line : 1197
File : /home/ronnieja/public_html/phpBB/includes/usercp_register.php



I can't find that confirm table anywhere.
Is there a manual SQL update I can use as something is not updating right.
Graham
Former Team Member
Posts: 8462
Joined: Tue Mar 19, 2002 7:11 pm
Location: UK
Contact:

Post by Graham »

If that table is missing you probably did an incoorect updare of a previous version. To create that table, get a full download of phpBB and then look in mysql_schema.sql for the SQL command to create that table and copy that block into phpMyAdmin and run it.
"So Long, and Thanks for All the Fish"

phpBB Useful Links: Knowledge Base | Userguide | Forum Search | MOD Database | Styles Database
My Links: Blog!
User avatar
MADMARY1
Registered User
Posts: 80
Joined: Fri Jun 18, 2004 12:52 am

Post by MADMARY1 »

I installed the update for 2.0.8 to 2.0.10 and the update for 2.0.10 to 2.0.11. Got confirmation that all was install without errors!! Which is wonderful considering I have many mods installed. Thanks! :D

But I have one problem that I can't figure out. :cry: ..when you go to the forum page, you cannot see the forums. But they are there in both the admin panel and if you click on the top forums on the portal. So I know they are there as there is 24 of them but for some reason they are not visable or cannot be seen on the index page. So can you help me??? Please??? :!:

Mary
User avatar
MADMARY1
Registered User
Posts: 80
Joined: Fri Jun 18, 2004 12:52 am

Post by MADMARY1 »

Thanks...but I resolved the problem. 8)

Mary
yby
Registered User
Posts: 41
Joined: Wed Dec 01, 2004 1:50 pm

Post by yby »

if you use a language different from english, you also have to change /language/lang_xxxx/lang_main.php and add

Code: Select all

 for italian
$lang['Confirm_code_wrong'] = 'Il Codice di Registrazione inserito non è corretto';
$lang['Too_many_registers'] = 'Hai superato il numero di tentativi di connessione per questa sessione. Prova più tardi.';
$lang['Confirm_code_impaired'] = 'Se non riesci a visualizzare il codice, per favore contatta l\' %sAmministratore%s per aiuto.';
$lang['Confirm_code'] = 'Codice di Registrazione';
$lang['Confirm_code_explain'] = 'Inserisci il codice alfanumerico che trovi qui sopra esattamente come appare scritto, facendo attenzione alle lettere MAIUSCOLE o minuscole; <bR>Ricorda: O è la lettera \'O\', Ø è il numero \'zero\'.';

User avatar
MADMARY1
Registered User
Posts: 80
Joined: Fri Jun 18, 2004 12:52 am

Post by MADMARY1 »

Ever since I updated all my icons on the viewtopic pages and in the privmessages are missing. The icons are there and I even tried to put the path in the template file but that did not work either. They are just not showing up. Is there a file like a functions file or something I can fix this in?

Got any ideas? I have been racking my head with this one as everything else is fine.

Mary :cry:
TeeDot
Registered User
Posts: 3
Joined: Sun Jan 16, 2005 7:22 am

Post by TeeDot »

I've run into a snag in upgrading to 2.0.11

In the instructions, it states:
#-----[ FIND ]---------------------------------------------
# Line 1135
$to_username = $HTTP_POST_VARS['username'];

#
#-----[ REPLACE WITH ]---------------------------------------------
#
$to_username = phpbb_clean_username($HTTP_POST_VARS['username']);


I can't find the specified line. Perhaps this was removed/edited with the install of the Custom Mass PM mod?

Has anyone else run into this problem?

Thanks in advance for any help/suggestions.


Editing my post to add:

I did remove that line when I installed the Custom Mass PM mod. These were the instructions:
Instructions from Custom Mass PM mod wrote: #-----[ FIND ]------------------------------------------------
#
$to_username = $HTTP_POST_VARS['username'];

#
#-----[ REPLACE WITH ]----------------------------------------
#

// Start replacement - Custom mass PM MOD
$to_username_array = explode (",", $HTTP_POST_VARS['username']);

foreach ($to_username_array as $name) $temp_array[] = trim($name);
$to_username_array=$temp_array;

sort ($to_username_array);

$n=0;
while ( !empty($to_username_array[$n]) )
{
$to_username_array[$n] = trim ($to_username_array[$n]);
$to_usernames .= (($to_usernames) ? "," : "" ) . "'" . $to_username_array[$n++]."'";
}
// End replacement - Custom mass PM MOD


How did others who have the Custom Mass PM mod installed handle the upgrade to 2.0.11?

Again, thanks for any help.
asinshesq
Registered User
Posts: 6266
Joined: Sun Feb 22, 2004 9:34 pm
Location: NYC
Name: Alan

Post by asinshesq »

Teedot,

I don't know for sure, but if I were you I would try this:

Code: Select all

FIND
$to_username_array = explode (",", $HTTP_POST_VARS['username']);

REPLACE WITH
$to_username_array = explode (",", phpbb_clean_username($HTTP_POST_VARS['username']));
If it works, I suspect it would be safe. If it doesn't work, post back and someone else will help you figure it out.
TeeDot
Registered User
Posts: 3
Joined: Sun Jan 16, 2005 7:22 am

Post by TeeDot »

asinshesq - Thank you for your help. I used your suggestion and I was at least able to upgrade to 2.0.11 successfully.

However, my Custom Mass PM mod is not working properly. This is the problem:

Let's say you want to to send a pm to 3 people and their usernames are Alexander1999, Beatrice2004 & Charlotte2005. You type this in the username field of your pm:

Alexander1999, Beatrice2004, Charlotte2005

You are then told that the user Beatrice20 does not exist. In other words, it is not reading the usernames past the 25th character.

Those of you who said you have a heavily modded board and were able to update to 2.0.11 with no problems - do you have the Custom Mass PM mod? Is it working properly for you?

Thanks
Janet Jackson
Registered User
Posts: 2
Joined: Thu Sep 30, 2004 11:30 pm
Location: The Netherlands
Contact:

Post by Janet Jackson »

Tonight I upgraded from 2.0.10 to 2.0.11 (better late than never, right ?). After following all directions in the .html manual I received the message everything was updated succesfully. But as soon as I tried to change my user profile I recieved the following error :

Code: Select all

* ***************************************************************************/
Warning: Cannot modify header information - headers already sent by (output started at gp/phpBB2/includes/usercp_register.php:2) in gp/phpBB2/includes/page_header.php on line 481

Warning: Cannot modify header information - headers already sent by (output started at gp/phpBB2/includes/usercp_register.php:2) in gp/phpBB2/includes/page_header.php on line 483

Warning: Cannot modify header information - headers already sent by (output started at gp/phpBB2/includes/usercp_register.php:2) in gp/phpBB2/includes/page_header.php on line 484
This happens with every account, with admins as well as with normal users. It also happens when registering as a new user (as soon as you click the 'register' text at the top).
Since I have a lot of mods installed, I suspect one of the mods to be the cause. But as you may have guessed my knowledge of PHP is zero, so I don't know where to start looking. I re-checked the changes I made in includes/page_header.php, but everything looked fine.

The mentioned lines above contain the following :
481 :

Code: Select all

	header ('Cache-Control: private, pre-check=0, post-check=0, max-age=0');
483 :

Code: Select all

header ('Expires: 0');
484 :

Code: Select all

header ('Pragma: no-cache');
The following mods were installed when under 2.0.10 and all still working fine :
  1. EasyMOD 0.1.13 - automates the installation of mods (didn't work well with this one, had to restore a backup
  2. Admins/mods color management 2.0.1 - now every admin/mod colour is used in almost all places instead of only on the index
  3. eXtreme Styles mod 2.0.1 - for advanced styles editing and speeding up the forums a little
  4. Country Flags 2.2.2 - adds the posibilty to add a flag of your country to your profile
  5. Fix Caret Bug 1.0.1 - some obscure bug fix for IE compatibility
  6. Signatures control 1.2.1 - to restrict the posibilities within the signatures (images are now forbidden)
  7. E-Mail Spambot Fighter 1.0.1 - this changes e-mail addresses to user AT domain DOT com, unfortunately it doesn't change the MSN addresses (yet)
  8. Multiple BBCode MOD 1.2.1 - to support the following :
    1. Anchor BBCode 1.0.1 - to link within a reply
    2. BBCode StrikeThrough 1.0.2 - speaks for itself
    3. Table BBCode 1.2.3 - to create tables without HTM
  9. 13 or Older Only 1.0.0 - simplifies the registration a little
  10. Improved IP Whois 1.0.0 - does a nslookup with ip addresses
  11. Easy Admin Topic Notifier 1.0.4 - sends an e-mail notification to the board administrator
  12. Forum Permissions List 1.0.1 - makes it easy to compare rights setting in forums
  13. Admin Userlist 2.0.2 - lists users, enables admins to make changes easily
  14. File Attachment Mod v2 2.3.10 - allows users to upload files when permitted
  15. Custom Title MOD 1.0.2 - to add titles to users
The address of the forums : http://www.ilnee.com/gp/phpBB2

Does any of you have a clue ? Thanks in advance !
Last edited by Janet Jackson on Fri Dec 01, 2006 9:48 pm, edited 1 time in total.
Shut up, be happy.
Post Reply

Return to “[2.0.x] MOD Database Releases”