[2.0.20] Event Registration

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
47
66%
Very Good
18
25%
Good
3
4%
Fair
1
1%
Poor
2
3%
 
Total votes: 71

User avatar
nepukjon
Registered User
Posts: 116
Joined: Sat Jul 23, 2005 8:07 pm
Location: Cardiff. S. Wales
Contact:

Post by nepukjon »

Whenever i install this mod, the same thing happens, installs fine, but when i come to use it, nothing happens.

I put in activate, write in my event things and slots, and submit...but it keeps refreshing itself to a normal thread, and no options to sign up come up. :(
knowledge is knowing a tomato is a fruit, wisdom is not putting it in a fruit salad
bourinii
Registered User
Posts: 21
Joined: Sat Apr 08, 2006 10:41 am

Post by bourinii »

I install this mod and when ever I try to post or replay I got this:

Error in posting

DEBUG MODE

INSERT INTO phpbb_posts (topic_id, forum_id, poster_id, post_username, post_time, poster_ip, enable_bbcode, enable_html, enable_smilies, enable_sig) VALUES (, , , '', , '505aab38', , , , )

Line : 346
File : functions_post.php

On:
http://1step2go.com/forums/posting.php? ... wtopic&f=1


Please Help
User avatar
nepukjon
Registered User
Posts: 116
Joined: Sat Jul 23, 2005 8:07 pm
Location: Cardiff. S. Wales
Contact:

Post by nepukjon »

bourinii wrote: I install this mod and when ever I try to post or replay I got this:

Error in posting

DEBUG MODE

INSERT INTO phpbb_posts (topic_id, forum_id, poster_id, post_username, post_time, poster_ip, enable_bbcode, enable_html, enable_smilies, enable_sig) VALUES (, , , '', , '505aab38', , , , )

Line : 346
File : functions_post.php

On:
http://1step2go.com/forums/posting.php? ... wtopic&f=1


Please Help


Got any other mods installed on your forum?

Had the same problem, and it was because i had put a peice of coding in the wrong place.... Double check over your adding in the functions post file....on the line stated

Either that or you havent done the SQL quiery properly.
knowledge is knowing a tomato is a fruit, wisdom is not putting it in a fruit salad
bourinii
Registered User
Posts: 21
Joined: Sat Apr 08, 2006 10:41 am

Post by bourinii »

will i install this 15 mods
- last 10 active topics
- bookmark
- phpbb2.0.20
- attachment
- No Flood Limit For Admins & Mods
- Autolang 1.1.1
- Massmail with HTML and preview
- Restrict Guest Access
- Admin Email List
- search box
- Member ID in viewtopic 1.0.3
- Signature V 2.0
- ACP member control
- Add News Block
- Refresh main page
:)

I also checked my SQL I can tell nothing wrong with the SQL installation although there might be something with the code modification but where to look?
Is it on the functions_post.php?
Give me a hint plz
User avatar
nepukjon
Registered User
Posts: 116
Joined: Sat Jul 23, 2005 8:07 pm
Location: Cardiff. S. Wales
Contact:

Post by nepukjon »

It'll be in functions post on the line it says. And ive known this mod in the past from its previous version to be very tempremental when it comes to working with other mods.

Thats why ive always installed it first. - But your best bet would be to check functions post on the line it says.
knowledge is knowing a tomato is a fruit, wisdom is not putting it in a fruit salad
bourinii
Registered User
Posts: 21
Joined: Sat Apr 08, 2006 10:41 am

Post by bourinii »

:roll:
noooooooooo
oh my god... im MCSD pro. i dont know how this php work and there is no code decumentation :( im lost here is my line

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
		$sql  = ($mode != "editpost") ? "INSERT INTO " . TOPICS_TABLE . " (topic_title, topic_poster


#
#-----[ REPLACE WITH ]----------------------------------
#
// Event Registration Begin
	$topic_reg = 0;
	if (!empty($reg_option1) || !empty($reg_option2) || !empty($reg_option3)) {
	    $topic_reg = 1;
	}
	$sql  = ($mode != "editpost") ? "INSERT INTO " . TOPICS_TABLE . " (topic_title, topic_poster, topic_time, forum_id, topic_status, topic_type, topic_vote, topic_reg) VALUES ('$post_subject', " . $userdata['user_id'] . ", $current_time, $forum_id, " . TOPIC_UNLOCKED . ", $topic_type, $topic_vote, $topic_reg)" : "UPDATE " . TOPICS_TABLE . " SET topic_title = '$post_subject', topic_type = $topic_type " . (($post_data['edit_vote'] || !empty($poll_title)) ? ", topic_vote = " . $topic_vote : "") . ", topic_reg = " . $topic_reg . " WHERE topic_id = $topic_id";
// Event Registration End

its wrong coz i have to change all the line :

Code: Select all

$sql  = ($mode != "editpost") ? "INSERT INTO " . TOPICS_TABLE . " (topic_title, topic_poster, topic_time, forum_id, topic_status, topic_type, topic_vote) VALUES ('$post_subject', " . $userdata['user_id'] . ", $current_time, $forum_id, " . TOPIC_UNLOCKED . ", $topic_type, $topic_vote)" : "UPDATE " . TOPICS_TABLE . " SET topic_title = '$post_subject', topic_type = $topic_type " . (($post_data['edit_vote'] || !empty($poll_title)) ? ", topic_vote = " . $topic_vote : "") . " WHERE topic_id = $topic_id";
i have even to merge it or change it all... i have merge it and this is the code:

Code: Select all

$topic_reg = 0;
		if (!empty($reg_option1) || !empty($reg_option2) || !empty($reg_option3))
		{
			$topic_reg = 1;
		}
		$sql  = ($mode != "editpost") ? "INSERT INTO " . TOPICS_TABLE . " (topic_title, topic_poster, topic_time, forum_id, topic_status, topic_type, topic_vote, topic_reg) VALUES ('$post_subject', " . $userdata['user_id'] . ", $current_time, $forum_id, " . TOPIC_UNLOCKED . ", $topic_type, $topic_vote, $topic_reg)" : "UPDATE " . TOPICS_TABLE . " SET topic_title = '$post_subject', topic_type = $topic_type " . (($post_data['edit_vote'] || !empty($poll_title)) ? ", topic_vote = " . $topic_vote : "") . ", topic_reg = " . $topic_reg . " WHERE topic_id = $topic_id";
Any suggestion ?
User avatar
nepukjon
Registered User
Posts: 116
Joined: Sat Jul 23, 2005 8:07 pm
Location: Cardiff. S. Wales
Contact:

Post by nepukjon »

No
knowledge is knowing a tomato is a fruit, wisdom is not putting it in a fruit salad
bourinii
Registered User
Posts: 21
Joined: Sat Apr 08, 2006 10:41 am

Post by bourinii »

These are the changes i made on the "functions_post.php" for the other Mod's:

Code: Select all

		if ($mode == 'newtopic' || $mode == 'reply' || $mode == 'editpost') 
	{
		//
		// Flood control
		//
		
// ====================================Start Mahdi Modifications (No Flood limit)======================================
//
// No Flood Limit For Administrators & Moderators MOD
//
	    if($userdata['user_level'] != ADMIN && $userdata['user_level'] != MOD)
	    {
// ====================================End Mahdi Modifications (No Flood limit)========================================
		
			$where_sql = ($userdata['user_id'] == ANONYMOUS) ? "poster_ip = '$user_ip'" : 'poster_id = ' . $userdata['user_id'];
			$sql = "SELECT MAX(post_time) AS last_post_time
				FROM " . POSTS_TABLE . "
				WHERE $where_sql";
			if ($result = $db->sql_query($sql))
			{
				if ($row = $db->sql_fetchrow($result))
				{
					if (intval($row['last_post_time']) > 0 && ($current_time - intval($row['last_post_time'])) < intval($board_config['flood_interval']))
					{
						message_die(GENERAL_MESSAGE, $lang['Flood_Error']);
					}
				}
			}
// ====================================Start Mahdi Modifications (No Flood limit)======================================
		}
// ====================================End Mahdi Modifications (No Flood limit)========================================

Code: Select all

if ($row = $db->sql_fetchrow($result))
				{
					$topic_update_sql .= ', topic_last_post_id = ' . $row['last_post_id'];
				}
				//==============================================Start Mahdi Modification===========================================
				// Bookmarks MOD, 1.0.1
				$sql = "DELETE FROM " . BOOKMARKS_TABLE . "
					WHERE topic_id = $topic_id";
				if (!$db->sql_query($sql))
				{
					message_die(GENERAL_ERROR, 'Error in deleting bookmark', '', __LINE__, __FILE__, $sql);
				}
				//================================================End Mahdi Modification===========================================

That’s it do you think there is anything I can do here?
groundfighter
Registered User
Posts: 1909
Joined: Sat Nov 08, 2003 2:15 am
Location: Las Vegas, NV
Contact:

Post by groundfighter »

Due to my template I need to change the width the mod makes on my template I looked in the .tpl file but cannot see what to change can anyone help I basically need it to stay within a 760 pix width otherwise IExplorer messes up my template but firefox displays correctly grrrr.
User avatar
Jackanape
Registered User
Posts: 1076
Joined: Wed Oct 13, 2004 6:01 am
Location: Capitol of the Great State of New York
Name: Jack Drury
Contact:

Post by Jackanape »

Is there a set of upgrade instructions from 2.0.2, or should we uninstall and reinstall?
~Extending the rule of meticulous exactitude to exaspirating punctillio...still.~
Treat your phpBB like a member of the family--Update and MOD her by hand, with HTML-Kit
: : Wanna Talk Poker? : : Image : :
bourinii
Registered User
Posts: 21
Joined: Sat Apr 08, 2006 10:41 am

Post by bourinii »

hi the mod works now great
just one question please

how can i administrate the mod. where in ACP I can find how to control it?

thanx in advance
groundfighter
Registered User
Posts: 1909
Joined: Sat Nov 08, 2003 2:15 am
Location: Las Vegas, NV
Contact:

Post by groundfighter »

You control it from your posts, to set permissions who can add it to the posts you select forum permissions.
bourinii
Registered User
Posts: 21
Joined: Sat Apr 08, 2006 10:41 am

Post by bourinii »

i would like to ask if there is a way that i can control who can see the result of the survey.

like the moderators only or the one who insert that survey.

I don't want all of the users to see the details answers of the survey
User avatar
vrflyer
Registered User
Posts: 503
Joined: Mon Feb 17, 2003 8:27 pm

Post by vrflyer »

Jackanape wrote: Is there a set of upgrade instructions from 2.0.2, or should we uninstall and reinstall?


Or from any previous version for that matter? :P
Always Under Construction !
en_shua
Registered User
Posts: 119
Joined: Sun Jan 25, 2004 1:39 am

Post by en_shua »

vrflyer wrote:
Jackanape wrote:Is there a set of upgrade instructions from 2.0.2, or should we uninstall and reinstall?


Or from any previous version for that matter? :P

I'm relatively certain that I had to uninstall and reinstall.
Post Reply

Return to “[2.0.x] MOD Database Releases”