[2.0.20] phpBB Jabber Support

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
5
71%
Very Good
1
14%
Good
0
No votes
Fair
1
14%
Poor
0
No votes
 
Total votes: 7

nmtdr
Registered User
Posts: 46
Joined: Tue Mar 28, 2006 4:41 am
Location: New Mexico

critical error

Post by nmtdr » Mon Apr 24, 2006 2:05 pm

Got this error installing phpbbjabbermod 1.1.0 to phpbb 2.0.20

mods include via easymod:
easymod
attachment
garage
realname
photo album
admin userlist
resend activation
admin email notification on new registration

Critical Error

FIND FAILED: In file [groupcp.php] could not find:

$sql = "SELECT username, user_id,

MOD script line #160 :: FAQ :: Report

UPDATE:
After looking into this further, realname mod adds realname after username in many lines. I uninstalled the realname mod with easymod, then installed phpbbjabbermod without errors. I can go into my profile and add my ID but there is no visible support on my posts.

nmtdr
Registered User
Posts: 46
Joined: Tue Mar 28, 2006 4:41 am
Location: New Mexico

Post by nmtdr » Fri Apr 28, 2006 6:34 pm

On a new install of 2.0.20 installation completes successfully.

But this portion of the install does not happen but reports it was done successfully.

viewtopic.php

#

#-----[ FIND ]------------------------------------------------

#

$sql = "SELECT u.username, u.user_id, u.user_posts

#

#-----[ IN-LINE FIND ]----------------------------------------

#

, u.user_msnm

#

'-----[ AFTER, ADD ]----------------------------------

#

, u.user_jabber

When I manually add ", u.user_jabber" to the file viewtopic.php the mod is working fine.

ptlis
Registered User
Posts: 90
Joined: Thu Aug 19, 2004 2:22 pm
Location: Newcastle, UK
Contact:

Post by ptlis » Fri Apr 28, 2006 11:58 pm

groundfighter wrote: How do you upgrade from previous versions? i.e. MOD Version: 1.0.4


Not right now, but i'll diff the two versions and make up a set of instructions on how to perform the required changes. Expect to see something here tomorrow(ish).

ptlis
I will not be pushed, filed, stamped, indexed, briefed, debriefed or numbered.....my life is my own.

User avatar
groundfighter
Registered User
Posts: 1909
Joined: Sat Nov 08, 2003 2:15 am
Location: Las Vegas, NV
Contact:

Post by groundfighter » Sat Apr 29, 2006 12:07 am

Sweet, thank you. 8)

ptlis
Registered User
Posts: 90
Joined: Thu Aug 19, 2004 2:22 pm
Location: Newcastle, UK
Contact:

Post by ptlis » Sat Apr 29, 2006 12:20 am

nmtdr wrote: [...]
UPDATE:
After looking into this further, realname mod adds realname after username in many lines. I uninstalled the realname mod with easymod, then installed phpbbjabbermod without errors. I can go into my profile and add my ID but there is no visible support on my posts.


For the next release i'll see if I can shorten the searches when they're looking at SQL queries to see if I can remove this incompatibility.
nmtdr wrote: On a new install of 2.0.20 installation completes successfully.

But this portion of the install does not happen but reports it was done successfully.
[...]
When I manually add ", u.user_jabber" to the file viewtopic.php the mod is working fine.

This is fairly odd, to my knowledge nobody else has had this problem - i'll check it out in the morning and see if I can reproduce it.

ptlis
I will not be pushed, filed, stamped, indexed, briefed, debriefed or numbered.....my life is my own.

User avatar
dnakata
Registered User
Posts: 7
Joined: Mon May 08, 2006 2:40 am
Contact:

Post by dnakata » Tue May 09, 2006 5:32 am

Well I feel stupid now. I just spent a good two or three hours grafting Jabber parameters into my phpBB code and templates, not knowing this mod existed until I search before posting mine.

C'est la vie..

nmtdr
Registered User
Posts: 46
Joined: Tue Mar 28, 2006 4:41 am
Location: New Mexico

Post by nmtdr » Tue May 09, 2006 2:34 pm

Got this error on a clean install on a godaddy server. Is there anything I can do to fix it? thanks.


Fatal error: Call to undefined function: iconv() in /forum/includes/usercp_jabber.php on line 101

ptlis
Registered User
Posts: 90
Joined: Thu Aug 19, 2004 2:22 pm
Location: Newcastle, UK
Contact:

Post by ptlis » Wed May 10, 2006 1:47 pm

nmtdr wrote: Got this error on a clean install on a godaddy server. Is there anything I can do to fix it? thanks.


Fatal error: Call to undefined function: iconv() in /forum/includes/usercp_jabber.php on line 101


That error is not related to this Modification - in phpBB2.x stock there is no file with that name, and this MOD doesn't add any files to stock phpBB - I suggest you look for support from the source of the MOD you're using.

ptlis
I will not be pushed, filed, stamped, indexed, briefed, debriefed or numbered.....my life is my own.

nmtdr
Registered User
Posts: 46
Joined: Tue Mar 28, 2006 4:41 am
Location: New Mexico

Post by nmtdr » Wed May 10, 2006 2:57 pm

sorry for the confusion.

Flokos
Registered User
Posts: 4
Joined: Tue Sep 27, 2005 3:18 pm

Post by Flokos » Thu Nov 30, 2006 7:29 pm

Hello,

Is it possible to make that field "active" ?

I mean that if someone clicks the button, makes him to send a message.
I field somewhere that the admin can add the public or the private jabber server and connects there to send a message ?

Now the only think that works is just the information that the x user has the z jabber id...

Thanks :)

Post Reply

Return to “[2.0.x] MOD Database Releases”

Who is online

Users browsing this forum: No registered users and 11 guests