[2.0.13] phpBB 2.0.13 to 2.0.14 Code Changes

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
81
71%
Very Good
12
11%
Good
10
9%
Fair
2
2%
Poor
9
8%
 
Total votes: 114

troll565
Registered User
Posts: 2
Joined: Sat Apr 16, 2005 1:52 am

Post by troll565 » Sat Apr 16, 2005 2:22 am

Marshalrusty wrote:
troll565 wrote:any idea about this error after going from 2.0.13 to 2.0.14?


Parse error: parse error, unexpected '}' in /home/starch3/public_html/forum/viewtopic.php on line 1229


You have an unexpected '}' in /home/starch3/public_html/forum/viewtopic.php on line 1229 :)
Are you sure you didn't paste the code in before a }, instead of after it?

Code: Select all

          }
     }                     (like after this one, instead of the last one)
}


sorry. I'm more of a copy and paste kinda guy. I got it working though. Thanks.

SeraphicGate
Registered User
Posts: 207
Joined: Tue Dec 23, 2003 6:54 am

Post by SeraphicGate » Sat Apr 16, 2005 2:22 am

Marshalrusty wrote:
troll565 wrote:any idea about this error after going from 2.0.13 to 2.0.14?


Parse error: parse error, unexpected '}' in /home/starch3/public_html/forum/viewtopic.php on line 1229


You have an unexpected '}' in /home/starch3/public_html/forum/viewtopic.php on line 1229 :)
Are you sure you didn't paste the code in before a }, instead of after it?

Code: Select all

          }
     }                     (like after this one, instead of the last one)
}


Load up your backup viewtopic.php and try redoing the changes needed.

van_Gogh
Registered User
Posts: 19
Joined: Tue Feb 10, 2004 12:55 am

Post by van_Gogh » Sat Apr 16, 2005 2:38 am

i've got a small question:
in the changed files package from .13 to .14 there is also a changed file in the templates (/subSilver/login_body.tpl) which is not included in this mod. as far as i can see, there is only

Code: Select all

class="post"
added twice. is this anything essential that should be changed too?

poregorn
Registered User
Posts: 138
Joined: Thu Sep 23, 2004 9:23 pm

Post by poregorn » Sat Apr 16, 2005 2:49 am

i cant do this part as it is not in my page_header file...any ideas?
(code changes listed first, the my page header 2nd)

Code: Select all

#-----[ OPEN ]--------------------------------------------- 
# 
includes/page_header.php

#
#-----[ FIND ]---------------------------------------------
# Line 38
	$useragent = (isset($_SERVER["HTTP_USER_AGENT"]) ) ? $_SERVER["HTTP_USER_AGENT"] : $HTTP_USER_AGENT;

#
#-----[ REPLACE WITH ]---------------------------------------------
# 
	$useragent = (isset($HTTP_SERVER_VARS['HTTP_USER_AGENT'])) ? $HTTP_SERVER_VARS['HTTP_USER_AGENT'] : getenv('HTTP_USER_AGENT');

Code: Select all

link to a txt file instead of posting the code here. - wGEric

tat
Registered User
Posts: 2
Joined: Sat Apr 16, 2005 2:44 am

Post by tat » Sat Apr 16, 2005 2:51 am

Help 8O :?

I made all the changes to the files listed in the mod file, and ran the file in the install folder. No errors came up on that, but all posts to my board have disappeared except for 'announcement' posts.

Presumably I haven't copied something quite right, but has anybody got any ideas on which file to start looking on?

cheers

Matthew

tat
Registered User
Posts: 2
Joined: Sat Apr 16, 2005 2:44 am

Post by tat » Sat Apr 16, 2005 3:10 am

:oops: :oops:

Fixed it :) I'd replaced a bit in postgres7.php instead of adding after it :oops:

Veeb0rg
Registered User
Posts: 8
Joined: Mon Oct 28, 2002 10:55 pm

Post by Veeb0rg » Sat Apr 16, 2005 3:33 am

*sigh*

you guys would have to release .14 the day after i spend 15 hours rebuilding my forums from a hack.. *15hours including mods, saving logs etc*


thanks for this guide thou

edit: heck i've installed mod's more complex and time consuming then this upgrade..

:)

NightriderXP
Registered User
Posts: 1418
Joined: Sat Oct 09, 2004 8:17 am
Location: Florida, US
Contact:

Post by NightriderXP » Sat Apr 16, 2005 4:36 am

This MOD installed FLAWLESSLY on my heavily modded board using EasyMod. Whoever wrote this MOD did a terrific job...

:lol:

th3zone
Registered User
Posts: 194
Joined: Tue Jan 04, 2005 11:02 pm

Post by th3zone » Sat Apr 16, 2005 4:43 am

thanks for the mods..updated my board with ZERO Problem so far...deleted oracle.php as well...work great :D

User avatar
alsakrah
Registered User
Posts: 166
Joined: Wed Dec 04, 2002 7:54 pm
Contact:

Post by alsakrah » Sat Apr 16, 2005 5:18 am

It's great that they give us the code changes. Thanks guys, I am now running 2.0.14 with no problems 8)

ThanX

DarksterV2
Registered User
Posts: 186
Joined: Thu Dec 23, 2004 3:24 pm
Contact:

Post by DarksterV2 » Sat Apr 16, 2005 5:43 am

Thanks for this file, much easier to do the update manually since I have a very heavily modded forum.

DmcMan
Registered User
Posts: 48
Joined: Sat Jan 01, 2005 5:23 am

Post by DmcMan » Sat Apr 16, 2005 6:21 am

:?: I'm also curios as to why this wasn't included in this mod.
van_Gogh wrote: i've got a small question:
in the changed files package from .13 to .14 there is also a changed file in the templates (/subSilver/login_body.tpl) which is not included in this mod. as far as i can see, there is only

Code: Select all

class="post"
added twice. is this anything essential that should be changed too?

alovesong
Registered User
Posts: 17
Joined: Wed Jan 05, 2005 2:47 pm

Post by alovesong » Sat Apr 16, 2005 6:21 am

Veeb0rg wrote: heck i've installed mod's more complex and time consuming then this upgrade..

:)


hah, I second that.

And thank you very much Acyd Burn, for making it so unbelievably easy to upgrade. Like others said I'd be lost without this as well. Rated "Excellent!" in my opinion.

snow leopard
Registered User
Posts: 90
Joined: Mon Dec 29, 2003 3:12 pm

Post by snow leopard » Sat Apr 16, 2005 6:31 am

Excellent as always *s* this is so much easier for upgrading heavily modded boards!!

bugfixed
Registered User
Posts: 101
Joined: Sun Apr 04, 2004 2:57 am
Location: Turkey
Name: Murat
Contact:

Post by bugfixed » Sat Apr 16, 2005 6:48 am

Thanks for mod's . :wink:

Post Reply

Return to “[2.0.x] MOD Database Releases”