[2.0.19] Invitation Only

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
48
63%
Very Good
19
25%
Good
6
8%
Fair
1
1%
Poor
2
3%
 
Total votes: 76

User avatar
Kellanved
Former Team Member
Posts: 2635
Joined: Wed Jan 26, 2005 2:48 pm
Location: Meta-level

Post by Kellanved » Wed Apr 27, 2005 1:50 pm

There wasn't a major change between the two versions. The 1.0.5 came with too many lang entries for the lang_admin file. The following block was removed - that's the only change.

Code: Select all

//BEGIN Invite Only MOD
$lang['Version_up_to_date'] = 'Your installation is up to date, no updates are available for your version of phpBB.';
$lang['Version_not_up_to_date'] = 'Your installation does <b>not</b> seem to be up to date. Updates are available for your version of phpBB, please visit <a href="http://www.phpbb.com/downloads.php" target="_new">http://www.phpbb.com/downloads.php</a> to obtain the latest version.';
$lang['Latest_version_info'] = 'The latest available version is <b>phpBB %s</b>.';
$lang['Current_version_info'] = 'You are running <b>phpBB %s</b>.';
$lang['Connect_socket_error'] = 'Unable to open connection to phpBB Server, reported error is:<br />%s';
$lang['Socket_functions_disabled'] = 'Unable to use socket functions.';
$lang['Mailing_list_subscribe_reminder'] = 'For the latest information on updates to phpBB, why not <a href="http://www.phpbb.com/support/" target="_new">subscribe to our mailing list</a>.';
$lang['Version_information'] = 'Version Information';
Nocando is in Idontwanna county. No support via PM

snafumedia
Registered User
Posts: 26
Joined: Wed May 04, 2005 4:05 am

Post by snafumedia » Wed May 04, 2005 4:11 am

I don't understand how to install this... There was not readme or anything in the one I downloaded, and when I uploaded the files, I got this error (in the admin panel):
General Error
Could not count invites

DEBUG MODE

SQL Error : 1146 Table 'db119358646.INVITATION_TABLE' doesn't exist

SELECT count(invitation_id) as total FROM INVITATION_TABLE

Line : 403
File : admin_invites.php


I looked at the file, and on line 403 all it said is "message_die(GENERAL_ERROR, 'Could not count invites', '', __LINE__, __FILE__, $sql);"


..thanks

User avatar
Kellanved
Former Team Member
Posts: 2635
Joined: Wed Jan 26, 2005 2:48 pm
Location: Meta-level

Post by Kellanved » Wed May 04, 2005 7:28 am

I see. To install the mod, you have to follow the instructions in the included .mod file.

Here is a tutorial on how to do that: http://www.phpbb.com/phpBB/viewtopic.php?t=61611


Also:
There is an automated Mod installer called Easymod. Have a look at it:

http://area51.phpbb.com/phpBB/viewtopic ... 17&t=15391

:D
Nocando is in Idontwanna county. No support via PM

snafumedia
Registered User
Posts: 26
Joined: Wed May 04, 2005 4:05 am

Post by snafumedia » Wed May 04, 2005 6:06 pm

Kellanved wrote: I see. To install the mod, you have to follow the instructions in the included .mod file.

Here is a tutorial on how to do that: http://www.phpbb.com/phpBB/viewtopic.php?t=61611


Also:
There is an automated Mod installer called Easymod. Have a look at it:

http://area51.phpbb.com/phpBB/viewtopic ... 17&t=15391

:D


Thanks! I'll try it out when I get home :D

kukacomone
Registered User
Posts: 55
Joined: Wed Jul 14, 2004 10:30 pm

Post by kukacomone » Wed May 11, 2005 3:41 pm

The mod doesnt send the invations email while i updated my forum from phpbb 2.0.14 to 2.0.15. Any idea?

User avatar
Kellanved
Former Team Member
Posts: 2635
Joined: Wed Jan 26, 2005 2:48 pm
Location: Meta-level

Post by Kellanved » Wed May 11, 2005 5:51 pm

No, I have no idea. I can't reproduce the issue.

Does your board send emails at all? I.e. do reply-notification and the other email-functions work?

Maybe something went wrong during the update?
Nocando is in Idontwanna county. No support via PM

kukacomone
Registered User
Posts: 55
Joined: Wed Jul 14, 2004 10:30 pm

Post by kukacomone » Thu May 12, 2005 3:00 pm

The other email-functions work great. The update doesnt edit the emailer.php, so... Maybe some other mistake, but i dont know what. I download the original emailer.php and replace it whit mine, but it doesnt work. I try 2.0.14 and 2.0.15 too.

User avatar
Kellanved
Former Team Member
Posts: 2635
Joined: Wed Jan 26, 2005 2:48 pm
Location: Meta-level

Post by Kellanved » Thu May 12, 2005 3:05 pm

But it does edit smtp.php ;-)

Is there any Error Message?
Nocando is in Idontwanna county. No support via PM

kukacomone
Registered User
Posts: 55
Joined: Wed Jul 14, 2004 10:30 pm

Post by kukacomone » Thu May 12, 2005 3:10 pm

No it isnt.

User avatar
Kellanved
Former Team Member
Posts: 2635
Joined: Wed Jan 26, 2005 2:48 pm
Location: Meta-level

Post by Kellanved » Thu May 12, 2005 3:16 pm

That is very strange indeed.

Is the "email-sent message" apppended to the description in the table?
Nocando is in Idontwanna county. No support via PM

kukacomone
Registered User
Posts: 55
Joined: Wed Jul 14, 2004 10:30 pm

Post by kukacomone » Thu May 12, 2005 3:25 pm

Problem solved. I check my test email accaunts, and there are the msg-s. But i sent it 3days ago, and yesterday there are werent in it. And other email thinks work f.e yesterday. Maybe my server play with me. :D So finally its work! Thanks ur help anyway, and big thanks for this mod. I really need it. Good work! ;)

Lachlan
Registered User
Posts: 2
Joined: Sat Jun 05, 2004 4:11 am

Post by Lachlan » Sat May 14, 2005 2:28 am

does this mod work with phpBB version 2.0.6 :?: :?: :?: :?:

User avatar
Kellanved
Former Team Member
Posts: 2635
Joined: Wed Jan 26, 2005 2:48 pm
Location: Meta-level

Post by Kellanved » Sat May 14, 2005 7:49 am

No, the mod template assumes the presence of the "visual confirmation" code. Hence the mod won't install on versions before 2.0.10 .


Updating to the current phpBB version might be a good idea, though ;-)
Nocando is in Idontwanna county. No support via PM

Claritone
Registered User
Posts: 4
Joined: Tue May 17, 2005 11:03 am

Post by Claritone » Tue May 17, 2005 12:18 pm

I'm using phpBB 2.0.15

Ive installed a couple mod's that look like they wouldnt have interfered with this, I also installed this one last.

When a user registers with a code, it doesnt put them into the specified usergroup, and it also does not use up the 1 use I set the key to have.

(im not positive about the usergroup part. i gave the key to a friend, he signed up (i set it to only allow 1 btw) and it still said 1 use left and no usernames created from it after he registered and then i edited the key to allow 2 uses and put a new user into a group and it didnt send them into the group)

User avatar
Kellanved
Former Team Member
Posts: 2635
Joined: Wed Jan 26, 2005 2:48 pm
Location: Meta-level

Post by Kellanved » Tue May 17, 2005 12:34 pm

It sounds as if something interferes with the mod. Have you any mod installed which affects the profiles?

Double-check the changes in usercp_register.php, as is sounds like your board doesn't execute the added code at all.
Nocando is in Idontwanna county. No support via PM

Post Reply

Return to “[2.0.x] MOD Database Releases”