[2.0.19] Invitation Only

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
48
63%
Very Good
19
25%
Good
6
8%
Fair
1
1%
Poor
2
3%
 
Total votes: 76

Claritone
Registered User
Posts: 4
Joined: Tue May 17, 2005 11:03 am

Post by Claritone » Tue May 17, 2005 12:54 pm

I checked the usercp_register.php file like you suggested and it checks out perfectly

and no I havent done anything to profiles



maybe if we could do this in real time we can come to solution quicker
Last edited by Claritone on Tue May 17, 2005 1:13 pm, edited 2 times in total.

User avatar
Kellanved
Former Team Member
Posts: 2635
Joined: Wed Jan 26, 2005 2:48 pm
Location: Meta-level

Post by Kellanved » Tue May 17, 2005 1:01 pm

Hmm. It looks good, as far as I can say without looking into the php.


It seems as if this addition isn't executed properly:

Code: Select all

#
#-----[ FIND ]------------------------------------------
#
					$emailer->reset();
				}
				$db->sql_freeresult($result);
			}
#
#-----[ AFTER, ADD ]------------------------------------------
#
			//BEGIN Invite Only MOD	  
			if ($board_config['invite_only'] && !empty...
 

I have no idea why this might be.
Nocando is in Idontwanna county. No support via PM

Claritone
Registered User
Posts: 4
Joined: Tue May 17, 2005 11:03 am

Post by Claritone » Tue May 17, 2005 1:11 pm

DOH!

I'm so sorry I feel like I wasted your time.

the problem was from a mod that disables email sending from the forum.

your mod works GREAT! +5

Code: Select all

## Files To Edit:
##    admin/admin_board.php
##    groupcp.php
##    includes/emailer.php

##    includes/usercp_register.php

##    includes/usercp_sendpasswd.php
##    language/lang_english/lang_admin.php
##    language/lang_english/lang_main.php
##    posting.php
##    privmsg.php
##    templates/subSilver/admin/board_config_body.tpl
##    templates/subSilver/profile_add_body.tpl

sonyboy
Registered User
Posts: 2980
Joined: Thu Oct 07, 2004 2:10 am

Post by sonyboy » Tue May 17, 2005 8:09 pm

Hey, I installed this MOD to my forum, then I try to register an account but it won't let me. I got to the agreement part with under 13 and 13 or over links. I clicked on either one and it won't take me to the register page. So has anybody have this problem?

User avatar
Kellanved
Former Team Member
Posts: 2635
Joined: Wed Jan 26, 2005 2:48 pm
Location: Meta-level

Post by Kellanved » Tue May 17, 2005 8:20 pm

Let's see: Where to do the links lead?
Nocando is in Idontwanna county. No support via PM

sonyboy
Registered User
Posts: 2980
Joined: Thu Oct 07, 2004 2:10 am

Post by sonyboy » Tue May 17, 2005 8:54 pm

Sorry, I forgot to mention that, it doesn't lead to anything, it just display the same page when I click the link.

User avatar
Kellanved
Former Team Member
Posts: 2635
Joined: Wed Jan 26, 2005 2:48 pm
Location: Meta-level

Post by Kellanved » Tue May 17, 2005 9:00 pm

Well, as a first guess: check the in-line edits in usercp_register.php .

And more to the point: what do the links look like? Especially the query string; is the "coppa=true" part in there?
Nocando is in Idontwanna county. No support via PM

buntyindia
Registered User
Posts: 69
Joined: Tue Mar 01, 2005 4:23 pm
Location: India
Contact:

Post by buntyindia » Wed May 18, 2005 9:15 am

is this MOD for whole board or we can use this with selected Forums?

i am using 2.0.15

Bunty
=====================
Knowledge Is Power Share It

User avatar
Kellanved
Former Team Member
Posts: 2635
Joined: Wed Jan 26, 2005 2:48 pm
Location: Meta-level

Post by Kellanved » Wed May 18, 2005 4:49 pm

No, the mod affects the registration procedure and hence is global.
Nocando is in Idontwanna county. No support via PM

sonyboy
Registered User
Posts: 2980
Joined: Thu Oct 07, 2004 2:10 am

Post by sonyboy » Thu May 19, 2005 1:44 am

I installed this MOD to my forum with a lot of MODs installed so I thought this may be cause by them, but then I installed this MOD to the original phpBB and the same problem happens, so from this, it tells me that the problem comes from the MOD itself.

buntyindia
Registered User
Posts: 69
Joined: Tue Mar 01, 2005 4:23 pm
Location: India
Contact:

Post by buntyindia » Thu May 19, 2005 4:10 am

this means i can't apply it on selecte forum..
right?
=====================
Knowledge Is Power Share It

User avatar
Kellanved
Former Team Member
Posts: 2635
Joined: Wed Jan 26, 2005 2:48 pm
Location: Meta-level

Post by Kellanved » Thu May 19, 2005 9:06 am

sonyboy wrote: I installed this MOD to my forum with a lot of MODs installed so I thought this may be cause by them, but then I installed this MOD to the original phpBB and the same problem happens, so from this, it tells me that the problem comes from the MOD itself.


I am unable to reproduce the issue. I tried it out on a vanilla phpBB2.0.15 and it does exactly what it is supposed to do.
It sounds like the links on the "agree" page are not created correctly. The coopa part in usercp_register is supposed to look like this post install: :)

Code: Select all

// ---------------------------------------
// Load agreement template since user has not yet
// agreed to registration conditions/coppa
//
function show_coppa($invite_code, $email)
{
	global $userdata, $template, $lang, $phpbb_root_path, $phpEx;

	$template->set_filenames(array(
		'body' => 'agreement.tpl')
	);

	$template->assign_vars(array(
		'REGISTRATION' => $lang['Registration'],
		'AGREEMENT' => $lang['Reg_agreement'],
		"AGREE_OVER_13" => $lang['Agree_over_13'],
		"AGREE_UNDER_13" => $lang['Agree_under_13'],
		'DO_NOT_AGREE' => $lang['Agree_not'],

		"U_AGREE_OVER13" => append_sid("profile.$phpEx?mode=register&agreed=true" .$invite_code . $email),
		"U_AGREE_UNDER13" => append_sid("profile.$phpEx?mode=register&agreed=true&coppa=true" .$invite_code . $email))
	);

	$template->pparse('body');

}
//
// ---------------------------------------
@buntyindia Exactly. It is for inviting formely unregistered people.
Last edited by Kellanved on Thu May 19, 2005 10:50 am, edited 2 times in total.
Nocando is in Idontwanna county. No support via PM

Fletch79
Registered User
Posts: 151
Joined: Thu Nov 07, 2002 3:48 am
Location: Scotland

Post by Fletch79 » Thu May 19, 2005 10:29 am

Works with EM ... no problems at all

stvwlf
Registered User
Posts: 1
Joined: Fri May 20, 2005 5:08 pm

Post by stvwlf » Fri May 20, 2005 5:34 pm

Hi - I am installing the Invitation Only mod and have created a problem. Double checked the code I modified - all seems to be OK. Using phpbb 2.0.15.

When I click on the Registration link, the Agreement Terms are correctly displayed. When I click on "agree to terms", I receive the following error message:

Parse error: parse error, unexpected T_LNUMBER in /home/urania/public_html/forum/includes/template.php(127) : eval()'d code on line 77

Prior to installing the mod, there were no errors appearing during the registration process.

I also have one question about the code mods in usercp_register.php...

Code: Select all

"U_AGREE_OVER13" => append_sid("profile.$phpEx?mode=register&agreed=true .$invite_code . $email"),
It is correct that there is no space between the period and $invite_code??

I appreciate any help or suggestions for debugging this problem
thank you
Steve

User avatar
Kellanved
Former Team Member
Posts: 2635
Joined: Wed Jan 26, 2005 2:48 pm
Location: Meta-level

Post by Kellanved » Fri May 20, 2005 6:47 pm

Yes, that part is correct.

The error occured in template.php; double check all modifications to the .tpl file and the template variable assignments further down in usercp_register.


Edited.
Nocando is in Idontwanna county. No support via PM

Post Reply

Return to “[2.0.x] MOD Database Releases”