Import Tools

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Post Reply

Rating:

Excellent!
16
50%
Very Good
9
28%
Good
4
13%
Fair
1
3%
Poor
2
6%
 
Total votes: 32

`Scorpio`
Registered User
Posts: 4
Joined: Mon Nov 07, 2005 9:50 am

Post by `Scorpio` » Fri Nov 11, 2005 1:04 pm

Rotsblok wrote: same problem here no users are imported.
Am trying to import it straight into the db through a sql script but one question is can i do the pw in plain text or does it give troubles due to the md5?

BTW have tripple checked the changes that had to be made etc. but no errors there


I have tried that. I made program to make MD5 format form plain text for passwords and than import it in base with script. Than I had problems with permissions because something was wrong in database. I done it with this mod. It works fine now.

Format in *.csv file is like this: username;email@something.net;password!


Here was mistake in file .csv because shouldn't be ; but ,(comma)

User avatar
Rotsblok
Registered User
Posts: 648
Joined: Fri Nov 11, 2005 12:47 pm
Location: Upper north of Holland
Name: Rikkert Westa
Contact:

Post by Rotsblok » Fri Nov 11, 2005 1:34 pm

have tried the comma but still doesnt work.

Here is an example what formats i have tried:

'erik','12345','fu@hotmail.com'
pier,12343,assole@dipshit.nl
'erik';'12345';'fu@hotmail.com'
pier;12343;assole@dipshit.nl

none are working

Will try later next week with a new fresh installation and see whats happening

`Scorpio`
Registered User
Posts: 4
Joined: Mon Nov 07, 2005 9:50 am

Post by `Scorpio` » Fri Nov 11, 2005 2:29 pm

username,email@something.net,password

This is the right string. First must be username[comma]email[comma]pass

Like this

scorpio,scorp@forum.si,12333
hacker,hack@forum.net,3321

and so on...

It will work!

webgod@goddessraven.com
Registered User
Posts: 4
Joined: Fri Nov 11, 2005 3:14 pm

HELP!! Imaging posting problems /Postimage.org

Post by webgod@goddessraven.com » Fri Nov 11, 2005 3:18 pm

How do I use a different service then postimage.org? or can I change the option to upload the files directly to my server instead of using a 3rd party? :?:

I took a look at the attachment mod but it was too complex and when trying to run the table installer always said couldn't connect to database. So not really interested in that option. :oops:

However, I know there must be a way to just upload the files directly to the server instead of postimage.org? Any help would be greatly appreciated.

Thanks in advance!

Graham
Former Team Member
Posts: 8462
Joined: Tue Mar 19, 2002 7:11 pm
Location: UK
Contact:

Post by Graham » Fri Nov 11, 2005 6:21 pm

As per the instructions in the first post, the input need to be comma separated - you seem to be using semi-colons
"So Long, and Thanks for All the Fish"

phpBB Useful Links: Knowledge Base | Userguide | Forum Search | MOD Database | Styles Database
My Links: Blog!

User avatar
Rotsblok
Registered User
Posts: 648
Joined: Fri Nov 11, 2005 12:47 pm
Location: Upper north of Holland
Name: Rikkert Westa
Contact:

Post by Rotsblok » Wed Nov 16, 2005 5:22 pm

got an error code:
Fatal error: Cannot redeclare class user in /var/www/3/3pinten.nl/HTML/rikkert/forum/includes/functions_mod_user.php on line 36

have installed easymod and the hierarchy mod Categories hierarchy - 2.1.0

dont have a clue what it is (im a noob concerning php) or how to solve it
any suggestions

deyv
Registered User
Posts: 12
Joined: Tue Jul 20, 2004 3:18 pm

Post by deyv » Wed Nov 16, 2005 6:33 pm

Everyone,

Make sure you don`t have a space between the coma and the parameters. It only works without.

jardeon
Registered User
Posts: 1
Joined: Fri Nov 18, 2005 8:18 pm

Post by jardeon » Fri Nov 18, 2005 8:22 pm

First off, GREAT MOD!

I've just finished migrating a 10,000 account member database into the phpbb_users table, and I ran into the following problem:

Our database stores passwords for users in plain text. So in compiling my CSV file, I told the database server to md5 the passwords before writing the output file. This gave me a csv file that had md5 hashes for passwords. When importing this 10,000 line CSV file using the Import Tools mod, in 1,000 line chunks, I found that it would properly import the passwords for the first 1,000 accounts, then, when I clicked the "continue importing" button, the script 'forgot' the password format flag, and treated my md5 passwords as cleartext, and re-md5'd them.

I was able to get around it by creating 10 CSV files of 1,000 lines each, and importing them each separately, but it seems that any multi-cycle import with md5'd passwords is going to fall back on plain text and force double md5'ing after the first N lines (N being the number you specify on the import page).

Any thoughts?

wGEric
Former Team Member
Posts: 8805
Joined: Sun Oct 13, 2002 3:01 am
Location: Friday
Name: Eric Faerber
Contact:

Post by wGEric » Tue Nov 22, 2005 10:09 pm

That number is a unix timestamp. You can use phpBB"s create_date function or php's date function to create a human readable form of the date. Use mktime to create the unix timestamp from a date.

FYI, binary is only 1s and 0s.
Eric

Best_Channel
Registered User
Posts: 23
Joined: Wed Nov 09, 2005 5:12 pm

Importing

Post by Best_Channel » Wed Nov 23, 2005 4:57 pm

Graham wrote: Strange, the code should set their registration date to the time you import them. The line to do it is certainly present, and it worked when I last tested it.


Posted: Fri Dec 05, 2003 3:26 pm

Question # 1: Does anyone know what the format of the registration_date data should be? This is the 4th column in the .csv file when importing members. Should it be a Unix Time format? Should it be a Readable Date format such as 17 March 2002 ? I wish someone would not speculate but will relay prior tested experience. Thanks!

--------------------------------------------------------------------------------
Graham wrote: It is recommended that you do not have more than 250 entries in the CSV file, otherwise the script may timeout and fail to import all the entries.


member wrote: Oh boy. I have 90.000 users. hm.

Would something like:
Code:
@set_time_limit(xxxx);

do any good when it comes to this timeout?
_________________
You don't know what you don't know.



--------------------------------------------------------------------------------
Graham wrote: Yes it would (although I'd personally set it to 0 to give an infinite limit), but you'd have no way of monitoring the progress if the browser times out. The ability to do a file a chunk at a time is something that I've not yet had the time to add to it (you'll see the option on the settings screen but I've not coded the stuff behind it).

Actually, if you have a reasonable server, then you can probably do 1000 or so without it timing out, but I put the lower figure in to give a definite safe upper size.

With that many records to import, I'd suggest you should add the time limit value, split your file into 10000 member chunks, and then run the convertor on one of these, leave it for say 10-15 minutes to make sure that it has finished, and then repeat on the next one.
_________________
"So Long, and Thanks for All the Fish"

phpBB Convertor Team Leader
phpBB Useful Links: Knowledge Base | Userguide | Forum Search | MOD Database | Styles Database
My Links: Blog!


Question # 2: In which script do you need to add the time limit set = o?
Can anyone share that piece of code please? Thanks!

Best_Channel
Registered User
Posts: 23
Joined: Wed Nov 09, 2005 5:12 pm

Post by Best_Channel » Sun Nov 27, 2005 2:19 am

Anyone?

User avatar
Rotsblok
Registered User
Posts: 648
Joined: Fri Nov 11, 2005 12:47 pm
Location: Upper north of Holland
Name: Rikkert Westa
Contact:

Post by Rotsblok » Mon Nov 28, 2005 6:24 pm

Never mind alreayd got it right

Best_Channel
Registered User
Posts: 23
Joined: Wed Nov 09, 2005 5:12 pm

Location

Post by Best_Channel » Wed Nov 30, 2005 3:19 am

Graham wrote: Yes. Sorry, I've been busy with convertor updates this week.

OK there are a few changes
Code:
$username = addslashes($member_data[0]);
$email = $member_data[1];
$user_password = $member_data[2];


will need changing so that the numbers match the column that data is actually in (noting that they start from 0)

You will need to add an extra line again with the correct number
Code:
$realname = addslashes($member_data[3])


You will then need to alter the SQL,
Find the bit that reads
Code:
user_actkey, user_posts)

and add
Code:
, field_name

before the bracket
and then find
Code:
$user_posts . "')";

and add
Code:
, '" . $realname . "'

before the bracket

That should be it.
_________________
"So Long, and Thanks for All the Fish"


Help! I'm trying to import some users with their respective locations etc, since I'm transitioning them from another board. Can someone tell me what changes do I have to make to the import scripts, as above, in order for me to add a 4th column representing the location of the user? I know the location field is related to MySQL user_from field. Thank You!

Best_Channel
Registered User
Posts: 23
Joined: Wed Nov 09, 2005 5:12 pm

Graham

Post by Best_Channel » Wed Nov 30, 2005 4:23 pm

Hello Graham,

You have developed a useful importing tool but I wonder if you still provide support here in this forum. I have also emailed you directly without any reply. Are you still providing support for this specific forum?

Thanks!

warnmar10
Registered User
Posts: 154
Joined: Mon Sep 13, 2004 2:13 pm

Post by warnmar10 » Sun Dec 04, 2005 12:25 am

Rotsblok wrote: got an error code:
Fatal error: Cannot redeclare class user in /var/www/3/3pinten.nl/HTML/rikkert/forum/includes/functions_mod_user.php on line 36

have installed easymod and the hierarchy mod Categories hierarchy - 2.1.0

dont have a clue what it is (im a noob concerning php) or how to solve it
any suggestions

Rotsblok wrote: Never mind alreayd got it right


How did you fix this?

Post Reply

Return to “[2.0.x] MOD Database Releases”