[Tool] phpBB 2.0.14 to 2.0.15 Code Changes

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.
Post Reply

Rating:

Excellent!
97
63%
Very Good
15
10%
Good
14
9%
Fair
7
5%
Poor
20
13%
 
Total votes: 153

Extensions Robot
Extensions Robot
Extensions Robot
Posts: 27957
Joined: Sat Aug 16, 2003 7:36 am

[Tool] phpBB 2.0.14 to 2.0.15 Code Changes

Post by Extensions Robot » Sat May 07, 2005 3:09 pm

MOD Name: phpBB 2.0.14 to 2.0.15 Code Changes
Author: Acyd Burn
MOD Description: Code Changes from phpBB 2.0.14 to 2.0.15 in three formats (text/mod, html, bbcode prepared for posting the changes on phpBB forums).


MOD Version: 1.0.0

Download File: phpbb_2014_to_2015.zip
mods overview page: View
File Size: 22987 Bytes

Security Score: 0
Last edited by Extensions Robot on Mon Apr 30, 2007 12:26 am, edited 1 time in total.
(this is a non-active account manager for the phpBB Extension Customisations Team)

wGEric
Former Team Member
Posts: 8805
Joined: Sun Oct 13, 2002 3:01 am
Location: Friday
Name: Eric Faerber
Contact:

Post by wGEric » Sat May 07, 2005 5:53 pm

MOD Validated/Released

Notes:
Use these instructions to update your board to 2.0.15.
Eric

User avatar
Rat
Registered User
Posts: 102
Joined: Wed Oct 23, 2002 4:46 am
Location: Houston, TX
Contact:

Post by Rat » Sat May 07, 2005 6:16 pm

great mod, working perfectly with ezmod no error install within 1 min :)
Rat

User avatar
bonelifer
Community Team Member
Community Team Member
Posts: 3475
Joined: Wed Oct 27, 2004 11:35 pm
Name: William
Contact:

Post by bonelifer » Sat May 07, 2005 6:25 pm

Gotta love those back-porting slaves errr... DEV TEAM/MOD TEAM. :lol: :wink: Keep up the superb work.

y0y0
Registered User
Posts: 85
Joined: Sun Apr 04, 2004 12:03 pm

Post by y0y0 » Sat May 07, 2005 6:29 pm

Excellent ! (I was the second guy who voted that :P)
>>>>>No sig at the time<<<<<<

User avatar
SlAiD
Registered User
Posts: 104
Joined: Sun Aug 03, 2003 6:18 pm
Location: Lisbon - Portugal
Contact:

Post by SlAiD » Sat May 07, 2005 6:31 pm

Great. (i'm second i think)

SeraphicGate
Registered User
Posts: 207
Joined: Tue Dec 23, 2003 6:54 am

Post by SeraphicGate » Sat May 07, 2005 6:38 pm

Problem

"Please read: INSTALL.html before attempting to update."

Comes up after making the code changes and then trying to run "update_to_latest.php".

And yes, I know it needs to be run in root/install/update_to_latest.php
Last edited by SeraphicGate on Sat May 07, 2005 7:28 pm, edited 3 times in total.

NewGuy
Registered User
Posts: 162
Joined: Tue Nov 18, 2003 4:40 am
Contact:

Post by NewGuy » Sat May 07, 2005 6:38 pm

Thanks heaps for that. Saves heaps of time.

Any possibility of having these update files published onto http://www.phpbb.com/downloads.php? The updates made here are much more useful than the "changed files" archives and "patch files only" downloads already listed on the download page ...

Revo1
Registered User
Posts: 21
Joined: Wed Nov 26, 2003 2:23 am
Location: Michigan
Contact:

Post by Revo1 » Sat May 07, 2005 7:15 pm

I have a question for the includes/bbcode.php specified function.

Inside the upgrade PHP file, it specifies to find the following:

Code: Select all

global $lang, $bbcode_tpl;
After add the following:

Code: Select all

$text = preg_replace('#(script|about|applet|activex|chrome):#is', "\\1:", $text);
However, below that very line is the following almost identical code:

Code: Select all

$text = preg_replace('#(script|about|applet|activex|chrome):#is', "1:", $text);
Maybe there's no problem, but I just thought it seems suspicious so I'd better ask. Is this code ok? Thanks.
www.pxalive.com - web design at your service.

z14
Registered User
Posts: 14
Joined: Thu May 05, 2005 4:35 pm

Post by z14 » Sat May 07, 2005 7:17 pm

Code: Select all

Parse error: parse error in c:\program files\apache group\apache\htdocs\travis\includes\sessions.php on line 423
On line 423 I found a ?>

Anyone know what the problem is???

edit: Nevermind Fixed it forgot to put the } on the line 189 part

:D
Last edited by z14 on Sat May 07, 2005 7:37 pm, edited 2 times in total.

darylt
Registered User
Posts: 151
Joined: Mon Jul 12, 2004 10:00 pm

Post by darylt » Sat May 07, 2005 7:19 pm

I have the following error after the upgrade

Code: Select all

Parse error: parse error, unexpected '}' in /home/httpd/vhosts/lsdogs.org.uk/httpdocs/phpBB/includes/sessions.php on line 207

Fatal error: Call to undefined function: session_pagestart() in /home/httpd/vhosts/lsdogs.org.uk/httpdocs/phpBB/index.php on line 31
Can anyone help please? :?

Revo1
Registered User
Posts: 21
Joined: Wed Nov 26, 2003 2:23 am
Location: Michigan
Contact:

Post by Revo1 » Sat May 07, 2005 7:21 pm

Again, I came across something similar, so perhaps I'm just overly-suspicious.

It says to find:

Code: Select all

 */
function make_clickable($text)
{
Add after:

Code: Select all

$text = preg_replace('#(script|about|applet|activex|chrome):#is', "\\1:", $text);
Although there's already:

Code: Select all

$text = preg_replace('#(script|about|applet|activex|chrome):#is', "1:", $text);
I doubt you made the same mistake twice, so thanks for the update.

Peace to the phpBB super crew.
www.pxalive.com - web design at your service.

bugfixed
Registered User
Posts: 101
Joined: Sun Apr 04, 2004 2:57 am
Location: Turkey
Name: Murat
Contact:

Post by bugfixed » Sat May 07, 2005 7:22 pm

very thanks.

FuNEnD3R
Registered User
Posts: 267
Joined: Sun Aug 03, 2003 6:57 pm
Contact:

Post by FuNEnD3R » Sat May 07, 2005 7:23 pm

For the new admin/pagestart.php code change instead of:

Code: Select all

if (!$userdata['session_admin'])
{
   redirect(append_sid("login.$phpEx?redirect=admin/&admin=1", true));
}
Would it be better as this:

Code: Select all

if (!$userdata['session_admin'])
{
   redirect(append_sid("login.$phpEx?redirect=admin/&admin=1", true));
}
With the ampersand?

agent00shoe
Registered User
Posts: 373
Joined: Sat Feb 12, 2005 9:39 pm

Post by agent00shoe » Sat May 07, 2005 7:32 pm

After upgrading, when I log in and click to go to the acp, it takes me to my webhost admin area after logging in the 2nd time.

*edit
In pagestart.php, I changed

redirect(append_sid("login.$phpEx?redirect=admin/&admin=1", true));

to

redirect(append_sid("login.$phpEx?redirect=admin/index.php&admin=1", true));

to point to the file itself and it works fine now.

As usual, thanks for the mod form update. :D

Post Reply

Return to “[2.0.x] MOD Database Releases”