[Tool] phpBB 2.0.14 to 2.0.15 Code Changes

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
97
63%
Very Good
15
10%
Good
14
9%
Fair
7
5%
Poor
20
13%
 
Total votes: 153

User avatar
~Romil
Registered User
Posts: 12
Joined: Tue Nov 09, 2004 6:53 pm
Location: Mystical India
Contact:

Post by ~Romil » Tue May 17, 2005 6:43 am

Ok, after much laziness now I'm on 2.0.15 with littile hiccup. Thanks Acyd Burn and EasyMOD team 8)

EM is the way to be!
Chillax!

~Romil

asinshesq
Registered User
Posts: 6266
Joined: Sun Feb 22, 2004 9:34 pm
Location: NYC
Name: Alan

Post by asinshesq » Tue May 17, 2005 8:50 am

crossfire39 wrote: I updated this from 14 to 15 using easymod. Everything works, but when I try to access the admin control panel and all it is is a white page. What could be the problem?


Make sure your server looks for index.php in directories if it doesn't find index.html. Otherwise, you will get a white page.

Or, you can disable the double login that this upgrade forces you to do when you go into the acfp...in order to do that, just look at the advice you will find in about 20 out of the 25 pages in this thread.

michaeldcoates
Registered User
Posts: 134
Joined: Sat Apr 02, 2005 8:16 pm

Post by michaeldcoates » Tue May 17, 2005 12:14 pm

i am running 13 but wish to upgrade to 15 - is there a mod from 13 to 14 as well as 14 to 15?

also is there any known clashes with other mods - i have several installed on my forum that i don't want to mess up.

thanks
mik x

NightriderXP
Registered User
Posts: 1418
Joined: Sat Oct 09, 2004 8:17 am
Location: Florida, US
Contact:

Post by NightriderXP » Tue May 17, 2005 1:33 pm

michaeldcoates wrote: i am running 13 but wish to upgrade to 15 - is there a mod from 13 to 14 as well as 14 to 15?

This might be a good page to bookmark for future reference:

§ phpBB Installation & Upgrade Tools

Here are several other useful links that you might want to add to your favorites as well:

§ MOD-Database
§ Styles-Database
§ [beta] EasyMOD v0.1.13

:lol:

michaeldcoates
Registered User
Posts: 134
Joined: Sat Apr 02, 2005 8:16 pm

Post by michaeldcoates » Tue May 17, 2005 1:38 pm

just what i was looking for - thank you!

stinestrain
Registered User
Posts: 17
Joined: Sat Apr 09, 2005 2:51 am

Post by stinestrain » Fri May 20, 2005 1:33 pm

when installing with easy mod I get the following error:

Code: Select all

Critical Error

FIND FAILED: In file [includes/bbcode.php] could not find:

// [img]image_url_here[/img] code.. 
// This one gets first-passed.. 
$patterns[] = "#\[img:$uid\](.*?)\[/img:$uid\]#si"; 

MOD script line #178

NightriderXP
Registered User
Posts: 1418
Joined: Sat Oct 09, 2004 8:17 am
Location: Florida, US
Contact:

Post by NightriderXP » Fri May 20, 2005 2:23 pm

stinestrain wrote: when installing with easy mod I get the following error:

Code: Select all

Critical Error

FIND FAILED: In file [includes/bbcode.php] could not find:

// [img]image_url_here[/img] code.. 
// This one gets first-passed.. 
$patterns[] = "#\[img:$uid\](.*?)\[/img:$uid\]#si"; 

MOD script line #178

This means that your board has been modified by some other MOD and the code no longer matches what is expected from a vanilla board. So what you do now is open your includes/bbcode.php file and search for part of this FIND statement. I would search on the following:

Code: Select all

// [img]image_url_here[/img] code.. 
If that fails shorten the search to:

Code: Select all

image_url_here
You probably will only find one match. Once you find this, then copy the code that you have in your includes/bbcode.php file and overwrite the FIND part in the MOD. Save and upload the file to your EM 2014->2015 folder and try again. Sometimes there will be other FIND searches in these MODs that no longer match the code on your board, so you will go through the same process for each conflict until the script will execute properly in EM...

:lol:

skullJ
Registered User
Posts: 70
Joined: Fri Oct 29, 2004 7:36 pm

Post by skullJ » Fri May 20, 2005 2:58 pm

i ll get this mod and in acp i see this:

Code: Select all

Parse error: parse error, unexpected T_ELSE in /usr/local/psa/home/vhosts/greekmusiciansforum.gr/httpdocs/forum/admin/admin_ug_auth.php on line 924
in spot that locate the menu!! :?

asinshesq
Registered User
Posts: 6266
Joined: Sun Feb 22, 2004 9:34 pm
Location: NYC
Name: Alan

Post by asinshesq » Fri May 20, 2005 3:02 pm

skullJ wrote: i ll get this mod and in acp i see this:

Code: Select all

Parse error: parse error, unexpected T_ELSE in /usr/local/psa/home/vhosts/greekmusiciansforum.gr/httpdocs/forum/admin/admin_ug_auth.php on line 924
in spot that locate the menu!! :?


It's telling you that you messed up in installing the mod (should have used easymod ;) ). And it's telling you exactly where to look for the problem, which is a parsing error that could be caused by a number of mistakes.

Look in line 924 of admin_ug_auth.php and find the else sttaement it is complaining about. Are you perhaps missing a close bracket (i.e. a '}' ) just before the else statement? Note that the lines the mod has you add to admin_ug_auth.php have two close brackets at the end a couple of lines before the existing else statment...maybe you left out one of those when you copied and pasted the new lines into the file?

skullJ
Registered User
Posts: 70
Joined: Fri Oct 29, 2004 7:36 pm

Post by skullJ » Fri May 20, 2005 3:17 pm

OK thats it...i miss a }!!!! :D

thank u a lot!

User avatar
shirleycaat
Registered User
Posts: 186
Joined: Mon Apr 07, 2003 1:11 am

Post by shirleycaat » Fri May 20, 2005 9:01 pm

HELP:

Code: Select all

<marquee>
stop working after upgrade to 2.0.15

and

Code: Select all

<embed>
stop working in the posting.

:?: why?


I view the source, it seems "<" and ">" can not be parsed

Code: Select all

<marquee>WHY MARQUEE NOT WORKING</marquee>

How can I fix this?

CyanBlue
Registered User
Posts: 409
Joined: Mon Jul 28, 2003 9:55 am

Post by CyanBlue » Sun May 22, 2005 3:54 am

CICarScene wrote:

Code: Select all

viewtopic.php

FIND - Line 1110 

2.0.14 Code: 

      $message = str_replace('\"', '"', substr(@preg_replace('#(\>(((?>([^><]+|(?R)))*)\<))#se', "@preg_replace('#\b(" . $highlight_match . ")\b#i', '<span style=\"color:#" . $theme['fontcolor3'] . "\"><b>\\\\1</b></span>', '\\0')", '>' . $message . '<'), 1, -1));

REPLACE WITH 
2.0.15 Code: 

      $message = str_replace('\"', '"', substr(@preg_replace('#(\>(((?>([^><]+|(?R)))*)\<))#se', "@preg_replace('#\b(" . str_replace('\\', '\\\\', $highlight_match) . ")\b#i', '<span style=\"color:#" . $theme['fontcolor3'] . "\"><b>\\\\1</b></span>', '\\0')", '>' . $message . '<'), 1, -1));
 
When I change this line, I get parse errors in my viewtopic.php (only shows up in the error log on the apache server) users just get a white screen :(

Certain topics will show, others will not :(

Any ideas?

Howdy, CICarScene... Did you figure out the problem??? I am getting the same parse error after I EM 2.0.14 to 2.0.15... :(

If I copy the viewtopic.php from my 2.0.14 backup, the board does not spit out the parse error... and the MOD says that $message line is the only change in the viewtopic.php file...

This is the modified viewtopic.php which generates parse error... Anybody have any idea what I am doing wrong???

Code: Select all

	//
	// Highlight active words (primarily for search)
	//
	if ($highlight_match)
	{
		// This was shamelessly 'borrowed' from volker at multiartstudio dot de
		// via php.net's annotated manual
//		$message = str_replace('\"', '"', substr(preg_replace('#(\>(((?>([^><]+|(?R)))*)\<))#se', "preg_replace('#\b(" . $highlight_match . ")\b#i', '<span style=\"color:#" . $theme['fontcolor3'] . "\"><b>\\\\1</b></span>', '\\0')", '>' . $message . '<'), 1, -1));
		$message = str_replace('\"', '"', substr(@preg_replace('#(\>(((?>([^><]+|(?R)))*)\<))#se', "@preg_replace('#\b(" . str_replace('\\', '\\\\', $highlight_match) . ")\b#i', '<span style=\"color:#" . $theme['fontcolor3'] . "\"><b>\\\\1</b></span>', '\\0')", '>' . $message . '<'), 1, -1));
	}
Thank you... :)

NightriderXP
Registered User
Posts: 1418
Joined: Sat Oct 09, 2004 8:17 am
Location: Florida, US
Contact:

Post by NightriderXP » Sun May 22, 2005 4:16 am

CyanBlue, I don't see anything wrong with the code you provided. I imagine that your error is in the code that precedes the code you supplied. I compared the code you provided with mine and it is exactly the same except for the line that is commented out. You can delete that line...

Code: Select all

//      $message = str_replace('\"', '"', substr(preg_replace('#(\>(((?>([^><]+|(?R)))*)\<))#se', "preg_replace('#\b(" . $highlight_match . ")\b#i', '<span style=\"color:#" . $theme['fontcolor3'] . "\"><b>\\\\1</b></span>', '\\0')", '>' . $message . '<'), 1, -1)); 
This line is commented out so it is just unnecessary clutter in your code. ..

:lol:

CyanBlue
Registered User
Posts: 409
Joined: Mon Jul 28, 2003 9:55 am

Post by CyanBlue » Sun May 22, 2005 4:55 am

Thanks for the reply, NightriderXP... :)

I must be going crazy with this... It turns out that I don't get to get that parse error message anymore IF I delete the line that is commented out... (The code that you see in NightriderXP's post)

I absolutely have no idea WHY PHP is hicupping at the commented line, but that's what seems to be solving the problem right this moment... Hm... Strange, eh???

chromenut
Registered User
Posts: 18
Joined: Fri Mar 04, 2005 6:17 am
Location: NC, USA
Contact:

Post by chromenut » Sun May 22, 2005 6:40 am

No offense to anyone here, but after this hubbub, I think it's time for me to move to SMF and stop all this silliness with phpBB... too darn much maintenance... :cry:

Post Reply

Return to “[2.0.x] MOD Database Releases”