[Tool] phpBB 2.0.14 to 2.0.15 Code Changes

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
97
63%
Very Good
15
10%
Good
14
9%
Fair
7
5%
Poor
20
13%
 
Total votes: 153

darylt
Registered User
Posts: 151
Joined: Mon Jul 12, 2004 10:00 pm

Post by darylt » Sat May 07, 2005 10:19 pm

:idea: Did you run install/update_to_latest.php

Can anyone help with my problem?

Code: Select all

Parse error: parse error, unexpected $ in /home/httpd/vhosts/lsdogs.org.uk/httpdocs/phpBB/includes/sessions.php on line 418

Fatal error: Call to undefined function: session_pagestart() in /home/httpd/vhosts/lsdogs.org.uk/httpdocs/phpBB/index.php on line 31

User avatar
MHobbit
Former Team Member
Posts: 4761
Joined: Thu Mar 18, 2004 5:32 pm
Location: There and Back Again

Post by MHobbit » Sat May 07, 2005 10:24 pm

Make sure you did the code changes for sessions.php correctly, first.
Former phpBB MOD Team member
No private support is offered.
"There’s too many things to get done, and I’m running out of days..."

User avatar
3Di
Former Team Member
Posts: 13906
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Post by 3Di » Sat May 07, 2005 10:34 pm

NightriderXP wrote: Awesome MOD Acyd Burn!!! This version update finished in under a minute without any problems using EasyMOD. Your MODs always seem to work flawlessly. Thanks for providing them...

It's a shame that so many people prefer to manually apply these MODs and then end up in here with "weird" problems. Someday they all might learn to use EM and make things a lot easier for themselves...

:lol:


Reading the topic and considering you're maybe one of the 3/4 peoples who had no probs doing it, well understanding your meaning and saying you I'd never used EM at all, (due to some strange issues it does, and reading also the disclaimer about it :"EM it's usefull just in case you have a fresh board and you want to install an heavy mod etc.."..

i declare here that all my MODs have be done manually and only in some cases i'd found problems, due to my fault but fixed in a quick way and easy too..

Consider i'm using phpbb2 and php only since 2 months..
and i don't think to be a genious.

Have a good day.
Greets, 3D.

p.s: to the stuff..

keep the good work, this it's the first time i saw something wrong into your MODs.

keep cool

:wink:
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

deny
Registered User
Posts: 565
Joined: Wed May 14, 2003 9:14 am
Location: Find-Ip-Address.org
Contact:

Post by deny » Sat May 07, 2005 10:43 pm

Not any problem at all with this update.If you did exactly what it state by install file then there will be not any problem.
I never believe in any automatic upgrde so i every changes do manually.
If you get session error then check session.php again, i fyou get another error check that file.
If you are still not able to fix error then simple backup old files and continue with old phpBB.

Phixx
Registered User
Posts: 1
Joined: Sat May 07, 2005 9:48 pm
Contact:

Post by Phixx » Sat May 07, 2005 10:47 pm

I had the same error when i was logging to the admin panel, I was redirected to the index page.
In fact, I forgot to change a line in the login.php page, at line 55. There are two lines to change not one!

Here's the right code:

Code: Select all

if( isset($HTTP_POST_VARS['login']) || isset($HTTP_GET_VARS['login']) || isset($HTTP_POST_VARS['logout']) || isset($HTTP_GET_VARS['logout']) )
{
	if( ( isset($HTTP_POST_VARS['login']) || isset($HTTP_GET_VARS['login']) ) && (!$userdata['session_logged_in'] || isset($HTTP_POST_VARS['admin'])) )
	{
		$username = isset($HTTP_POST_VARS['username']) ? phpbb_clean_username($HTTP_POST_VARS['username']) : '';
		$password = isset($HTTP_POST_VARS['password']) ? $HTTP_POST_VARS['password'] : '';
I hope it will help! :)

User avatar
SlAiD
Registered User
Posts: 104
Joined: Sun Aug 03, 2003 6:18 pm
Location: Lisbon - Portugal
Contact:

Post by SlAiD » Sat May 07, 2005 10:48 pm

ldd wrote: how to use this MOD ?

hand upgrade and upgrade_to_lastest.php ? or only copy files and upgrade_to_lastest.php ?


Download it, read the .txt file (not bbcode) or html file and make the change on it.

User avatar
3Di
Former Team Member
Posts: 13906
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Post by 3Di » Sat May 07, 2005 10:49 pm

deny wrote: Not any problem at all with this update.If you did exactly what it state by install file then there will be not any problem.
I never believe in any automatic upgrde so i every changes do manually.
If you get session error then check session.php again, i fyou get another error check that file.
If you are still not able to fix error then simple backup old files and continue with old phpBB.



Indeed. 8)
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

__ARIE__
Registered User
Posts: 2
Joined: Sat Oct 23, 2004 8:39 am

Post by __ARIE__ » Sat May 07, 2005 10:57 pm

I just update in 10 min wihtout any errors.
So every is working.

darylt
Registered User
Posts: 151
Joined: Mon Jul 12, 2004 10:00 pm

Post by darylt » Sat May 07, 2005 11:06 pm

I have solved my first problem by re installing a fresh copy of sessions.php.

I tried this also with login.php however I still can not access my acp, I just get redirected back to index.php

kukacomone
Registered User
Posts: 55
Joined: Wed Jul 14, 2004 10:30 pm

Post by kukacomone » Sat May 07, 2005 11:08 pm

darylt wrote: I have solved my first problem by re installing a fresh copy of sessions.php.

I tried this also with login.php however I still can not access my acp, I just get redirected back to index.php


Me too.. :( :(

ChaosBringer
Registered User
Posts: 412
Joined: Mon Apr 19, 2004 11:30 pm
Contact:

Post by ChaosBringer » Sat May 07, 2005 11:12 pm

GJ

WOrks perfectly in my board(edited by hand :P )

01000001 01101100 01101100 00100000 01111001 01101111 01110101 01110010 00100000 01100010 01101001 01101110 01100001 01110010 01111001 00100000 01100001 01110010 01100101 00100000 01100010 01100101 01101100 01101111 01101110 01100111 00100000 01110100 01101111 00100000 01110101 01110011 00100001

gretchenland.com
Registered User
Posts: 93
Joined: Wed Oct 29, 2003 5:05 pm
Location: USA Bristol, TN
Contact:

Post by gretchenland.com » Sat May 07, 2005 11:24 pm

worked fine for me -- (by hand with dreamweaver find replace)

Thanks a ton!!!

discusws
Registered User
Posts: 59
Joined: Tue Dec 09, 2003 9:54 pm

Post by discusws » Sat May 07, 2005 11:27 pm

installation went fine with easymod (did it twice) but no Junior admin anymore as earlier posted.

User avatar
SlAiD
Registered User
Posts: 104
Joined: Sun Aug 03, 2003 6:18 pm
Location: Lisbon - Portugal
Contact:

Post by SlAiD » Sat May 07, 2005 11:33 pm

Hi there.

There is a litle problem whti that code:

// [url=xxxx://www.phpbb.com]phpBB[/url] code..
$patterns[] = "#\[url=([\w]+?://[^ \"\n\r\t<]*?)\]([^?].*?)\[/url\]#i";
$replacements[] = $bbcode_tpl['url3'];

// [url=www.phpbb.com]phpBB[/url] code.. (no xxxx:// prefix).
$patterns[] = "#\[url=((www|ftp)\.[^ \"\n\r\t<]*?)\]([^?].*?)\[/url\]#i";


It *DONT* shot link with names (ex: [url=http://phpbb.com]phpBB r0x[/url] show only the adress and do *NOT* link to it, link to a mail (ex: mailto:phpbb.com)

I need help to fix this.

baumfarn
Registered User
Posts: 106
Joined: Sat Jul 17, 2004 11:49 pm
Location: Austria
Contact:

Post by baumfarn » Sun May 08, 2005 12:00 am

worked perfect

What do you think about a small docu (esspecially if the changes covers security issues) to check that all necessary changes are working?

thanks
Peter

Post Reply

Return to “[2.0.x] MOD Database Releases”