[2.0.17] Report Posts

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
50
62%
Very Good
16
20%
Good
7
9%
Fair
2
2%
Poor
6
7%
 
Total votes: 81

User avatar
3dhue
Registered User
Posts: 17
Joined: Sat Nov 05, 2005 4:45 pm

Post by 3dhue »

I have been using this mod and it works great unless the "auto-report" problem. I have the same sql error as fatihalp89 on one forum..and with the exact same files and database. Really weird.
Does anybody know how to get rid of the sql error? I get this:

Code: Select all

Error by getting reported posts.

DEBUG MODE

SQL Error : 1054 Unknown column 'p.poster_id' in 'on clause'

SELECT f.forum_name, f.forum_id, t.topic_title, t.topic_id, p.post_id, pt.post_subject, p.post_username, u.username, u.user_id, u2.username as reportername, u2.user_id as reporter_id, p.reporter_comment FROM phpbb_forums f, phpbb_topics t, phpbb_posts p, phpbb_posts_text pt LEFT JOIN phpbb_users u ON u.user_id = p.poster_id LEFT JOIN phpbb_users u2 ON u2.user_id = p.reporter_id WHERE p.reporter_id <> 0 AND f.forum_id = p.forum_id AND t.topic_id = p.topic_id AND pt.post_id = p.post_id ORDER BY p.post_id ASC

Line : 315
File : report.php 
Hope somebody knows. Dont want to uninstall it..
Admin
3dhue.com
RickyC
Registered User
Posts: 39
Joined: Wed Oct 26, 2005 3:05 pm

Post by RickyC »

hey guys, I get these two errors:
Could not get reports count

DEBUG MODE

SQL Error : 1146 Table 'fdixjssd_phpb8.phpbb_post_reports' doesn't exist

SELECT COUNT(pr.report_id) as total FROM phpbb_post_reports pr, phpbb_posts p WHERE pr.report_status = 1 AND pr.post_id = p.post_id AND p.forum_id IN (1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25)

Line : 332
File : functions_report.php

Could not query reports

DEBUG MODE

SQL Error : 1146 Table 'fdixjssd_phpb8.phpbb_post_reports' doesn't exist

SELECT pr.*, u.username, t.topic_title, f.forum_id, f.forum_name FROM phpbb_post_reports pr, phpbb_users u, phpbb_posts p, phpbb_topics t, phpbb_forums f WHERE u.user_id = pr.reporter_id AND pr.post_id = p.post_id AND p.topic_id = t.topic_id AND t.forum_id = f.forum_id AND pr.report_status = 1 AND p.forum_id IN (1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25) ORDER BY report_time DESC

Line : 210
File : functions_report.php
chatasos
Registered User
Posts: 748
Joined: Wed May 15, 2002 1:16 pm
Location: Paralia

Post by chatasos »

RickyC wrote: hey guys, I get these two errors:
Could not get reports count

DEBUG MODE

SQL Error : 1146 Table 'fdixjssd_phpb8.phpbb_post_reports' doesn't exist

SELECT COUNT(pr.report_id) as total FROM phpbb_post_reports pr, phpbb_posts p WHERE pr.report_status = 1 AND pr.post_id = p.post_id AND p.forum_id IN (1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25)

Line : 332
File : functions_report.php

Could not query reports

DEBUG MODE

SQL Error : 1146 Table 'fdixjssd_phpb8.phpbb_post_reports' doesn't exist

SELECT pr.*, u.username, t.topic_title, f.forum_id, f.forum_name FROM phpbb_post_reports pr, phpbb_users u, phpbb_posts p, phpbb_topics t, phpbb_forums f WHERE u.user_id = pr.reporter_id AND pr.post_id = p.post_id AND p.topic_id = t.topic_id AND t.forum_id = f.forum_id AND pr.report_status = 1 AND p.forum_id IN (1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,21,22,23,24,25) ORDER BY report_time DESC

Line : 210
File : functions_report.php

Please make sure you have followed the instructions exactly as they are written..
It seems you missed the SQL commands.

Report Posts 1.2.3c (MODDB) - Report Posts 2.1.5 (ALPHA)
Rebuild Search 2.4.0 (MODDB)
MOD Version Checker 1.2.0 (MODDB)
Mega Mail System 0.9.8 (ALPHA)
Pagination Select List & Input Box (MODDB)
chatasos
Registered User
Posts: 748
Joined: Wed May 15, 2002 1:16 pm
Location: Paralia

Post by chatasos »

3dhue wrote: I have been using this mod and it works great unless the "auto-report" problem. I have the same sql error as fatihalp89 on one forum..and with the exact same files and database. Really weird.
Does anybody know how to get rid of the sql error? I get this:

Code: Select all

Error by getting reported posts.

DEBUG MODE

SQL Error : 1054 Unknown column 'p.poster_id' in 'on clause'

SELECT f.forum_name, f.forum_id, t.topic_title, t.topic_id, p.post_id, pt.post_subject, p.post_username, u.username, u.user_id, u2.username as reportername, u2.user_id as reporter_id, p.reporter_comment FROM phpbb_forums f, phpbb_topics t, phpbb_posts p, phpbb_posts_text pt LEFT JOIN phpbb_users u ON u.user_id = p.poster_id LEFT JOIN phpbb_users u2 ON u2.user_id = p.reporter_id WHERE p.reporter_id <> 0 AND f.forum_id = p.forum_id AND t.topic_id = p.topic_id AND pt.post_id = p.post_id ORDER BY p.post_id ASC

Line : 315
File : report.php 
Hope somebody knows. Dont want to uninstall it..


It seems you're using another mod.
Please check your mod...

Report Posts 1.2.3c (MODDB) - Report Posts 2.1.5 (ALPHA)
Rebuild Search 2.4.0 (MODDB)
MOD Version Checker 1.2.0 (MODDB)
Mega Mail System 0.9.8 (ALPHA)
Pagination Select List & Input Box (MODDB)
RickyC
Registered User
Posts: 39
Joined: Wed Oct 26, 2005 3:05 pm

Post by RickyC »

I rechecked already and it doesn't help.

below thaose erros it also shows this:

Code: Select all

message_die() was called multiple times. This isn't supposed to happen. Was message_die() used in page_tail.php?
Last edited by RickyC on Sun Jun 04, 2006 10:39 pm, edited 2 times in total.
chatasos
Registered User
Posts: 748
Joined: Wed May 15, 2002 1:16 pm
Location: Paralia

Post by chatasos »

3dhue wrote: I have been using this mod and it works great unless the "auto-report" problem. I have the same sql error as fatihalp89 on one forum..and with the exact same files and database. Really weird.
Does anybody know how to get rid of the sql error? I get this:

Code: Select all

Error by getting reported posts.

DEBUG MODE

SQL Error : 1054 Unknown column 'p.poster_id' in 'on clause'

SELECT f.forum_name, f.forum_id, t.topic_title, t.topic_id, p.post_id, pt.post_subject, p.post_username, u.username, u.user_id, u2.username as reportername, u2.user_id as reporter_id, p.reporter_comment FROM phpbb_forums f, phpbb_topics t, phpbb_posts p, phpbb_posts_text pt LEFT JOIN phpbb_users u ON u.user_id = p.poster_id LEFT JOIN phpbb_users u2 ON u2.user_id = p.reporter_id WHERE p.reporter_id <> 0 AND f.forum_id = p.forum_id AND t.topic_id = p.topic_id AND pt.post_id = p.post_id ORDER BY p.post_id ASC

Line : 315
File : report.php 
Hope somebody knows. Dont want to uninstall it..


This error is not from this mod.
It seems you're using another mod.

Report Posts 1.2.3c (MODDB) - Report Posts 2.1.5 (ALPHA)
Rebuild Search 2.4.0 (MODDB)
MOD Version Checker 1.2.0 (MODDB)
Mega Mail System 0.9.8 (ALPHA)
Pagination Select List & Input Box (MODDB)
chatasos
Registered User
Posts: 748
Joined: Wed May 15, 2002 1:16 pm
Location: Paralia

Post by chatasos »

RickyC wrote: I rechecked already and it doesn't help.

below thaose erros it also shows this:

Code: Select all

message_die() was called multiple times. This isn't supposed to happen. Was message_die() used in page_tail.php?
bump*


Have you run the following sql commands?

Code: Select all

CREATE TABLE `phpbb_post_reports` (
  `report_id` mediumint(8) NOT NULL auto_increment,
  `post_id` mediumint(8) NOT NULL default '0',
  `reporter_id` mediumint(8) NOT NULL default '0',
  `report_status` tinyint(1) NOT NULL default '0',
  `report_time` int(11) NOT NULL default '0',
  `report_comments` text,
  `last_action_user_id` mediumint(8) default '0',
  `last_action_time` int(11) NOT NULL default '0',
  `last_action_comments` text,
  PRIMARY KEY  (`report_id`)
);

ALTER TABLE phpbb_users ADD user_report_optout TINYINT( 1 ) DEFAULT '0' NOT NULL ;

INSERT INTO phpbb_config ( config_name, config_value ) VALUES ('report_email', '1');

Last edited by chatasos on Sun Jun 04, 2006 10:40 pm, edited 1 time in total.

Report Posts 1.2.3c (MODDB) - Report Posts 2.1.5 (ALPHA)
Rebuild Search 2.4.0 (MODDB)
MOD Version Checker 1.2.0 (MODDB)
Mega Mail System 0.9.8 (ALPHA)
Pagination Select List & Input Box (MODDB)
RickyC
Registered User
Posts: 39
Joined: Wed Oct 26, 2005 3:05 pm

Post by RickyC »

RickyC wrote: I rechecked already and it doesn't help.

below thaose erros it also shows this:

Code: Select all

message_die() was called multiple times. This isn't supposed to happen. Was message_die() used in page_tail.php?


bump*
RickyC
Registered User
Posts: 39
Joined: Wed Oct 26, 2005 3:05 pm

Post by RickyC »

chatasos wrote:
RickyC wrote:I rechecked already and it doesn't help.

below thaose erros it also shows this:

Code: Select all

message_die() was called multiple times. This isn't supposed to happen. Was message_die() used in page_tail.php?
bump*


Have you run the following sql commands?

Code: Select all

CREATE TABLE `phpbb_post_reports` (
  `report_id` mediumint(8) NOT NULL auto_increment,
  `post_id` mediumint(8) NOT NULL default '0',
  `reporter_id` mediumint(8) NOT NULL default '0',
  `report_status` tinyint(1) NOT NULL default '0',
  `report_time` int(11) NOT NULL default '0',
  `report_comments` text,
  `last_action_user_id` mediumint(8) default '0',
  `last_action_time` int(11) NOT NULL default '0',
  `last_action_comments` text,
  PRIMARY KEY  (`report_id`)
);

ALTER TABLE phpbb_users ADD user_report_optout TINYINT( 1 ) DEFAULT '0' NOT NULL ;

INSERT INTO phpbb_config ( config_name, config_value ) VALUES ('report_email', '1');



Yes, I did it again just in case and it says that it is already there:

Code: Select all

#1050 - Table 'phpbb_post_reports' already exists 
chatasos
Registered User
Posts: 748
Joined: Wed May 15, 2002 1:16 pm
Location: Paralia

Post by chatasos »

Then you shouldn't see the "SQL Error : 1146 Table 'fdixjssd_phpb8.phpbb_post_reports' doesn't exist " errors you described before...

Report Posts 1.2.3c (MODDB) - Report Posts 2.1.5 (ALPHA)
Rebuild Search 2.4.0 (MODDB)
MOD Version Checker 1.2.0 (MODDB)
Mega Mail System 0.9.8 (ALPHA)
Pagination Select List & Input Box (MODDB)
RickyC
Registered User
Posts: 39
Joined: Wed Oct 26, 2005 3:05 pm

Post by RickyC »

but i do.
chatasos
Registered User
Posts: 748
Joined: Wed May 15, 2002 1:16 pm
Location: Paralia

Post by chatasos »

Maybe you're using another database?
Maybe multiple forums?

Report Posts 1.2.3c (MODDB) - Report Posts 2.1.5 (ALPHA)
Rebuild Search 2.4.0 (MODDB)
MOD Version Checker 1.2.0 (MODDB)
Mega Mail System 0.9.8 (ALPHA)
Pagination Select List & Input Box (MODDB)
MarioKnight
Registered User
Posts: 20
Joined: Fri Sep 10, 2004 11:42 pm
Location: Oswego, NY
Contact:

Post by MarioKnight »

3dhue wrote: I have been using this mod and it works great unless the "auto-report" problem. I have the same sql error as fatihalp89 on one forum..and with the exact same files and database. Really weird.
Does anybody know how to get rid of the sql error? I get this:

Code: Select all

Error by getting reported posts.

DEBUG MODE

SQL Error : 1054 Unknown column 'p.poster_id' in 'on clause'

SELECT f.forum_name, f.forum_id, t.topic_title, t.topic_id, p.post_id, pt.post_subject, p.post_username, u.username, u.user_id, u2.username as reportername, u2.user_id as reporter_id, p.reporter_comment FROM phpbb_forums f, phpbb_topics t, phpbb_posts p, phpbb_posts_text pt LEFT JOIN phpbb_users u ON u.user_id = p.poster_id LEFT JOIN phpbb_users u2 ON u2.user_id = p.reporter_id WHERE p.reporter_id <> 0 AND f.forum_id = p.forum_id AND t.topic_id = p.topic_id AND pt.post_id = p.post_id ORDER BY p.post_id ASC

Line : 315
File : report.php 
Hope somebody knows. Dont want to uninstall it..


I have been getting this same error. Here's the weird thing though. While I admit my board is heavily MODed, this MOD works just fine alongside the other ones I had installed. With the exception of the phpBB upgrades, I haven't MODed my forum is at least a year. I was running my site and forums on a homemade server for the past few years, and have recentally moved everything to a pay host. I changed none of the code and the databases were copied over with no change to the actual data. But now ever since the move, that pop-up error appears for all the admins and mods on my forums everytime a page loads, which is quite annoying. You say earlier that the error isn't from your MOD, yet it stems from a file that was provided in your MOD. I've used this MOD for years with no problems so this strikes me as really odd. I was wondering if you had any idea whatsoever as to why it started doing this out of nowhere. The only thing I can possibly think of is that the MySQL software might be a later version than what I'm used to, I know I had issues with some of my PHP when I had the new server set to use PHP5, but then changing it to PHP4 resolved them. Maybe a change has to be made for newer MySQL and/or PHP versions?
Dan Bednarski ~ MarioKnight
My mods: Change forum banner
chatasos
Registered User
Posts: 748
Joined: Wed May 15, 2002 1:16 pm
Location: Paralia

Post by chatasos »

MarioKnight & 3dhue, this error isn't from this mod....
There is no "report.php" file included in it. :wink:

Report Posts 1.2.3c (MODDB) - Report Posts 2.1.5 (ALPHA)
Rebuild Search 2.4.0 (MODDB)
MOD Version Checker 1.2.0 (MODDB)
Mega Mail System 0.9.8 (ALPHA)
Pagination Select List & Input Box (MODDB)
User avatar
NappilyEvahAftah
Registered User
Posts: 94
Joined: Wed Apr 12, 2006 1:24 am
Location: Michigan
Contact:

Tried to install with EasyMOD

Post by NappilyEvahAftah »

Image

I got this "critical error" and the MOD didn't install. What is it looking for? How do I supply the file?

Also, please explain it so a non-techie can understand it.

Thanks a bunch!
Post Reply

Return to “[2.0.x] MOD Database Releases”