Page 3 of 21

Posted: Mon Jun 27, 2005 9:00 pm
by Forau
Heh, that's only partially possible, since the file ends at line 1334.

Code: Select all

	);
	display_post_attachments($postrow[$i]['post_id'], $postrow[$i]['post_attachment']);
}

if ( $show_qr_form )
{
	$template->assign_block_vars('switch_quick_reply', array());
	include($phpbb_root_path . 'includes/viewtopic_quickreply.'.$phpEx);
}

$template->pparse('body');

include($phpbb_root_path . 'includes/page_tail.'.$phpEx);

?>
Also, is this code correct? I copied it from the file, but it doesn't look right with the singular "else".

Code: Select all

#
#-----[ FIND ]---------------------------------------------
# Line 455
		$avatar_sql = user_avatar_delete($userdata['user_avatar_type'], $userdata['user_avatar']);
	}

#
#-----[ AFTER, ADD ]---------------------------------------------
# 
	else


# 
#-----[ OPEN ]--------------------------------------------- 
# 
modcp.php

Posted: Mon Jun 27, 2005 9:32 pm
by Ex0dus
Can anyone point out the exact sql changes between 2.0.15 and 2.0.16 for me? Other than the version number change, I dont see any. Are there any other changes between 2.0.15 and 2.0.16? Im just double checking before i run the install file (as i always like to know exactly what im changing in the db before i do it).

-Ex0dus

:) :) :) :) :) :)

Posted: Mon Jun 27, 2005 9:33 pm
by mobilemick
I am also stuck with 2.2 instructions, cant find that line anywhere, what i do..........

thanks
mick

Posted: Mon Jun 27, 2005 9:34 pm
by Saint_hh
Ex0dus wrote: Can anyone point out the exact sql changes between 2.0.15 and 2.0.16 for me? Other than the version number change, I dont see any.

And thats it - there aren't any. :D

Posted: Mon Jun 27, 2005 9:43 pm
by v-h
everything went as expected :)

:) :) :) :) :) :)

Posted: Mon Jun 27, 2005 9:45 pm
by mobilemick
everything went as expected



So how did you manage part 2.2 then :)


Mick

Posted: Mon Jun 27, 2005 10:07 pm
by ViPeR5000
very nice thks team

Posted: Mon Jun 27, 2005 10:23 pm
by ChrissySkyking
Great MOD!! Saved me so much time (I administer 9 installations of phpBB!!). Only one with a problem, and that seems to have been a previous mod that was the culprit.

Thanks!!!

Posted: Mon Jun 27, 2005 11:06 pm
by egriz
i did this and it is all ok except for the fact that I can;t get into my admin panel anymore. Everytime I click the link for admin panel it says I have to reauthenticate. So i reenter my info press enter and it just clears the login info and asks for it again!

Any ideas?

here's my nickel...

Posted: Mon Jun 27, 2005 11:23 pm
by panda317
Flawless...

...of *course*!

;-)

Posted: Mon Jun 27, 2005 11:25 pm
by Desummoner
Hi, All.
The next in case someone needs it.

My board in not so heavily modded, but there's a little...
Original mod version conflicts with my installed categories hierarchy mod.
So, there're problems with directives

Code: Select all

#
#-----[ FIND ]---------------------------------------------
# Line 466
			$new_forum_id = intval($HTTP_POST_VARS['new_forum']);
			$old_forum_id = $forum_id;
and

Code: Select all

#
#-----[ FIND ]---------------------------------------------
# Line 773
				$new_forum_id = intval($HTTP_POST_VARS['new_forum_id']);
				$topic_time = time();
As second search string in each directive still unique (in my case, at least), directives can be fixed by removing first serch string of each directive so they are become respectively:

Code: Select all

#
#-----[ FIND ]---------------------------------------------
# Line 466
			$old_forum_id = $forum_id;
and

Code: Select all

#
#-----[ FIND ]---------------------------------------------
# Line 773
				$topic_time = time();
In my case it solved problem and EM had applied mod with no probs.

And big thanks to Acyd Burn for fast release of this mod (and prev. mods as well).

Posted: Mon Jun 27, 2005 11:43 pm
by 3Di
Desummoner wrote: Hi, All.
The next in case someone needs it.

My board in not so heavily modded, but there's a little...
Original mod version conflicts with my installed categories hierarchy mod.
So, there're problems with directives

Code: Select all

#
#-----[ FIND ]---------------------------------------------
# Line 466
			$new_forum_id = intval($HTTP_POST_VARS['new_forum']);
			$old_forum_id = $forum_id;
and

Code: Select all

#
#-----[ FIND ]---------------------------------------------
# Line 773
				$new_forum_id = intval($HTTP_POST_VARS['new_forum_id']);
				$topic_time = time();
As second search string in each directive still unique (in my case, at least), directives can be fixed by removing first serch string of each directive so they are become respectively:

Code: Select all

#
#-----[ FIND ]---------------------------------------------
# Line 466
			$old_forum_id = $forum_id;
and

Code: Select all

#
#-----[ FIND ]---------------------------------------------
# Line 773
				$topic_time = time();
In my case it solved problem and EM had applied mod with no probs.

And big thanks to Acyd Burn for fast release of this mod (and prev. mods as well).


Yeah, this is related to modcp.php, i did it manually into a CH 2.1.1 RC5, so no probs. ;)

admin/admin_ug_auth.php it is Managed by CH RC5, so i missed to edit that file (it doesn't exists on CH).

Everything seems to be allright (just in case, I have the backup of files).

install/update_to_latest.php have to be executed, in order to change the phpbb2 version number.

Greets

Heavily Modded 2.0.15 mod installed perf3ctly

Posted: Mon Jun 27, 2005 11:49 pm
by stardotstar
Everything went exactly as expected! Thanks once again for a great update :)

Regards,
Will.*

Posted: Tue Jun 28, 2005 1:56 am
by Revo1
Smooth update! Thanks for the great tutorial.

Posted: Tue Jun 28, 2005 2:38 am
by chattalk
I did the code changes, and then just ran the update_to_latest.php and i get these warnings:

Warning: main(./../extension.inc): failed to open stream: No such file or directory in /home/chattalk/public_html/forums/update_to_latest.php on line 46

Warning: main(./../extension.inc): failed to open stream: No such file or directory in /home/chattalk/public_html/forums/update_to_latest.php on line 46

Warning: main(): Failed opening './../extension.inc' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/chattalk/public_html/forums/update_to_latest.php on line 46

Warning: main(./../config.): failed to open stream: No such file or directory in /home/chattalk/public_html/forums/update_to_latest.php on line 47

Warning: main(./../config.): failed to open stream: No such file or directory in /home/chattalk/public_html/forums/update_to_latest.php on line 47

Warning: main(): Failed opening './../config.' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/chattalk/public_html/forums/update_to_latest.php on line 47
Please read: INSTALL.html before attempting to update.

?? :?