[2.0.17] Inline Banner Ad

All new MODs released in our MOD Database will be announced in here. All support for released MODs needs to take place in here. No new MODs will be accepted into the MOD Database for phpBB2
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

On February 1, 2009 this forum will be set to read only as part of retiring of phpBB2.

Rating:

Excellent!
86
60%
Very Good
26
18%
Good
18
13%
Fair
4
3%
Poor
9
6%
 
Total votes: 143

User avatar
45ish
Registered User
Posts: 81
Joined: Sun Nov 26, 2006 6:38 am
Location: usa canada uk - where ever the english language takes me!
Contact:

Re: [2.0.17] Inline Banner Ad

Post by 45ish » Mon May 14, 2007 2:37 pm

Hi,
I put this on my forum today. I use the recent version of phpbb2. I had a strange color effect after I installed and I wonder if anyone can help me repair the colors back to their previous set up. I did not alter the colors, but after I put the ads inline, the backgrounds of posted messages are sort of switched around with the background of the forum. Please look at the screen captures below and see if you can offer a fix for me. I'm sorry to keep bugging you every day, but I have very little experience with codes. Thank you for checking.
This is the color BEFORE I installed mod (preferred)
Image

This is what happened to post background AFTER I installed mod
Image

Here is front of forum color layout, no colors were changed after install.
Image

PS. This is a very nice modification code.

geocator
Registered User
Posts: 16242
Joined: Fri Jan 09, 2004 11:56 pm
Location: On dry land
Contact:

Re: [2.0.17] Inline Banner Ad

Post by geocator » Mon May 14, 2007 11:43 pm

Looks like you made a mistake editing the css values, or viewtopic_body.tpl

User avatar
xmenfile
Registered User
Posts: 163
Joined: Sun Apr 22, 2007 10:32 pm

Re: [2.0.17] Inline Banner Ad

Post by xmenfile » Tue May 15, 2007 3:58 am

Hi, I am using EM mod to install it, but geting this errors. Can anyone help, please? Thank you so much,

Code: Select all

Warning

Function Trace: open_files[2]->modio_open[1]

Could not open [templates/Glass2/overall_header.tpl] for reading.
MOD script line #226 :: FAQ :: Report



Warning

FIND FAILED: In file [templates/Glass/overall_header.tpl] could not find:

.helpline { background-color: {T_TR_COLOR2}; border-style: none; } 

MOD script line #228 :: FAQ :: Report



Warning

FIND FAILED: In file [templates/ca_aphrodite_green/overall_header.tpl] could not find:

.helpline { background-color: {T_TR_COLOR2}; border-style: none; } 

MOD script line #228 :: FAQ :: Report



Warning

FIND FAILED: In file [templates/MorpheusXBlue/overall_header.tpl] could not find:

.helpline { background-color: {T_TR_COLOR2}; border-style: none; } 

MOD script line #228 :: FAQ :: Report



Warning

FIND FAILED: In file [templates/topsecret/overall_header.tpl] could not find:

.helpline { background-color: {T_TR_COLOR2}; border-style: none; } 

MOD script line #228 :: FAQ :: Report



Warning

FIND FAILED: In file [templates/Wii/overall_header.tpl] could not find:

.helpline { background-color: {T_TR_COLOR2}; border-style: none; } 

MOD script line #228 :: FAQ :: Report



Warning

FIND FAILED: In file [templates/GreenTech/overall_header.tpl] could not find:

.helpline { background-color: {T_TR_COLOR2}; border-style: none; } 

MOD script line #228 :: FAQ :: Report



Warning

FIND FAILED: In file [templates/bozUNtu/overall_header.tpl] could not find:

.helpline { background-color: {T_TR_COLOR2}; border-style: none; } 

MOD script line #228 :: FAQ :: Report



Warning

FIND FAILED: In file [templates/Cobalt/overall_header.tpl] could not find:

.helpline { background-color: {T_TR_COLOR2}; border-style: none; } 

MOD script line #228 :: FAQ :: Report



Warning

FIND FAILED: In file [templates/MobtownBlues/overall_header.tpl] could not find:

.helpline { background-color: {T_TR_COLOR2}; border-style: none; } 

MOD script line #228 :: FAQ :: Report

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"> <html dir="{S_CONTENT_DIRECTION}"> <head> <meta http-equiv="Content-Type" content="text/html; charset={S_CONTENT_ENCODING}"> <meta http-equiv="Content-Style-Type" content="text/css"> {META} {NAV_LINKS} <title>{SITENAME} :: {PAGE_TITLE}</title> <!-- link rel="stylesheet" href="templates/subSilver/{T_HEAD_STYLESHEET}" type="text/css" --> <style type="text/css"> <!-- /* The original subSilver Theme for phpBB version 2+ Created by subBlue design http://www.subBlue.com NOTE: These CSS definitions are stored within the main page body so that you can use the phpBB2 theme administration centre. When you have finalised your style you could cut the final CSS code and place it in an external file, deleting this section to save bandwidth. */ /* General page style. The scroll bar colours only visible in IE5.5+ */ body { background-color: {T_BODY_BGCOLOR}; scrollbar-face-color: {T_TR_COLOR2}; scrollbar-highlight-color: {T_TD_COLOR2}; scrollbar-shadow-color: {T_TR_COLOR2}; scrollbar-3dlight-color: {T_TR_COLOR3}; scrollbar-arrow-color: {T_BODY_LINK}; scrollbar-track-color: {T_TR_COLOR1}; scrollbar-darkshadow-color: {T_TH_COLOR1}; } /* General font families for common tags */ font,th,td,p { font-family: {T_FONTFACE1} } a:link,a:active,a:visited { color : {T_BODY_LINK}; } a:hover { text-decoration: underline; color : {T_BODY_HLINK}; } hr { height: 0px; border: solid {T_TR_COLOR3} 0px; border-top-width: 1px;} /* This is the border line & background colour round the entire page */ .bodyline { background-color: {T_TD_COLOR2}; border: 1px {T_TH_COLOR1} solid; } /* This is the outline round the main forum tables */ .forumline { background-color: {T_TD_COLOR2}; border: 2px {T_TH_COLOR2} solid; } /* Main table cell colours and backgrounds */ td.row1 { background-color: {T_TR_COLOR1}; } td.row2 { background-color: {T_TR_COLOR2}; } td.row3 { background-color: {T_TR_COLOR3}; } /* This is for the table cell above the Topics, Post & Last posts on the index.php page By default this is the fading out gradiated silver background. However, you could replace this with a bitmap specific for each forum */ td.rowpic { background-color: {T_TD_COLOR2}; background-image: url(templates/subSilver/images/{T_TH_CLASS3}); background-repeat: repeat-y; } /* Header cells - the blue and silver gradient backgrounds */ th { color: {T_FONTCOLOR3}; font-size: {T_FONTSIZE2}px; font-weight : bold; background-color: {T_BODY_LINK}; height: 25px; background-image: url(templates/subSilver/images/{T_TH_CLASS2}); } td.cat,td.catHead,td.catSides,td.catLeft,td.catRight,td.catBottom { background-image: url(templates/subSilver/images/{T_TH_CLASS1}); background-color:{T_TR_COLOR3}; border: {T_TH_COLOR3}; border-style: solid; height: 28px; } /* Setting additional nice inner borders for the main table cells. The names indicate which sides the border will be on. Don't worry if you don't understand this, just ignore it :-) */ td.cat,td.catHead,td.catBottom { height: 29px; border-width: 0px 0px 0px 0px; } th.thHead,th.thSides,th.thTop,th.thLeft,th.thRight,th.thBottom,th.thCornerL,th.thCornerR { font-weight: bold; border: {T_TD_COLOR2}; border-style: solid; height: 28px; } td.row3Right,td.spaceRow { background-color: {T_TR_COLOR3}; border: {T_TH_COLOR3}; border-style: solid; } th.thHead,td.catHead { font-size: {T_FONTSIZE3}px; border-width: 1px 1px 0px 1px; } th.thSides,td.catSides,td.spaceRow { border-width: 0px 1px 0px 1px; } th.thRight,td.catRight,td.row3Right { border-width: 0px 1px 0px 0px; } th.thLeft,td.catLeft { border-width: 0px 0px 0px 1px; } th.thBottom,td.catBottom { border-width: 0px 1px 1px 1px; } th.thTop { border-width: 1px 0px 0px 0px; } th.thCornerL { border-width: 1px 0px 0px 1px; } th.thCornerR { border-width: 1px 1px 0px 0px; } /* The largest text used in the index page title and toptic title etc. */ .maintitle { font-weight: bold; font-size: 22px; font-family: "{T_FONTFACE2}",{T_FONTFACE1}; text-decoration: none; line-height : 120%; color : {T_BODY_TEXT}; } /* General text */ .gen { font-size : {T_FONTSIZE3}px; } .genmed { font-size : {T_FONTSIZE2}px; } .gensmall { font-size : {T_FONTSIZE1}px; } .gen,.genmed,.gensmall { color : {T_BODY_TEXT}; } a.gen,a.genmed,a.gensmall { color: {T_BODY_LINK}; text-decoration: none; } a.gen:hover,a.genmed:hover,a.gensmall:hover { color: {T_BODY_HLINK}; text-decoration: underline; } /* The register, login, search etc links at the top of the page */ .mainmenu { font-size : {T_FONTSIZE2}px; color : {T_BODY_TEXT} } a.mainmenu { text-decoration: none; color : {T_BODY_LINK}; } a.mainmenu:hover{ text-decoration: underline; color : {T_BODY_HLINK}; } /* Forum category titles */ .cattitle { font-weight: bold; font-size: {T_FONTSIZE3}px ; letter-spacing: 1px; color : {T_BODY_LINK}} a.cattitle { text-decoration: none; color : {T_BODY_LINK}; } a.cattitle:hover{ text-decoration: underline; } /* Forum title: Text and link to the forums used in: index.php */ .forumlink { font-weight: bold; font-size: {T_FONTSIZE3}px; color : {T_BODY_LINK}; } a.forumlink { text-decoration: none; color : {T_BODY_LINK}; } a.forumlink:hover{ text-decoration: underline; color : {T_BODY_HLINK}; } /* Used for the navigation text, (Page 1,2,3 etc) and the navigation bar when in a forum */ .nav { font-weight: bold; font-size: {T_FONTSIZE2}px; color : {T_BODY_TEXT};} a.nav { text-decoration: none; color : {T_BODY_LINK}; } a.nav:hover { text-decoration: underline; } /* titles for the topics: could specify viewed link colour too */ .topictitle,h1,h2 { font-weight: bold; font-size: {T_FONTSIZE2}px; color : {T_BODY_TEXT}; } a.topictitle:link { text-decoration: none; color : {T_BODY_LINK}; } a.topictitle:visited { text-decoration: none; color : {T_BODY_VLINK}; } a.topictitle:hover { text-decoration: underline; color : {T_BODY_HLINK}; } /* Name of poster in viewmsg.php and viewtopic.php and other places */ .name { font-size : {T_FONTSIZE2}px; color : {T_BODY_TEXT};} /* Location, number of posts, post date etc */ .postdetails { font-size : {T_FONTSIZE1}px; color : {T_BODY_TEXT}; } /* The content of the posts (body of text) */ .postbody { font-size : {T_FONTSIZE3}px; line-height: 18px} a.postlink:link { text-decoration: none; color : {T_BODY_LINK} } a.postlink:visited { text-decoration: none; color : {T_BODY_VLINK}; } a.postlink:hover { text-decoration: underline; color : {T_BODY_HLINK}} /* Quote & Code blocks */ .code { font-family: {T_FONTFACE3}; font-size: {T_FONTSIZE2}px; color: {T_FONTCOLOR2}; background-color: {T_TD_COLOR1}; border: {T_TR_COLOR3}; border-style: solid; border-left-width: 1px; border-top-width: 1px; border-right-width: 1px; border-bottom-width: 1px } .quote { font-family: {T_FONTFACE1}; font-size: {T_FONTSIZE2}px; color: {T_FONTCOLOR1}; line-height: 125%; background-color: {T_TD_COLOR1}; border: {T_TR_COLOR3}; border-style: solid; border-left-width: 1px; border-top-width: 1px; border-right-width: 1px; border-bottom-width: 1px } /* Copyright and bottom info */ .copyright { font-size: {T_FONTSIZE1}px; font-family: {T_FONTFACE1}; color: {T_FONTCOLOR1}; letter-spacing: -1px;} a.copyright { color: {T_FONTCOLOR1}; text-decoration: none;} a.copyright:hover { color: {T_BODY_TEXT}; text-decoration: underline;} /* Form elements */ input,textarea, select { color : {T_BODY_TEXT}; font: normal {T_FONTSIZE2}px {T_FONTFACE1}; border-color : {T_BODY_TEXT}; } /* The text input fields background colour */ input.post, textarea.post, select { background-color : {T_TD_COLOR2}; } input { text-indent : 2px; } /* The buttons used for bbCode styling in message post */ input.button { background-color : {T_TR_COLOR1}; color : {T_BODY_TEXT}; font-size: {T_FONTSIZE2}px; font-family: {T_FONTFACE1}; } /* The main submit button option */ input.mainoption { background-color : {T_TD_COLOR1}; font-weight : bold; } /* None-bold submit button */ input.liteoption { background-color : {T_TD_COLOR1}; font-weight : normal; } /* This is the line in the posting page which shows the rollover help line. This is actually a text box, but if set to be the same colour as the background no one will know ;) */ .helpline { background-color: {T_TR_COLOR2}; border-style: none; } 

td.inlineadtitle {
	background-color: {T_TR_COLOR3}; border: {T_TH_COLOR3}; border-style: solid; border-width: 1px;
}
td.inlinead {
	background-color: {T_TR_COLOR3}; border: {T_TH_COLOR3}; border-style: solid; border-width: 1px; text-align: center;
}

/* Import the fancy styles for IE only (NS4.x doesn't use the @import function) */
@import url("templates/subSilver/formIE.css"); 
-->
</style>
<!-- BEGIN switch_enable_pm_popup -->
<script language="Javascript" type="text/javascript">
<!--
	if ( {PRIVATE_MESSAGE_NEW_FLAG} )
	{
		window.open('{U_PRIVATEMSGS_POPUP}', '_phpbbprivmsg', 'HEIGHT=225,resizable=yes,WIDTH=400');;
	}
//-->
</script>
<!-- END switch_enable_pm_popup -->
</head>
<body bgcolor="{T_BODY_BGCOLOR}" text="{T_BODY_TEXT}" link="{T_BODY_LINK}" vlink="{T_BODY_VLINK}">

<a name="top"></a>

<table width="100%" cellspacing="0" cellpadding="10" border="0" align="center"> 
	<tr> 
		<td class="bodyline"><table width="100%" cellspacing="0" cellpadding="0" border="0">
			<tr> 
				<td><a href="{U_INDEX}"><img src="templates/subSilver/images/logo_phpBB.gif" border="0" alt="{L_INDEX}" vspace="1" /></a></td>
				<td align="center" width="100%" valign="middle"><span class="maintitle">{SITENAME}</span><br /><span class="gen">{SITE_DESCRIPTION}<br />&nbsp; </span> 
				<table cellspacing="0" cellpadding="2" border="0">
					<tr> 
						<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_FAQ}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_faq.gif" width="12" height="13" border="0" alt="{L_FAQ}" hspace="3" />{L_FAQ}</a>&nbsp; &nbsp;<a href="{U_SEARCH}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_search.gif" width="12" height="13" border="0" alt="{L_SEARCH}" hspace="3" />{L_SEARCH}</a>&nbsp; &nbsp;<a href="{U_MEMBERLIST}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_members.gif" width="12" height="13" border="0" alt="{L_MEMBERLIST}" hspace="3" />{L_MEMBERLIST}</a>&nbsp; &nbsp;<a href="{U_GROUP_CP}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_groups.gif" width="12" height="13" border="0" alt="{L_USERGROUPS}" hspace="3" />{L_USERGROUPS}</a>&nbsp; 
						<!-- BEGIN switch_user_logged_out -->
						&nbsp;<a href="{U_REGISTER}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_register.gif" width="12" height="13" border="0" alt="{L_REGISTER}" hspace="3" />{L_REGISTER}</a>&nbsp;
						<!-- END switch_user_logged_out -->
						</span></td>
					</tr>
					<tr>
						<td height="25" align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_PROFILE}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_profile.gif" width="12" height="13" border="0" alt="{L_PROFILE}" hspace="3" />{L_PROFILE}</a>&nbsp; &nbsp;<a href="{U_PRIVATEMSGS}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_message.gif" width="12" height="13" border="0" alt="{PRIVATE_MESSAGE_INFO}" hspace="3" />{PRIVATE_MESSAGE_INFO}</a>&nbsp; &nbsp;<a href="{U_LOGIN_LOGOUT}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_login.gif" width="12" height="13" border="0" alt="{L_LOGIN_LOGOUT}" hspace="3" />{L_LOGIN_LOGOUT}</a>&nbsp;</span></td>
					</tr>
				</table></td>
			</tr>
		</table>

		<br />

Code: Select all

Warning

Function Trace: open_files[2]->modio_open[1]

Could not open [templates/Glass2/viewtopic_body.tpl] for reading.
MOD script line #243 :: FAQ :: Report



Warning

FIND FAILED: In file [templates/MorpheusXBlue/viewtopic_body.tpl] could not find:

<!-- END postrow --> 

MOD script line #245 :: FAQ :: Report

<table width="100%" cellspacing="2" cellpadding="2" border="0"> <tr> <td align="left" valign="bottom" colspan="2"><a class="maintitle" href="{U_VIEW_TOPIC}">{TOPIC_TITLE}</a><br /> <span class="gensmall"><b>{PAGINATION}</b><br /> &nbsp; </span></td> </tr> </table> <table width="100%" cellspacing="2" cellpadding="2" border="0"> <tr> <td align="left" valign="bottom" nowrap="nowrap"><span class="nav"><a href="{U_POST_NEW_TOPIC}"><img src="{POST_IMG}" border="0" alt="{L_POST_NEW_TOPIC}" align="middle" /></a>&nbsp;&nbsp;&nbsp;<a href="{U_POST_REPLY_TOPIC}"><img src="{REPLY_IMG}" border="0" alt="{L_POST_REPLY_TOPIC}" align="middle" /></a></span></td> <td align="left" valign="middle" width="100%"><span class="nav">&nbsp;&nbsp;&nbsp;<a href="{U_INDEX}" class="nav">{L_INDEX}</a> -> <a href="{U_VIEW_FORUM}" class="nav">{FORUM_NAME}</a></span></td> </tr> </table> <table class="forumline" width="100%" cellspacing="1" cellpadding="3" border="0"> <tr align="right"> <td class="catHead" colspan="2" height="28"><span class="nav"><a href="{U_VIEW_OLDER_TOPIC}" class="nav">{L_VIEW_PREVIOUS_TOPIC}</a> :: <a href="{U_VIEW_NEWER_TOPIC}" class="nav">{L_VIEW_NEXT_TOPIC}</a> &nbsp;</span></td> </tr> {POLL_DISPLAY} <tr> <th class="thLeft" width="150" height="26" nowrap="nowrap">{L_AUTHOR}</th> <th class="thRight" nowrap="nowrap">{L_MESSAGE}</th> </tr> <!-- BEGIN postrow --> <tr> <td width="150" align="left" valign="top" class="{postrow.ROW_CLASS}"><span class="name"><a name="{postrow.U_POST_ID}"></a><b>{postrow.POSTER_NAME}</b></span><br /><span class="postdetails">{postrow.POSTER_RANK}<br />{postrow.RANK_IMAGE}{postrow.POSTER_AVATAR}<br /><br />{postrow.POSTER_JOINED}<br />{postrow.POSTER_POSTS}<br />{postrow.POSTER_FROM}</span><br /></td> <td class="{postrow.ROW_CLASS}" width="100%" height="28" valign="top"><table width="100%" border="0" cellspacing="0" cellpadding="0"> <tr> <td width="100%"><a href="{postrow.U_MINI_POST}"><img src="{postrow.MINI_POST_IMG}" width="12" height="9" alt="{postrow.L_MINI_POST_ALT}" title="{postrow.L_MINI_POST_ALT}" border="0" /></a><span class="postdetails">{L_POSTED}: {postrow.POST_DATE}<span class="gen">&nbsp;</span>&nbsp; &nbsp;{L_POST_SUBJECT}: {postrow.POST_SUBJECT}</span></td> <td valign="top" nowrap="nowrap">{postrow.QUOTE_IMG} {postrow.EDIT_IMG} {postrow.DELETE_IMG} {postrow.IP_IMG}</td> </tr> <tr> <td colspan="2"><hr /></td> </tr> <tr> <td colspan="2"><span class="postbody">{postrow.MESSAGE}{postrow.SIGNATURE}</span><span class="gensmall">{postrow.EDITED_MESSAGE}</span></td> </tr> </table></td> </tr> <tr> <td class="{postrow.ROW_CLASS}" width="150" align="left" valign="middle"><span class="nav"><a href="#top" class="nav">{L_BACK_TO_TOP}</a></span></td> <td class="{postrow.ROW_CLASS}" width="100%" height="28" valign="bottom" nowrap="nowrap"><table cellspacing="0" cellpadding="0" border="0" height="18" width="18"> <tr> <td valign="middle" nowrap="nowrap">{postrow.PROFILE_IMG} {postrow.PM_IMG} {postrow.EMAIL_IMG} {postrow.WWW_IMG} {postrow.AIM_IMG} {postrow.YIM_IMG} {postrow.MSN_IMG}<script language="JavaScript" type="text/javascript"><!-- if ( navigator.userAgent.toLowerCase().indexOf('mozilla') != -1 && navigator.userAgent.indexOf('5.') == -1 && navigator.userAgent.indexOf('6.') == -1 ) document.write(' {postrow.ICQ_IMG}'); else document.write('</td><td>&nbsp;</td><td valign="top" nowrap="nowrap"><div style="position:relative"><div style="position:absolute">{postrow.ICQ_IMG}</div><div style="position:absolute;left:3px;top:-1px">{postrow.ICQ_STATUS_IMG}</div></div>'); //--></script><noscript>{postrow.ICQ_IMG}</noscript></td> </tr> </table></td> </tr> <tr> <td class="spaceRow" colspan="2" height="1"><img src="templates/subSilver/images/spacer.gif" alt="" width="1" height="1" /></td> </tr> 

	<!-- BEGIN switch_ad -->
	<tr> 
		<td width="150" align="left" valign="top" class="inlineadtitle"><span class="name"><b>{postrow.L_SPONSOR}</b></span><br /</td>
		<td class="inlinead" width="100%" height="28" valign="top">
			{postrow.INLINE_AD}
		</td>
	</tr>
	<tr> 
		<td class="spaceRow" colspan="2" height="1"><img src="templates/subSilver/images/spacer.gif" alt="" width="1" height="1" /></td>
	</tr>
	<!-- END switch_ad -->
	<!-- BEGIN switch_ad_style2 -->
	<tr>
		<td colspan=2 class="inlinead">
			{postrow.INLINE_AD}
		</td>
	</tr>
	<!-- END switch_ad_style2 -->

	<!-- END postrow -->
	<tr align="center"> 
		<td class="catBottom" colspan="2" height="28"><table cellspacing="0" cellpadding="0" border="0">
			<tr><form method="post" action="{S_POST_DAYS_ACTION}">
				<td align="center"><span class="gensmall">{L_DISPLAY_POSTS}: {S_SELECT_POST_DAYS}&nbsp;{S_SELECT_POST_ORDER}&nbsp;<input type="submit" value="{L_GO}" class="liteoption" name="submit" /></span></td>
			</form></tr>
		</table></td>
	</tr>
</table>

<table width="100%" cellspacing="2" cellpadding="2" border="0" align="center">
  <tr> 
	<td align="left" valign="middle" nowrap="nowrap"><span class="nav"><a href="{U_POST_NEW_TOPIC}"><img src="{POST_IMG}" border="0" alt="{L_POST_NEW_TOPIC}" align="middle" /></a>&nbsp;&nbsp;&nbsp;<a href="{U_POST_REPLY_TOPIC}"><img src="{REPLY_IMG}" border="0" alt="{L_POST_REPLY_TOPIC}" align="middle" /></a></span></td>
	<td align="left" valign="middle" width="100%"><span class="nav">&nbsp;&nbsp;&nbsp;<a href="{U_INDEX}" class="nav">{L_INDEX}</a> 
	  -> <a href="{U_VIEW_FORUM}" class="nav">{FORUM_NAME}</a></span></td>
	<td align="right" valign="top" nowrap="nowrap"><span class="gensmall">{S_TIMEZONE}</span><br /><span class="nav">{PAGINATION}</span> 
	  </td>
  </tr>
  <tr>
	<td align="left" colspan="3"><span class="nav">{PAGE_NUMBER}</span></td>
  </tr>
</table>

<table width="100%" cellspacing="2" border="0" align="center">
  <tr> 
	<td width="40%" valign="top" nowrap="nowrap" align="left"><span class="gensmall">{S_WATCH_TOPIC}</span><br />
	  &nbsp;<br />
	  {S_TOPIC_ADMIN}</td>
	<td align="right" valign="top" nowrap="nowrap">{JUMPBOX}<span class="gensmall">{S_AUTH_LIST}</span></td>
  </tr>
</table>


geocator
Registered User
Posts: 16242
Joined: Fri Jan 09, 2004 11:56 pm
Location: On dry land
Contact:

Re: [2.0.17] Inline Banner Ad

Post by geocator » Tue May 15, 2007 1:06 pm

You will have to do the template changes by hand. Those templates have seprate css files instead of css in overall_header.tpl.

User avatar
45ish
Registered User
Posts: 81
Joined: Sun Nov 26, 2006 6:38 am
Location: usa canada uk - where ever the english language takes me!
Contact:

Re: [2.0.17] Inline Banner Ad

Post by 45ish » Tue May 15, 2007 1:39 pm

geocator wrote: Looks like you made a mistake editing the css values, or viewtopic_body.tpl


I went and "re did" the view topic edits, still didn't fix it. I did not adjust the css during this install. I missed that part of the instruction, if there is one. anyhow, I just changed the rest of the colors on the forum to fit in with the new look. It is OK for now. Hope I did not break anything. Thank you for your reply.

User avatar
xmenfile
Registered User
Posts: 163
Joined: Sun Apr 22, 2007 10:32 pm

Re: [2.0.17] Inline Banner Ad

Post by xmenfile » Tue May 15, 2007 9:24 pm

geocator wrote: You will have to do the template changes by hand. Those templates have seprate css files instead of css in overall_header.tpl.



Hi, I am kind of new. Can you give me more details. I appreciate it.

geocator
Registered User
Posts: 16242
Joined: Fri Jan 09, 2004 11:56 pm
Location: On dry land
Contact:

Re: [2.0.17] Inline Banner Ad

Post by geocator » Tue May 15, 2007 10:45 pm

xmenfile wrote:
geocator wrote: You will have to do the template changes by hand. Those templates have seprate css files instead of css in overall_header.tpl.



Hi, I am kind of new. Can you give me more details. I appreciate it.


There are two css classes that the instructions say to add to overall_header.tpl. Since your css is in seperate files you will need to put them in the css files. But you will also need to manualy add the corect colors in place of the template variables (the bits in the {}).

User avatar
David Wilding
Registered User
Posts: 5
Joined: Mon Nov 27, 2006 9:54 pm
Location: Provo, UT
Contact:

Re: [2.0.17] Inline Banner Ad

Post by David Wilding » Wed May 16, 2007 8:36 pm

Geocator,

So, I've gotten the MOD installed and it works just like you've told us it would. I'm looking to have just one ad show per page, but have it be after the last post on each page. It would work to have it show after post 15, but then if there are fewer posts than that in a topic, the ad won't show. I've tried moving the code around in viewtopic_body.tpl, but that doesn't work. Is there a way to set it to show after the last post on a page regardless of whether it's post number 3 or 15?

Thanks
Dave

geocator
Registered User
Posts: 16242
Joined: Fri Jan 09, 2004 11:56 pm
Location: On dry land
Contact:

Re: [2.0.17] Inline Banner Ad

Post by geocator » Thu May 17, 2007 1:15 am

This MOD is not really designed for that. To be honest it has been so long since I have looked at this code that I cant give you a specific answer at this point. However, in viewtopic.php you should be able to detect if it is the last post on the page and modify the MOD code appropriately.

User avatar
David Wilding
Registered User
Posts: 5
Joined: Mon Nov 27, 2006 9:54 pm
Location: Provo, UT
Contact:

Re: [2.0.17] Inline Banner Ad

Post by David Wilding » Thu May 17, 2007 5:30 pm

geocator,

Thanks for the tip. After looking at the code for a few minutes in viewtopic.php, I found an easy solution. all you need to do is change one line of code. The MOD says to add
if ($display_ad){
...
All that needs to be done is to modify that if statement to read:
if ($display_ad && !next($postrow)){
...
Basically it says that if an ad is supposed to be displayed and the next item in the array is empty (if this is the last post on the page) then post the ad. All you have to do after that is go to the Admin Panel and modify the Inline Ad Config to display an ad every 1 posts. That makes it so the ads would show after every post, but the modification of the if statement only allows it to show after the last post.

hponce
Registered User
Posts: 40
Joined: Mon Apr 10, 2006 2:22 pm

Re: [2.0.17] Inline Banner Ad

Post by hponce » Fri May 18, 2007 5:58 pm

I just install this mod with easy install getting complete and correct installation, but when i'm try to configure in "Inline Ad Config" it doesn't keep Display Ad After x Post and Display Ad Every x Post settings.

If i enter again in to inline ad config is blank everytime.

geocator
Registered User
Posts: 16242
Joined: Fri Jan 09, 2004 11:56 pm
Location: On dry land
Contact:

Re: [2.0.17] Inline Banner Ad

Post by geocator » Sun May 20, 2007 1:40 am

That sounds like the database updates where not done.

wired076
Registered User
Posts: 1441
Joined: Mon May 21, 2007 10:19 am

Re: [2.0.17] Inline Banner Ad

Post by wired076 » Thu May 24, 2007 9:41 am

I need some help. I tried installing it on my own in my forum with no avail with me causing many issues but now I only get this error Parse error: syntax error, unexpected '}' in /home/wired076/public_html/forum/includes/template.php(127) : eval()'d code on line 21 and I know that it probably isn't this file but I am not sure which file to fix so that I can access the page correctly so that I can put my ad code in. All the other pages are working except for this ad code page which I would like to fix.

I used EasyMod to install the mod on my forum.

Please help

Forum Address http://www.wired.profusehost.net/forum

chimeranzl
Registered User
Posts: 17
Joined: Wed Feb 14, 2007 2:36 am
Location: NZL
Contact:

Re: [2.0.17] Inline Banner Ad

Post by chimeranzl » Thu May 24, 2007 12:46 pm

Hey,

Great mod! Just a quick question, I'm updating the php script manually from the .mod file. Half way through the file it says:
#
#-----[ OPEN ]------------------------------------------
#
templates/subSilver/overall_header.tpl
#
#-----[ FIND ]------------------------------------------
#
.helpline { background-color: {T_TR_COLOR2}; border-style: none; }
#
#-----[ AFTER, ADD ]------------------------------------------
#
td.inlineadtitle {
background-color: {T_TR_COLOR3}; border: {T_TH_COLOR3}; border-style: solid; border-width: 1px;
}
td.inlinead {
background-color: {T_TR_COLOR3}; border: {T_TH_COLOR3}; border-style: solid; border-width: 1px; text-align: center;
}
I can't find ".helpline" in this file at all. Is this needed? I continued anyway and it works ok. I'm running phpbb 2.0.22

Cheers
NZ Marine Aquarium Society
http://www.nzmas.co.nz/

geocator
Registered User
Posts: 16242
Joined: Fri Jan 09, 2004 11:56 pm
Location: On dry land
Contact:

Re: [2.0.17] Inline Banner Ad

Post by geocator » Thu May 24, 2007 10:31 pm

wired076: That error indicates an error in one of the template files. In this case probably overall_header.tpl or viewtopic_body.tpl.

chimeranzl: Your style uses an external css file, rather than putting the css in the header. You will need to add those lines to the end of your css file and change the template variables (bits between and including the {}) to the correct hex color codes for your template.

Post Reply

Return to “[2.0.x] MOD Database Releases”